Support » Allgemeine Fragen » Es lassen sich nur noch Seiten zum Menü hinzufügen

  • QUEERmdb

    (@queermdb)


    Ich habe ein Problem mit dem WordPress-Interface von Design -> Menüs -> Menüeinträge hinzufügen (/wp-admin/nav-menus.php). Es lassen sich nur noch Seiten zum Menü hinzufügen, weil die anderen Möglichkeiten Beiträge, Individuelle Links, Kategorien nicht anwählbar sind.

    Ich kann den Block der Beiträge, individuellen Links und Kategorien nicht ausklappen, genauso wenig wie ich die Seiten zuklappen kann.

    Ich habe verschiedene Browser, verschiedene Betriebssystem und verschiedene Devices probiert. Überall ist das gleiche Problem. Woanders als im Menü habe ich keine Probleme Blöcke auf- und zuzuklappen.

    Gibt es da Probleme mit dem letzten WordPress-Update oder bin ich der einzige mit diesem Problem? Verursacht ein Plugin diesen Bug?

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 3 Antworten - 1 bis 3 (von insgesamt 3)
  • Moderator Bego Mario Garde

    (@pixolin)

    QUEERmdb

    (@queermdb)

    Herzlichen Dank! Ich konnte das Problem lösen. Es lag an der Deaktivierung des jQuery Migrate.

    Nun frage ich mich aber, warum das Problem in einer WordPress-Core-Komponente auftritt (nav-menus.php), also nichts mit Themes oder Plugins zu tun hat. Das heißt ja, dass WordPress nur funktioniert, wenn man dieses Überbrückungs-Plugin installiert.

    Aber dann müsste es doch schon lange ein WordPress-Update gegeben haben.

    Ist das noch nicht aufgefallen?

    Moderator Bego Mario Garde

    (@pixolin)

    Das ist wohl irgendwie falsch angekommen.

    WordPress hat die Unterstützung technisch veralteter JavaScript-Bibliotheken nach einer Ankündigung aufgegeben. Viele Theme- und Plugin-Entwickler haben das bisher ignoriert und die Benutzer hatten dadurch nach dem Update ein mehr oder weniger großes Problem.

    Als zusätzliches Hilfsangebot hat die WordPress-Community das Plugin Enable jQuery Migrate Helper zur Verfügung gestellt, das als Workaround verwendet werden kann, bis der Theme- oder Plugin-Entwickler nachgessert hat. Schau mal, ob es für dein Theme bereits ein Update gibt – aber so steht es ja auch im Hinweis, der dir im Dashboard angezeigt wird, wenn du Enable jQuery Migrate Helper installiert hast.

    Es wäre nett, wenn du den Thread als „gelöst“ markierst, wenn dein Problem behoben wurde.

Ansicht von 3 Antworten - 1 bis 3 (von insgesamt 3)