Support » Allgemeine Fragen » Fatal error

  • Gelöst tacworkhoffmann

    (@tacworkhoffmann)


    Hallo Zusammen,
    nach der Installation Yoast SEO und empfohlene AMP ist komplett alles abgesturtzt.

    Außerdem der Aktualesierung der Plugins gehen gar nicht.

    Ich hoffe mir kann jemande helfen

    Fatal error: Allowed memory size of 268435456 bytes exhausted (tried to allocate 262144 bytes) in /homepages/43/d830301714/htdocs/clickandbuilds/TacticalWorkshops/wp-content/plugins/woocommerce/includes/wc-page-functions.php on line 53

    Fatal error: Allowed memory size of 268435456 bytes exhausted (tried to allocate 262144 bytes) in /homepages/43/d830301714/htdocs/clickandbuilds/TacticalWorkshops/wp-includes/class-wp-fatal-error-handler.php on line 67

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 7 Antworten - 1 bis 7 (von insgesamt 7)
  • Hallo,
    das heißt so viel wie: WordPress hat zu wenig Arbeitsspeicher.
    Wenn du dich im Dashboard noch anmelden kannst, findest du unter Werkzeuge > Websitezustand > Info einen Bericht zur Website und kannst den Bericht über den Button „Bericht in die Zwischenablage kopieren“ und anschließend hier posten. Evtl. ergeben sich dann weitere Anhaltspunkte, ob und wo das Problem liegt.
    Viele Grüße,
    Hans-Gerd

    Thread-Starter tacworkhoffmann

    (@tacworkhoffmann)

    
    ### wp-core ###
    
    version: 5.4.2
    site_language: de_DE
    user_language: de_DE
    timezone: +00:00
    permalink: /%postname%
    https_status: true
    user_registration: 0
    default_comment_status: open
    multisite: false
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /homepages/43/d830301714/htdocs/clickandbuilds/TacticalWorkshops
    wordpress_size: loading...
    uploads_path: /homepages/43/d830301714/htdocs/clickandbuilds/TacticalWorkshops/wp-content/uploads
    uploads_size: loading...
    themes_path: /homepages/43/d830301714/htdocs/clickandbuilds/TacticalWorkshops/wp-content/themes
    themes_size: loading...
    plugins_path: /homepages/43/d830301714/htdocs/clickandbuilds/TacticalWorkshops/wp-content/plugins
    plugins_size: loading...
    database_size: loading...
    total_size: loading...
    
    ### wp-active-theme ###
    
    name: Storefront (storefront)
    version: 2.5.7 (latest version: 2.5.8)
    author: Automattic
    author_website: https://woocommerce.com/
    parent_theme: none
    theme_features: post-thumbnails, woocommerce, wc-product-gallery-zoom, wc-product-gallery-lightbox, wc-product-gallery-slider, automatic-feed-links, custom-logo, menus, html5, custom-background, custom-header, site-logo, title-tag, customize-selective-refresh-widgets, wp-block-styles, align-wide, editor-styles, editor-font-sizes, editor-style, responsive-embeds, starter-content, widgets
    theme_path: /homepages/43/d830301714/htdocs/clickandbuilds/TacticalWorkshops/wp-content/themes/storefront
    
    ### wp-mu-plugins (1) ###
    
    1&1 Product Subdomain: version: 1.1.0, author: 1&1
    
    ### wp-plugins-active (11) ###
    
    AMP: version: 1.5.5, author: AMP Project Contributors
    Elementor: version: 2.9.13, author: Elementor.com
    Elementor - Header, Footer & Blocks: version: 1.5.1, author: Brainstorm Force, Nikhil Chavan
    Klarna Payments for WooCommerce: version: 2.1.0, author: krokedil, klarna, automattic
    Premium Addons for Elementor: version: 3.20.7, author: Leap13 (latest version: 3.20.8)
    Premium Addons PRO: version: 2.0.4, author: Leap13 (latest version: 2.0.6)
    Really Simple SSL: version: 3.3.4, author: Really Simple Plugins
    WooCommerce: version: 4.3.0, author: Automattic
    WooCommerce Stripe Gateway: version: 4.5.0, author: WooCommerce
    WooLentor - WooCommerce Elementor Addons + Builder: version: 1.6.5, author: HasThemes (latest version: 1.6.6)
    Yoast SEO: version: 14.5, author: Team Yoast
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_GD
    imagick_module_version: Nicht verfügbar
    imagemagick_version: Nicht verfügbar
    gd_version: 2.1.1-dev
    ghostscript_version: 9.26
    
    ### wp-server ###
    
    server_architecture: Linux 4.4.0-ui20086.041-uiabi1-infong-amd64 x86_64
    httpd_software: Apache
    php_version: 7.4.7 64bit
    php_sapi: cgi-fcgi
    max_input_variables: 1000
    time_limit: 30
    memory_limit: 268435456
    max_input_time: -1
    upload_max_size: 67108864
    php_post_max_size: 67108864
    curl_version: 7.38.0 OpenSSL/1.0.1t
    suhosin: false
    imagick_availability: false
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.7.30-log
    client_version: mysqlnd 7.4.7
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /homepages/43/d830301714/htdocs/clickandbuilds/TacticalWorkshops/wp-content
    WP_PLUGIN_DIR: /homepages/43/d830301714/htdocs/clickandbuilds/TacticalWorkshops/wp-content/plugins
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    mu-plugins: writable
    
    ### amp_wp ###
    
    amp_mode_enabled: reader
    amp_templates_enabled: post
    amp_serve_all_templates: Diese Option gilt nicht für den Lesemodus.
    amp_css_transient_caching_disabled: false
    amp_css_transient_caching_threshold: 5000 transients per day
    amp_css_transient_caching_sampling_range: 14 days
    amp_css_transient_caching_transient_count: undefined
    amp_css_transient_caching_time_series: 
    
    

    Leider hast du nicht gewartet, bis die Größe der Ordner komplett eingelesen worden sind, z. B. hier:

    wordpress_path: /homepages/43/d830301714/htdocs/clickandbuilds/TacticalWorkshops
    wordpress_size: loading...
    

    Möglicherweise kannst du mehr Arbeitsspeicher zuweisen (hängt vom Vertrag und Hoster ab):
    Trag doch bitte mal mit einem geeigneten Code-Editor (z.B. VS Code oder Notepad++) in der wp-config.php oberhalb von /* That's all, stop editing! Happy blogging. */ folgende Zeile ein:
    define( 'WP_MEMORY_LIMIT', '512M' );
    Vorher aber bitte die Datei lokal sichern.
    Evtl. hilft es auch, wenn du testweise das eine oder andere Plugin (wie z. B. AMP) deaktivierst.

    Thread-Starter tacworkhoffmann

    (@tacworkhoffmann)

    Hallo Hans-Gerd,

    vielen Dank für diene Hilfe.

    Ich habe die SEO deaktiviert, danach war Welt wieder in Ordnung.
    AMT funktioniert eiwandfrei
    Komisch……
    Soll ich vielleicht mit anderen SEO Plugins probieren…!!???
    Oder wie soll ich meine Webseite an Google-Dienste etc. anbinden.

    MfG

    • Diese Antwort wurde geändert vor 3 Jahren, 9 Monaten von tacworkhoffmann.

    Hallo,
    sonst teste mal Rank Math. Das Plugin setze ich auf einigen Webseiten als Alternative zu YOAST ein.
    Viele Grüße,
    Hans-Gerd

    Thread-Starter tacworkhoffmann

    (@tacworkhoffmann)

    So, ich habe jetzt original WordPress installiert funktioniert momentan super.

    Noch einmal vielen Dank für die Hilfe!!!

    MfG
    TACWORK

    gerne 🙂
    Dann markiere ich das Thema mal als gelöst.

Ansicht von 7 Antworten - 1 bis 7 (von insgesamt 7)
  • Das Thema „Fatal error“ ist für neue Antworten geschlossen.