Support » Allgemeine Fragen » Fatal error

  • Gelöst gruendemitstil

    (@gruendemitstil)


    Hallo,

    ich habe zwei Fehler auf der oben genannten Website.

    Wenn ich in WordPress in Backend eine neue Seite erstellen möchte, erhalte ich diese Fehlermeldung:

    Warning: Attempt to read property "post_type" on null in /homepages/39/d4295622708/htdocs/medicareers/wp-admin/includes/post.php on line 693
    
    Fatal error: Uncaught Error: Attempt to assign property "post_content" on null in /homepages/39/d4295622708/htdocs/medicareers/wp-admin/includes/post.php:732 Stack trace: #0 /homepages/39/d4295622708/htdocs/medicareers/wp-admin/post-new.php(66): get_default_post_to_edit('page', true) #1 {main} thrown in /homepages/39/d4295622708/htdocs/medicareers/wp-admin/includes/post.php on line 732

    Zweiter Fehler – wenn ich die Seite „Kaufmännische Berfe in Gesundheitswesen“ bearbeiten möchte, erhalte ich diese Fehlermeldung:

    atal error: Out of memory (allocated 497549312) (tried to allocate 581632 bytes) in /homepages/39/d4295622708/htdocs/medicareers/wp-includes/wp-db.php on line 2022

    Was soll ich machen? Ich besitze leider keine Programmierkenntnisse und habe die Website mit Hilfe von Elementor erstellt.

    Ein Backup habe ich, aber mein letzter BackUp enthält nicht die Änderungen, die ich vor dem Fehlerauftritt gemacht habe. Ich habe nicht geschafft ein neues Backup zu machen. Deswegen ist es wichtig, dass die Änderungen erhalten bleiben.

    Ich wäre für die Hilfe sehr dankbar.

    Liebe Grüße
    Anna

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 19)
  • Hallo,
    du findest unter Werkzeuge > Websitezustand > Info einen Bericht zur Website. Warte bitte einen Moment bis die Ladeanzeige ganz oben abgeschlossen ist und kopiere dann per Button den Website-Bericht in deine Zwischenablage. Über den Button „Bericht in die Zwischenablage kopieren“ kannst du den Bericht unverändert (bitte mit den Akzentzeichen am Anfang und Ende) einfügen und anschließend hier posten. Evtl. ergeben sich dann weitere Anhaltspunkte, ob und wo das Problem liegt.
    Viele Grüße
    Hans-Gerd

    Thread-Starter gruendemitstil

    (@gruendemitstil)

    
    ### wp-core ###
    
    version: 5.7.2
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Berlin
    permalink: /%year%/%monthnum%/%day%/%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: open
    environment_type: production
    user_count: 2
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /homepages/39/d4295622708/htdocs/medicareers
    wordpress_size: 46,51 MB (48764979 bytes)
    uploads_path: /homepages/39/d4295622708/htdocs/medicareers/wp-content/uploads
    uploads_size: 106,45 kB (109005 bytes)
    themes_path: /homepages/39/d4295622708/htdocs/medicareers/wp-content/themes
    themes_size: 13,41 MB (14057414 bytes)
    plugins_path: /homepages/39/d4295622708/htdocs/medicareers/wp-content/plugins
    plugins_size: 27,35 MB (28679350 bytes)
    database_size: 916,28 MB (960790528 bytes)
    total_size: 1.003,65 MB (1052401276 bytes)
    
    ### wp-active-theme ###
    
    name: Mein Child Theme (oceanwp-child)
    version: 1.0
    author: Kreativbüro Annika Gievers
    author_website: https://oceanwp.org/
    parent_theme: OceanWP (oceanwp)
    theme_features: core-block-patterns, align-wide, wp-block-styles, responsive-embeds, editor-styles, editor-style, menus, post-formats, title-tag, automatic-feed-links, post-thumbnails, custom-header, custom-logo, html5, woocommerce, wc-product-gallery-zoom, wc-product-gallery-lightbox, wc-product-gallery-slider, customize-selective-refresh-widgets, widgets
    theme_path: /homepages/39/d4295622708/htdocs/medicareers/wp-content/themes/oceanwp-child
    auto_update: Deaktiviert
    
    ### wp-parent-theme ###
    
    name: OceanWP (oceanwp)
    version: 2.1.1
    author: Nick
    author_website: https://oceanwp.org/about-me/
    theme_path: /homepages/39/d4295622708/htdocs/medicareers/wp-content/themes/oceanwp
    auto_update: Deaktiviert
    
    ### wp-plugins-active (6) ###
    
    coveto.de Beispiel Plugin: version: 1.1, author: coveto.de, Christian Asche, Automatische Aktualisierungen deaktiviert
    Elementor: version: 3.2.5, author: Elementor.com, Automatische Aktualisierungen deaktiviert
    Elementor Pro: version: 3.3.1, author: Elementor.com, Automatische Aktualisierungen deaktiviert
    IgniteUp: version: 3.4.1, author: Ceylon Systems, Automatische Aktualisierungen deaktiviert
    UpdraftPlus - Backup/Restore: version: 1.16.56, author: UpdraftPlus.Com, DavidAnderson, Automatische Aktualisierungen deaktiviert
    Yoast SEO: version: 16.6, author: Team Yoast, Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-inactive (1) ###
    
    WP Super Cache: version: 1.7.3, author: Automattic, Automatische Aktualisierungen deaktiviert
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_GD
    imagick_module_version: Nicht verfügbar
    imagemagick_version: Nicht verfügbar
    file_uploads: File uploads is turned off
    post_max_size: 64M
    upload_max_filesize: 64M
    max_effective_size: 64 MB
    max_file_uploads: 20
    gd_version: 2.2.5
    ghostscript_version: 9.27
    
    ### wp-server ###
    
    server_architecture: Linux 4.4.262-icpu-066 x86_64
    httpd_software: Apache
    php_version: 8.0.7 64bit
    php_sapi: cgi-fcgi
    max_input_variables: 5000
    time_limit: 50000
    memory_limit: -1
    max_input_time: -1
    upload_max_filesize: 64M
    php_post_max_size: 64M
    curl_version: 7.64.0 OpenSSL/1.1.1d
    suhosin: false
    imagick_availability: false
    pretty_permalinks: true
    htaccess_extra_rules: false
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.7.33-log
    client_version: mysqlnd 8.0.7
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /homepages/39/d4295622708/htdocs/medicareers/wp-content
    WP_PLUGIN_DIR: /homepages/39/d4295622708/htdocs/medicareers/wp-content/plugins
    WP_MEMORY_LIMIT: 40M
    WP_MAX_MEMORY_LIMIT: -1
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8mb4
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    

    Hallo,
    das könnte mit memory_limit zusammenhängen und beispielsweise durch eine Änderung in der wp-config.php geändert werden:
    define('WP_MEMORY_LIMIT', '256M');

    Möglicherweise kannst du mehr Arbeitsspeicher zuweisen (hängt vom Vertrag und Hoster ab):
    Trag doch bitte mal mit einem geeigneten Code-Editor (z.B. VS Code oder Notepad++) in der wp-config.php oberhalb von /* That's all, stop editing! Happy blogging. */ folgende Zeile ein:
    define( 'WP_MEMORY_LIMIT', '512M' );
    Vorher aber bitte die Datei lokal sichern.
    Viele Grüße
    Hans-Gerd

    ### wp-server ###
    memory_limit: -1

    Da wird der Hoster dicht machen

    allocated 497549312

    Das sind schon knapp 475 MB

    Thread-Starter gruendemitstil

    (@gruendemitstil)

    @bscu

    Hallo, kannst du bitte ausführlicher erklären, was das bedeutet? Was du damit gemeint hast?

    LG

    Eigentlich bedeutet

    ### wp-server ###
    memory_limit: -1

    das es kein Memory-Limit für PHP gibt. Der Hoster hat aber trotzdem noch die Möglichkeit, das Limit einzuschränken. Um dieses Problem zu beseitigen, musst du deinen Hoster kontaktieren und ihn bitten, das Memory-Limit zu erhöhen.

    Allerdings halte ich 475 MB schon für recht viel, ist die Frage, wer verbraucht so viel Speicher? Kann ich dir leider nicht sagen.

    Und noch ein Hinweis: PHP 8.x würde ich noch nicht einsetzen, nicht alle Plugins kommen schon damit zurecht.

    • Diese Antwort wurde geändert vor 1 Jahr, 5 Monaten von bscu.
    Thread-Starter gruendemitstil

    (@gruendemitstil)

    Vielen Dank für eure Hilfe.

    Also, ich habe Memori-Limit beim Hoster auf 512M erhöht und PHP auf 7.3 geändert.

    in das Fenster „neue Seite erstellen“ komme ich rein. Aber es sind trotzdem diese Fehlern vorhanden:

    Warning: Creating default object from empty value in /homepages/39/d4295622708/htdocs/medicareers/wp-admin/includes/post.php on line 732
    
    Warning: Cannot modify header information - headers already sent by (output started at /homepages/39/d4295622708/htdocs/medicareers/wp-admin/includes/post.php:732) in /homepages/39/d4295622708/htdocs/medicareers/wp-admin/admin-header.php on line 9
    
    Warning: Invalid argument supplied for foreach() in /homepages/39/d4295622708/htdocs/medicareers/wp-content/plugins/wordpress-seo/admin/metabox/class-metabox.php on line 1067

    Wenn ich eine neue Seite erstelle habe ich die Meldung „Du bearbeitest gerade die Seite, die deine letzten Beiträge anzeigt.“

    Und dann wenn ich auf „Speichern“ klicke, erhalte ich diese Meldung „Du bist leider nicht berechtigt, diesen Beitrag zu bearbeiten.“

    Vielen Dank für eure Hilfe.

    Thread-Starter gruendemitstil

    (@gruendemitstil)

    
    ### wp-core ###
    
    version: 5.7.2
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Berlin
    permalink: /%year%/%monthnum%/%day%/%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: open
    environment_type: production
    user_count: 2
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /homepages/39/d4295622708/htdocs/medicareers
    wordpress_size: 46,51 MB (48764979 bytes)
    uploads_path: /homepages/39/d4295622708/htdocs/medicareers/wp-content/uploads
    uploads_size: 106,45 kB (109005 bytes)
    themes_path: /homepages/39/d4295622708/htdocs/medicareers/wp-content/themes
    themes_size: 13,41 MB (14057414 bytes)
    plugins_path: /homepages/39/d4295622708/htdocs/medicareers/wp-content/plugins
    plugins_size: 27,35 MB (28679350 bytes)
    database_size: 916,28 MB (960790528 bytes)
    total_size: 1.003,65 MB (1052401276 bytes)
    
    ### wp-active-theme ###
    
    name: Mein Child Theme (oceanwp-child)
    version: 1.0
    author: Kreativbüro Annika Gievers
    author_website: https://oceanwp.org/
    parent_theme: OceanWP (oceanwp)
    theme_features: core-block-patterns, align-wide, wp-block-styles, responsive-embeds, editor-styles, editor-style, menus, post-formats, title-tag, automatic-feed-links, post-thumbnails, custom-header, custom-logo, html5, woocommerce, wc-product-gallery-zoom, wc-product-gallery-lightbox, wc-product-gallery-slider, customize-selective-refresh-widgets, widgets
    theme_path: /homepages/39/d4295622708/htdocs/medicareers/wp-content/themes/oceanwp-child
    auto_update: Deaktiviert
    
    ### wp-parent-theme ###
    
    name: OceanWP (oceanwp)
    version: 2.1.1
    author: Nick
    author_website: https://oceanwp.org/about-me/
    theme_path: /homepages/39/d4295622708/htdocs/medicareers/wp-content/themes/oceanwp
    auto_update: Deaktiviert
    
    ### wp-plugins-active (5) ###
    
    coveto.de Beispiel Plugin: version: 1.1, author: coveto.de, Christian Asche, Automatische Aktualisierungen deaktiviert
    Elementor: version: 3.2.5, author: Elementor.com, Automatische Aktualisierungen deaktiviert
    Elementor Pro: version: 3.3.1, author: Elementor.com, Automatische Aktualisierungen deaktiviert
    IgniteUp: version: 3.4.1, author: Ceylon Systems, Automatische Aktualisierungen deaktiviert
    Yoast SEO: version: 16.6, author: Team Yoast, Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-inactive (2) ###
    
    UpdraftPlus - Backup/Restore: version: 1.16.56, author: UpdraftPlus.Com, DavidAnderson, Automatische Aktualisierungen deaktiviert
    WP Super Cache: version: 1.7.3, author: Automattic, Automatische Aktualisierungen deaktiviert
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_GD
    imagick_module_version: Nicht verfügbar
    imagemagick_version: Nicht verfügbar
    file_uploads: File uploads is turned off
    post_max_size: 8M
    upload_max_filesize: 2M
    max_effective_size: 2 MB
    max_file_uploads: 20
    gd_version: bundled (2.1.0 compatible)
    ghostscript_version: 9.27
    
    ### wp-server ###
    
    server_architecture: Linux 4.4.262-icpu-066 x86_64
    httpd_software: Apache
    php_version: 7.3.28 64bit
    php_sapi: cgi-fcgi
    max_input_variables: 1000
    time_limit: 30
    memory_limit: 512M
    max_input_time: -1
    upload_max_filesize: 2M
    php_post_max_size: 8M
    curl_version: 7.64.0 OpenSSL/1.1.1d
    suhosin: false
    imagick_availability: false
    pretty_permalinks: true
    htaccess_extra_rules: false
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.7.33-log
    client_version: mysqlnd 5.0.12-dev - 20150407 - $Id: 7cc7cc96e675f6d72e5cf0f267f48e167c2abb23 $
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /homepages/39/d4295622708/htdocs/medicareers/wp-content
    WP_PLUGIN_DIR: /homepages/39/d4295622708/htdocs/medicareers/wp-content/plugins
    WP_MEMORY_LIMIT: 40M
    WP_MAX_MEMORY_LIMIT: 512M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8mb4
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    
    Thread-Starter gruendemitstil

    (@gruendemitstil)

    Und wenn ich versuche in Backend WordPress neu zu installieren, geht nicht und ich erhalte diese Meldung:

    „Momentan wird eine andere Aktualisierung durchgeführt“

    Hallo,

    PHP auf 7.3 geändert.

    wenn möglich, solltest du die PHP 7.4 einstellen.
    Installiere doch mal nach einer Sicherung das plugin Health Check & Troubleshooting. Wenn du auf den Button „Problembehandlungsmodus aktivieren“ unter Problembehandlung klickst, werden alle plugins deaktiviert und als Standardtheme (wenn vorhanden) twenty twenty oder Twenty Twenty-One aktiviert. Dann kannst du sehen, ob die beschriebenen Probleme noch weiterhin auftauchen. Aktiviere dann Plugin für Plugin im Problembehandlungsmodus und schaue jeweils nach Aktivierung eines Plugins, ob das Problem noch besteht. Auf diese Weise kannst du möglicherweise ein Plugin finden, dass das Problem verursacht. Vorteil dabei ist, dass Besucher deine Webseite mit allen Infos und plugins sehen, während nur für dich alle plugins deaktiviert sind.
    Lies dir dazu bitte auch mal die Informationen in dem Beitrag zu Health Check durch.
    Noch ein Hinweis: Bei kostenpflichtigen Plugins (hier Elementor Pro) können wir dir nicht helfen, weil uns das Plugin nicht zur Verfügung steht. Ich setze Elementor aus gewissen Gründen nicht ein, sondern nutze fast ausschließlich den Block-Editor (Gutenberg).
    Viele Grüße
    Hans-Gerd

    Thread-Starter gruendemitstil

    (@gruendemitstil)

    @hage Vielen Dank. Ich versuche mit diesem plugin.

    Ich habe allerdings alle plugins ausgeschaltet und dann versucht die neue Seite zu erstellen. Das ging auch nicht.

    Verursacher ist Elementor, aber die Folgen sind, vermute ich, etwas in Datenbank beschädigt wurde. Aber ich weißt das nicht genau.

    Aber ich versuche mit dem plugin Health Check & Troubleshootingden Fehler zu suchen.

    Verursacher ist Elementor …

    Du verwendest die Pro-Version. Soll ich mir die jetzt kaufen, um nach den wenigen Angaben eine Website nachzubauen und den Fehler möglicherweise zu reproduzieren?

    Eigentlich schließen wir an dieser Stelle die Threads mit Verweis auf die Forenregeln („kein Support für gekaufte Themes und Plugins“). Vielleicht lässt sich der Fehler aber weiter eingrenzen, wenn du den Problembehandlungsmodus im Plugin Health Check nutzt. Liegt es dann tatsächlich an Elementor, solltest du dich an die Entwickler wenden. Die hast du bereits bei Kauf des Plugins für Support bezahlt.

    Thread-Starter gruendemitstil

    (@gruendemitstil)

    Ich glaube, ich habe den Fehler gefunden. Es liegt an der Datenbankgröße. Bei diesem Hoster ist die DB Größe auf 1 GB (habe ich sowas noch nie gesehen) begrenzt und wenn ich die Website Daten anschaue, übersteigt das. Ich verstehe nicht, wie kann so eine einfache Seite 1 GB übersteigen?

    Kann jemand mir bitte netterweise erläutern, wieso database_size: 916,28 MB so groß ist???

    ### wp-paths-sizes ###

    wordpress_path: /homepages/39/d4295622708/htdocs/medicareers
    wordpress_size: 46,51 MB (48764979 bytes)
    uploads_path: /homepages/39/d4295622708/htdocs/medicareers/wp-content/uploads
    uploads_size: 106,45 kB (109005 bytes)
    themes_path: /homepages/39/d4295622708/htdocs/medicareers/wp-content/themes
    themes_size: 13,41 MB (14057414 bytes)
    plugins_path: /homepages/39/d4295622708/htdocs/medicareers/wp-content/plugins
    plugins_size: 27,35 MB (28679350 bytes)
    database_size: 916,28 MB (960790528 bytes)
    total_size: 1.003,65 MB (1052401276 bytes)`

    Vielen Dank.

    Hallo,
    das können wir von außen gar nicht beurteilen. Diese Info erhältst du aber, wenn du dir nach Anmeldung im Kundenbereich deines Hosters über phpMyAdmin bei der entsprechenden Datenbank die Tabellen in der Übersicht ansiehst. Da findest du rechts die Spalte „Größe“. Hier kannst du dann schon einen ersten Hinweis erhalten, welche Tabellen(n) für die Größe deiner Datenbank verantwortlich sind.
    Viele Grüße
    Hans-Gerd

    Thread-Starter gruendemitstil

    (@gruendemitstil)

    Hallo,

    vielen Dank für den Hinweis. Ich habe aufgemacht und geschaut. Die größten Tabellen sind:

    wp_postmeta 482 MiB
    wp_post 430 MiB

    Was steckt da drin? Die Website besteht nur aus Bildern, die ich verkleinert habe und Texten. Woher kommen solche Größen. Ich verstehe nicht. Ich wäre sehr dankbar für eure Hilfe.

    LG
    Anna

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 19)
  • Das Thema „Fatal error“ ist für neue Antworten geschlossen.