Support » Themes » Fehldarstellung auf Site (mit TT4) – CSS nicht geladen oder falscher Block ?

  • Gelöst 24jobs

    (@24jobs)


    Hallo – guten Tag,

    ich habe gerade den wp-jobmanager auf einem frisch installierten WordPress hinzugefügt (immer noch: echter Beta-Beta-Status! Sorry)

    die Site: https://www.jobstarter24.de/

    das setup:
    WordPress 6.5.2
    WP-Jobmanager
    Theme Twenty-twenty-four tt4

    Seht, was ich auf der Vorderseite eines WordPress Twenty-Twenty Four-Themes bekomme, wenn ich den [Jobs]-Shortcode hinzufüge

    in der Auflistung einiger Jobs – und außerdem die Kategorieliste – hinzugefügt:
    Frage: Kann es sein dass die CSS nicht sauber geladen werden – denn die Kategorie–Liste, also die Liste mit den Begriffen ordnet diese vertikal (!!) an.
    Freelance, part time, Fulltime, Internship usw. usf. Das ist doch iwie merkwürdig oder!?

    Hmm _ also so siehts komisch aus würde ich mals sagen:
    Ausschalten, oder abschalten kann ich das wohl nicht, Hmm – wäre großartig, wenn ich die Anzeige dieser Begriffe ausschalten könnte.
    Aber es kann auch sein dass die CSS des Plugins nicht sauber geladen werden!?

    Normale Ansicht: – so sollte das sein

    Falsche Darstellung – so ists bei mir:

    komisch oder

    die stylesheets: wp-content/plugins/wp-job-manager/assets/dist/css/frontend.css die für das verantwortlich sind

    Die andere Annahme: kann es denn sein, dass ich mit meinem rudimentären TT4 Wissen, diese Jobs-Ansicht einfach in einen so engen Block „hineingepackt“ habe,
    dass es gar nicht anders geht – und dass dann eben diese o.g. _Kategorien notwendig vertikal aufgeloest und dargestellt werden.

    wie würdet ihr hier vorgehen.

    hmm – ich kanns ja auch noch ausprobieren, und mit einem anderen Theme testen. Das fällt mir gerade noch ein. Muss jetzt auf den Zug. Das werde ich aber auf alle Fälle
    heute Abend auch noch machen.

    hmm – freue mich auf einen Tipp

    euch allen noch einen schönen Einstieg ins WE – ich guck heut Abend wieder rein.. VG

    Hier noch die SiteHealth-Daten:

    ### wp-core ###
    
    version: 6.5.2
    site_language: en_US
    user_language: en_US
    timezone: +00:00
    permalink: /index.php/%year%/%monthnum%/%day%/%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: open
    environment_type: production
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /sites/www.jobstarter24.de
    wordpress_size: loading...
    uploads_path: /sites/www.jobstarter24.de/wp-content/uploads
    uploads_size: loading...
    themes_path: /sites/www.jobstarter24.de/wp-content/themes
    themes_size: loading...
    plugins_path: /sites/www.jobstarter24.de/wp-content/plugins
    plugins_size: loading...
    database_size: loading...
    total_size: loading...
    
    ### wp-active-theme ###
    
    name: Twenty Twenty-Four (twentytwentyfour)
    version: 1.0 (latest version: 1.1)
    author: the WordPress team
    author_website: https://wordpress.org
    parent_theme: none
    theme_features: core-block-patterns, post-thumbnails, responsive-embeds, editor-styles, html5, automatic-feed-links, widgets-block-editor, block-templates
    theme_path: /sites/www.jobstarter24.de/wp-content/themes/twentytwentyfour
    auto_update: Disabled
    
    ### wp-themes-inactive (2) ###
    
    Twenty Twenty-Three: version: 1.3, author: the WordPress team (latest version: 1.4), Auto-updates disabled
    Twenty Twenty-Two: version: 1.6, author: the WordPress team (latest version: 1.7), Auto-updates disabled
    
    ### wp-plugins-active (1) ###
    
    WP Job Manager: version: 2.2.2, author: Automattic, Auto-updates disabled
    
    ### wp-plugins-inactive (5) ###
    
    Akismet Anti-spam: Spam Protection: version: 5.3, author: Automattic - Anti-spam Team (latest version: 5.3.2), Auto-updates disabled
    Contact Form 7: version: 5.9.3, author: Takayuki Miyoshi, Auto-updates disabled
    GDPR Cookie Compliance: version: 4.13.4, author: Moove Agency, Auto-updates disabled
    Hello Dolly: version: 1.7.2, author: Matt Mullenweg, Auto-updates disabled
    Restricted Site Access: version: 7.5.0, author: 10up, Auto-updates disabled
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1656
    imagemagick_version: ImageMagick 6.7.8-8 2014-11-13 Q16 http://www.imagemagick.org
    imagick_version: 3.7.0
    file_uploads: 1
    post_max_size: 64M
    upload_max_filesize: 64M
    max_effective_size: 64 MB
    max_file_uploads: 32
    imagick_limits: 
    	imagick::RESOURCETYPE_AREA: 8 GB
    	imagick::RESOURCETYPE_DISK: 1.844674407371E+19
    	imagick::RESOURCETYPE_FILE: 3072
    	imagick::RESOURCETYPE_MAP: 8 GB
    	imagick::RESOURCETYPE_MEMORY: 4 GB
    	imagick::RESOURCETYPE_THREAD: not available
    	imagick::RESOURCETYPE_TIME: 1.844674407371E+19
    imagemagick_file_formats: Unable to determine
    gd_version: bundled (2.1.0 compatible)
    gd_formats: GIF, PNG, BMP
    ghostscript_version: unknown
    
    ### wp-server ###
    
    server_architecture: unknown
    httpd_software: Apache
    php_version: 7.4.28 64bit
    php_sapi: apache2handler
    max_input_variables: 1000
    time_limit: 600
    memory_limit: 512M
    max_input_time: 60
    upload_max_filesize: 64M
    php_post_max_size: 64M
    curl_version: not available
    suhosin: false
    imagick_availability: true
    pretty_permalinks: true
    htaccess_extra_rules: false
    current: 2024-04-10T12:50:50+00:00
    utc-time: Wednesday, 10-Apr-24 12:50:50 UTC
    server-time: 2024-04-10T12:50:46+00:00
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.5.33
    client_version: mysqlnd 7.4.28
    max_allowed_packet: 1048576
    max_connections: 64
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /sites/www.jobstarter24.de/wp-content
    WP_PLUGIN_DIR: /sites/www.jobstarter24.de/wp-content/plugins
    WP_MEMORY_LIMIT: 40M
    WP_MAX_MEMORY_LIMIT: 512M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_ENVIRONMENT_TYPE: Undefined
    WP_DEVELOPMENT_MODE: undefined
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    
Ansicht von 5 Antworten - 1 bis 5 (von insgesamt 5)
  • bscu

    (@bscu)

    Bei mir stehen Freelance, Full Time, Internship, Part Time und Temporary auf einer Höhe, also eigentlich alles gut.

    Moderator Hans-Gerd Gerhards

    (@hage)

    Hallo,
    ich sehe das ähnlich wie @24jobs und nicht wie @bscu 🤔

    Ich vermute, dass die Darstellung per CSS etwas geändert wurde.

    Hier ein Ansatz für eine mögliche Anpassung in der gewünschten Art. Füge bitte die folgenden CSS-Regel unter Design > Customizer > Zusätzliches CSS am Ende ein und teste dann bitte, ob es funktioniert:

    .search_jobs {
        display: flex;
        column-gap: 20px;
    }
    
    ul.job_types {
        display: flex;
        column-gap: 20px;
    }

    Welche Shortcodes möglich sind, findest du auf der folgenden Seite: https://wpjobmanager.com/document/advanced-usage/shortcode-reference/#top

    Eine weitere Möglichkeit besteht darin, dass du dich an den Support des Plugins wendest.

    Viele Grüße
    Hans-Gerd

    Thread-Starter 24jobs

    (@24jobs)

    hallo @hage – hallo @bscu

    (Bin im Mom. etwas in Eile).

    vielen dank für Eure Rückmeldung – und für die tollen Tipps. Danke dir ganz besonders Hans Gerd für den CSS.
    Das werde ich gleich heute Abend ausprobieren – melde mich danach wieder.
    Vielen vielen Dank für euren überragenden Support hier – ihr seid WordPress-Helden …

    Ich empfehl euch immer weiter…

    Herzliche Grüße
    24jobs..

    Thread-Starter 24jobs

    (@24jobs)

    hallo @hage 😉

    vielen vielen Dank – das war mal wieder ein Volltreffer: Genauso wie du das beschrieben hast wars – und dein Custom-CSS hat geholfen.

    vgl. hier: https://imgur.com/a/AQvVhAv

    Eine Ansicht – nach dem Einfügen des Customized CSS

    vielen vielen DANK. – ich kann nun weitermachen u die Seite einrichten.
    Dabei geh ich Schritt für Schritt vor.

    Das ists- euer Forum ist eines der coolsten Orte im ganzen WordPress-Kosmos. Support der auf den Punkt kommt u. noch dazu sooo freundlich.

    vielen vielen Dank für deinen Tipp heut – und so oft schon!
    BTW: ich markiere den Thread als gelöst…

    Vielen Dank Dir, Hans Gerd – dir und allen hier wünsche ich ein schönes Wochenende

    viele Grüße 24jobs

    Moderator Hans-Gerd Gerhards

    (@hage)

    Hallo @24jobs
    super – freut uns. Danke für die Rückmeldung und “Gelöst”-Markieren. 👍
    Viele Grüße und einen schönen Sonntag
    Hans-Gerd

Ansicht von 5 Antworten - 1 bis 5 (von insgesamt 5)