Support » Installation » Fehler 500, kein WP-Login mehr möglich!

  • Gelöst d00mster2

    (@d00mster2)


    Hallo zusammen!

    Ich habe seit gestern ein großes Problem:

    Wenn ich mich in den Admin-Bereich unter meinedomain.de/wp-login.php einloggen möchte, versucht der Server lange Zeit eine Verbindung aufzubauen. Letztendlich scheitert es dann mit der Fehlermeldung:

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, service@webmailer.de and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Ich habe bei meinem Provider (Strato) angerufen, die können nichts machen und geben dem „Fremd“programm WordPress die Schuld.

    Der Rest der Webseite funktioniert (Links, Theme usw.). Natürlich kann ich auch keine Beiträge mehr moderieren, da irgendetwas mit dem wp-admin wohl nicht stimmt. Also auch die Moderationslinks in den Emails funktionieren nicht.

    Habe schon folgendes mit negativem Ergebnis versucht:

    – umbenennen des Ordners plugins, Einlogg-Versuch – NEGATIV
    – wp-admin und wp-includes neu aufgespielt von einer jungfräulichen WP-Version – NEGATIV
    – Strato fragen – NEGATIV

    Habt ihr eine Idee, was ich machen kann und woran es liegen könnte? Bin für jede Idee dankbar!

    Danke schonmal vorab

Ansicht von 15 Antworten - 16 bis 30 (von insgesamt 44)
  • Moderator PraetorIM

    (@praetorim)

    Habe den Code „define( ‚WP_MAX_MEMORY_LIMIT‘, ‚256M‘ );“

    Da ist ein Fehler in Deiner Eingabe, Du hast aus den Anführungszeichen Kommas gemacht. Richtig ist, wie oben beschrieben, define('WP_MEMORY_LIMIT', '256M');

    Moderator PraetorIM

    (@praetorim)

    Ansonsten versuche die beschriebene dritte Alternative.

    Flower33

    (@flower33)

    @d00mster2
    War mir (danke, praetorIM!) gar nicht aufgefallen, dass du den von mir angegebenen Code falsch übernommen hast.
    Wenn hier von den Helfern korrekt ausgezeichneter Code (also auf grau hinterlegtem Hintergrund) angegeben wird, dann diesen bitte nicht abtippen oder irgendwo zwischenspeichern, sondern per Copy/Paste direkt in die entsprechende Datei kopieren.

    Die Umsetzung der bisher vorgeschlagenen Schritte und den jeweiligen Code könntest du also noch mal auf ihre Richtigkeit überprüfen.

    Mittlerweile haben wir die üblichen Troubleshooting-Schritte für diesen Fehler ja so ziemlich durchgeackert. Eher ungewöhnlich, dass die Fehlerursache immer noch nicht gefunden wurde.

    Was mir ansonsten noch so einfällt:

    (1)
    Das Löschen des Ordners cgi-data hast du ja erst ziemlich spät „gestanden“ (ist wohl nicht der Grund für dein Problem).
    Gibt es weitere eigenhändige Eingriffe im Zeitraum des Fehlerauftretens, die dir nachträglich einfallen?

    (2)
    Was noch gar nicht zur Sprache kam: Bist du testweise mal auf eines der Standard-Themes, wie z.B. Twenty-Sixteen, gewechselt? Der Fehler könnte ja auch beim Theme liegen.
    Dazu erst dafür sorgen, dass im Verzeichnis wp-content/themes auch tatsächlich ein Standard-Theme liegt. Anschließend deinen aktuellen, in wp-content/themes befindlichen, Theme-Ordner wp-content/themes/dein-theme per FTP umbenennen, sodass WordPress automatisch auf das Standard-Theme umschaltet.
    Cache löschen und erneut testen.

    (3)
    Kannst du jetzt doch mal alle Plugins aufzählen, die aktuell im Einsatz sind?

    (4)
    Hast du nach dem Ersetzen von Dateien (wp-config.php etc.) Cache und Cookies gelöscht?

    • Diese Antwort wurde geändert vor 4 Jahre von Flower33.
    Moderator Bego Mario Garde

    (@pixolin)

    Kurzer Hinweis: Die neue Forensoftware scheint uns hier einen Streich zu spielen, indem doppelte und einfache Anführungszeichen (‚Hochkomma‘) in typographische „Anführungszeichen“ konvertiert werden. Lediglich bei Code, der in Gravis („Backticks“) gesetzt wird, werden die Hochkommas nicht konvertiert:

    
    define( 'RELOCATE', true );
    
    d00mster2

    (@d00mster2)

    @flower33:

    (1)
    Das gleiche gilt für den Ordner „cgi-bin“. Auch diesen hatte ich mal aus Versehen gelöscht, aber wieder aus einem älteren Backup VOR dem Problem widerhergestellt.

    (2)
    Wenn ich mein Theme per ftp umbenenne, erschient lediglich eine weiße Seite mit der domain als URL. Keine Fehlermeldung, nichts. Wenn ich das Theme wieder umbenenne, funktioniert wieder alles (bis auf mein Problem eben…). Oder muss ich das erst irgendwo einstellen, dass das Standard-Theme geladen wird?

    (3)
    Meine Plugins:
    – akismet
    – all in one seo pack
    – antispam-bee
    – cookie-notice
    – google sitemap generator
    – wp-optimize (noch nie benutzt)
    – wp-social-sharing

    (4)
    Habe bislang die Cookies und den Cache nicht gelöscht, sondern die Seite immer nur aktualisiert bzw. neu geladen. Habe heute beides gelöscht, das Problem besteht nach wie vor.

    @all:

    Auch die bisherigen Umsetzungen eurer Ratschläge habe ich nochmal gecheckt, hat alles nichts gebracht. Sowas hab ich noch nie erlebt…

    d00mster2

    (@d00mster2)

    Letztendlich wiederholt sich immer nur der Fehler

    „09.08.2016 17:13:48 meinedomain.de [client XX.XXXX.XXX] Premature end of script headers: wp-login.php“

    aus dem Server-Logg. Daran liegt es, aber keine Ahnung wie ich das beheben kann.

    d00mster2

    (@d00mster2)

    Sollten alle Stricke reißen und ich würde WP komplett neu installieren: Kann ich meine Posts, Seiten und Beiträge irgendwie retten ohne die Gefahr einzugehen, das Problem auch wieder zu importieren?!

    • Diese Antwort wurde geändert vor 4 Jahre von d00mster2.
    Moderator PraetorIM

    (@praetorim)

    Wenn ich mein Theme per ftp umbenenne, erschient lediglich eine weiße Seite mit der domain als URL. Keine Fehlermeldung, nichts.

    Schon klar, WP hat halt kein Theme zum anzeigen, daher die leere Startseite. Aber die Frage ist doch: kannst Du Dich dann einloggen?

    Hattest Du bereits einmal dieses ausprobiert:

    Lade Dir von der WordPress-Seite die von Dir genutzte Version von WordPress auf Deinen PC herunter, entpacke das Archiv und lade sowohl die wp-login.php wie auch das gesamte Verzeichnis wp-admin per FTP auf Deinen Webspace hoch (vorher dort bitte die wp-login.php-Datei und das wp-admin-Verzeichnis löschen).

    Flower33

    (@flower33)

    Hallo PraetorIM,

    Wenn ich mein Theme per ftp umbenenne, erschient lediglich eine weiße Seite mit der domain als URL. Keine Fehlermeldung, nichts.

    Schon klar, WP hat halt kein Theme zum anzeigen, daher die leere Startseite. Aber die Frage ist doch: kannst Du Dich dann einloggen?

    nach meinem Verständnis müsste WP eigentlich, sofern, wie von mir oben empfohlen, ein Standard-Theme vorhanden ist, beim Umbenennen des aktuellen Themes dann auf das Standard-Theme zurückfallen, vgl. auch folgende Aussage im Codex:

    Rename the active theme folder (in wp-content/themes) by using FTP. Once renamed, WordPress will revert to using the WordPress Twenty Sixteen theme. When finally logged in, change to a different theme.

    Oder übersehe ich da was?

    • Diese Antwort wurde geändert vor 4 Jahre von Flower33.
    • Diese Antwort wurde geändert vor 4 Jahre von Flower33.
    d00mster2

    (@d00mster2)

    Das Theme twentysixteen ist in dem Verzeichnis, es hat aber NICHT automatisch geladen und mein Theme ersetzt.

    Habe gerade nochmal den Ordner meines Themes umbenannt. Ein Login geht trotzdem nicht. Der bekannte Fehler 500 kommt nach wie vor, auch ohne Theme. Daran dürfte es also auch nicht liegen…

    Habe gerade nochmal die wp-login.php und den ordner wp-admin von einer jungfräulichen Installation per ftp hochgeladen. Keine Änderung, Fehler 500…

    • Diese Antwort wurde geändert vor 4 Jahre von d00mster2.
    Flower33

    (@flower33)

    Da du es nicht ausdrücklich erwähnst: Ist außer deinem Theme tatsächlich noch ein Standard-Theme in wp-content/themes als Fallback-Möglichkeit vorhanden?

    • Diese Antwort wurde geändert vor 4 Jahre von Flower33.
    d00mster2

    (@d00mster2)

    Ja, siehe editierter Beitrag oben.

    Flower33

    (@flower33)

    Das Theme twentysixteen ist in dem Verzeichnis, es hat aber NICHT automatisch geladen und mein Theme ersetzt.

    Ah, danke, das hatte ich übersehen. Das Verhalten passt leider nicht zu dem zitierten Codex-Text.

    Rename the active theme folder (in wp-content/themes) by using FTP. Once renamed, WordPress will revert to using the WordPress Twenty Sixteen theme. When finally logged in, change to a different theme.

    Moderator PraetorIM

    (@praetorim)

    So, ich steige dann jetzt hier zunächst einmal aus. Alle Vorschläge waren bisher im „Blindflug“, da wir keine näheren Angaben haben – abgesehen davon, dass unsere Vorschläge teilweise nicht umgesetzt wurden.

    Sag Bescheid, wenn auch die verbliebenen Vorschläge nicht geholfen haben. Dann benötigen wir allerdings diese Angaben.

    Flower33

    (@flower33)

    PraetorIM, bleibe bitte im Thread, die verschiedensten Tipps und Anweisungen sind ja für einen Nicht-Spezialisten auch gar nicht so leicht umzusetzen. Ich kann da bei d00mster2 keinen bösen Willen oder Unwilligkeit feststellen. 🙂

Ansicht von 15 Antworten - 16 bis 30 (von insgesamt 44)
  • Das Thema „Fehler 500, kein WP-Login mehr möglich!“ ist für neue Antworten geschlossen.