Support » Allgemeine Fragen » Fehler bei Domain-Umzug gemacht, inkl. SSL-Änderung & Plugin-Nutzung Search&Repl

Ansicht von 11 Antworten - 1 bis 11 (von insgesamt 11)
  • Hallo @smyllam und willkommen im Forum,

    erst einmal vielen Dank, dass du dir die Mühe gemacht hast, dein Problem und die bisherigen Arbeitsschritte so ausführlich zu schildern – das ist ganz vorbildlich und ich würde es mir in vielen anderen Threads ähnlich wünschen.

    An einigen Stellen habe ich ein wenig gestutzt, weil ich den Sinn nicht ganz nachvollziehen konnte. Gehen wir das mal im Einzelnen durch?

    Lokales Backup der WP Installation über SFTP
    Auch hier wieder: vorbildlich. Damit bist du schon mal auf der sicheren Seite, was die Dateien angeht. Allerdings vermisse ich das Backup der Datenbank?

    Änderung der Site und Home URL in den WP-Einstellungen von https://www.content-manufaktur.com auf http://www.content-manufaktur.com
    Hier verstehe ich den Zwischenschritt nicht, wenn es doch darum gehen soll, auf content-kabine.com umzuziehen. Eigentlich hättest du gleich die neue URL eingeben können. Oder übersehe ich da etwas?

    Installation des Plugins Search & Replace
    Da gibt es verschiedene. Ich empfehle hier immer wieder gerne Better Search Replace. Welches hast du verwendet?

    Eigentlich auch egal, bei der Nutzung des Plugins geht es ja vor allem darum, die absoluten URLs, die z.B. für bereits eingebundene Mediendateien oder auch eine interne Verlinkung verwendet werden, auszutauschen. Das ist aber erst ein Schritt, den ich mache, wenn die Website schon unter der neuen URL online ist (aber komisch aussieht, weil die Bilder nicht richtig geladen werden).

    Änderung der WordPress-Adresse in WP Einstellungen – Allgemein von http://content-manufaktur.com zu https://content-kabine.com
    Hast du nur die WordPress-Adresse oder auch die Website-URL geändert?

    Die Website-URL sagt soviel wie „wo ist deine Website erreichbar?“, während die WordPress-URL die Auskunft zur Frage „wo liegen deine WordPress-Dateien?“ gibt. Das ist in den meisten Fällen identisch (und nur eine URL zu ändern führt zwangsläufig zu Problemen), kann aber abweichen, wenn du die WordPress-Dateien in einem eigenen Verzeichnis wordpress ablegen möchtest, die URL aber nur https://example.com sein soll (ohne die Angabe des Unterverzeichnisses).

    Seither kann ich mich nicht wieder über den wp-login oder wp-admin.php einloggen.
    Es gibt keine Datei wp-admin.php, sondern ein Verzeichnis wp-admin mit den PHP-Dateien für die Darstellung deines Backend. Rufst du https://example.com/wp-admin/ auf, prüft WordPress zunächst, ob ein Anmelde-Cookie vorliegt und leitet dich anderenfalls zum Anmeldeformular https://example.com/wp-login.php um. Wenn solche Probleme vorkommen, wie du sie schilderst, solltest du immer die Anmeldung über https://example.com/wp-login.php wählen (und dich nicht auf die Weiterleitung verlassen). Dass nun bei Aufruf der nicht existierenden Dateiwp-admin.php keine Fehlerseite „404 – Seite nicht gefunden“ angezeigt wird, bedeutet eigentlich, dass bei der Serverkonfiguration etwas nicht stimmt. Prüf doch bitte nochmal, ob die neue Domain auf das Verzeichnis mit den WordPress-Dateien verweist.

    Kleiner Kunstgriff: erstelle in diesem Verzeichnis eine Datei phpinfo.php mit dem Inhalt <?php phpinfo(); und versuche dann, im Browser http://example.com/phpinfo.php aufzurufen. Du solltest dann Angaben zur PHP-Version sehen. Falls nicht, stimmt mit der Serverkonfiguration etwas nicht – das hat dann garantiert nichts mit WordPress zu tun.

    Ich habe auch das Sicherheitszertifikat letztendlich der alten Adresse wieder zugewiesen, um alles in den ursprünglichen Zustand zu setzen und es dann nochmal mit der alten Adresse probiert. Ebenfalls nicht erfolgreich.
    Das kannst du dann auch mit http://example.com/phpinfo.php und https://example.com/phpinfo.php testen. Soviel ich weiß, wird ein SSL-Zertifikat passend zu einer URL ausgestellt und kann nicht einfach beliebig ausgetauscht werden. Ich kenne die Optionen nicht, die dein Webhoster dir da anbietet, aber es kann einfach sein, dass die Ausstellung und Einbindung eine Weile dauert.

    In der wp-config.php die Zeile eingefügt:
    define('RELOCATE', true);

    Damit arbeite ich sehr gerne und eigentlich bekomme ich die meisten Websites damit schnell ans Laufen. Allerdings musst du dich, nachdem du die Zeile oberhalb von oberhalb von /* That's all, stop editing! Happy blogging. */ eingetragen hast, mit https://neuedomain.com/wp-login.php anmelden.
    Alternativ kannst du natürlich auch einfach mal in der Datenbank schauen, was in Tabelle wp_options unter siteurl und home aktuell eingetragen ist.

    https://content-manufaktur.com/wp-admin.php bzw.
    http://content-manufaktur.com/wp-admin.php
    … gibt’s nicht 🙂
    Da sollte aber, wenn alles richtig eingerichtet ist, eine 404-Fehlermeldung kommen. Also bitte nochmal Serverkonfiguration prüfen.

    https://content-manufaktur.com/wp-login.php = Anmeldemaske wp, nach der Anmeldung wird weitergeleitet zur URL https://content-kabine.com/wp-login.php
    Vermutlich hast du nur eine URL geändert … siehe oben.

    https://content-kabine.com/wp-login.php sowie admin.php = Fehlerseite, keine sichere Verbindung möglich.
    Du versuchst die Seiten per https abzurufen, aber es gibt kein passendes SSL-Zertifikat. Sprich ggf. nochmal mit dem Support deines Webhoster.

    Fatal error: Uncaught Error: [] operator not supported for strings in /homepages/

    Das sieht mir wie eine Fehlermeldung wegen einer falschen PHP-Version aus. Vermutlich kommt das Plugin für den Revolution Slider nicht mit der aktuell gesetzten PHP-Version zurecht. Vgl. https://wordpress.stackexchange.com/questions/260187/how-can-i-fix-fatal-revslider-error-in-dashboard-after-upgrading-to-php-7

    Du könntest das Verzeichnis /wp-content/plugins/revslider mal umbenennen, damit du dich erst einmal auf die anderen Themen konzentrieren kannst.

    Im Moment ist das für dich alles ein wenig mühsam, aber ich denke, das bekommst du auch schnell wieder in den Griff. Dran bleiben … 😉

    Thread-Ersteller smyllam

    (@smyllam)

    Hallo Herr Garde,

    erstmal vielen, vielen Dank für die ausführliche und schnelle Antwort und dass sie sich die Zeit für meine Anfrage nehmen. Das gibt mir wirklich Hoffnung und zahlreiche neue Ansatzpunkte für eine Lösung. Da ich nicht so der Crack bin, muss ich mich tatsächlich nochmal ein bisschen genauer Einlesen in Ihre Nachricht und melde mich baldmöglichst wieder mit den entsprechenden Antworten.

    Herzlichsten Dank soweit!
    Michaela S.

    Alles prima … bis auf das „Sie“. 😀

    Wir verwenden hier, wie in Open Source Communities üblich, das (nicht weniger respektvoll gemeinte) informelle und unkompliziertere „Du“.

    Sag bescheid, wenn’s irgendwo hakt oder Sachen unklar sind.

    Thread-Ersteller smyllam

    (@smyllam)

    Vielen Dank nochmal für die wahnsinnig schnelle und ausführliche Antwort! Die Erklärungen haben mir zudem einiges verständlicher gemacht. Mit folgenden Infos kann ich mich nun zurückmelden:

    Backup über SFTP: Hier hab ich mich vermutlich einfach nur ungünstig ausgedrückt. Denke, mein Backup umfasst auch die Datenbank.

    Änderung der Site und Home URL in den WP-Einstellungen von https://www.content-manufaktur.com auf http://www.content-manufaktur.com: Den Schritt habe ich lediglich gemacht, weil ich erstmal das Sicherheitszertifikat für diese Adresse deaktivieren wollte (wollte es wie beschrieben bei meinem Hoster der neuen URL zuweisen, ohne ein weiteres buchen zu müssen. 1&1 bietet in meinem Vertrag nur ein Inklusiv-Zertifikat an, dass ich aber beliebig zuweisen kann. Wird im Hintergrund bei 1&1 dann sicher entsprechend individuell für die jeweilige Adresse ausgestellt, vermute ich). Daher also der seltsame Zwischenschritt.

    Installation des Plugins Search & Replace:
    Das Plugin, das ich verwendet hab, heißt tatsächlich einfach nur Search & Replace 😉
    https://de.wordpress.org/plugins/search-and-replace

    Änderung der WordPress-Adresse in WP Einstellungen – Allgemein von http://content-manufaktur.com zu https://content-kabine.com
    Hast du nur die WordPress-Adresse oder auch die Website-URL geändert?

    -> Ich befürchte, ich habe tatsächlich im ersten Schritt nur die WP-Adresse geändert und wollte es dann erstmal speichern. Das war dann aber leider auch schon das Ende für den Login.

    Wenn solche Probleme vorkommen, wie du sie schilderst, solltest du immer die Anmeldung über https://example.com/wp-login.php wählen:
    Also diese Variante hatte ich auch in meinem letzten Test probiert. Hier kommt zwar erstmal die Anmeldemaske, aber dann eben die Weiterleitung an die neue URL und der Hinweis, dass keine sichere Verbindung hergestellt werden kann.
    ->Hab aber auch nochmal gecheckt, ob die Domain mit den WordPress Dateien verknüpft ist. Also sprich mit dem entsprechenden Webspace, korrekt? Das ist der Fall.

    Kleiner Kunstgriff: erstelle in diesem Verzeichnis eine Datei phpinfo.php mit dem Inhalt <?php phpinfo(); und versuche dann, im Browser http://example.com/phpinfo.php aufzurufen. Du solltest dann Angaben zur PHP-Version sehen.
    ->Habe ich gemacht und es hat geklappt. Sowohl für die neue als auch für die alte URL. Nur für die URL-Variante https://content-kabine.com ging es nicht, aber da gibt es ja auch kein Zertifikat, also sollte alles passen bei der Serverkonfiguration oder?
    ->Was kann ich denn aus der „Litanei“ dieser phpinfo Seiten evtl. noch für nützliche Infos gewinnen?
    http://content-manufaktur.com//phpinfo.php
    http://content-kabine.com/phpinfo.php
    https://content-manufaktur.com/phpinfo.php

    Alternativ kannst du natürlich auch einfach mal in der Datenbank schauen, was in Tabelle wp_options unter siteurl und home aktuell eingetragen ist.
    :
    -> Konnte ich auch finden. Allerdings ist da soweit ich es sehen kann, nichts eingetragen. Ist das möglich.
    Der Code lautet:
    if ( !is_multisite() ) {
    if ( !defined( ‚WP_SITEURL‘ ) )
    $whitelist_options[‚general‘][] = ’siteurl‘;
    if ( !defined( ‚WP_HOME‘ ) )
    $whitelist_options[‚general‘][] = ‚home‘;

    Ich hoffe, das ist der richtige Ausschnitt.

    Die Error 404 Seite tauchte an den entsprechenden Stellen übrigens auch auf. Einen Fehler in der Serverkonfiguration würde ich daher ausschließen, wenn ich die ganzen Ergebnisse richtig interpretiere.

    Soweit so gut 🙂 Leider weiß ich noch nicht so recht, wie ich nun das Problem mit dem Zugang zum Backend final lösen kann. Ich hoffe, die neuen Ausführungen geben noch ein paar nützliche Hinweise für die Lösung.

    Vielen Dank schon mal!

    Alternativ kannst du natürlich auch einfach mal in der Datenbank schauen, was in Tabelle wp_options unter siteurl und home aktuell eingetragen ist.
    :
    -> Konnte ich auch finden. Allerdings ist da soweit ich es sehen kann, nichts eingetragen. Ist das möglich.
    Der Code lautet:
    if ( !is_multisite() ) {
    if ( !defined( ‚WP_SITEURL‘ ) )

    Du solltest in der Datenbank eine Datenbanktabelle aufrufen, hast aber in einem Verzeichnis eine Datei aufgerufen.

    Thread-Ersteller smyllam

    (@smyllam)

    ok, danke auch diesmal wieder für die schnell Antwort. Das bringt mich in meinem Verständnis auch weiter, aber wenn ich es richtig verstanden habe, war es auch nur eine Alternative, oder?
    Den ersten Ansatz, also die phpinfo Datei habe ich ja erstellen können. Reicht das zur Problemlösung nicht auch aus?

    Also wenn ich weiß, wonach ich in der phpinfo suchen soll, um den Fehler zu lokalisieren, dann würde es mir sehr helfen.

    Vielen Dank schonmal und sorry für die Umstände!

    lg Michaela

    Thread-Ersteller smyllam

    (@smyllam)

    Hallo nochmal,

    also letztendlich hat es tatsächlich nach dem Umbenennen des Verzeichnis /wp-content/plugins/revslider und der Zeile define(‚RELOCATE‘, true); erstmal mit dem login ins backend wieder geklappt. Puh.

    Jetzt muss ich zwar noch das Problem mit dem slider lösen, aber ich komme immerhin schon mal wieder rein.

    Vielen, vielen Dank für den Hinweis. Da hätte ich ja lange suchen können.

    lg

    Das Anlegen der phpinfo.php war nur dazu gedacht, ganz allgemein die Funktionalität des Browsers zu prüfen. (Läuft der Browser? Läuft PHP? Welche PHP-Version? Klappt die Verschlüsselung?

    Als nächstest solltest du die Einträge unter Einstellungen > Allgemein > Website-URL/WordPress-URL prüfen, die zumindest auf die gleiche Domain lauten sollten.

    Thread-Ersteller smyllam

    (@smyllam)

    Ah, verstehe. Danke für die Erklärung!

    Ja, die Einträge habe ich geprüft und entsprechend auf die gleiche Domain angepasst. Das ist soweit behoben.

    Tatsächlich hat es das Revolution Slider Plugin scheinbar erwischt. Da wird noch diese Fatal error Meldung (wie oben beschrieben) angezeigt. Das Plugin kann ich daher derzeit auch nicht mehr aktivieren.

    Allerdings wird mir noch eine andere Warnung permanent im Backend ganz oben angezeigt:

    Warning: count(): Parameter must be an array or an object that implements Countable in /homepages/9/d645282326/htdocs/clickandbuilds/ContentManufaktur/wp-admin/includes/template.php on line 1425

    Hier mal der Auszug aus dem template.php der Zeilen 1424-1426, sofern das was zur Lösung beitragen könnte:

    // Check global in case errors have been added on this pageload.
    if ( ! count( $wp_settings_errors ) )
    return array();

    Gibt es dafür evtl. auch einen „Code“, den ich da eintragen kann? Bzw. was sagt mir die Warnung? Ich konnte leider nichts für diese Spezifische Warnung finden im Netz.

    Traue mich somit auch erstmal nicht, das Update auf die neue WP Version zu machen.

    Danke schon mal und lg

    Thread-Ersteller smyllam

    (@smyllam)

    Noch eine kleine Ergänzung:

    Das Austauschen von Bilddateien in den globalen Theme Optionen wird zwar übertragen, allerdings wird mir nach dem Abspeichern erstmal eine weiße Seite mit folgender Meldung angezeigt:

    Warning: count(): Parameter must be an array or an object that implements Countable in /homepages/9/d645282326/htdocs/clickandbuilds/ContentManufaktur/wp-admin/includes/template.php on line 1425

    Warning: Cannot modify header information – headers already sent by (output started at /homepages/9/d645282326/htdocs/clickandbuilds/ContentManufaktur/wp-admin/includes/template.php:1425) in /homepages/9/d645282326/htdocs/clickandbuilds/ContentManufaktur/wp-includes/pluggable.php on line 1195

    Vielleicht gibt das ja auch nochmal einen Hinweis.
    VG Michaela

    Hallo zusammen;

    ich bin in einer ähnlichen Falle gefangen, bringe aus dem Geschriebenen aber keine Deckung zu meiner Herausforderung.

    Ich habe bei Strato eine Url bestellt und WordPress installiert. Die Seite läuft, alles gut.
    Heute möchte ich den Namen der Seite (und somit der Url) ändern, habe die neue Domain bestellt und bekommen.
    Nun will ich, dass die „alte“ Domain nicht mehr erscheint, also alles über die Neue geleitet wird.

    (BackUp WP via FileZilla und SQL – BackUp via Strato habe ich gemacht)

    Im Strato-Admin, bei der Domain-Verwaltung, kann ich Domain-Umleitungen angeben, die Aktive (und ursprüngliche) zeigt auf /wordpress_01/. Die Neue Domain zeigt noch ins „Nichts“.

    Ich habe verstanden, dass ich sowohl bei Strato (Domain-Umleitungen) als auch bei WP (Einstellungen/Allgemein) Änderungen vornehmen muss. Zudem muss ich die „fest“ verdrahteten Links ebenfalls ersetzen (in den WP – Dateien).
    Soweit richtig?

    In welcher Reihenfolge gehe ich nun vor, ohne mich auszusperren?
    1) Im Strato-Admin / Domain-Verwaltung bei der neuen Domain die Umleitung ebenfalls auf /wordpress_01/ umstellen.
    2) in WP/Einstellungen/Allgemein sowohl WordPress-Adress(URL) als auch Website-Adresse (URL) auf die neue Domain umstellen
    3)Testen: die Domain müsste aufzurufen sein, allerdings werden einige Aufrufe nicht funktionieren
    4) Mit „Better Search Replace“ -Plugin die Links korrigieren.

    Fertig?

    Ich habe mich, wie smyllam, auch schon selber rausgeworfen (i.e.: website war nicht mehr erreichbar… ) und bin nun sehr verunsichert wie ich vorgehen muss (Ich komme wieder rein).

    Ich bin für Hilfe sehr dankbar.

    Gruß, Dirk

    P.S.: Ich habe es, nach BackUps, einfach getan. In Strato die Umleitung für die Neue Domain auf „/wordpress_01/“ (dort befindet sich die Workpressinstallation) eingestellt.
    Dann in WP beide Domains umgestellt.
    Ich musste mich nach Speicher neue einloggen in WP, und zu meiner hellen Begeisterung läuft alles.
    Ich habe nicht mal das Replace – PlugIn laufen lassen.
    Offenbar ist meine Installation sehr geradelinig.

    Daher: Case closed!

    • Diese Antwort wurde geändert vor 3 Jahre, 2 Monaten von Dirk_Staudt.
Ansicht von 11 Antworten - 1 bis 11 (von insgesamt 11)
  • Das Thema „Fehler bei Domain-Umzug gemacht, inkl. SSL-Änderung & Plugin-Nutzung Search&Repl“ ist für neue Antworten geschlossen.