Support » Installation » Fehler bei Multisite – Domainmapping

  • Gelöst matthias58

    (@matthias58)


    Hallo,

    ich versuche eine Multisite einzurichten mit Domainmapping. Ich habe hier im Unterforum einige Threads dazu nachgelesen und Hinweise daraus übernommen und getestet, leider ohne Erfolg.
    Daher bitte ich auf diese Weise um Hilfe.

    Das Ganze ist bei all-inkl gehostet und im Moment eine reine Testumgebung.

    WP wurde unter einer Subdomain installiert: http://wpmulti.malu-city.de/, ist gleichzeitig die Hauptseite.

    Danach erfolgte die Netzwerkeinrichtung nach Vorgaben:

    • Einrichtung mit Unterordnern, also http://wpmulti.malu-city.de/foto als eine „Unterseite“ (ich bezeichne das weiter so zur Unterscheidung)
    • die wp-coonfig.php und die .htaccess wurden mit den Codestücken ergänzt
    • Codeschnipsel gegen den Cookie-Error wurde eingefügt
    • Plugins alle deaktiviert
    • Themes sind 2019 (v. 2.0), 2020 (v. 1.7) und 2021 (v. 1.3) vorhanden, nur 2021 ist netzwerkweit aktiv
    • WP ist Version 5.7.2
    • Bis hierhin lassen sich die Hauptseite und die Unterseite mit Ihren Adressen
      http://wpmulti.malu-city.de/
      und
      http://wpmulti.malu-city.de/foto

      aufrufen. Zur Unterscheidung wurde das Template (Hintergrundfarbe) bei foto etwas geändert, Artikel, Seiten und Überschriften enthalten immer das Wort Foto mit.

      Als nächstes wollte ich das Domainmapping einrichten.
      Ich habe dazu eine freie Domain im gleichen Hosting-Paket bei all-inkl verwendet: http://www.heart-of-phoenix.de. Diese ist mit einer Weiterleitung (Redirect, Status 301) versehen und leitet auf http://wpmulti.malu-city.de/ weiter.

      Unter Netzwerkverwaltung – Websites wähle ich den Eintrag der Unterseite zum Bearbeiten aus.

      Folgende Eintragungen sind vorgenommen:
      Unter Info
      Website-Adresse (URL): http://heart-of-phoenix.de/

      Unter Einstellungen:

      Siteurl: http://wpmulti.malu-city.de/foto/
      Home: http://wpmulti.malu-city.de/foto/

      Der Aufruf von http://heart-of-phoenix.de/ führt damit zur Hauptseite. Browsercache wurde dabei stets zuvor geleert.

      Ich habe auch andere Varianten der vorstehenden URL getestet, ich lande entweder auf der Hauptseite oder einer Meldung „Beitrag nicht gefunden“ (oder so ähnlich).

      Jetzt sind mir die Ideen ausgegangen und bitte hier um Hilfe.

      Vielen Dank!

      Matthias

    • Dieses Thema wurde geändert vor 1 Monat, 2 Wochen von matthias58.
    • Dieses Thema wurde geändert vor 1 Monat, 2 Wochen von matthias58.
    • Dieses Thema wurde geändert vor 1 Monat, 2 Wochen von matthias58.

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 2 Antworten - 1 bis 2 (von insgesamt 2)
  • Wenn du ein Domain-Mappping vornehmen möchtest, ist das Verzeichnis, unter der du die neue Multisite-Website einrichtest, eigentlich herzlich egal. Ich nenne das Verzeichnis aus reiner Faulheit „one“ oder „foo“ oder „bar“ oder … egal. Dann prüfe ich kurz, ob die neue Website unter diesem Verzeichnis erreichbar ist, die Multisite-Einrichtung also funktioniert. Danach richte ich die Domain im Kundenmenü des Webhosters ein und gebe dabei als Web-Stammverzeichnis der Domain das Verzeichnis der allerersten WordPress-Website an (keine! Weiterleitung/Redirect – sonst ist es ja kein Domainmapping). Dann melde ich mich im Backend dieser Website an, gehe auf Netzwerkverwaltung [1] > Websites [2] > Website bearbeiten und ändere im Tab Einstellungen [3] die neu URL der neu eingerichteten Website [4]. Das sollte dann so aussehen:

    Screenshot Einstellungen
    (zum Vergrößern anklicken)

    Das Verzeichnis (wie war das? One? foo? bar?) taucht nirgendwo mehr auf, deshalb auch die Nachlässigkeit bei der Namensvergabe.

    Thread-Ersteller matthias58

    (@matthias58)

    ….und gebe dabei als Web-Stammverzeichnis der Domain das Verzeichnis der allerersten WordPress-Website an (keine! Weiterleitung/Redirect – sonst ist es ja kein Domainmapping)

    Dankeschön, das war’s!
    Das muss ich an anderen Stellen überlesen oder falsch verstanden haben.
    Jetzt klappt das.
    Ich wünsche noch einen schönen Abend!

Ansicht von 2 Antworten - 1 bis 2 (von insgesamt 2)