• Gelöst aleks0208

    (@aleks0208)


    Der Update auf 7.03 (von 6.8.7) bringt einen krtischen Fehler.
    Ich bekomme allerdings keine Mail, wie angegeben.

    Wie kann ich da eingrenzen?

Ansicht von 15 Antworten – 1 bis 15 (von insgesamt 36)
  • Thread-Starter aleks0208

    (@aleks0208)

    Die Webseite läuft problemlos, nur der Update bricht mit dem Fehler ab.

    ml

    Gibt es irgendwelche Fehler (siehe developer console) im Backend oder Frontend?

    Hilfreich für eine Analyse wäre der Website-Bericht:
    Du findest unter Werkzeuge > Website-Zustand > Info einen Bericht zur Website. Warte bitte einen Moment bis die Ladeanzeige ganz oben abgeschlossen ist und kopiere dann per Button den Website-Bericht in deine Zwischenablage. Über den Button „Bericht in die Zwischenablage kopieren“ kannst du den Bericht unverändert (bitte mit den Akzentzeichen am Anfang und Ende) einfügen und anschließend hier posten. Evtl. ergeben sich dann weitere Anhaltspunkte, ob und wo das Problem liegt.
    Hier ein Screenshot dazu (bei Klick auf das Bild, wird das Bild vergrößert):
    Website-Bericht

    Und mit z. B. STRG V in die Antwort bei diesem Thema einfügen.

    Mehr Infos zum Website-Zustand findest du z. B. in dem folgenden Video

    Hilfreich könnte auch die Aktivierung des Debug-Modus sein. Damit Fehler ausgelesen werden können, müssen die Fehler in eine Log-Datei auf dem Server geschrieben werden, auf die man dann per FTP (oder auch SSH) zugreifen kann.
    Sichere bitte zunächst die wp-config.php auf deinem lokalen Rechner.
    Gib dann bitte mit einem geeigneten Programmier-Editor (z. B. Notepad++) in der wp-config.php oberhalb von /* That's all, stop editing! Happy blogging. */ folgendes ein:

    define( 'WP_DEBUG', true );
    define( 'WP_DEBUG_DISPLAY', false);
    define( 'WP_DEBUG_LOG', true );

    Achte darauf, dass du define('WP_DEBUG', false); überschreibst, falls die Zeile bereits in der wp-config.php steht. Wenn versucht wird, diese Konstante ein zweites mal zu definieren, gibt es einen Fehler, der deine Seite lahmlegen würde.
    Mit diesen drei Codezeilen sagen wir WordPress, dass der Debug-Modus aktiviert werden soll. Die Fehlermeldungen sollen aber nicht direkt angezeigt werden, sondern in die Datei /wp-content/debug.log geschrieben werden.
    Wenn der Fehler gefunden wurde bzw. wenn die Fehler nicht mehr in die debug.log geschrieben werden sollen, dann musst du daran denken, die Variable
    define( 'WP_DEBUG_LOG', true );
    wieder auf false zu setzen:
    define( 'WP_DEBUG_LOG', false);

    Webspace voll?

    Thread-Starter aleks0208

    (@aleks0208)

    reichlich Platz.

    Moderator threadi

    (@threadi)

    Was haben deine anderen Prüfungen zu o.g. ergeben?

    Thread-Starter aleks0208

    (@aleks0208)

    gemach. Es gibt noch andere Baustellen.

    Thread-Starter aleks0208

    (@aleks0208)

    Zunächst mal ein kritisches Problem :
    Seiten-Cache wurde nicht erkannt und die Antwortzeit ist langsam.

    Wie kann ich das beheben?

    Thread-Starter aleks0208

    (@aleks0208)

    Ich habe auch das Debuging im WP-Config.php eingeschaltet.

    define( ‚WP_DEBUG‘, true );
    define( ‚WP_DEBUG_DISPLAY‘, false);
    define( ‚WP_DEBUG_LOG‘, true );

    Es kommt aber kein LOG.

    Moderator threadi

    (@threadi)

    Hast du die Zeilen an der richtigen Stelle in der wp-config.php eingefügt? Sie dürfen nicht einfach am Ende der Datei stehen sondern direkt oberhalb von /* That's all, stop editing! Happy blogging. */. Achte ebenfalls auf die Schreibweise der einfachen Anführungszeichen. Das müssten ' und nicht wie hier im Forum dargestellt und sein.

    Beachte auch, dass du die richtige wp-config.php bearbeitest. Gerade wenn man mehrere Websites betreuten sollte, verwechselt man die im Hosting durchaus mal.

    Seiten-Cache wurde nicht erkannt und die Antwortzeit ist langsam.

    Das ist im Gegenteil zu

    Der Update auf 7.03 (von 6.8.7) bringt einen krtischen Fehler.

    kein kritisches Problem. Die Meldung bezieht sich auf eine mögliche Optimierung deiner Website hinsichtlich der Auslieferungszeit. Der von dir genannte kritische Fehler beim Update von WordPress jedoch, ist tatsächlich kritisch im Sinne der Erreichbarkeit deiner Website.

    Meine Empfehlung wäre daher dich zuerst um den richtigen kritischen Fehler zu kümmern. Mit dem Update von WordPress 6.8.7 auf 7.0.3 erhältst du auch Optimierungen hinsichtlich der Auslieferungszeiten, wodurch der von dir genannte Hinweis aus dem Website-Zustand möglicherweise behoben werden könnte. Falls nicht wäre das Schritt 2.

    Bitte denke auch dran den Website-Bericht wie oben oder auch hier beschrieben bereitzustellen.

    Thread-Starter aleks0208

    (@aleks0208)

    /* That's all, stop editing! Happy blogging. */

    gibt es in der wp-config.php nicht.

    Thread-Starter aleks0208

    (@aleks0208)

    der Bericht:

    ` wp-core

    version: 6.8.7
    site_language: de_DE
    user_language: de_DE
    timezone: +00:00
    permalink: /%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: undefined
    environment_type: production
    user_count: 4
    dotorg_communication: true wp-paths-sizes

    wordpress_path: C:\inetpub\vhosts\dasv-postgeschichte.de\httpdocs\wp
    wordpress_size: 65,63 MB (68815438 bytes)
    uploads_path: C:\inetpub\vhosts\dasv-postgeschichte.de\httpdocs\wp/wp-content/uploads
    uploads_size: 5,26 GB (5644164920 bytes)
    themes_path: C:\inetpub\vhosts\dasv-postgeschichte.de\httpdocs\wp/wp-content/themes
    themes_size: 76,14 MB (79843257 bytes)
    plugins_path: C:\inetpub\vhosts\dasv-postgeschichte.de\httpdocs\wp/wp-content/plugins
    plugins_size: 35,67 MB (37398664 bytes)
    fonts_path: C:\inetpub\vhosts\dasv-postgeschichte.de\httpdocs\wp/wp-content/uploads/fonts
    fonts_size: directory not found
    database_size: 26,22 MB (27492352 bytes)
    total_size: 5,46 GB (5857714631 bytes) wp-dropins (1)

    maintenance.php: true wp-active-theme

    name: Enfold Child (enfold-child)
    version: 1.0
    author: Kriesi
    author_website: http://www.kriesi.at
    parent_theme: Enfold (enfold)
    theme_features: core-block-patterns, avia_exclude_bbPress, deactivate_tribe_events_calendar, avia_exclude_GFForms, avia_exclude_menu_exchange, avia_exclude_wp_accessibility, avia_exclude_relevanssi, avia_exclude_WooCommerce, avia_exclude_wpSEO, avia_exclude_wpml, avia_exclude_instagram_feed, avia_exclude_leaflet_map, avia_exclude_acf, avia_mega_menu, avia_improved_backend_style, avia_option_pages_toggles, avia_alb_checkbox_toggles, avia_sidebar_manager, automatic-feed-links, post-formats, avia_post_meta_compat, force-post-thumbnails-in-widget, title-tag, nav_menus, post-thumbnails, widgets, widgets-block-editor, block-templates, menus, editor-styles, editor-style, customize-selective-refresh-widgets, responsive-embeds, editor-color-palette, editor-font-sizes
    theme_path: C:\inetpub\vhosts\dasv-postgeschichte.de\httpdocs\wp/wp-content/themes/enfold-child
    auto_update: Deaktiviert wp-parent-theme

    name: Enfold (enfold)
    version: 7.1.6
    author: Kriesi
    author_website: https://kriesi.at
    theme_path: C:\inetpub\vhosts\dasv-postgeschichte.de\httpdocs\wp/wp-content/themes/enfold
    auto_update: Aktiviert wp-plugins-active (14)

    Classic Editor: version: 1.7.0, author: WordPress Contributors, Automatische Aktualisierungen aktiviert
    Disable & Remove Google Fonts: version: 2.0.1, author: Fonts Plugin, Automatische Aktualisierungen aktiviert
    Disable Comments: version: 2.8.0, author: WPDeveloper, Automatische Aktualisierungen aktiviert
    Duplicate Page: version: 4.5.9, author: mndpsingh287, Automatische Aktualisierungen deaktiviert
    Email Address Encoder: version: 1.0.25, author: Till Krüss, Automatische Aktualisierungen deaktiviert
    Enhanced Media Library: version: 2.9.4, author: wpUXsolutions, Automatische Aktualisierungen deaktiviert
    Jetpack Boost: version: 4.5.9, author: Automattic - Jetpack Site Speed team, Automatische Aktualisierungen deaktiviert
    Malware Cleanup Remediator: version: 1.0.0, author: Nextendweb, Automatische Aktualisierungen deaktiviert
    Mindspun Responsive Blocks: version: 0.18.1, author: Mindspun, Automatische Aktualisierungen deaktiviert
    Popup Anything - A Marketing Popup: version: 2.9.1.1, author: Essential Plugin, Automatische Aktualisierungen aktiviert
    Smart Slider 3 Pro: version: 3.5.1.39, author: Nextend, Automatische Aktualisierungen aktiviert
    TablePress: version: 3.3.3, author: Tobias Bäthge, Automatische Aktualisierungen deaktiviert
    Theme Test Drive: version: 2.9.1, author: Vladimir Prelovac, Automatische Aktualisierungen deaktiviert
    WP-PageNavi: version: 3.0.0, author: Lester 'GaMerZ' Chan, Automatische Aktualisierungen deaktiviert wp-media

    image_editor: WP_Image_Editor_GD
    imagick_module_version: Nicht verfügbar
    imagemagick_version: Nicht verfügbar
    imagick_version: Nicht verfügbar
    file_uploads: 1
    post_max_size: 8M
    upload_max_filesize: 10M
    max_effective_size: 8 MB
    max_file_uploads: 20
    gd_version: bundled (2.1.0 compatible)
    gd_formats: GIF, JPEG, PNG, WebP, BMP, AVIF, XPM
    ghostscript_version: not available wp-server

    server_architecture: Windows NT 10.0 AMD64
    httpd_software: Microsoft-IIS/10.0
    php_version: 8.4.24 64bit
    php_sapi: cgi-fcgi
    max_input_variables: 1000
    time_limit: 60
    memory_limit: 128M
    admin_memory_limit: 256M
    max_input_time: 60
    upload_max_filesize: 10M
    php_post_max_size: 8M
    curl_version: 8.21.0 OpenSSL/3.0.21
    suhosin: false
    imagick_availability: false
    pretty_permalinks: true
    htaccess_extra_rules: true
    static_robotstxt_file: false
    current: 2026-08-12T07:04:25+00:00
    utc-time: Wednesday, 12-Aug-26 07:04:25 UTC
    server-time: 2026-08-12T07:04:23+00:00 wp-database

    extension: mysqli
    server_version: 11.4.12-MariaDB
    client_version: mysqlnd 8.4.24
    max_allowed_packet: 16777216
    max_connections: 151 wp-constants

    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: C:\inetpub\vhosts\dasv-postgeschichte.de\httpdocs\wp/wp-content
    WP_PLUGIN_DIR: C:\inetpub\vhosts\dasv-postgeschichte.de\httpdocs\wp/wp-content/plugins
    WP_MEMORY_LIMIT: 40M
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_ENVIRONMENT_TYPE: undefined
    WP_DEVELOPMENT_MODE: undefined
    DB_CHARSET: utf8mb3
    DB_COLLATE: undefined wp-filesystem

    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    fonts: does not exist
    mu-plugins: writable disable-comments

    status: Comments are disabled site-wide for all content types
    plugin_configured: Yes
    total_comments: 1
    global_disable: Yes
    disabled_post_type_count: 4 of 4
    disabled_post_types: Beiträge, Seiten, Medien, Portfolio Einträge
    xmlrpc_comments: Enabled
    rest_api_comments: Enabled
    show_existing_comments: No
    network_active: No
    sitewide_settings: Not applicable
    role_exclusion_enabled: Disabled
    excluded_roles: None
    Moderator threadi

    (@threadi)

    Der Text könnte auch deutsch lauten, finde den gerade nicht. Schau dir einfach mal diesen Screenshot an, da sieht man es wie es aussehen sollte: https://wpforms.com/wp-content/uploads/2021/01/wpforms-debug-code.jpg

    Alternativ kannst du es auch mit diesem Plugin probieren: https://de.wordpress.org/plugins/wp-debugging/

    Sobald du den Code eingefügt hast, musst du den Fehler erneut verursachen. Erst dann würde etwas im debug.log stehen.

    Danke für deinen Website-Bericht. Mir fällt hier direkt auf, dass du nicht alle Plugins auf dem aktuellsten Stand hast. Wenn du also WordPress aktualisieren willst, aktualisiere zuerst die Plugins um diese als Ursache für den Fehler auszuschließen.

    Das Plugin „Malware Cleanup Remediator“ sagt mir gar nichts, auch finde ich dazu nichts. Nextendweb als Entwickler ist durchaus bekannt, möglicherweise ist das auch ein von dir genutztes kommerzielles Plugin. So wie es jetzt da steht, wirkt es auf mich jedoch wie ein möglicher Hack. Wenn dir das Plugin bekannt und bewusst ist, ist alles ok.

    Von „Jetpack Boost“ würde ich aus Datenschutzgründen abraten. Ich bin unsicher, ob das mit dem EU-Recht kompatibel ist, da Jetpack gerne „nach Hause“ in die USA telefoniert und man nicht weiß was für Daten dabei übermittelt werden. Optimierungsplugins gibt es noch einige mehr, die würden möglicherweise auch datenschutzkonform deinen Hinweis im Website-Zustand beheben.

    Könnte auch am Child Theme liegen.
    Versuche mal, ob die Website funktioniert, wenn du das Parent Theme Enfold verwendest.
    Wenn das funktioniert, musst du testen, welche function im Child Theme nicht mehr korrekt ausgeführt wird.

    Thread-Starter aleks0208

    (@aleks0208)

    Wer zu blöd zum Lesen ist….
    Werde WP-Config.php richtig anpassen.
    Mir werden keine Plugins als veraltet gemeldet.
    Malware Cleanup Remediator habe ich rausgeworfen.
    Cacheoptimierung suche ich etwas anderes.

Ansicht von 15 Antworten – 1 bis 15 (von insgesamt 36)

Du musst angemeldet sein, um auf dieses Thema zu antworten.