• Gelöst aleks0208

    (@aleks0208)


    Der Update auf 7.03 (von 6.8.7) bringt einen krtischen Fehler.
    Ich bekomme allerdings keine Mail, wie angegeben.

    Wie kann ich da eingrenzen?

Ansicht von 6 Antworten – 31 bis 36 (von insgesamt 36)
  • Thread-Starter aleks0208

    (@aleks0208)

    Wenn die .maintenance da ist, dann bringt die Seite den Wartungshinweis. Ist nicht da – kein Wartungshinweis. Es soll noch eine Einstellung geben, die das Update selbst betrifft.

    Wenn man größere ASP-Programme hat, geht am Windows nichts vorbei.

    Moderator threadi

    (@threadi)

    Ich weiß ehrlich gesagt nicht wie ich dir hier weiterhelfen soll. Ich weiß weiterhin nicht um welches Update es geht (WordPress, Plugin oder Theme?) noch weiß ich wann das Problem genau auftritt. Wie schon geschrieben wird die .maintenance-Datei im Moment des Updates gesetzt und danach entfernt. Passiert das nicht, ist das Update abgebrochen. Theoretisch müsste das wiederum im Error-Log erkenntlich sein.

    Thread-Starter aleks0208

    (@aleks0208)

    Ich habe jetzt den Eintrag core_updater.lock aus den Options gelöscht.
    Dann wieder das Update angeworfen.
    Jetzt kam wieder ein kritischer Fehler. Im LOG Stand dann aber nur ein Eintrag:
    [31-Aug-2026 11:51:32 UTC] PHP Fatal error: Maximum execution time of 60 seconds exceeded in C:\inetpub\vhosts\arge-polen.de\krakau\wp-admin\includes\class-wp-filesystem-direct.php on line 66
    Ich hatte aber die Max time schon auf 120 gestellt.
    Jetzt war auch der Eintrag core_updater.lock wieder da.

    • Diese Antwort wurde vor 6 Tagen, 3 Stunden von aleks0208 geändert.
    Moderator threadi

    (@threadi)

    Das scheint der gleiche Fehler wie bei dem Update, um das es hier eigentlich mal ging, zu sein: die Max-Execution-Time von 60 Sekunden wird erreichen. 120 wird vielleicht auch nicht ausreichen. Ich stelle es bei manchen Projekten auf 180, da es Plugins gibt, die das empfehlen (auch wenn ich es nicht gut empfinde). Versuchs mal mit 180 und wenn es dann weiterhin nicht sauber durchläuft, liegt es an irgendwelchen Verzögerungen im Hosting (was ich von Windows-Servern aus der Vergangenheit schon kenne).

    Thread-Starter aleks0208

    (@aleks0208)

    Leider lässt Plesk nur 120 maximal zu. Muss wohl den Provider kontakten.

    Thread-Starter aleks0208

    (@aleks0208)

    Ich habe jetzt mal direkt in der class-wp-filesystem-direct.php das Timeout auf 180 gesetzt. Es kam zwar nach einiger Zeit ein Fehler 500, aber nach dem Aktualisieren war das Update auf 7.1 durch.

    Schauen wir mal was die Zukunft bringt.

Ansicht von 6 Antworten – 31 bis 36 (von insgesamt 36)

Du musst angemeldet sein, um auf dieses Thema zu antworten.