Support » Allgemeine Fragen » FEHLER: Cookies sind wegen einer unerwarteten Ausgabe gesperrt

  • Guten Tag,

    ich kann mich neuerdings nicht mehr in meinem Dashboard anmelden. Sobald ich die Seite https://www.emdia.eu/site/wp-login besuche, warten auch schon zwei Fehlermeldungen auf mich.

    Warning: Cannot modify header information – headers already sent by (output started at /homepages/10/d584357167/htdocs/site/wp-includes/functions.php:1) in /homepages/10/d584357167/htdocs/site/wp-login.php on line 402

    header(‚Content-Type: ‚.get_bloginfo(‚html_type‘).‘; charset=‘.get_bloginfo(‚charset‘));

    Warning: Cannot modify header information – headers already sent by (output started at /homepages/10/d584357167/htdocs/site/wp-includes/functions.php:1) in /homepages/10/d584357167/htdocs/site/wp-login.php on line 415

    setcookie( TEST_COOKIE, ‚WP Cookie check‘, 0, COOKIEPATH, COOKIE_DOMAIN, $secure );

    Ich weiß wirklich nicht mehr weiter. Über jede Hilfe wäre ich dankbar.

    Vielen Dank im Voraus!

Ansicht von 15 Antworten - 16 bis 30 (von insgesamt 41)
  • Sorry, bitte Post ignorieren.

    • Diese Antwort wurde geändert vor 3 Jahre, 9 Monaten von erneston.

    Also, ich habe die Datei mit FileZilla heruntergeladen, bearbeitet und im nächsthöheren Ordner hochgeladen – was ja eine Kopie gleichstellt. Dennoch kommt die Fehlermeldung. :/

    Das habe ich jetzt gemacht, ohne Erfolg.

    So wie ich das betrachte, ist das Kopieren im Filezilla ehe nicht möglich. Du kannst verschieden oder die Datei herunterladen und wieder beim Hochladen wo anders platzieren.

    ich habe die Datei nur von einem Verzeichnis ins nächste kopiert. Macht das wirklich ein Unterschied??

    kopieren (index.php): Datei liegt dann in beiden Verzeichnissen (im neuen allerdings leicht abgeändert)
    verschieben (wp-config.php): Datei liegt nicht mehr im ursprünglichen Verzeichnis, sondern nur noch im neuen.

    oder die Datei herunterladen und wieder beim Hochladen wo anders platzieren.

    Dann mache es doch auf diese Weise. 🙂

    Ernesto, es ist von außen natürlich extrem schwer nachzuvollziehen, was genau der User macht. Es gab zweimal eine Fehlermeldung, dann waren die Permalinks mal defekt und alle Links führten zur Startseite. Es gibt bei mir aktuell keine Fehlermeldungen, die Links funktionieren jetzt wieder, nur ist die Website-URL immer noch identisch mit der WordPress-URL.

    Was genau steht denn aktuell bei dir für die beiden URLs in Einstellungen > Allgemein.
    Bitte mal die genauen Textstrings für beide URLs.

    • Diese Antwort wurde geändert vor 3 Jahre, 9 Monaten von Flower33. Grund: Tippfehler

    Habe ich ja gemacht ohne den gewünschten Erfolg. Ich komme da einfach nicht weiter. Grundsätzlich hatte ich es ja schon geschafft, dass die Seite unter http://www.emdia.eu erreichbar ist, aber die Unterseiten bekamen die Fehlermeldung 404. Ich denke, weil die Permalinks mit dem Unterverzeichnis übernommen werden, also sprich mit /site. Ich habe versucht diese wie im Tutorial zu ändern, klappt aber nicht. Zumindest wird die htaccess Datei nicht aktualisiert, wie im Tutorial beschrieben.

    Jetzt bist du auch schon fast fertig. Im WordPress Back End solltest du jetzt noch unter Einstellungen > Permalinks die gewünschte Link-Form auswählen und darauf achten, ob die Angaben in eine neue .htaccess geschrieben werden (falls nicht, erhältst du einen Fehlerhinweis, dass du den Eintrag selber kopieren und einfügen musst).

    Kannst du bitte mal noch die beiden URLs (siehe meinen letzten Beitrag) im genauen Wortlaut posten und am besten auch mal die .htaccess

    Es gibt bei mir aktuell keine Fehlermeldungen, die Links funktionieren jetzt wieder, nur ist die Website-URL immer noch identisch mit der WordPress-URL.

    Jepp, ich habe wieder den ursprünglichen Zustand wiederhergestellt. Ich ändere das wieder wie im Tutorial beschrieben.

    Ferndiagnosen sind immer schwierig, dafür machst du das aber wirklich gut! 🙂

    Ah, ok, ursprünglicher Zustand, habs mir schon gedacht.

    Nun meldest du dich über http://www.beispiel.de/wordpress/wp-login.php im Back End an und änderst unter Einstellungen > Allgemein die Site-URL in http://www.beispiel.de (Die WordPress-URL bleibt unverändert bei http://www.beispiel.de/wordpress !)

    Kannst du aus der Erinnerung heraus mal genau angeben, in welcher Form du die beiden URLs eingetragen hast?

    Hier die Infos:

    Die htaccess sieht so aus

    # BEGIN WordPress
    
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
     # END WordPress

    Moderationshinweis: Code-Auszeichnung und Bild-Links korrigiert. Grüße, Bego

    • Diese Antwort wurde geändert vor 3 Jahre, 9 Monaten von erneston.
    • Diese Antwort wurde geändert vor 3 Jahre, 9 Monaten von erneston.
    • Diese Antwort wurde geändert vor 3 Jahre, 9 Monaten von erneston.
    • Diese Antwort wurde geändert vor 3 Jahre, 9 Monaten von Bego Mario Garde.
    • Diese Antwort wurde geändert vor 3 Jahre, 9 Monaten von Bego Mario Garde.
    • Diese Antwort wurde geändert vor 3 Jahre, 9 Monaten von Bego Mario Garde.

    Also hier die Settings:

    https://postimg.org/image/k4qdvmu7x/

    Das Verzeichnis sieht nach Vorgabe des Tutorials so aus:
    https://postimg.org/image/m70vtb30d/

    Die htaccess schaut so aus:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    Hallo Ernesto,

    URLs und .htaccess (die gewünschte, nicht die aktuelle, richtig?) sehen korrekt aus.
    Ich nehme an, du hattest beim Befolgen des Tutorials natürlich /wordpress in das von dir verwendete /site abgeändert.
    Ich würde mal (im Rahmen eines etwaigen erneuten Tests) in dem im Screenshot gezeigten Verzeichnis die index.html umbenennen in __index.html. Falls es nichts bringt, wieder rückbenennen.

    Ansonsten bin ich für den Moment leider auch am Ende meines Lateins.
    Vielleicht schaut ja auch Bego oder sonst noch wer mal hier rein und hat eine weitere Idee.

    • Diese Antwort wurde geändert vor 3 Jahre, 9 Monaten von Flower33. Grund: Tippfehler

    Ich nehme an, du hattest beim Befolgen des Tutorials natürlich /wordpress in das von dir verwendete /site abgeändert.

    Ja, das habe ich.

    Ich würde mal (im Rahmen eines etwaigen erneuten Tests) in dem im Screenshot gezeigten Verzeichnis die index.html umbenennen in __index.html. Falls es nichts bringt, wieder rückbenennen.

    Richtig, bringt leider nichts.

    Ich werde alles wieder in den ursprünglichen Zustand bringen. Dann mache ich es wie zuvor, zwar ist dann die Seite ohne /site abrufbar, aber die Unterseiten nicht. Vermutlich aufgrund der Permalinks.

    Danke Flower33!

Ansicht von 15 Antworten - 16 bis 30 (von insgesamt 41)
  • Das Thema „FEHLER: Cookies sind wegen einer unerwarteten Ausgabe gesperrt“ ist für neue Antworten geschlossen.