Support » Allgemeine Fragen » FEHLER: Cookies sind wegen einer unerwarteten Ausgabe gesperrt

  • Guten Tag,

    ich kann mich neuerdings nicht mehr in meinem Dashboard anmelden. Sobald ich die Seite https://www.emdia.eu/site/wp-login besuche, warten auch schon zwei Fehlermeldungen auf mich.

    Warning: Cannot modify header information – headers already sent by (output started at /homepages/10/d584357167/htdocs/site/wp-includes/functions.php:1) in /homepages/10/d584357167/htdocs/site/wp-login.php on line 402

    header(‚Content-Type: ‚.get_bloginfo(‚html_type‘).‘; charset=‘.get_bloginfo(‚charset‘));

    Warning: Cannot modify header information – headers already sent by (output started at /homepages/10/d584357167/htdocs/site/wp-includes/functions.php:1) in /homepages/10/d584357167/htdocs/site/wp-login.php on line 415

    setcookie( TEST_COOKIE, ‚WP Cookie check‘, 0, COOKIEPATH, COOKIE_DOMAIN, $secure );

    Ich weiß wirklich nicht mehr weiter. Über jede Hilfe wäre ich dankbar.

    Vielen Dank im Voraus!

Ansicht von 11 Antworten - 31 bis 41 (von insgesamt 41)
  • Ich nehme es zurück. Er leitet dennoch weiter, obwohl die Index.html eigentlich nur auf emdia.eu zugreift und die Einstellungen die Site-URL ebenfalls auf emdia.eu eingestellt ist und WP-URL auf die emdia.eu/site.

    Ich verstehe es nicht. Irgendwie unlogisch. Nur dass jetzt die Unterseiten nicht mehr erreichbar sind – siehe 404 Fehlermeldung.

    Das wird schon noch klappen. Es könnte z.B. noch sein, dass du, als du der Anleitung „Changing the URL“ gefolgt bist, irgendwas in die wp-config.php geschrieben hast, das da nicht hingehört.
    Könntest du deren Inhalt bitte mal posten und dabei sensible Daten durch xxx unkenntlich machen?

    • Diese Antwort wurde geändert vor 3 Jahre, 9 Monaten von Flower33. Grund: Tippfehler
    • Diese Antwort wurde geändert vor 3 Jahre, 9 Monaten von Flower33.

    Nachtrag:
    Hast du irgendein Redirect-Plugin im Einsatz?

    Ein Plugin habe ich dafür nicht im Einsatz. An der Config habe ich in der Tat rumgespielt, aber meines Wissens wieder in den Ursprungszustand gebracht.

    <?php
    /**
     * The base configuration for WordPress
     *
     * The wp-config.php creation script uses this file during the
     * installation. You don't have to use the web site, you can
     * copy this file to "wp-config.php" and fill in the values.
     *
     * This file contains the following configurations:
     *
     * * MySQL settings
     * * Secret keys
     * * Database table prefix
     * * ABSPATH
     *
     * @link https://codex.wordpress.org/Editing_wp-config.php
     *
     * @package WordPress
     */
    
    // ** MySQL settings - You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define('DB_NAME', 'xxxxxxxxxx');
    
    /** MySQL database username */
    define('DB_USER', 'xxxxxxxxxxxx');
    
    /** MySQL database password */
    define('DB_PASSWORD', 'xxxxxxxxxxx');
    
    /** MySQL hostname */
    define('DB_HOST', 'xxxxxxxxxxxxxx');
    
    /** Database Charset to use in creating database tables. */
    define('DB_CHARSET', 'utf8');
    
    /** The Database Collate type. Don't change this if in doubt. */
    define('DB_COLLATE', '');
    
    /**#@+
     * Authentication Unique Keys and Salts.
     *
     * Change these to different unique phrases!
     * You can generate these using the {@link https://api.wordpress.org/secret-key/1.1/salt/ WordPress.org secret-key service}
     * You can change these at any point in time to invalidate all existing cookies. This will force all users to have to log in again.
     *
     * @since 2.6.0
     */
    define('AUTH_KEY',         'put your unique phrase here');
    define('SECURE_AUTH_KEY',  'put your unique phrase here');
    define('LOGGED_IN_KEY',    'put your unique phrase here');
    define('NONCE_KEY',        'put your unique phrase here');
    define('AUTH_SALT',        'put your unique phrase here');
    define('SECURE_AUTH_SALT', 'put your unique phrase here');
    define('LOGGED_IN_SALT',   'put your unique phrase here');
    define('NONCE_SALT',       'put your unique phrase here');
    
    /**#@-*/
    
    /**
     * WordPress Database Table prefix.
     *
     * You can have multiple installations in one database if you give each
     * a unique prefix. Only numbers, letters, and underscores please!
     */
    $table_prefix  = 'wp_';
    
    /**
     * For developers: WordPress debugging mode.
     *
     * Change this to true to enable the display of notices during development.
     * It is strongly recommended that plugin and theme developers use WP_DEBUG
     * in their development environments.
     *
     * For information on other constants that can be used for debugging,
     * visit the Codex.
     *
     * @link https://codex.wordpress.org/Debugging_in_WordPress
     */
    define('WP_DEBUG', false);
    
    /* That's all, stop editing! Happy blogging. */
    
    /** Absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
    	define('ABSPATH', dirname(__FILE__) . '/');
    
    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');
    • Diese Antwort wurde geändert vor 3 Jahre, 9 Monaten von erneston.

    Damit der Code hier im Forum richtig angezeigt wird:

    1. Code eingeben
    2. Cursor in eine leere Zeile vor dem Code setzen, oben auf Button „code“ klicken
    3. Cursor in eine leere Zeile nach dem Code setzen, oben auf Button „/code“ klicken

    Der gesamte Code muss also von den beiden jeweils in einer eigenen Zeile stehenden „Back-Ticks“ eingerahmt sein.

    Ist hoffentlich jetzt richtig 🙂 Danke für deine Geduld!

    Korrekt, danke!
    Ja, das ist wieder die ursprünliche Form, daran kann es nicht liegen.
    Hm, ich werde das Problem mal im Hinterkopf behalten, und, wie gesagat, vielleicht kommt ja auch noch Unterstützung von anderer Seite (Bego, Espiat etc.)
    Wenn du schon so weit warst, dass dir emdia.eu angezeigt wurde (durch welche Maßnahmen eigentlich?), und nur die Unterseiten nicht klappten, dann liegst es vermutlich nur noch an einer Kleinigkeit.

    Grundsätzlich hatte ich es ja schon geschafft, dass die Seite unter http://www.emdia.eu erreichbar ist, aber die Unterseiten bekamen die Fehlermeldung 404. Ich denke, weil die Permalinks mit dem Unterverzeichnis übernommen werden, also sprich mit /site.

    War das im Rahmen des Tutorials?

    Ich würde, falls ein Caching-Plugin im Einsatz sein sollte, mal den Cache löschen (kann zumindest nicht schaden) und zweitens bei Permalink-Problemen mal kurzfristig auf die Standard-Einstellung (Nummerierung der Seiten) zurückstellen, abspeichern, danach wieder auf die gewünschte Permalink-Einstellung (ich nehme an Beitragsname) und erneut abspeichern.

    Im Moment wird die 404-Fehlerseite angezeigt, hast du die Umstellung noch nict abgeschlossen?

    • Diese Antwort wurde geändert vor 3 Jahre, 9 Monaten von Flower33.

    Ernesto, ich verabschiede mich mal für heute Abend, ich muss jetzt mal noch ein bisschen was anderes zur Entspannung machen. 🙂 Tut mir leid, dass es noch nicht klappt hat, aber man darf da auch nicht zu schnell aufgeben.

    Ok, ich werde das testen. Ich muss es nochmal alles probieren, ich weiß schon garnicht welche Methode den gewünschten pfad anzeigte. Und dann teste ich deine Permalink-Methode aus. Mal gucken, vielleicht sind nur die Permalinks das Problem 🙂

    Danke nochmal für deine Zeit und Mühe und genieße dein Wochenende!

    Danke, dir auch ein schönes Wochnende!

Ansicht von 11 Antworten - 31 bis 41 (von insgesamt 41)
  • Das Thema „FEHLER: Cookies sind wegen einer unerwarteten Ausgabe gesperrt“ ist für neue Antworten geschlossen.