Support » Allgemeine Fragen » Fehler: Die Antwort ist keine gültige JSON-Antwort.

  • Gelöst marst84

    (@marst84)


    Mit meiner neuen Seite habe ich diese Probleme:
    – erstelle ich eine Seite/Post oder aktualisiere sie, kommt der Fehler Die Antwort ist keine gültige JSON-Antwort..
    – Außerdem ist lediglich die Startseite erreichbar.
    – bei allen Unterseiten bzw. /wp-json kommt Fehler 404.

    Ausgangssituation:
    -auf meinem heimischen NAS Server von Synology liegen WordPressdaten und die Datenbank.
    -DynDDS von do.de wird und genutzt.

    Was ich schon versucht habe:
    -Permalinks aktualisiert.
    -Server neu gestartet.
    -.htaccess gelöscht.
    -Theme gewechselt.
    -zur Zeit sind alle Plugins deaktiviert.

    Woran kann das liegen?

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 3 Antworten - 1 bis 3 (von insgesamt 3)
  • Thread-Starter marst84

    (@marst84)

    
    ### wp-core ###
    
    version: 5.5.3
    site_language: de_DE
    user_language: de_DE
    timezone: +01:00
    permalink: /%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 0
    default_comment_status: open
    environment_type: production
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /volume1/web/wordpress
    wordpress_size: 44,36 MB (46516114 bytes)
    uploads_path: /volume1/web/wordpress/wp-content/uploads
    uploads_size: 3,06 MB (3212496 bytes)
    themes_path: /volume1/web/wordpress/wp-content/themes
    themes_size: 4,05 MB (4251084 bytes)
    plugins_path: /volume1/web/wordpress/wp-content/plugins
    plugins_size: 11,02 MB (11555979 bytes)
    database_size: 1,92 MB (2015232 bytes)
    total_size: 64,42 MB (67550905 bytes)
    
    ### wp-active-theme ###
    
    name: GeneratePress (generatepress)
    version: 3.0.3
    author: Tom Usborne
    author_website: https://tomusborne.com
    parent_theme: none
    theme_features: core-block-patterns, automatic-feed-links, post-thumbnails, post-formats, woocommerce, title-tag, html5, customize-selective-refresh-widgets, align-wide, responsive-embeds, custom-logo, menus, editor-style, widgets
    theme_path: /volume1/web/wordpress/wp-content/themes/generatepress
    
    ### wp-themes-inactive (1) ###
    
    Twenty Seventeen: version: 2.7, author: WordPress-Team
    
    ### wp-mu-plugins (1) ###
    
    Disable XML-RPC Pingback: version: 1.1, author: Samuel Aguilera
    
    ### wp-plugins-inactive (3) ###
    
    3D FlipBook : Dflip Lite: version: 1.7.6.1, author: DearHive
    Enable jQuery Migrate Helper: version: 1.3.0, author: The WordPress Team
    Ultimate Member: version: 2.1.20, author: Ultimate Member
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1690
    imagemagick_version: ImageMagick 6.9.10-27 Q8 armle 2021-02-02 https://imagemagick.org
    file_uploads: File uploads is turned off
    post_max_size: 320M
    upload_max_filesize: 320M
    max_effective_size: 320 MB
    max_file_uploads: 20
    imagick_limits: 
    	imagick::RESOURCETYPE_AREA: 1.000 MB
    	imagick::RESOURCETYPE_DISK: 1.844674407371E+19
    	imagick::RESOURCETYPE_FILE: 768
    	imagick::RESOURCETYPE_MAP: 1.000 MB
    	imagick::RESOURCETYPE_MEMORY: 500 MB
    	imagick::RESOURCETYPE_THREAD: 2
    gd_version: bundled (2.1.0 compatible)
    ghostscript_version: not available
    
    ### wp-server ###
    
    server_architecture: Linux 3.10.105 armv7l
    httpd_software: nginx/1.16.1
    php_version: 7.4.9
    php_sapi: fpm-fcgi
    max_input_variables: 1000
    time_limit: 240
    memory_limit: 256M
    max_input_time: 60
    upload_max_filesize: 320M
    php_post_max_size: 320M
    curl_version: 7.54.0 OpenSSL/1.0.2u
    suhosin: false
    imagick_availability: true
    pretty_permalinks: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 10.3.24-MariaDB
    client_version: mysqlnd 7.4.9
    
    ### wp-constants ###
    
    WP_HOME: https://szbad-neues.de
    WP_SITEURL: https://szbad-neues.de
    WP_CONTENT_DIR: /volume1/web/wordpress/wp-content
    WP_PLUGIN_DIR: /volume1/web/wordpress/wp-content/plugins
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    mu-plugins: writable
    
    
    Moderator Bego Mario Garde

    (@pixolin)

    Rufe ich bei deiner Website https://szbad-neues.de/wp-json auf, bekomme ich einen „500 – Internal Server Error“ ausgegeben. Offensichtlich funktioniert also die REST API nicht. Hier scheint in der Serverkonfiguration etwas nicht zu stimmen. Der Error-Log des Servers sollte mehr Informationen zur Fehlerursache liefern.

    Noch ein paar kurze Anmerkungen zu deinem Website-Bericht, die aber eher nichts mit dem eigentlichen Problem zu tun haben:

    • Du verwendest eine veraltete WordPress-Version. Aktuell ist 5.7.2.
    • Bei Zeitzone solltest du als Ort Berlin auswählen, damit eine Zeitumstellung (Sommer-/Winterzeit) funktioniert.
    • Du hast scheinbar in der wp-config.php die Konstanten WP_SITEURL und WP_HOME festgelegt (vermutlich im Rahmen einer Umstellung auf https?). Diese Konstanten solltest du nur verwenden, wenn du laufend zwischen einer Entwicklungs- und Produktiv-Umgebung wechselst und die Einträge in der Datenbank überschreiben musst. Du kannst die beiden Zeilen aus der wp-config.php löschen und statt dessen in der MySQL-Datenbanktabelle wp_options die Felder siteurl und home (ggf. etwas in der Tabelle blättern) anpassen.
    Thread-Starter marst84

    (@marst84)

    Es war offenbar ein Problem auf meinem NAS Server. Habe den Server, Virtual Host auf von Nginx Apache umgestellt.

Ansicht von 3 Antworten - 1 bis 3 (von insgesamt 3)
  • Das Thema „Fehler: Die Antwort ist keine gültige JSON-Antwort.“ ist für neue Antworten geschlossen.