• Gelöst Thobie

    (@thobie)


    Moin, Moin,

    nach dem Suchen/Ersetzen in der Datenbank von „http://www.nudelheissundhos.de“ durch „https://www.nudelheissundhos.de“ in 127 Tabellen und etwa 100.000 Zellen machen sich die ersten Fehler im Backend bemerkbar.

    Ich kann:
    1. Die Mediathek aufrufen, Fotos importieren und beschreiben.
    2. Die Beiträge aufrufen.
    3. Den Entwurf eines einzelnen Beitrags (vorher mit der WordPress App auf dem iPad erstellt) aufrufen.
    4. Den Text bearbeiten und Fotos in den Beitrag importieren.

    Ich kann nicht:
    1. Einen Beitrag neu erstellen, weder über die Menüleiste links noch über den „Erstellen“-Button in der Beitragsübersicht.
    2. Ich kann einen editierten Beitrag nicht speichern.
    3. Ich kann bedingt (!) einen editierten Beitrag veröffentlichen. Die „Kritische Fehlermeldung auf der Website“ taucht auf, gehe ich zurück, ist der Beitrag dennoch veröffentlicht, auch im Frontend.

    Bei den beiden zuerst genannten Problemen erscheint auch die „Kritische Fehlermeldung auf der Website“ und nichts geht mehr.

    Wie behebe ich das Problem?

    Grüße aus Hamburg

    Thobie

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 15 Antworten – 1 bis 15 (von insgesamt 17)
  • Hallo,
    bekommst du dann auch eine Mail? – wenn ja, schau da doch mal bitte rein. Da stehen noch weitere Infos, was zu tun ist.

    Viele Grüße
    Hans-Gerd

    Fehlermeldungen in den Logfiles oder in der Browser-Konsole?

    Moderator Michi91

    (@michi91)

    Wie hast du das suchen und ersetzen gemacht? Mit dem search and replace plugin oder anders?

    Thread-Starter Thobie

    (@thobie)

    @Hans-Gerd Ja, eine Mail habe ich erhalten. Ich schaue sie mir morgen genauer an und hoffe, dass ich daraus schlau werde und einige Korrekturen vornehmen kann.

    @bscu Noch nicht geschaut. Mache ich morgen.

    @michi91 Ja, mit dem Plugin Search & Replace.

    Vorher in der lokalen Testumgebung geprüft. Erfolgreich durchgeführt. Danach im Live-Blog durchgeführt. Ebenfalls erfolgreich. Frontend und Backend funktionierten. Ich habe natürlich gerade das Backend nicht bis ins Detail danach getestet, die Fehler fielen mir erst auf, als ich wieder Beiträge veröffentlichen wollte.

    ch schaue sie mir morgen genauer an

    Noch nicht geschaut.

    Das sind doch alles Dinge, die man zuerst macht, bevor man in einem Forum postest. Denn da könnten Informationen zu finden sein, die einem selber auf die Sprünge helfen und/oder wichtig für die Fragestellung im Forum sein könnten.

    Ich schaue sie mir morgen genauer an und hoffe, dass ich daraus schlau werde und einige Korrekturen vornehmen kann.

    hmm, verstehe ich nicht. Diese Mail anzuschauen kostet deutlich weniger Zeit als hier ins Forum zu schreiben. Verstehe mich nicht falsch: Es ist völlig ok, hier ins Forum zu schreiben, aber die Mail anzuschauen wäre doch sicher ein Schritt davor, oder?

    Ich kann nicht:
    1. Einen Beitrag neu erstellen, weder über die Menüleiste links noch über den „Erstellen“-Button in der Beitragsübersicht.
    2. Ich kann einen editierten Beitrag nicht speichern.

    Unvollständige Fehlerbeschreibungen kosten uns ebenfalls unnötig Zeit.

    Was bedeutet denn hier „ich kann nicht“?
    Gibt es Fehlermeldungen? Welche?

    Wenn es „kristische Fehler“ gibt, gibt es auch einen Eintrag im Error-Log des Servers. Wie lautet der?

    Ist der Debug-Modus aktiviert? Warum nicht? Oder wenn doch: welche Fehlermeldungen werden ausgegeben?

    Vier Teilnehmer, die hier sinnlos ihre Zeit vertun, weil nur unzureichende Informationen zur Verfügung gestellt werden?

    Thread-Starter Thobie

    (@thobie)

    Moin, Moin, das ist wohl doch nicht so das Gelbe vom Ei mit der lokalen WP-Testumgebung, dem Suchen/Ersetzen von Code in der Datenbank und dann der gleichen Ausführung im Live-Blog.

    Ich stelle heute entsetzt fest, dass das Live-Blog derzeit noch 107 Kommentare hat. Beim Nachschauen fand ich jedoch und hatte es so fest in Erinnerung, dass ich im Juli 2017 einen Blogbeitrag veröffentlicht habe, in dem ich auf den damals mittlerweile 1.000sten Kommentar hingewiesen habe.

    Wo also sind die ganzen restlichen 900 Kommentare verblieben?

    Kein Mensch weiß, was du da bastelst, allerdings hinterlässt du den Eindruck, als wenn das alles sehr chaotisch abläuft.

    Wo also sind die ganzen restlichen 900 Kommentare verblieben?

    Im Reich der ewigen Jagdgründe? Woher sollen wir das wissen?

    das ist wohl doch nicht so das Gelbe vom Ei mit der lokalen WP-Testumgebung

    Doch, man muss es nur richtig machen.

    Und wieder lieferst du keinerlei Informationen, um dir auch nur annähernd zu helfen. 🙁

    • Diese Antwort wurde geändert vor 2 Jahren, 5 Monaten von bscu.
    Thread-Starter Thobie

    (@thobie)

    Ich rudere einmal vorsichtig zurück. War leider ein Schuss ins Blaue. Die Anzeige auf meinem iPad war aus mir nicht bekannten Gründen nicht korrekt. Im Backend auf dem Mac sind wieder alle 1.700 Kommentare vorhanden. Entschuldigung. 🙁

    • Diese Antwort wurde geändert vor 2 Jahren, 5 Monaten von Thobie.

    Und wieder lieferst du keinerlei Informationen, um dir auch nur annähernd zu helfen. 🙁

    … und gehst nicht auf Fragen von uns ein. Ich bin dann mal raus.

    Thread-Starter Thobie

    (@thobie)

    Ich habe mittlerweile nur festgestellt, dass es sich um das Plugin AZIndex handelt, wenn ich einen neuen Beitrag erstellen oder einen editierten Beitrag abspeichern will.

    Diese Fehlermeldung habe ich von WordPress per Mail erhalten:

    In diesem Fall hat WordPress einen Fehler in einem deiner Plugins, AZIndex, abgefangen.
    
    Fehler-Details
    ==============
    Ein Fehler vom Typ E_ERROR wurde in der Zeile 158 der Datei /mnt/web502/b2/71/53358571/htdocs/nudelheissundhos/wp-content/plugins/azindex/az-index-cache.php verursacht. Fehlermeldung: Uncaught Error: Cannot use string offset as an array in /mnt/web502/b2/71/53358571/htdocs/nudelheissundhos/wp-content/plugins/azindex/az-index-cache.php:158
    Stack trace:
    #0 /mnt/web502/b2/71/53358571/htdocs/nudelheissundhos/wp-content/plugins/azindex/az-index-cache.php(77): az_add_dirty_post()
    #1 /mnt/web502/b2/71/53358571/htdocs/nudelheissundhos/wp-includes/class-wp-hook.php(309): az_cache_post_changed()
    #2 /mnt/web502/b2/71/53358571/htdocs/nudelheissundhos/wp-includes/class-wp-hook.php(331): WP_Hook->apply_filters()
    #3 /mnt/web502/b2/71/53358571/htdocs/nudelheissundhos/wp-includes/plugin.php(474): WP_Hook->do_action()
    #4 /mnt/web502/b2/71/53358571/htdocs/nudelheissundhos/wp-includes/post.php(4686): do_action()
    #5 /mnt/web502/b2/71/53358571/htdocs/nudelheissundhos/wp-admin/includes/post.php(700): wp_insert_post()
    #6 /mnt/web502/b2/71/53358571/htdocs/nudelheissundhos/wp-admin/post-new.php(66): get_default_post_to_edit()
    #7 {main}
     thrown

    Was sagt mir dies? Wie behebe ich den Fehler?

    Ich habe das Plugin derzeit deaktiviert. Nun kann ich neue Beiträge erstellen und editierte Beiträge abspeichern und veröffentlichen. Alles ohne Fehlermeldung.

    Was sagt mir dies?

    Keine Ahnung, musst du selber wissen. Mir sagt das, dass in dem Script wp-content/plugins/azindex/az-index-cache.php in Zeile 158 ein Fehler ist. Vermutlich ist das Script veraltet.

    • Diese Antwort wurde geändert vor 2 Jahren, 5 Monaten von bscu.
    • Diese Antwort wurde geändert vor 2 Jahren, 5 Monaten von bscu.
    Moderator Michi91

    (@michi91)

    Zitat von https://de.wordpress.org/plugins/azindex/#developers

    Zuletzt aktualisiert:vor 13 Jahren
    WordPress-Version:2.5 oder höher

    Auch wenn ich ganz nostalgisch werde, Version 2.5, die mit dem „neuen Backend“ und der Einführung von shortcodes war die erste Version mit der ich produktiv gearbeitet habe, möchte ich sagen: schmeiß das Plugin runter, der Code ist einfach zu alt…

    Falls du es noch nicht tun mochtest: wenn es vor dem search and replace lief, versuch den Cache von azindex zu leeren… (keine Ahnung ob das überhaupt übers Backend noch geht), das war der letzte Tipp aus dem Plugin Support Forum von azindex.

    • Diese Antwort wurde geändert vor 2 Jahren, 5 Monaten von Michi91.
    Thread-Starter Thobie

    (@thobie)

    @michi91

    „Auch wenn ich ganz nostalgisch werde, Version 2.5, die mit dem „neuen Backend“ und der Einführung von shortcodes war die erste Version mit der ich produktiv gearbeitet habe, möchte ich sagen: schmeiß das Plugin runter, der Code ist einfach zu alt …“

    Okay, erscheint mir sinnvoll.

    „Falls du es noch nicht tun mochtest: wenn es vor dem search and replace lief, versuch den Cache von azindex zu leeren… (keine Ahnung ob das überhaupt übers Backend noch geht), das war der letzte Tipp aus dem Plugin Support Forum von azindex.“

    Wo finde ich den Cache von AZIndex?

    Gegenfrage: Hast Du eine Alternative für ein Plugin, das alle Beiträge alphabetisch auflistet?

Ansicht von 15 Antworten – 1 bis 15 (von insgesamt 17)
  • Das Thema „Fehler im Backend nach Suchen/Ersetzen in der Datenbank“ ist für neue Antworten geschlossen.