Support » Plugins » Fehler nach automatischem Update des IONOS Performance Plug-Ins

  • Gelöst exodusn

    (@exodusn)


    Guten Tag,
    ich habe einen Brief erhalten:

    Hallo! Einige Plugins auf deiner Website https://temperatur-berlin.de wurden automatisch auf ihre neueste Version aktualisiert. Es ist keine weitere Aktion deinerseits erforderlich.

    Diese Plugins sind jetzt auf dem neuesten Stand:
    – IONOS Performance (von Version 1.0.1 auf 1.1.2)

    Danach bleibt ein Fehler auf der Startseite der Website hängen:

    Warning: file_put_contents(/homepages/28/d520199976/htdocs/clickandbuilds/TemperaturBerlin/.htaccess): Failed to open stream: Permission denied in /homepages/28/d520199976/htdocs/clickandbuilds/TemperaturBerlin/wp-content/plugins/ionos-performance/inc/class-htaccess.php on line 86

    Wenn Sie versuchen, sich bei https://temperatur-berlin.de/wp-admin/ anzumelden, erscheint eine Seite mit Text:

    `Warning: file_put_contents(/homepages/28/d520199976/htdocs/clickandbuilds/TemperaturBerlin/.htaccess): Failed to open stream: Permission denied in /homepages/28/d520199976/htdocs/clickandbuilds/TemperaturBerlin/wp-content/plugins/ionos-performance/inc/class-htaccess.php on line 86

    Warning: Cannot modify header information – headers already sent by (output started at /homepages/28/d520199976/htdocs/clickandbuilds/TemperaturBerlin/wp-content/plugins/ionos-performance/inc/class-htaccess.php:86) in /homepages/28/d520199976/htdocs/clickandbuilds/TemperaturBerlin/wp-includes/pluggable.php on line 1421

    Warning: Cannot modify header information – headers already sent by (output started at /homepages/28/d520199976/htdocs/clickandbuilds/TemperaturBerlin/wp-content/plugins/ionos-performance/inc/class-htaccess.php:86) in /homepages/28/d520199976/htdocs/clickandbuilds/TemperaturBerlin/wp-includes/pluggable.php on line 1424`

    Das heißt, es gibt keinen Zugang zum Verwaltungsbereich

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 13 Antworten - 1 bis 13 (von insgesamt 13)
  • Guten Morgen @exodusn,

    das ist ein ärgerliches Problem. Ich kümmere mich darum, dass das Performance-Plugin sich mit dem nächsten Update nicht mehr so verhält.

    Auf deiner Website scheint mir die Ausgaben von Fehlern aktiv zu sein was dazu führt, dass du diese Warnungen überhaupt angezeigt bekommst. Wenn du die Ausgabe deaktivierst, solltest du ohne Probleme weiterarbeiten können.

    Dazu musst du dich mittels FTP auf den Server verbinden und in der wp-config.php Datei nach der Zeile define( 'WP_DEBUG', true ); suchen. Wenn du das true durch ein false ersetzt und die Datei speicherst, sollten die Fehler nicht mehr ausgegeben werden.

    Beste Grüße,
    Simon

    @krafit
    Das kann aber nur eine Notlösung sein, der Fehler ist damit ja nicht beseitigt, wird nur nicht mehr angezeigt, die Logfiles werden trotzdem vollgeschrieben. Und welche Symptome können durch diesen Fehler noch auftreten? Ich würde das Plugin eher deaktivieren.

    Thread-Starter exodusn

    (@exodusn)

    @bscu Ich werde das Plugin auf jeden Fall deaktivieren, sobald ich Zugriff auf das Admin-Panel bekomme

    @exodusn
    Logge dich per FTP ein und nenne das Verzeichnis ionos-performance unter /homepages/28/d520199976/htdocs/clickandbuilds/TemperaturBerlin/wp-content/plugins um, dann sollte das Plugin deaktiviert sein.

    Das kann aber nur eine Notlösung sein, der Fehler ist damit ja nicht beseitigt

    jo, da hat @bscu recht. Das wäre mein Lösungsvorschlag für heute. Ich kann nichts versprechen, aber ich würde mit einem sehr zeitnahen Update des Plugins rechnen. Das, lieber @exodusn muss also nicht der Grund sein dem Plugin den Rücken zu kehren.

    Thread-Starter exodusn

    (@exodusn)

    @bscu @krafit Habe ich gemacht, Problem vorerst gelöst, danke.

    Dann markieren wir den Thread doch auch gleich mal als „gelöst“. 🙂

    Thread-Starter exodusn

    (@exodusn)

    Das Problem hat sich ausgeweitet, und um kein neues Thema zu eröffnen, werde ich es hier veröffentlichen.

    Ich habe heute die Links zum PDF-Katalog auf der Website aktualisiert, und es hat sich herausgestellt, dass es auf der Seite https://temperatur-berlin.de/leistungen/ einen Fehler gibt.

    Die unterschiedlichen Links zum PDF-Katalog 3 (Explosionsschutz) werden für eingeloggte und nicht eingeloggte Benutzer angezeigt.

    Als eingeloggter Benutzer habe ich einen neuen Link angezeigt bekommen: /wp-content/uploads/Gebaudetechnik_26.08.22-DE.pdf
    
    Alle nicht angemeldeten Benutzer werden den alten Link sehen: /https://temperatur-berlin.de/wp-content/uploads/2021/05/Explosionsschutz.pdf
    
    In WP wurden die Änderungen gespeichert und der Link ist neu.
    
    Ich nahm an, dass die Lücke mit der Seite zusammenhängen könnte, und versuchte, sie zu duplizieren, woraufhin ich eine Fehlermeldung erhielt:
    <blockquote>

    Warning: Trying to access array offset on value of type bool in /homepages/28/d520199976/htdocs/clickandbuilds/TemperaturBerlin/wp-content/plugins/sitepress-multilingual-cms/sitepress.class.php on line 4327

    Warning: Cannot modify header information – headers already sent by (output started at /homepages/28/d520199976/htdocs/clickandbuilds/TemperaturBerlin/wp-content/plugins/sitepress-multilingual-cms/sitepress.class.php:4327) in /homepages/28/d520199976/htdocs/clickandbuilds/TemperaturBerlin/wp-includes/pluggable.php on line 1421

    Warning: Cannot modify header information – headers already sent by (output started at /homepages/28/d520199976/htdocs/clickandbuilds/TemperaturBerlin/wp-content/plugins/sitepress-multilingual-cms/sitepress.class.php:4327) in /homepages/28/d520199976/htdocs/clickandbuilds/TemperaturBerlin/wp-includes/pluggable.php on line 1424`

    In der Annahme, dass das Problem mit dem WPML Multilingual CMS Plugin zusammenhängen könnte, habe ich versucht, es zu aktualisieren und eine Fehlermeldung erhalten:

    Update failed: undefined

    Kann man eine ungefähre Vorstellung davon bekommen, was das Problem ist und wie es gelöst werden kann?

    Ich danke Ihnen vielmals.

    Thread-Starter exodusn

    (@exodusn)

    Das Problem betrifft auch die Startseite der Website, den Block: „InnnoTrans in Berlin vom 20. bis zum 23. September 2022“.

    Für eingeloggte Benutzer wird der Text wie folgt angezeigt: „Die internationale Leitmesse für Verkehrstechnik Die InnoTrans ist die internationale Leitmesse für Verkehrstechnik, die alle zwei Jahre in Berlin stattfindet.“

    Bei nicht angemeldeten Benutzern wird der Text angezeigt: „Die internationale Leitmesse für Verkehrstechnik Die InnoTrans ist die internationale Leitmesse für Verkehrstechnik, die alle“

    Der Text wurde heute geändert

    • Diese Antwort wurde geändert vor 3 Wochen, 5 Tage von exodusn.

    Ich rate mal, da du keinen Webseiten-Bericht geliefert hast: bei dir ist PHP 8 aktiviert. Stelle das mal auf PHP 7.4 um, da noch nicht alle Plugins und Themes mit PHP 8 klar kommen.

    Bevor du ein neues Thema/Thread erstellst

    • Diese Antwort wurde geändert vor 3 Wochen, 5 Tage von bscu.

    Hier nochmal der Hinweis: Bitte nur eine Frage pro Thread.

    Der Thread ist als „gelöst“ markiert, was für die Helfenden hier vereinfacht bedeutet: „Thema erledigt, hier brauchst du nicht mehr helfen“ – eine sehr sichere Möglichkeit, keine Antworten mehr zu bekommen. Wär doch schade, wenn deine neue Frage so untergeht.

    Thread-Starter exodusn

    (@exodusn)

    
    ### wp-core ###
    
    version: 6.0.2
    site_language: en_US
    user_language: en_US
    timezone: Europe/Berlin
    permalink: /%year%/%monthnum%/%day%/%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: undefined
    environment_type: production
    user_count: 10
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /homepages/28/d520199976/htdocs/clickandbuilds/TemperaturBerlin
    wordpress_size: 9,32 GB (10002978344 bytes)
    uploads_path: /homepages/28/d520199976/htdocs/clickandbuilds/TemperaturBerlin/wp-content/uploads
    uploads_size: 715,29 MB (750039927 bytes)
    themes_path: /homepages/28/d520199976/htdocs/clickandbuilds/TemperaturBerlin/wp-content/themes
    themes_size: 20,61 MB (21607494 bytes)
    plugins_path: /homepages/28/d520199976/htdocs/clickandbuilds/TemperaturBerlin/wp-content/plugins
    plugins_size: 126,23 MB (132366402 bytes)
    database_size: 206,75 MB (216793088 bytes)
    total_size: 10,36 GB (11123785255 bytes)
    
    ### wp-active-theme ###
    
    name: Paul Rüster (paul-ruster)
    version: 1.0.0
    author: Brainstorm Force
    author_website: http://wpastra.com/about/
    parent_theme: Astra (astra)
    theme_features: core-block-patterns, astra_hooks, widgets-block-editor, align-wide, automatic-feed-links, title-tag, post-thumbnails, html5, post-formats, custom-logo, customize-selective-refresh-widgets, editor-style, woocommerce, amp, widgets, menus
    theme_path: /homepages/28/d520199976/htdocs/clickandbuilds/TemperaturBerlin/wp-content/themes/paul-ruster
    auto_update: Disabled
    
    ### wp-parent-theme ###
    
    name: Astra (astra)
    version: 3.0.3 (latest version: 3.9.1)
    author: Brainstorm Force
    author_website: https://wpastra.com/about/
    theme_path: /homepages/28/d520199976/htdocs/clickandbuilds/TemperaturBerlin/wp-content/themes/astra
    auto_update: Disabled
    
    ### wp-themes-inactive (5) ###
    
    P&M Base Theme: version: 1.0.0, author: Waldemar Schiller, Auto-updates disabled
    Twenty Nineteen: version: 2.0, author: the WordPress team (latest version: 2.3), Auto-updates disabled
    Twenty Twenty: version: 1.7, author: the WordPress team (latest version: 2.0), Auto-updates disabled
    Twenty Twenty-One: version: 1.3, author: the WordPress team (latest version: 1.6), Auto-updates disabled
    Twenty Twenty-Two: version: 1.2, author: the WordPress team, Auto-updates disabled
    
    ### wp-mu-plugins (1) ###
    
    1&1 Product Subdomain: version: 1.1.0, author: 1&1
    
    ### wp-plugins-active (18) ###
    
    Advanced Custom Fields PRO: version: 5.8.7, author: Elliot Condon (latest version: 5.12.3), Auto-updates disabled
    Astra Pro: version: 3.0.1, author: Brainstorm Force (latest version: 3.9.1), Auto-updates disabled
    ConvertKit: version: 1.9.7.6, author: ConvertKit (latest version: 1.9.8.3), Auto-updates disabled
    CookieFirst Plugin: version: 1.0.4.0, author: Qoorts (latest version: 1.0.25), Auto-updates disabled
    Duplicate Page: version: 4.4, author: mndpsingh287 (latest version: 4.4.9), Auto-updates disabled
    Duplicator Pro: version: 4.5.4, author: Snap Creek, Auto-updates disabled
    Elementor: version: 3.1.1, author: Elementor.com (latest version: 3.7.4), Auto-updates disabled
    Elementor Pro: version: 3.0.10, author: Elementor.com, Auto-updates disabled
    Header and Footer Scripts: version: 2.2.1, author: Digital Liberation, Auto-updates disabled
    Import / Export Customizer Settings: version: 1.0.4, author: Brainstorm Force (latest version: 1.0.6), Auto-updates disabled
    Max upload filesize: version: 1.1.0, author: Yinlong, Auto-updates disabled
    Ninja Forms: version: 3.5.8.4, author: Saturday Drive (latest version: 3.6.13), Auto-updates disabled
    Ninja Forms Multilingual: version: 0.1.2, author: OnTheGoSystems (latest version: 0.2.0), Auto-updates disabled
    Rank Math SEO: version: 1.0.64, author: Rank Math (latest version: 1.0.96), Auto-updates disabled
    WP Mail SMTP: version: 2.8.0, author: WPForms (latest version: 3.5.2), Auto-updates disabled
    WPML Multilingual CMS: version: 4.4.10, author: OnTheGoSystems (latest version: 4.5.8), Auto-updates disabled
    WPML String Translation: version: 3.1.8, author: OnTheGoSystems (latest version: 3.2.1), Auto-updates disabled
    WPML Translation Management: version: 2.10.6, author: OnTheGoSystems (latest version: 2.10.8), Auto-updates disabled
    
    ### wp-plugins-inactive (1) ###
    
    IONOS Performance: version: 1.1.2, author: IONOS, Auto-updates disabled
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_GD
    imagick_module_version: Not available
    imagemagick_version: Not available
    imagick_version: Not available
    file_uploads: File uploads is turned off
    post_max_size: 128M
    upload_max_filesize: 128M
    max_effective_size: 128 MB
    max_file_uploads: 20
    gd_version: 2.2.5
    gd_formats: GIF, JPEG, PNG, WebP, BMP, XPM
    ghostscript_version: 9.27
    
    ### wp-server ###
    
    server_architecture: Linux 4.4.302-icpu-088 x86_64
    httpd_software: Apache
    php_version: 8.0.22 64bit
    php_sapi: cgi-fcgi
    max_input_variables: 1000
    time_limit: 30
    memory_limit: 1024M
    max_input_time: -1
    upload_max_filesize: 128M
    php_post_max_size: 128M
    curl_version: 7.64.0 OpenSSL/1.1.1n
    suhosin: false
    imagick_availability: false
    pretty_permalinks: true
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.7.38-log
    client_version: mysqlnd 8.0.22
    max_allowed_packet: 67108864
    max_connections: 3000
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /homepages/28/d520199976/htdocs/clickandbuilds/TemperaturBerlin/wp-content
    WP_PLUGIN_DIR: /homepages/28/d520199976/htdocs/clickandbuilds/TemperaturBerlin/wp-content/plugins
    WP_MEMORY_LIMIT: 40M
    WP_MAX_MEMORY_LIMIT: 1024M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_ENVIRONMENT_TYPE: Undefined
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    mu-plugins: writable
    
    ### wp_mail_smtp ###
    
    version: 2.8.0
    license_key_type: lite
    debug: No debug notices found.
    db_tables: wp_wpmailsmtp_tasks_meta
    lite_install_date: Jun 10, 2021 @ 2:15pm
    
    

    Auch steht:
    „Error Some files are not writable by WordPress: index.php“

    • Diese Antwort wurde geändert vor 3 Wochen, 5 Tage von exodusn.

    Wie vermutet, PHP 8. Schon umgestellt auf 7.4?

Ansicht von 13 Antworten - 1 bis 13 (von insgesamt 13)