Support » Allgemeine Fragen » Fehler nach Update

  • Gelöst kurzvor

    (@kurzvor)


    Guten Morgen,

    ich habe mich gestern, nachdem mein Blog sehr langsam lief, mal an das Update gewagt.
    Seitdem geht leider gar nichts mehr. Ich komme nicht mehr in das Dashboard, kann nichts mehr bearbeiten und meine Seite wird nicht mehr angezeigt. Mein Theme ist Rosenary und ich habe die üblichen Plugins.
    Das erscheint wenn ich auf das Dashbaord klicken möchte: http://kurzvor.com/wp-admin/upgrade.php?_wp_http_referer=%2Fwp-admin%2F.
    Bin für jeden Tipp dankbar. Leider kein Technikprofi.
    Danke und Grüße,
    Sylvia

Ansicht von 13 Antworten - 1 bis 13 (von insgesamt 13)
  • Da schließe ich mich an, meine Seite ( http://www.karmann-photo.de ) wird auch nicht angezeigt (leeres Fenster, URL wird in der Adressleiste richtig angezeigt).. Die HP wurde über Nacht automatisach auf 4.7 aktualisiert. Eine weitere Seite, die noch mit 4.5 läuft, macht keine Probleme.

    @kurzvor
    Versuch mal, dich über http://kurzvor.com/wp-login.php anzumelden. Das Anmeldeformular wird ja ganz normal angezeigt und die Website läuft auch schon unter 4.7 Ggf. auch mal Browser-Cache löschen.

    @digi-nik
    Neue Frage? Neuer Thread. Darum bitten wir immer wieder, weil sich die Probleme doch in den meisten Fällen unterscheiden. Deine Website liefert einen HTTP-Error 500, während die Seite von @kurzvor läuft. Also: Bitte neuen Thread starten, dann schauen wir weiter.

    Thread-Ersteller kurzvor

    (@kurzvor)

    Vielen Dank für dein Feedback 🙂 Nachdem ich mich angemeldet habe, ist die Seite leider weiß.
    In einem anderen Browser habe ich die Seite noch und könnte auf Cache löschen drücken – sobald ich klicke kommt: http://kurzvor.com/wp-admin/upgrade.php?_wp_http_referer=%2Fwp-admin%2Fadmin.php%3Fpage%3Dw3tc_dashboard%26w3tc_flush_all%26_wpnonce%3D62b339c3d1

    Ich bin langsam echt verzweifelt. Habe mir bereits durchgelesen, wie ich eine Rücksetzung mache. Leider verstehe ich da nur die Hälfte und habe Angst mehr kaputt zu machen.

    • Diese Antwort wurde geändert vor 4 Jahre, 9 Monaten von kurzvor.

    Hallo – hast du ein Backup deiner Seite?

    Vielleicht kann Dir auch der Hoster helfen, deine Seite wieder herzustellen – via Backup vom Hoster.

    LG

    Moderator espiat

    (@espiat)

    @kurzvor
    1. Schalte bitte mal den WP_DEBUG an. https://codex.wordpress.org/WP_DEBUG
    Trage dazu folgende Werte in die wp-config.php vor diese Zeile – /* That’s all, stop editing! Happy blogging. */

    define( 'WP_DEBUG', true );
    define( 'WP_DEBUG_DISPLAY', true );

    Wenn du eine Fehlermeldung hast, dann bitte hier eintragen.

    Du kannst zudem auch deine Plugins deaktivieren, in dem du den Ordner per FTP:
    wp-content/plugins

    zb in wp-content/plugins-test

    umbenennst. Einstellungen gehen dadurch nicht verloren. Wenn du dies gemacht hast, dann versuche dich erneut einzuloggen.

    Zum Cache löschen: Da du nicht mehr eingeloggt bist, kannst du diesen nicht löschen.

    Du kannst auch den Cache selbst per FTP löschen, aber das machen wir, wenn du die vorangegangenen Schritte erledigt hast.

    PS: Was heisst konkret?

    habe die üblichen Plugins.

    • Diese Antwort wurde geändert vor 4 Jahre, 9 Monaten von espiat.
    Thread-Ersteller kurzvor

    (@kurzvor)

    Ähm, ich weiß leider nicht genau wie ich das machen soll. Ich bin da leider echt eine völlige Niete auf diesem Gebiet. Ich hatte damals einen Admin, der sich um solche Sachen gekümmert hat.
    Mein Problem ist ja, dass ich gar nicht erst auf den Blog komme. Somit kann ich auch nichts ändern oder anschalten.
    Ich komme an keine Plugins, somit auch keine Deaktivierung möglich. Via FTP habe ich leider noch nie gearbeitet.

    Plugins:
    SEO, Jetpack, W3 Total Cache, Akismet, etc.

    Ich habe gelesen, dass man alle vor dem Update besser deaktivieren sollte. Bis jetzt gab es nie Probleme und leider habe ich es erst danach gelesen.

    Moderator espiat

    (@espiat)

    Plugins:
    SEO, Jetpack, W3 Total Cache, Akismet, etc.

    etc.???

    Bitte beantworte meine Fragen ausführlich.

    Moderator espiat

    (@espiat)

    Zudem: Wenn du nicht mehr, wie in diesem Fall, in das WP-Backend kommst, dann ist der einzige Weg jetzt per FTP. Anders geht es nicht.

    Thread-Ersteller kurzvor

    (@kurzvor)

    Entschuldigung. Das war keine Faulheit, sondern mehr eine Überlegung. Ich habe noch ein Plugin für die Bildvorschau und das war es, glaube ich. Ich kann die Übersicht ja nicht mehr einsehen.

    Leider habe ich keinerlei Erfahurngen mit FTP. Ich gehöre zu den Usern, die ein bisschen klicken und das wars. Ich bin auf der Suche nach einem Support, würde das natürlich auch alles bezahlen! :/

    @kurzvor
    Scheinbar funkt da dein Cache-Plugin W3 Total Cache dazwischen. Das würde ich erst einmal manuell deinstallieren, damit du wieder in dein Backend kommst. Dazu musst du per (Web-)FTP auf deinen Server zugreifen, um dort Dateien zu löschen.

    Die meisten Webhoster bieten in ihren Hilfeseiten für den Zugriff per FTP eine Anleitung, wie du das kostenlos erhältliche FTP-Programm Filezilla nutzen kannst. Oder du schaust, ob dein Webhoster im Kundenmenü eine Seite zur Dateiverwaltung hat – das ist dann Web-FTP.

    Wenn du auf die Dateien zugreifen kannst, gehst du folgende Schritte durch:

    1. Im Verzeichnis wp-content löschst du
    • advanced-cache.php
    • db.php
    • object-cache.php
    • Verzeichnis w3tc-config
    • Verzeichnis cache
    • Verzeichnis plugins/w3-total-cache
    • In der Datei wp-config.php löschst du die Zeilen
      /** Enable W3 Total Cache */
      define('WP_CACHE', true); // Added by W3 Total Cache

      Achte darauf, dass vor dem <?php in der ersten Zeile keine Zeilen eingefügt werden dürfen. Für die Änderung solltest du einen Programmiereditor (z.B. Atom Editor) nutzen. Das Windows-Programm Notepad speichert die Datei in einem falschen Format ab.

    • Zuletzt benennst du die Datei .htaccess um (z.B. .htaccess-w3tc)
    • Nun solltest du dich wieder im Backend anmelden können. Hier speicherst du unter Einstellungen > Permalinks deine gewünschte Link-Struktur und achtest auf mögliche Fehlermeldungen. (WordPress versucht eine neue .htaccess anzulegen. Wenn das klappt, ist alles OK. Wenn du eine Fehlermeldung bekommst, musst du den angebotenen Code kopieren und in einer neuen .htaccess abspeichern.)
    • Nun kannst du überlegen, ob du wieder W3 Total Cache oder ein anderes Cache-Plugin installierst. Ich empfinde das Plugin Comet Cache als benutzerfreundlicher.
    • Wenn Fragen sind, meld dich wieder – am besten unter Angabe des Punktes, bei dem es hakt.

      (Falls du das Gefühl hast, das überfordert dich, kannst du auch rasch anrufen. Meine Telefonnummer findest du auf meiner Website. Normalerweise lehne ich persönlichen Support strikt ab, weil es der Community nicht weiterhilft, aber mit den richtigen Zugangsdaten ist das ein Vorgang von 10 Minuten. Ich mache hier also eine Ausnahme.)

    • Diese Antwort wurde geändert vor 4 Jahre, 9 Monaten von Bego Mario Garde. Grund: Nachtrag
    Thread-Ersteller kurzvor

    (@kurzvor)

    Vielen Dank, ich versuche mal mein Glück! 🙂

    Thread-Ersteller kurzvor

    (@kurzvor)

    Es lag tatsächlich an W3 Total Cache. Vielen Dank an euch alle! Das Plugin kommt jetzt weg.
    Lieben Dank nochmal und viele Grüße!

    Auch ich habe jetzt ein ähnliches Problem.

    Ich habe heute an meinem Blog gebastel (www.yourneys.de) und plötzlich ging nichts mehr. Es kam eine äußerst komische Ansicht des Log-ins wenn ich http://yourneys.de/wp-login.php eingebe (lila Blockschrift auf weißem Untergrund. Furchtbar) und der Blog an sich sieht auch nicht mehr ansatzweise so aus, wie vorher (eigentlich benutze ich Theme Redewood).

    Ich hab keine Ahnung, was da passiert sein könnte. Habt ihr vielleicht Ideen?

    Meine letzte Amtshandlung war das installieren eines Plug-Ins für SEO, das ich schon wieder gelöscht habe. Und ich habe im Dashboard unter „Nutzer“ was am Titel verändert. Da gab es zwei Fenster. In beiden stand http://yourneys.de und ich habe die Adresse in einem der beiden (unter dem ein Link zu folgender Seite war: https://codex.wordpress.org/Giving_WordPress_Its_Own_Directory). zu http://www.yourneys.de geändert. Weiß der Geier, was ich mir dabei gedacht hab. Seitdem ist der Breakdown da. Ich komme weder in mein Log-in, noch wird meine Seite vernünftig angezeigt.
    Plug-Ins hatte ich über FTP alle deaktiviert. Kann also eigentlich nicht sein 🙁

Ansicht von 13 Antworten - 1 bis 13 (von insgesamt 13)
  • Das Thema „Fehler nach Update“ ist für neue Antworten geschlossen.