Support » Allgemeine Fragen » Fehler und Probleme beim Bildupload

  • Liebe Community,
    ich betreibe zwei Websiten beim Provider 1&1. Seit etwa einer Woche ist es auf beiden Seiten nicht mehr möglich, Bilder komplett hochzuladen (beschreibe ich später). Die zwei Seiten sind unterschiedliche WordPress-Versionen, von daher kann es eigentlich nicht von einem Update kommen. Auch das deaktiveren sämtlicher Plugins hilft nicht weiter. Beispielsweise ein .pdf kann hochgeladen werden.

    Möchte ich nun ein Bild in der Mediathek hochladen, bleibt der Uploader bei ‚verarbeiten‘ hängen. Gehe ich nun nochmals in die Mediathek, werden die Titel der Bilder, aber keine Thumbs angezeigt. Klicke ich nun auf das Bild, wird groß es angezeigt – es wurde also hochgeladen. Jedoch wird es beim Upload anscheinend nicht verkleinert, es ist die Ausgangsgröße.
    Möchte ich eine Datei direkt in einem Beitrag hochladen (z.B. Beitragsbild) erscheint die Fehlermeldung ‚Bei dem Upload ist ein Fehler aufgetaucht. Probiere es später noch einmal.‘. Das Bild ist jedoch gleich wie bereits angeführt hochgeladen worden. Es kann jedoch nicht für den Beitrag ausgewählt werden (ausgegraut).

    Bezügl. der Ordner-Berechtigungen: Ich habe bemerkt, dass diese auf 705 eingestellt waren, habe dann 755 bzw. 777 eingestellt, bracht aber keine Besserung. Auch Gallery-Plugins wie Nextgengallery funktioniert nicht mehr.

    Noch etwas zur Einstellung: Ich hab umgestellt, dass WordPress die Dateien Monateweise speichert. (Einstellungen – Medien – Haken bei ‚Organisiere meine Uploads in monats- und jahresbasierten Ordnern‘).

    Ich vermute also, dass es Probleme mit den Thumbs und der Skalierung/Größenreduziertung gibt. Kann man den Upload von WordPress irgendwie zurücksetzen/neu installieren?

    Danke für eure Hilfe.

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 18)
  • Thread-Starter 11Rick11

    (@11rick11)

    Okay, sollte jemand von euch das selbe Problem haben: Es liegt tatsächlich am Provider 1&1.
    Meine Lösung war hier zu finden: https://www.websplash-online.de/blog/fehlermeldung-bilderupload-wordpress/#comment-6643

    Instllation des Plugins ‚Resize images before upload‘ und der WordPress-eigene Upload funktioniert wieder. Andere Plugins wie Nextgengallery jedoch immer noch nicht..!

    Bei zu großen Bildern ist der Speicher vielleicht einfach zu klein bemessen. Dann schafft WordPress es nicht, die Bilder-Thumbnails zu erstellen. Ggf. in neueren Tarif mit mehr Speicher wechseln, wenn es sich um einen alten 1und1-Tarif handelt.

    Gruß, Torsten

    Thread-Starter 11Rick11

    (@11rick11)

    Hi Thorsten,
    danke für die Info. Am Speicher lags nicht, habe die upload-size mittels php.ini auf 32mb gestellt, jedoch hat es trotzdem nicht funktioniert. Das Speicher-Limit des Serves liegt bei über 100mb (was ich jetzt im Kopf hab). Der 1&1 Support konnte auch nicht weiterhelfen (wie leider so oft). Jedoch scheint lt. dem o.a. Link echt öfter bei 1&1 Hosting zu diesem Problem zu kommen.

    Wäre interessant woran es wirklich liegt.

    LG Patrick

    Hi allerseits,
    habe das gleiche oder selbe Problem: Bis vor einigen Tagen gab es kein Problem mit dem Hochladen von Bildern oder auch einem Video. Plötzlich wurde dann der Upload-Verlauf zwar angezeigt, danach aber die Fehlermeldung ausgegeben: ‚Bei dem Upload ist ein Fehler aufgetaucht. Probiere es später noch einmal.“
    Was ist zu tun? Was muss ich ändern?
    Gruss
    Micha

    Keine fremden Themen hijacken. Eigene Frage = eigener Thread. Danke.

    Gruß, Torsten

    Hallo Torsten Landsiedel, ich denke es geht hier nicht um hijacken eines Themas, sondern vielmehr, so geht es mir jedenfalls, ziemlichen Ärger und reine Verzweiflung!
    Es kann ja wohl auf keinen Fall sein, das WordPress als CMS gepriesen wird die Updates dann allerdings dafür sorgen das die Nutzer nicht mehr damit arbeiten können. Ich selbst habe das Problem mit dem Bildupload ebenfalls, allerdings speziell bei dem Hoster Strato, bei meinem 2. Hoster All-Inkl funktioniert der Bildupload und das Darstellen der Thumbnails so das ich die Bilder auch verwenden kann. WordPress ist aber auf ALLE Hoster und Provider ausgelegt oder? … Es ist ziemlich frustrierend und auch geschäftsschädigend wenn das meistgenutzte und, meiner Ansicht nach, beste CMS durch ungetestete Updates zerstört wird. Als Fazit bleibt da eigentlich nur: AUF KEINEN FALL UPDATEN.
    Bin mal gespannt auf ihre Antwort.
    Als kleine Anmerkung: Ich arbeite nebenberuflich als Internet-Marketing Berater, entwickle eigene Trainings und empfehle WordPress ausdrücklich. Wie soll man bitteschön einem zahlenden Kunden erklären das Neue Bilder für Neue Produkte, Services etc. zur Zeit nicht hochzuladen sind weil WordPress nicht funktioniert??
    Mit den Besten Grüßen
    Thomas Raabe

    Salute community,
    bin völlig einer Meinung mit Thomas Raabe. Mimr geht es so, dass ich das Problem des uploads gegoogelt habe und dann auf dieses Forum gestoßen bin. Allerdings war in diesem Forum auch noch keine schlüssige Antwort zu finden. Irgendwo sonst habe ich dann gefunden, dass mit dem plugin“resize before upload“ das Problem zu lösen sei. Das habe ich dann auch getan und bei mir funktioniert der upload neuer Medien jetzt einwandfrei. Es hat ja wohl kaum etwas mit hijacken von Themen zu tun, wenn man das forum eines Kollegen nutzt, in dem er ein ähnliches Problem schildert und man dazu dann ergänzende Probleme dazugibt. dies führt aus meiner Sicher eher dazu, das Problem noch mehr einzugrenzen und ggfls dann auch für alle zu lösen. Vergesst also diesen blöden Formalismus ein Problem=ein thread und kümmert euch lieber darum, die Probleme zu lösen. Wir sind ja wohl hier nicht in einer Behörde. Oder doch?
    Gruss
    MGMedien

    Edi

    (@psychosopher)

    @thomas Rabe und @mgmedien Dazu gäbe es schon einiges zu schreiben. Da es aber nichts mit Lösungen im Zusammenhang mit „Fehler und Probleme beim Bildupload“ zu tun hat, bitte einen eigenen Thread in der Rubrik „Diskussion“ eröffnen.

    @mgmedien – vielen Dank für ihre Meinung, freut mich das Sie derselben Meinung sind. Sicher ist es sinnvoll ein Problem=ein Thread um zu vermeiden das ein heilloses Wirrwarr entsteht. Dennoch bin ich ebenso der Ansicht, das LÖSUNGEN hier eingestellt werden sollten, erst recht wenn dieses Problem extrem viele Nutzer haben. Inzwischen habe ich mit Hilfe von Nutzern bei Google+ die Erklärung und Lösung für das Problem gefunden, eine Schritt für Schritt Anleitung finden Sie hier: https://youtu.be/Ncs_Cw1VK4I, ist übrigens nicht nur für Strato-Kunden wie im Video erwähnt. Das Problem ist die php-Version des Servers.
    @edi Goetschel – Ich verstehe zwar ihre Haltung, teile diese aber nicht. Dieses Forum soll doch Lösungen bringen und keinesfalls nur die Probleme ausbreiten oder? Schauen Sie sich doch mal im Warrior-Forum mal um, dort werden Lösungen für die Probleme angeboten, und nicht auf irgendwelche Formalitäten verwiesen. Wie gesagt, ich verstehe es aber ich teile keinesfalls ihre Meinung.
    Beste Grüße Thomas Raabe, Marketingspezialist

    Edi

    (@psychosopher)

    @thomas Raabe Du kannst hier im Forum unter „Diskussionen“ einen Thread für die angesprochenen Grundsatzfragen und/oder Deine persönliche Meinung eröffnen, wie bereits vorgeschlagen wurde. Das hat nichts mit Formalitäten zu tun, sondern mit der Art, wie in einem Forum vernünftigerweise Gedanken ausgetauscht werden.

    HI

    ich habe das gleiche Problem auf Strato. Und zwar bei 2 verschiedenen WordPress Installationen. Eine Dritte auf 1 Blue funktioniert.
    Habe auch all das nötige schon unternommen… any ideas?

    @vindivindaloo: Bitte einen eigenen Thread dazu eröffnen. Danke!

    Und aus aktuellem Anlass, hier nochmal die Erklärung:
    Warum ein eigener Thread?

    – Die Forensoftware ermöglicht es uns nicht ein Thema zu splitten.

    – Ich kann einen Thread als gelöst markieren. Was passiert, wenn jemand das Problem als gelöst sieht und ein anderer aus dem Thread nicht?

    – Wir stellen Rückfragen, um eine individuelle Lösung zu finden. Vielleicht liegt das scheinbar identische Problem bei einem an zu wenig Speicher, bei einem anderen an falschen Dateirechten. (Was allein in diesem Thread schon der Fall ist, wenn man die Beiträge genau liest.)

    – Um Antworten auf *deine* Frage zu bekommen, abonnierst du den Thread und wirst per Mail benachrichtigt. Jetzt kommt jemand dazu und stellt neue Fragen, gibt andere Umgebungen als Antwort an, etc. und du bekommst immer noch für dich ggf. irrelevante Infomails.

    => Fazit: Eine Frage = ein Thread ist übersichtlicher, erzeugt weniger Spam und erzeugt individuellere und somit bessere Lösungen.

    Für die „Beantworter“ in diesem Forum ist es so deutlich einfacher zu helfen.

    Sollte ein Thema von so vielen Menschen hervorgebracht werden, dass es sich tatsächlich um ein allgemeines WordPress-Problem handelt, dass viele User gleichmäßig betrifft, dann werden wir Moderatoren es bemerken und einen Sticky-Post einrichten, der als Sammelthread dienen kann, um möglichst viel Feedback zu sammeln, um dem Fehler auf die Schliche zu kommen. Das ist bei dem hier geschilderten Fall mit dem Uploadproblem aber nicht der Fall gewesen. Es sind Individualprobleme, die auch individuelle beantwortet gehören.

    Es geht auch nicht um inhaltlose Formalitäten, sondern um die oben genannten Punkte.

    Uploadprobleme können viele Gründe haben.
    Manchmal liegt es am Hoster/Server, PHP, Größe, Benennung, Internetverbindung, etc.

    WordPress selbst ist es in den meisten Fällen nicht, sondern eine Verkettung von Umständen, die nicht durch WordPress lösbar sind.
    Sam Wood hat dazu mal einen guten Forenpost geschrieben, wo er versucht viele Punkte zu Bildupload-Problemen abzudecken:
    https://wordpress.org/support/topic/25-imagemedia-uploader-problems?replies=1#post-719496

    Als Fazit bleibt da eigentlich nur: AUF KEINEN FALL UPDATEN.

    Diesen Rat sollte jeder ignorieren, wenn man bedenkt, dass es sich in den letzten Tagen um Security-relevante Updates gehandelt hat.

    Gruß, Torsten

    @vindivindaloo: Habe gerade einen Neuen Thread eröffnet, die Lösung findest du dort. Titel ist: LÖSUNG Bild Upload Probleme bei Version 4.2.1 , gerne auch verbreiten.

    @torsten Landsiedel: Wie ich schon vorher geschrieben hatte, ich verstehe es durchaus das ein Forum organisiert werden muß um den Überblick nicht zu verlieren und Spam zu verhindern ebenso wie fruchtlose Diskussionen. Das „Auf keinen Fall Updaten“ war dahingehend gemeint, das kein Update von Verkaufsseiten, Geschäftsseiten etc erfolgen sollte bevor nicht die Probleme geklärt sind und vor allem Lösungen dafür vorhanden sind! Bis dahin ist es weitaus effektiver und sicherer eine ältere, aber Funktionsfähige Version zu nutzen! Machen Sie sich bitte einmal bewußt das sehr viele Verkaufsseiten mit WordPress betrieben werden, diese Nutzer werden schier in den Wahnsinn getrieben(etwas überspitzt gesagt), vor allem ist Geschäftsschädigend. Insofern sollte das Developerteam sich einfach mal als Tester sowohl Geschäftskunden wie auch Privatleute mit wenig Technikvorwissen aussuchen und dann einen Test laufen lassen. Sicherlich ist es ein Problem (diesesmal) beim Hoster, aber es ist eigenartig das es nicht nur Einen sondern Mehrere Hoster betrifft mit sehr vielen Kunden.
    Das ist das Zauberwort: KUNDEN! Es sind auch IHRE KUNDEN(!).
    Es wäre sicher sehr interessant einen Hangout mit Ihnen, einem der Entwickler und einigen Usern als Gesprächspartner in naher Zukunft zu starten. Schreiben Sie mir gerne ihre Meinung dazu.
    Eins noch zum Schluß: Ich wollte Sie auf keinen Fall persönlich angreifen, nichts liegt mir ferner. Mein Interesse liegt darin Lösungen zu schaffen die Einfach, Verständlich und so beschrieben sind das ein 6jähriger es nachmachen kann. Das ist sowohl in meinen Trainings wie auch in Lösungsvorschlägen Priorität.
    Mit Besten Grüßen
    Thomas Raabe

    @thomas Raabe: Ihre Lösung ist nicht hilfreich, da sie nicht den Kern trifft. Es ist nicht per se ein Problem mit der PHP-Version. WordPress läuft mit PHP 5.2.4+. Siehe meine Antwort im anderen Thread. Damit erübrigt sich auch jede Diskussion über Tests.

    Gruß, Torsten

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 18)
  • Das Thema „Fehler und Probleme beim Bildupload“ ist für neue Antworten geschlossen.