• Gelöst cocolorez

    (@cocolorez)


    Hallo,

    hiermit bitte ich um Eure freundliche Hilfe, nachdem ich im Forum nicht fündig geworden bin. Ich habe folgendes Problem :

    Seit dem Umzug/ Übertragung unserer ersten Strato/Wordpress Website an meine Tochter ( evelynbox.de ) scheitern wir nach dem upload der zuvor bei mir gesicherten Datein an einer korrekten Wiederherstellung der Word-Press-Webseite in dem neuen Domain-Account (auch bei Strato).

    Wird die Webseite im Netz aufgerufen, erscheint diese Fehlermeldung als Zeile ganz oben auf der Homepage :

    Error: Your upload path is not valid or does not exist: /mnt/web123/c3/80/51439980/htdocs/STRATO-apps/wordpress_01/app/wp-content/uploads.

    Aber schlimmer noch : Das (diesbzgl.) Word Press Login funktioniert zur Zeit nicht mehr !! Dort heißt es :

    "Fehler : Cookies sind wegen einer unerwarteten Ausgabe gesperrt." , bzw.: "Error: Cookies are blocked due to unexpected output.."

    Ein Einloggen ist somit nicht möglich.

    Nun frage ich mich, was ich meiner Tochter da möglicherweise an der vorher in meinem Strato-Account noch funktionierenden versemmelt habe. Liegt der Fehler vielleicht im Bereich meiner vorherigen Dateien wp-config.php aus meiner Datensicherung (Strato-app), die nach einem i.Ü. automatisch inzw. erfolgten update evtl. nicht mehr kompatibel sind ? Wie könnte ich das ggf. beheben ?

    Die in den Foren allgemein empfohlene Anpassung der wp-config.php habe ich über den notepad Editor mit den neuen Daten aus dem neuen Strato-Hosting-Paket angepaßt.

    Der o.g. Fehler bleibt – für jeden Besucher ersichtlich – aber trotzdem leider bestehen.

    Wäre super, wenn ich mit Eurer Hilfe hier vielleicht eine Lösung finden könnte, um diese Error-Meldung auf der Webseite vom Hals zu bekommen und wieder bei word press einloggt werden kann.

    Im Moment bin ich ganz schön verzweifelt. 🙁
    Was kann ich tun ?

    Wäre für jeden Ratschlag sehr dankbar.
    LG Rita



    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 8 Antworten – 1 bis 8 (von insgesamt 8)
  • Moderator Bego Mario Garde

    (@pixolin)

    Seit dem Umzug/ Übertragung unserer ersten Strato/Wordpress Website …

    Wie bist du dabei vorgegangen?

    Die in den Foren allgemein empfohlene Anpassung

    Was meinst du damit?

    Bitte teile den Inhalt der wp-config.php. Achte darauf, dass du in der Foren-Antwort die Zeilen mit den Zugangsdaten zur Datenbank und den Sicherheitsschlüsseln entfernst – sie sind für die Beurteilung der Einstellungen erst einmal unerheblich.

    Im Moment bin ich ganz schön verzweifelt.

    Krieg, ein krankes Kind, Klimawandel … es gibt viele Gründe, wieso man verzweifelt sein kann. Eine Website gehört nicht dazu.

    Thread-Starter cocolorez

    (@cocolorez)

    Hallo Bego,

    erstmal vielen Dank für den quick response.

    Zu Deinen Rückfragen
    (wie bist Du vorgegangen ? / was meinst Du mit Anpassung ? ) hier das folgende zum näheren Verständnis :

    Meine Tochter hat inzwischen ein eigenes Strato-Hosting Paket und wir haben die Domain evelynbox.de deshalb auf sie und dorthin übertragen.

    Ich habe von der für meine Tochter zunächst noch bei mir auf meinem eigenen Strato-Hosting/Serverspace erstellten WP Präsenz (evelynbox.de) dann also zunächst ein backup gemacht, und Sicherungskopie der Datenbank heruntergeladen.

    Es erfolgte dann also der Umzug nach der denic-Übertragung der domain evelynbox.de auf meine Tochter und für ihren eigenen (neuen) Server, aber beim gleichen Hoster Strato.

    Man beginnt dafür ja zunächst mit dem noch jungfräulich und noch mit dem „Hello World“ Standard-Platzhalter des Hosters mit einem Standard Hintergrundbild und der darauf abgebildeten Titelzeile der Webseite.

    Dann haben wir die Grundfunktionen auf dem neuen Serverplatz meiner Tochter erstmal eingerichtet, also wie SSL und Email, etc. p.p.

    Das Einloggen beim (neuen) Strato Serverzugang funktionierte zunächst auch ganz korrekt genauso wie das Einloggen in WP ohne Probleme.

    Wie bei codex.wordpress.org empfohlen, habe ich dann vor dem Aufsetzen, also vor der weiteren Übertragung der gesicherten Dateien vorsorglich die vorhandenen Plug Inns deaktiviert und mich dann erst einmal ausgeloggt.

    Dann habe ich den Serverzugang (zu Strato) fertig eingerichtet und alle notwendigen Server-Daten mit filezilla dort eingetragen.

    Sodann habe ich alle gesicherten Dateien übertragen. (also wp-content, htaccess, wp-config und die übrigen Dateien und Ordner )

    Dann habe ich die wp-config.php nach den Anleitungen bei Strato und bei codex.wordpress.org mit den neuen Serverdaten angepaßt.
    ( siehe : wordpress.org/documentation/article/moving-wordpress/ )

    Dann habe ich mich wieder in den neuen Strato Account eingeloggt und in die dort bereitstehende neue Datenbank die gesicherten Datei importiert.

    Das führte dann zu dem vorliegenden und hier im Posting beschriebenen PROBLEM :

    Der Inhalt ist auf der Website evelynbox.de zwar vorhanden und auch die Unterordner sind alle aufrufbar, es erscheint aber auf den Webseiten am oberen Rand die Fehlermeldung :

    Error: Your upload path is not valid or does not exist: /mnt/web123/c3/80/51439980/htdocs/STRATO-apps/wordpress_01/app/wp-content/uploads

    I.Ü. wird ein Einloggen bei WP blockiert wie bereits oben beschrieben :

    "Fehler : Cookies sind wegen einer unerwarteten Ausgabe gesperrt." , bzw.: "Error: Cookies are blocked due to unexpected output.."

    Alle Versuche das Problem z.B. durch das Löschen der htaccess (wurde anschließend natürlich wieder eingesetzt), und alle serverspezifischen Anpassungen in der wp-config.php haben nichts gebracht und das Problem ist bis jetzt nicht gelöst.

    Sogar die Repair Option für die Datenbank habe ich in der wp-config.php noch eingetragen und ausgelöst. Allerdings auch ohne Erfolg. Meldung lautet (bis auf die „upload path ist not valid“-Meldung „alles in Ordnung“ siehe hier :

    Error: Your upload path is not valid or does not exist: /mnt/web123/c3/80/51439980/htdocs/STRATO-apps/wordpress_01/app/wp-content/uploads
    
    WordPress
    Ergebnisse der Datenbank-Reparatur Die Tabelle rysd_users ist in Ordnung. Die Tabelle rysd_usermeta ist in Ordnung. Die Tabelle rysd_posts ist in Ordnung. Die Tabelle rysd_comments ist in Ordnung. Die Tabelle rysd_links ist in Ordnung. Die Tabelle rysd_options ist in Ordnung. Die Tabelle rysd_postmeta ist in Ordnung. Die Tabelle rysd_terms ist in Ordnung. Die Tabelle rysd_term_taxonomy ist in Ordnung. Die Tabelle rysd_term_relationships ist in Ordnung. Die Tabelle rysd_termmeta ist in Ordnung. Die Tabelle rysd_commentmeta ist in Ordnung. Reparaturen abgeschlossen. Bitte entferne die folgende Zeile aus wp-config.php, um diese Seite vor unauthorisierten Zugang zu schützen. define('WP_ALLOW_REPAIR', true);

    Im Moment bin ich somit in der Zwickmühle, dass die Webseite komplett mit allen Inhalten zwar erreichbar ist, dann aber eben immer mit dieser upload-path-Fehlermeldung und der Zugung zu WP dann auch außerdem komplett blockiert ist (s.o.),

    oder

    ich setze alles zurück auf die am Anfang noch inhaltslose Startplattform, also mit diesem einfachen Arbeits-Platzhalter-Template von Strato. Dann ist ein WP LogIn zwar wieder möglich, die Webseite findet aber die jedenfalls übertragenen und in die Datenbank geladenen Bilder und Einstellungen und das richtige Template nicht.

    Die library scheint wie leer und unsichtbar und jegl. Zugriff auf den content scheint nicht zu klappen.

    Vielleicht liegt hier nur ein kleiner blöder Denkfehler vor ?
    Nur welcher ?

    Ein kurzer Hinweis noch mit der Bitte um Geduld und Verständnis :
    Ich bin zwar ein WP-Newbie, aber im Übrigen auch schon eine Omi 😉

    Unsere wp-config.php hier unten anbei.
    (ohne die Zugangsdaten und Sicherheitsschlüssel)

    Vielen Dank schon mal für alle freundlichen Hinweise.
    LG Rita

    <?php
    
    /**
    
     * The base configuration for WordPress
    
     *
    
     * The wp-config.php creation script uses this file during the installation.
    
     * You don't have to use the web site, you can copy this file to "wp-config.php"
    
     * and fill in the values.
    
     *
    
     * This file contains the following configurations:
    
     *
    
     * * Database settings
    
     * * Secret keys
    
     * * Database table prefix
    
     * * ABSPATH
    
     *
    
     * @link https://wordpress.org/support/article/editing-wp-config-php/
    
     *
    
     * @package WordPress
    
     */
    
    // ** Database settings - You can get this info from your web host ** //
    
    /** The name of the database for WordPress */
    
    define( 'DB_NAME', '' );
    
    /** Database username */
    
    define( 'DB_USER', '' );
    
    /** Database password */
    
    define( 'DB_PASSWORD', '' );
    
    /** Database hostname */
    
    define( 'DB_HOST', 'rdbms.strato.de' );
    
    /** Database charset to use in creating database tables. */
    
    define( 'DB_CHARSET', 'utf8' );
    
    /** The database collate type. Don't change this if in doubt. */
    
    define( 'DB_COLLATE', '' );
    
    /**#@+
    
     * Authentication unique keys and salts.
    
     *
    
     * Change these to different unique phrases! You can generate these using
    
     * the {@link https://api.wordpress.org/secret-key/1.1/salt/ WordPress.org secret-key service}.
    
     *
    
     * You can change these at any point in time to invalidate all existing cookies.
    
     * This will force all users to have to log in again.
    
     *
    
     * @since 2.6.0
    
     */
    
    define('AUTH_KEY',         '');
    
    define('SECURE_AUTH_KEY',  '');
    
    define('LOGGED_IN_KEY',    '');
    
    define('NONCE_KEY',        '');
    
    define('AUTH_SALT',        '');
    
    define('SECURE_AUTH_SALT', '');
    
    define('LOGGED_IN_SALT',   '');
    
    define('NONCE_SALT',       '');
    
    /**
    
     * Other customizations.
    
     */
    
    define('FS_METHOD','direct');
    
    define('FS_CHMOD_DIR',0755);
    
    define('FS_CHMOD_FILE',0644);
    
    define('WP_TEMP_DIR',dirname(__FILE__).'/wp-content/uploads');
    
    /**#@-*/
    
    /**
    
     * WordPress database table prefix.
    
     *
    
     * You can have multiple installations in one database if you give each
    
     * a unique prefix. Only numbers, letters, and underscores please!
    
     */
    
    $table_prefix = 'rysd_';
    
    /**
    
     * For developers: WordPress debugging mode.
    
     *
    
     * Change this to true to enable the display of notices during development.
    
     * It is strongly recommended that plugin and theme developers use WP_DEBUG
    
     * in their development environments.
    
     *
    
     * For information on other constants that can be used for debugging,
    
     * visit the documentation.
    
     *
    
     * @link https://wordpress.org/support/article/debugging-in-wordpress/
    
     */
    
    define( 'WP_DEBUG', false );
    
    /* Add any custom values between this line and the "stop editing" line. */
    
    define('WP_ALLOW_REPAIR', true);
    
    /* That's all, stop editing! Happy publishing. */
    
    /** Absolute path to the WordPress directory. */
    
    if ( ! defined( 'ABSPATH' ) ) {
    
                define( 'ABSPATH', __DIR__ . '/' );
    
    }
    
    /** Sets up WordPress vars and included files. */
    
    require_once ABSPATH . 'wp-settings.php';
    
    define( "WP_AUTO_UPDATE_CORE", true );
    
    ?>
    bscu

    (@bscu)

    und Sicherungskopie der Datenbank heruntergeladen.

    Das dürfte das Problem sein, denn in der Datenbank stehen URL’s und Dateipfade drin, die natürlich jetzt nicht mehr stimmen. Kommst du noch an die erste Domain? Wenn ja, dann installiere dort mal das Plugin „WP Migrate DB“ und exportiere damit die Datenbank, in dem du vorher in dem Plugin URL und Pfad zum ersetzen einträgst. Die dann erstellte SQL-Datei importierst du dann auf dem neuen Server. Du solltest dich danach zumindest wieder einloggen können.

    Moderator Bego Mario Garde

    (@pixolin)

    Bitte entferne die folgende Zeile aus wp-config.php, um diese Seite vor unauthorisierten Zugang zu schützen.

    define(‚WP_ALLOW_REPAIR‘, true);

    Diese Anweisung solltest du noch umsetzen.

    Außerdem solltest du die Zeilen

    define( "WP_AUTO_UPDATE_CORE", true );
    
    ?>

    löschen. Es ist sinnvoll, dass bei Bekanntwerden schwerwiegender Sicherheitslücken automatisch Updates vorgenommen werden (auch wenn Strato das anders sieht).

    Bitte öffne über das Kundenmenü von Strato die Datenbank und prüfe in der Datenbank-Tabelle rysd_options, ob der Eintrag für das Feld upload_path stimmt. Der Pfad dürfte nach dem Wechsel nicht mehr stimmen.

    Thread-Starter cocolorez

    (@cocolorez)

    Hallo,

    Ganz herzl. Dank für die ausgezeichneten und verständlichen Hinweise !
    Ihr habt uns wirklich den Sonntag gerettet. 

    zunächst @ bscu :  Dein guter Rat :

    „..in der Datenbank stehen URL’s und Dateipfade drin, die natürlich jetzt nicht mehr stimmen. Kommst du noch an die erste Domain? Wenn ja, dann installiere dort mal das Plugin „WP Migrate DB“ und exportiere damit die Datenbank, in dem du vorher in dem Plugin URL und Pfad zum ersetzen einträgst. Die dann erstellte SQL-Datei importierst du dann auf dem neuen Server. Du solltest dich danach zumindest wieder einloggen können.“

    Leider konnte ich dem zunächst nicht folgen, weil ich an die ursprüngliche Domain nicht mehr herangekommen bin. Aber gedanklich konnte ich das gut nachvollziehen und habe mir das gemerkt.

    @ bego :

    „..Bitte entferne ( … )
    define(‚WP_ALLOW_REPAIR‘, true);
    Diese Anweisung solltest du noch umsetzen.
    Außerdem solltest du die Zeilen
    define( „WP_AUTO_UPDATE_CORE“, true );
    ?> löschen…“

    Dem konnte ich gerne folgen. Auch folgendes habe ich gut verstanden.

    „Es ist sinnvoll, dass bei Bekanntwerden schwerwiegender Sicherheitslücken automatisch Updates vorgenommen werden (auch wenn Strato das anders sieht)…“

    Dann führte Dein 2. Hinweis – nach dem Hinweis von bscu – zum Erfolg :

    „..Bitte öffne über das Kundenmenü von Strato die Datenbank und prüfe in der Datenbank-Tabelle rysd_options, ob der Eintrag für das Feld upload_path stimmt. Der Pfad dürfte nach dem Wechsel nicht mehr stimmen.“Bitte öffne über das Kundenmenü von Strato die Datenbank und prüfe in der Datenbank-Tabelle rysd_options, ob der Eintrag für das Feld upload_path stimmt. Der Pfad dürfte nach dem Wechsel nicht mehr stimmen..“

    Ja !!

    Genau dort befand sich nun auch tatsächlich der falsch übertragene, alte Pfad-Eintrag meiner ursprünglichen Domain , welcher mit der auf der Webseite erschienenen Fehlermeldung ersichtlich identisch war.

    Da ich dagegen den neuen Server-upload-Pfad und die jetzige (korrekte) Kennung aber nirgendwo finden und auslesen konnte, konnte ich den falschen Eintrag allerdings auch nicht ändern.

    Ich habe bei ‚upload path‘ in der Tabelle ‚rysd options‘ also dann einfach mutig den falschen Pfadeintrag entfernt, sodaß dort in der letzten Spalte dieser Zeile nun nichts mehr stand und nichts mehr steht.  Die Hoffnung dass der repair mode dann die richtigen Pfade findet hat sich zu meiner Freude dann anscheinend erfüllt und die Webseite mit allem content und WP-LogIn und Mail-Weiterleitungen etc funktionieren wieder.

    Einzig die Frage bleibt mir jetzt noch, ob ich vielleicht in der (jetzt leeren) Spalte bei rysd options den richtigen upload-path noch eintragen sollte, müßte, oder könnte 😉  ( falls dieser irgendwo auffindbar und ablesbar ist ).

    Also nochmal ein dickes Dankeschön für all Eure liebe Mühe und die sehr wertvollen und erfolgreichen Tips !

    Rita

    Moderator Bego Mario Garde

    (@pixolin)

    Einzig die Frage bleibt mir jetzt noch, ob ich vielleicht in der (jetzt leeren) Spalte bei rysd options den richtigen upload-path noch eintragen sollte, müßte, oder könnte 😉 ( falls dieser irgendwo auffindbar und ablesbar ist ).

    Es ist OK, wenn das Feld leer bleibt, wenn du keinen abweichenden Pfad einrichten willst.

    Wo z.B. deine Themes und Plugins gespeichert werden, kannst du unter Werkzeuge > Website-Zustand im Tab Bericht unter Verzeichnisse und Größen ablesen. Dort sollte auch der aktuell verwendete Upload-Pfad stehen.

    bscu

    (@bscu)

    falls dieser irgendwo auffindbar und ablesbar ist

    Wie @pixolin schon schrieb, kann man das per WordPress herausfinden. Wenn man keinen Zugriff auf das Dashboard hat und/oder andere Server-Information sehen möchte, reicht dieser 3-Zeiler

    <?php
       phpinfo();
    ?>

    Diese 3 Zeilen in eine Datei kopieren, als z.B. info.php speichern, die Datei per FTP auf den Server kopieren und dann im Browser aufrufen. Wobei der Dateiname info.php hier wirklich nur als Beispiel dienen soll, ich würde eher einen kryptischen Namen nehmen, denn so manche bösen Bots suchen gerne nach Dateien mit Namen wie info.php, phpinfo.php, etc.

    Thread-Starter cocolorez

    (@cocolorez)

    Super-klasse Informationen !
    Ihr habt uns sehr geholfen und die ganze Familie ist glücklich !

    LG
    Rita

Ansicht von 8 Antworten – 1 bis 8 (von insgesamt 8)
  • Das Thema „Fehler: „Your upload path is not valid“ nach Domainumzug“ ist für neue Antworten geschlossen.