Support » Allgemeine Fragen » Fehlermeldung auf der Frontpage

  • Hallo WordPress Community,

    ich hoffe, ihr könnt ihr helfen. Ich kriege folgende Fehlermeldung auf der Frontpage:
    Warning: Trying to access array offset on value of type bool in /homepages/6/d4296061091/htdocs/absichtsvoll-leben.de/wp-content/themes/arcade/functions.php on line 240

    Ich kann bereits im Forum lesen, dass andere den Fehler auch hatten, weiß aber nicht, ob die vorgeschlagene Lösung für alle gleich ist.

    Ich nutze das Theme Arcade, habe alles upgedated (WordPress, Plugins, Themes)

    Danke vorab!

    Grüße
    Christina

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 8 Antworten - 1 bis 8 (von insgesamt 8)
  • Das ist ein Fehler im Theme, deshalb solltest du den Hersteller kontaktieren.

    Moderator Hans-Gerd Gerhards

    (@hage)

    Hallo,

    Warning Trying to access array offset on value of type bool in <b>/homepages/6/d4296061091/htdocs/…/wp-content/themes/arcade/functions.php

    Wahrscheinlich ist in der wp-config.php WP_DEBUG_DISPLAY aktiviert.
    Ändere bitte mit einem geeigneten Programmier-Editor (z. B. Notepad++) nach einer Sicherung der Datei in der wp-config.php die folgende Zeile wie folgt:
    define( 'WP_DEBUG_DISPLAY', true);
    in
    define( 'WP_DEBUG_DISPLAY', false);
    Dann sollte die Meldung im Frontend nicht mehr erscheinen. Das ist allerdings nur eine Notlösung. Der Entwickler sollte das Problem beheben.
    Viele Grüße
    Hans-Gerd

    Thread-Ersteller christina3

    (@christina3)

    @hage Danke für Deinen Hinweis. Es gab tatsächlich noch mehr Fehlermeldungen, Was wir geändert haben im wp-config.php ist:
    define(‚WP_DEBUG‘,false);

    Die Zeile
    define( ‚WP_DEBUG_DISPLAY‘, true);

    finde ich in dem File nicht.

    Sollte man die anlegen?

    Danke vorab!

    Grüße
    Christina

    Thread-Ersteller christina3

    (@christina3)

    @bscu Danke für Deinen Hinweis. Ich habe den Hersteller aufgrund Deines Tipps angeschrieben.

    Leider bin ich schon aus dem Support „raus“ von der zeitlichen Sicht (2018 gekauft). Aber mal schauen, ob sie antworten.

    Grüße
    Christina

    Moderator Hans-Gerd Gerhards

    (@hage)

    @christina3
    Teste doch mal bitte, ob die Meldung verschwindet, wenn du
    define( 'WP_DEBUG_DISPLAY', false );
    in die wp-config.php oberhalb von /* That’s all, stop editing! Happy blogging. */ schreibst.

    Leider bin ich schon aus dem Support „raus“ von der zeitlichen Sicht (2018 gekauft).

    Möglicherweise erhältst du dann auch keine Updates mehr, bei denen (hoffentlich) das Problem behoben ist.
    Viele Grüße
    Hans-Gerd

    Thread-Ersteller christina3

    (@christina3)

    @hage ich hab Deinen Tipp direkt ausprobiert. Hat leider nicht direkt funktioniert. Daher nochmal ne Rückfrage, ob ich nen Fehler gemacht hab. Ich habs hintereinander weggeschrieben im Log (an der Stelle, die Du benannt hast):

    define(‚WP_DEBUG‘,false);
    define( ‚WP_DEBUG_DISPLAY‘, false );

    Moderator Hans-Gerd Gerhards

    (@hage)

    @christina3
    prüfe mal bitte, ob du die Hochkommatas richtig geschrieben hast:

    define('WP_DEBUG',false);
    define( 'WP_DEBUG_DISPLAY', false );

    und bitte beim posten von Code hier „Code“ wählen.
    Schau auch mal bitte in den folgenden Beitrag auf wordpress.org.
    Evtl. hilft auch ein Beitrag, den ich vor ein paar Wochen geschrieben habe:
    Debug-Modus auf WordPress-Seiten mit und ohne Plugins

    Moderator Hans-Gerd Gerhards

    (@hage)

    @christina3
    an sich sollte der folgende Eintrag schon reichen:
    define('WP_DEBUG',false);

Ansicht von 8 Antworten - 1 bis 8 (von insgesamt 8)