Support » Allgemeine Fragen » Fehlermeldung bei Anmeldung

  • Bei einer von 8 Webseiten erhalte ich bei der Anmeldung eine Fehlermeldung.
    Cookies sind gesperrt oder werden vom Browser nicht unterstützt.
    Ich habe alle Cookies in Chrome aktiviert, mehr kann ich nicht tun. Wie erwähnt kommt diese Meldung nur bei einer von vielen Webseiten.
    Woran kann das liegen.

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 15)
  • Kann es sein, dass du bei der Website Änderungen an der wp-config.php vorgenommen hast?

    Thread-Starter neelix1201

    (@neelix1201)

    Hallo Bego Mario
    Hier der Zustandsbericht

    ### wp-core ###
    
    version: 5.9
    site_language: de_DE
    user_language: de_DE
    timezone: +00:00
    permalink: /%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: open
    environment_type: production
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /var/www/vhosts/f-brunner.ch/httpdocs
    wordpress_size: 942,20 MB (987973078 bytes)
    uploads_path: /var/www/vhosts/f-brunner.ch/httpdocs/wp-content/uploads
    uploads_size: 33,56 MB (35189773 bytes)
    themes_path: /var/www/vhosts/f-brunner.ch/httpdocs/wp-content/themes
    themes_size: 24,29 MB (25475143 bytes)
    plugins_path: /var/www/vhosts/f-brunner.ch/httpdocs/wp-content/plugins
    plugins_size: 49,72 MB (52138309 bytes)
    database_size: 9,23 MB (9682944 bytes)
    total_size: 1,03 GB (1110459247 bytes)
    
    ### wp-dropins (1) ###
    
    maintenance.php: true
    
    ### wp-active-theme ###
    
    name: OceanWP (oceanwp)
    version: 3.1.3
    author: OceanWP
    author_website: https://oceanwp.org/about-me/
    parent_theme: none
    theme_features: core-block-patterns, widgets-block-editor, align-wide, wp-block-styles, responsive-embeds, editor-styles, editor-style, menus, post-formats, title-tag, automatic-feed-links, post-thumbnails, custom-header, custom-logo, html5, woocommerce, wc-product-gallery-zoom, wc-product-gallery-lightbox, wc-product-gallery-slider, customize-selective-refresh-widgets, widgets
    theme_path: /var/www/vhosts/f-brunner.ch/httpdocs/wp-content/themes/oceanwp
    auto_update: Aktiviert
    
    ### wp-themes-inactive (1) ###
    
    Twenty Twenty-Two: version: 1.0, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-active (3) ###
    
    Elementor: version: 3.5.5, author: Elementor.com, Automatische Aktualisierungen aktiviert
    Elementor Pro: version: 3.5.1, author: Elementor.com (latest version: 3.6.2), Automatische Aktualisierungen deaktiviert
    Ocean Extra: version: 1.9.3, author: OceanWP, Automatische Aktualisierungen aktiviert
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1690
    imagemagick_version: ImageMagick 6.9.10-68 Q16 x86_64 2021-10-14 https://imagemagick.org
    imagick_version: 3.6.0
    file_uploads: File uploads is turned off
    post_max_size: 128M
    upload_max_filesize: 128M
    max_effective_size: 128 MB
    max_file_uploads: 20
    imagick_limits: 
    	imagick::RESOURCETYPE_AREA: 63 GB
    	imagick::RESOURCETYPE_DISK: 9.2233720368548E+18
    	imagick::RESOURCETYPE_FILE: 6144
    	imagick::RESOURCETYPE_MAP: 63 GB
    	imagick::RESOURCETYPE_MEMORY: 31 GB
    	imagick::RESOURCETYPE_THREAD: 1
    imagemagick_file_formats: 3FR, 3G2, 3GP, AAI, AI, ART, ARW, AVI, AVS, BGR, BGRA, BGRO, BMP, BMP2, BMP3, BRF, CAL, CALS, CANVAS, CAPTION, CIN, CIP, CLIP, CMYK, CMYKA, CR2, CRW, CUR, CUT, DATA, DCM, DCR, DCX, DDS, DFONT, DNG, DOT, DPX, DXT1, DXT5, EPDF, EPI, EPS, EPS2, EPS3, EPSF, EPSI, EPT, EPT2, EPT3, ERF, EXR, FAX, FILE, FITS, FRACTAL, FTP, FTS, G3, G4, GIF, GIF87, GRADIENT, GRAY, GRAYA, GROUP4, GV, H, HALD, HDR, HISTOGRAM, HRZ, HTM, HTML, HTTP, HTTPS, ICB, ICO, ICON, IIQ, INFO, INLINE, IPL, ISOBRL, ISOBRL6, J2C, J2K, JNG, JNX, JP2, JPC, JPE, JPEG, JPG, JPM, JPS, JPT, JSON, K25, KDC, LABEL, M2V, M4V, MAC, MAGICK, MAP, MASK, MAT, MATTE, MEF, MIFF, MKV, MNG, MONO, MOV, MP4, MPC, MPEG, MPG, MRW, MSL, MSVG, MTV, MVG, NEF, NRW, NULL, ORF, OTB, OTF, PAL, PALM, PAM, PANGO, PATTERN, PBM, PCD, PCDS, PCL, PCT, PCX, PDB, PDF, PDFA, PEF, PES, PFA, PFB, PFM, PGM, PGX, PICON, PICT, PIX, PJPEG, PLASMA, PNG, PNG00, PNG24, PNG32, PNG48, PNG64, PNG8, PNM, PPM, PREVIEW, PS, PS2, PS3, PSB, PSD, PTIF, PWP, RADIAL-GRADIENT, RAF, RAS, RAW, RGB, RGBA, RGBO, RGF, RLA, RLE, RMF, RW2, SCR, SCT, SFW, SGI, SHTML, SIX, SIXEL, SPARSE-COLOR, SR2, SRF, STEGANO, SUN, SVG, SVGZ, TEXT, TGA, THUMBNAIL, TIFF, TIFF64, TILE, TIM, TTC, TTF, TXT, UBRL, UBRL6, UIL, UYVY, VDA, VICAR, VID, VIFF, VIPS, VST, WBMP, WMF, WMV, WMZ, WPG, X, X3F, XBM, XC, XCF, XPM, XPS, XV, XWD, YCbCr, YCbCrA, YUV
    gd_version: bundled (2.1.0 compatible)
    gd_formats: GIF, JPEG, PNG, WebP, BMP, XPM
    ghostscript_version: unknown
    
    ### wp-server ###
    
    server_architecture: Linux 3.10.0-1160.53.1.el7.x86_64 x86_64
    httpd_software: Apache
    php_version: 7.4.27 64bit
    php_sapi: fpm-fcgi
    max_input_variables: 4000
    time_limit: 300
    memory_limit: 256M
    max_input_time: 60
    upload_max_filesize: 128M
    php_post_max_size: 128M
    curl_version: 7.69.1 NSS/3.44
    suhosin: false
    imagick_availability: true
    pretty_permalinks: true
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 10.2.43-MariaDB-log
    client_version: mysqlnd 7.4.27
    max_allowed_packet: 33554432
    max_connections: 128
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /var/www/vhosts/f-brunner.ch/httpdocs/wp-content
    WP_PLUGIN_DIR: /var/www/vhosts/f-brunner.ch/httpdocs/wp-content/plugins
    WP_MEMORY_LIMIT: 40M
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_ENVIRONMENT_TYPE: Nicht definiert
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    

    Dankeschön, aber … dann kannst du dich ja doch anmelden?

    Thread-Starter neelix1201

    (@neelix1201)

    Jein, wenn ich mich anmelden will kommt diese Meldung, aber ich kann dann via: ->zurück zu F. Brunner AG auf die Seite zugreifen. Dann erscheint nicht das Backend von WP sondern meine Webseite mit dem schwarzen Balken oben, von wo aus ich dann auf das Dashboard zugreifen kann. Wie schon erwähnt dies betrifft nur diese eine Seite, alle anderen sind normal zugänglich.

    Teste das doch mal in einem privaten Fenster (Firefox) und/oder im Inkognitomodus (Chrome). Die Option findest du oben rechts bei den drei senkrechten Punkten in Chrome.
    Vielleicht ist das ein Problem mit dem Cache des Browsers. Ggfs. auch mal den Browsercache löschen.

    Thread-Starter neelix1201

    (@neelix1201)

    Das Problem tritt auch bei Firefox auf den ich sonst nicht verwende. In Chrome habe ich den Cache schon mehrmals gelöscht und es tritt auch im Inkognitomodus auf.
    Die Ursache muss wohl bei WP liegen.

    Kannst du bitte mal den Inhalt der wp-config.php posten?
    Bitte entferne aus deiner Antwort die Zugangsdaten und Sicherheitsschlüssel.

    Thread-Starter neelix1201

    (@neelix1201)

    wo finde ich den Inhalt der wp-config.php ?

    Die Datei wp-config.php ist eine Konfigurationsdatei, die im Rahmen der WordPress-Installation im Web-Stammverzeichnis deiner Website abgelegt wird. Du kannst sie mit einem FTP-Programm oder über die Dateiverwaltung deines Webhosters herunterladen, solltest sie dann aber nur mit einem geeigneten Code-Editor (oder dem Online-Editor https://vscode.dev/) bearbeiten, wenn du Änderungen vornehmen möchtest.

    Thread-Starter neelix1201

    (@neelix1201)

    Hier also der php Code

    <?php
    /**
     * The base configuration for WordPress
     *
     * The wp-config.php creation script uses this file during the
     * installation. You don't have to use the web site, you can
     * copy this file to "wp-config.php" and fill in the values.
     *
     * This file contains the following configurations:
     *
     * * MySQL settings
     * * Secret keys
     * * Database table prefix
     * * ABSPATH
     *
     * @link https://codex.wordpress.org/Editing_wp-config.php
     *
     * @package WordPress
     */
    
    // ** MySQL settings - You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define( 'DB_NAME', '' );
    
    /** MySQL database username */
    define( 'DB_USER', '' );
    
    /** MySQL database password */
    define( 'DB_PASSWORD', '' );
    
    /** MySQL hostname */
    define( 'DB_HOST', 'localhost:3306' );
    
    /** Database Charset to use in creating database tables. */
    define( 'DB_CHARSET', 'utf8' );
    
    /** The Database Collate type. Don't change this if in doubt. */
    define( 'DB_COLLATE', '' );
    
    /**
     * Authentication Unique Keys and Salts.
     *
     * Change these to different unique phrases!
     * You can generate these using the {@link https://api.wordpress.org/secret-key/1.1/salt/ WordPress.org secret-key service}
     * You can change these at any point in time to invalidate all existing cookies. This will force all users to have to log in again.
     *
     * @since 2.6.0
     */
    
    /**
     * WordPress Database Table prefix.
     *
     * You can have multiple installations in one database if you give each
     * a unique prefix. Only numbers, letters, and underscores please!
     */
    $table_prefix = 'wp_';
    
    define('WP_ALLOW_MULTISITE', true);
    
    /* That's all, stop editing! Happy publishing. */
    
    /** Absolute path to the WordPress directory. */
    if ( ! defined( 'ABSPATH' ) ) {
    	define( 'ABSPATH', dirname( __FILE__ ) . '/' );
    }
    
    /** Sets up WordPress vars and included files. */
    require_once ABSPATH . 'wp-settings.php';


    Moderationshinweis: Bitte niemals Zugangsdaten veröffentlichen.

    In den Konfigurationsdatei und im Website-Bericht ist nichts Auffälliges, was das Problem erklären könnte.

    Ich kann mir das im Moment nur so erklären, dass es im Browser ein Problem mit Cookies gibt.

    In Chrome habe ich den Cache schon mehrmals gelöscht …

    Da es um Cookies geht: Geb bitte ins Backend deiner Website, mach einen Rechtsklick auf die Webseite > Untersuchen > Tab „App“ > linke Spalte „Cookies“ > Rechtsklick auf den Link darunter > alle Cookies löschen. Danach erneut anmelden.

    Thread-Starter neelix1201

    (@neelix1201)

    Es hilft alles nichts ich habe alle cookies (4) von dieser Webseite gelöscht. Trotzdem erscheint diese Meldung immer noch.
    Ich glaube wir lassen es ich kann ja indirekt immer noch auf das Backend zugreifen.

    Du gibst aber schnell auf?

    Du hast bereits die wp-config.php abgerufen. Trag bitte mal oberhalb von /* That's all, stop editing! Happy blogging. */ folgende Zeile ein:

    define('COOKIE_DOMAIN', false);

    Lad die wp-config.php auf den Server hoch und schau, ob der Fehler immer noch besteht.

    Thread-Starter neelix1201

    (@neelix1201)

    Auch das hat nichts bewirkt die Fehlermeldung ist immer noch da.

    Fehler: Cookies sind gesperrt oder werden von deinem Browser nicht unterstützt. Du musst Cookies aktivieren, um WordPress verwenden zu können.

    StoRicMan

    (@storicman)

    Hallo neelix1201, bis eben hatte ich das gleiche Problem. Die Standard-Kontrollen hatte ich alle ausgeschlossen: Browser, Caching, Cookie-Einstellungen, wp-config.php (Leerzeichen, utf8), .htaccess. Per Ausschlussverfahren und Vergleich zu meinen anderen zahlreichen Webseiten kam eigentlich nur noch das Theme in Frage. Da ich wie Du nicht mehr ins Backend kam, bleibt ja immer noch FTP.

    Versuche mal das Theme auszutauschen. Eine Anleitung gibts hier: https://www.nathanson.org/davesays/2017/how-to-switch-wordpress-theme-when-you-cant-login-to-dashboard-via-ftp/

    Beste Grüsse Manni

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 15)
  • Das Thema „Fehlermeldung bei Anmeldung“ ist für neue Antworten geschlossen.