Support » Allgemeine Fragen » Fehlermeldung: Du bist leider nicht berechtigt, diesen Beitrag zu bearbeiten

  • Gelöst kladi

    (@kladi)


    Ich kann keine Seiten und Beiträge erfassen.
    Die Plugins wurden zum Test alle deaktiviert, ohne Erfolg.
    Permalink-Struktur wurde zum Test ebenfalls ohne Erfolg geändert.
    Das Customizing von Themes ist ebenfalls nicht möglich.
    Hinweis:
    Der Upgrade von WP 4.7.23 auf 6.0.1 ist ohne Probleme gelaufen.
    Dieser war erforderlich, da die php-Version durch den Provider angehoben wurde.
    Update der Plugins ohne Problem durchgeführt.
    Es ist die php-Version 7.4.30 im Einsatz.

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 24)
  • Hast du geprüft, ob du als Administrator angemeldet bist?

    Hast du nach dem Update die Cookies gelöscht und dich neu angemeldet?

    Wenn das alles nicht klappt, kannst du per phpMyAdmin in der Datenbank einen neuen Administratoren anlegen. Ein gutes (englisches) Tutorial findest du hier: https://www.wpbeginner.com/wp-tutorials/how-to-add-an-admin-user-to-the-wordpress-database-via-mysql/

    Thread-Starter kladi

    (@kladi)

    Ich bin als Administrator angemeldet.
    Ja, die Cookies des verwendeten Browsers wurden gelöscht.
    An einen neuen Admin habe ich schon gedacht, Über die WP-Oberfläche funktioniert das auch nicht.

    Thread-Starter kladi

    (@kladi)

    Das Einfügen eines neuen Administrator funktioniert in der Tabelle wp_users.
    Ein Problem gibt es mit der Tabelle wp_usermeta, hier gibt es Datensätze mit dem Feldinhalt umeta_id = NULL.
    Das sollte doch eigentlich nicht sein?
    Auch die beiden Einträge für den neuen Administrator werden mit umeta_id = NULL geführt. Ein Login auf diesen User ist nicht möglich.

    Nein, das ist nicht so, wie es sein soll.

    Ich würde jetzt erst einmal die Datenbank per phpMyAdmin (Kundenmenü deines Webhosters) exportieren, damit du eine Sicherung hast. Danach probier doch bitte mal folgendes:

    1. in der wp-config.php trägst du oberhalb von /* That's all, stop editing! Happy publishing. */ folgende Zeile ein:
      define( 'WP_ALLOW_REPAIR', true );
    2. Nun gehst du auf http://svn.sch***ine.de/wp/wp-admin/maint/repair.php (URL bitte ausschreiben)
    3. Auf der Seite klickst du auf den unteren Button.
    4. Schau dann mal, was mit der Datenbanktabelle passiert ist und ob du als Administrator arbeiten kannst.
    Thread-Starter kladi

    (@kladi)

    Ich habe die Änderung in die wp-config.php eingefügt und den Repair laufen lassen. Die Funktion berichtete „Die Tabelle wp_usermeta ist in Ordnung.“ Es hat sich aber an den Datensätzen nichts geändert.
    Das Feld 1 umeta_id ist ein smallint und sollte eigentlich mit einem numerischen Wert gefüllt sein. Wenn ich in meiner lokalen DB einen User neu hinzufüge und Metadaten-Einstellungen erzeuge werden diese alle mit umeta_id = „fortlaufende Nummerierung“ geführt.
    Ich werde nochmal einen User erstellen und schauen, wie sich die Metadaten verhalten.
    Frage: Datensätze mit umeta_id=NULL löschen, oder gibt es eine andere Möglichkeit?

    Das habe ich so noch nicht gehört. Ich hätte wahrscheinlich (nach einem Backup) versucht, eine fortlaufende Numerierung einzufügen. Allerdings steht die Datenbank-Tabelle nicht für sich alleine, sondern wird über die ID mit anderen Tabellen verknüpft.

    Sorry, ich kann da leider nicht viel zu sagen. Vielleicht fällt jemand anders hier in der Runde etwas ein?

    Thread-Starter kladi

    (@kladi)

    Die Probleme mit den beiden Tabelle wp_users und wp_usermeta konnte ich über DB-Export, Korrektur und DB-Import lösen. Das Problem war der interne Wert AUTO_INCREMENT, der in beiden Tabellen zerstört war.
    Ich muss dazu sagen, dass der Webserver gehackt und deshalb neu aufgesetzt wurde.
    Beide Tabellen arbeiten nun einwandfrei, User können angelegt werden, Metadaten werden auch geschrieben.
    Nur ich kann immer noch keine Beiträge+Seiten neu anlegen, auch nicht mit dem neuen Admin-User.
    Hast du noch eine Idee?

    Hallo,
    wenn du dich wieder anmelden kannst, dann wäre der Bericht evtl. hilfreich:
    Du findest unter Werkzeuge > Websitezustand > Info einen Bericht zur Website. Warte bitte einen Moment bis die Ladeanzeige ganz oben abgeschlossen ist und kopiere dann per Button den Website-Bericht in deine Zwischenablage. Über den Button „Bericht in die Zwischenablage kopieren“ kannst du den Bericht unverändert (bitte mit den Akzentzeichen am Anfang und Ende) einfügen und anschließend hier posten. Evtl. ergeben sich dann weitere Anhaltspunkte, ob und wo das Problem liegt.

    Viele Grüße
    Hans-Gerd

    Thread-Starter kladi

    (@kladi)

    
    ### wp-core ###
    
    version: 6.0.1
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Berlin
    permalink: /%postname%/
    https_status: false
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: closed
    environment_type: production
    user_count: 8
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /var/www/clients/client8/web8/web/wp
    wordpress_size: 52,04 MB (54571292 bytes)
    uploads_path: /var/www/clients/client8/web8/web/wp/wp-content/uploads
    uploads_size: 80,30 MB (84200993 bytes)
    themes_path: /var/www/clients/client8/web8/web/wp/wp-content/themes
    themes_size: 9,12 MB (9560930 bytes)
    plugins_path: /var/www/clients/client8/web8/web/wp/wp-content/plugins
    plugins_size: 50,25 MB (52695577 bytes)
    database_size: 6,41 MB (6717440 bytes)
    total_size: 198,12 MB (207746232 bytes)
    
    ### wp-active-theme ###
    
    name: Twenty Ten (twentyten)
    version: 3.6
    author: WordPress-Team
    author_website: https://de.wordpress.org/
    parent_theme: none
    theme_features: core-block-patterns, widgets-block-editor, editor-style, editor-styles, wp-block-styles, editor-color-palette, post-formats, post-thumbnails, automatic-feed-links, menus, custom-background, custom-header, widgets
    theme_path: /var/www/clients/client8/web8/web/wp/wp-content/themes/twentyten
    auto_update: Deaktiviert
    
    ### wp-themes-inactive (4) ###
    
    GeneratePress: version: 3.1.3, author: Tom Usborne, Automatische Aktualisierungen deaktiviert
    Twenty Fifteen: version: 3.2, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    Twenty Fourteen: version: 3.4, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    Twenty Twenty: version: 2.0, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-active (5) ###
    
    Akismet Anti-Spam: version: 5.0, author: Automattic, Automatische Aktualisierungen deaktiviert
    Classic Editor: version: 1.6.2, author: WordPress Contributors, Automatische Aktualisierungen deaktiviert
    Database Backup for WordPress: version: 2.5.2, author: Delicious Brains, Automatische Aktualisierungen deaktiviert
    HTML Import 2: version: 2.6, author: Stephanie Leary, Automatische Aktualisierungen deaktiviert
    TablePress: version: 1.14, author: Tobias Bäthge, Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-inactive (2) ###
    
    All-in-One Event Calendar by Time.ly: version: 3.0.0, author: Time.ly Network Inc., Automatische Aktualisierungen deaktiviert
    Jetpack: version: 11.2, author: Automattic, Automatische Aktualisierungen deaktiviert
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_GD
    imagick_module_version: Nicht verfügbar
    imagemagick_version: Nicht verfügbar
    imagick_version: Nicht verfügbar
    file_uploads: File uploads is turned off
    post_max_size: 8M
    upload_max_filesize: 2M
    max_effective_size: 2 MB
    max_file_uploads: 20
    gd_version: 2.3.0
    gd_formats: GIF, JPEG, PNG, WebP, BMP, XPM
    ghostscript_version: 9.53.3
    
    ### wp-server ###
    
    server_architecture: Linux 5.10.0-15-amd64 x86_64
    httpd_software: Apache
    php_version: 7.4.30 64bit
    php_sapi: fpm-fcgi
    max_input_variables: 1000
    time_limit: 30
    memory_limit: 128M
    admin_memory_limit: 256M
    max_input_time: 60
    upload_max_filesize: 2M
    php_post_max_size: 8M
    curl_version: 7.74.0 OpenSSL/1.1.1n
    suhosin: false
    imagick_availability: false
    pretty_permalinks: true
    htaccess_extra_rules: false
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 10.5.15-MariaDB-0+deb11u1
    client_version: mysqlnd 7.4.30
    max_allowed_packet: 16777216
    max_connections: 151
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /var/www/clients/client8/web8/web/wp/wp-content
    WP_PLUGIN_DIR: /var/www/clients/client8/web8/web/wp/wp-content/plugins
    WP_MEMORY_LIMIT: 40M
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_ENVIRONMENT_TYPE: Nicht definiert
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    

    Ich sehe auf den ersten Blick hier keine Auffälligkeiten (abgesehen davon, dass Akismet nicht datenschutzkonform ist und daher besser gelöscht werden sollte). Die Rechte scheinen auch ok zu sein.

    Hast du schon versucht, ein manuelles Update von WP durchzuführen ?

    Bei deinem Vertrag hat du sicher auch mehr als 200 MB Webspace dabei? – Sonst könnte es daran liegen, dass der Webspace ausgereizt ist.

    Vorher aber bitte eine Sicherung erstellen.

    Ich schlage vor, dass du das Berechtigungssystem einmal resetest.

    https://publishpress.com/blog/how-to-restore-the-default-wordpress-user-permissions/

    Vermutlich sind die default Rollen kaputt.

    Das Plugin Reset Roles and Capabilities aus dem WordPress Repository stellt wohl eine ähnliche Lösung dar.

    Thread-Starter kladi

    (@kladi)

    @michi91 :
    Vielen Dank für den Hinweis.
    Das mit dem RESET des Berechtigungssystem würde ich gerne angehen, das Plugin kostet $69, habe ich das richtige?
    @hage :
    Die Einstellung mit 200 MB Webspace würde ich gerne vom Provider prüfen lassen, welcher Parameter müsste das sein?

    Thread-Starter kladi

    (@kladi)

    Das Plugin Reset Roles and Capabilities hat keine Lösung des Problems gebracht.

    Das Plugin Reset Roles and Capabilities hat keine Lösung des Problems gebracht.

    BITTE nicht für das andere Plugin bezahlen, hatte nicht gesehen dass es Geld kostet. Wenn Reset Roles and Capabilities nicht funktioniert, wird das andere sicherlich kein besseres Ergebnis liefern..

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 24)