Support » Allgemeine Fragen » Fehlermeldung im Gutenberg-Editor: Unerwarteter Fehler

  • Gelöst dajolens

    (@dajolens)


    Hallo zusammen,

    seit gestern Abend ist mein Gutenberg-Editor (nach Aktualisierung des Plugins auf die Version 3.7.0) während des Schreibens eines Blogbeitrags plötzlich umgesprungen auf diese Fehlermeldung.

    Im Editor ist ein unerwarteter Fehler aufgetreten.

    Darunter 3 Buttons:

    Wiederherstellung versuchen
    Beitragstext kopieren
    Fehlermeldung kopieren

    Keiner dieser Buttons bewirkt irgendetwas. Seitdem funktioniert nichts mehr: Ich kann meinen neuen Beitrag verfassen oder alten Beitrag bearbeiten, zumindest nicht im neuen Editor. Immer erscheint diese Fehlermeldung.

    Wenn ich mich als anderer User (nicht als Admin) anmelde, geht’s – zum Glück – noch. Aber ich muss das Problem dringend beheben, da ich so massiv in meiner Arbeit eingeschränkt bin.

    Verwendetes Theme: Pukeko (von Elmastudio)
    Verwendete WordPress-Version: 4.9.8

    Hat jemand eine Idee, was es mit dieser Fehlermeldung auf sich haben könnte, bzw. was ich tun muss, um wieder normal mit Gutenberg arbeiten zu können?

    Herzliche Grüße,
    David

    • Dieses Thema wurde geändert vor 1 Jahr, 5 Monate von dajolens.
    • Dieses Thema wurde geändert vor 1 Jahr, 5 Monate von dajolens.
Ansicht von 10 Antworten - 1 bis 10 (von insgesamt 10)
  • Hey David,
    das Problem wird von Yoast SEO 8.1 verursacht, sie haben es gerade in der Version 8.1.1 behoben. Also einmal Yoast aktualisieren und es sollte wieder funktionieren.

    Schöne Grüße
    Sören

    YES! Vielen lieben Dank für die rasch und präzise Hilfe – hat geklappt und läuft wieder, wie es soll.

    Moderator Bego Mario Garde

    (@pixolin)

    Viele Grüße nach Hamburg und Danke für diese (doch recht spezielle) Lösung, @soean. 👋🏼

    @dajolens Danke für das Feedback.

    Bleibt mir nur, den Thread noch rasch als „gelöst“ zu markieren. ✅

    Hallo, ich habe heute auf WP 5.0 geupdatet und alle PlugIns auch. Seit dem habe ich beim Bearbeiten von Seitentexten genau den Fehler wie ganz oben beschrieben. Ich habe Yoast Seo deaktiviert und dann geht die Bearbeitung der Inhaltsseoten wieder ohne Fehler.

    Kann ich jetzt das Yoast Seo 9.2.1 nicht mehr nutzen? Oder was ist zu tun bei dieser Fehlermeldung?

    WENN YOAST AKTIVIERT IST, DANN GEHT DAS SEITEN AKTUALISIEREN NICHT DIESE MELDUNG KOMMT DANN.
    TypeError: Object(...) is not a function
        at ve (http://www.meinesite.ch/wp-includes/js/dist/blocks.min.js?ver=6.0.3:2:83680)
        at http://www.meinesite.ch/wp-includes/js/dist/blocks.min.js?ver=6.0.3:2:83120
        at i (http://www.meinesite.ch/wp-includes/js/dist/vendor/lodash.min.js?ver=4.17.11:6:91)
        at An.filter (http://www.meinesite.ch/wp-includes/js/dist/vendor/lodash.min.js?ver=4.17.11:99:338)
        at _e (http://www.meinesite.ch/wp-includes/js/dist/blocks.min.js?ver=6.0.3:2:83097)
        at we (http://www.meinesite.ch/wp-includes/js/dist/blocks.min.js?ver=6.0.3:2:83557)
        at t.value (http://www.meinesite.ch/wp-includes/js/dist/editor.min.js?ver=9.0.4:55:266041)
        at Fd (http://www.meinesite.ch/wp-includes/js/dist/vendor/react-dom.min.js?ver=16.6.3:92:367)
        at Mf (http://www.meinesite.ch/wp-includes/js/dist/vendor/react-dom.min.js?ver=16.6.3:92:160)
        at ph (http://www.meinesite.ch/wp-includes/js/dist/vendor/react-dom.min.js?ver=16.6.3:98:474)

    Danke für Hilfe

    Hallo,
    bei mir ist dieser Fehler aufgetreten, sobald ich das WPML Plugin installiert habe. Ich benutze WordPress 5.0.1. Bis gestern funktionierte alles noch tadellos. Ich habe kein Yoast installiert. Weiß jemand vielleicht woran es noch liegen könnte?
    Danke im Voraus!

    @irgendwascom ich hab das selbe Problem. Das automatische Aktualisieren bei Posts oder Seiten geht nicht mehr. Erst wenn ich yoast deaktiviere …
    Nutze aktuelles WP 5.0.3 & Yoast 9.4

    @boombatze, bei mir war es so, dass auch das in dem Template integrierte „Custom Fields“ nicht mehr funktionierte un das Yoast eben auch nicht. Ich habe dann nach dem Update auf das WP 5 die folgenden zwei Plugins in meiner WP Site installiert: „“Custom Fields for Gutenberg“ und „Disable Gutenberg“, dann waren alle Fehler bei mir wieder weg und ich habe das yoast auch wieder aktivieren können. „Disable Gutenberg“ macht dann wieder ein WP Backend, wie man es kennt draus.

    Ich weiß nicht, ob dir das hilft, aber ich dacht mal, ich schreibe, was bei mir geholfen hat.

    @irgendwascom Hmm, Custom Fields nutz ich nicht. Aber die plugins „Next Gen gallery“ & „Short URL“ vertagen sich zusammen mit Yoast & Gutenberg nicht. Also hab ich jetzt auch „Disable Gutenberg“ installiert und der Rest funzt wieder wie vorher 😀

    • Diese Antwort wurde geändert vor 1 Jahr, 1 Monat von .

    @boombatze ja ist doch fein … 🙂 … P.S.: Gutenberg gefällt mir zwar vom Konzept her total gut, aber wenn’s noch nicht ganz mit bestehenden WP Sites arbeitet …

    • Diese Antwort wurde geändert vor 1 Jahr, 1 Monat von irgendwascom.

    @irgendwascom Perfekt ist das auch nicht. Aber geht schon.
    So schlecht find ich den Gutenberg-Editor auch gar nicht.

    • Diese Antwort wurde geändert vor 1 Jahr, 1 Monat von .
Ansicht von 10 Antworten - 1 bis 10 (von insgesamt 10)
  • Das Thema „Fehlermeldung im Gutenberg-Editor: Unerwarteter Fehler“ ist für neue Antworten geschlossen.