Support » Installation » Fehlermeldung nach Installation

  • Bekomme nach Installation (web.de)die Fehlermeldungen, dass Header nicht übernommen werden können:
    Warning: Cannot modify header information – headers already sent by (output started at /homepages/5/d233564672/htdocs/wp-config.php:1) in /homepages/5/d233564672/htdocs/wp-login.php on line 424

    Warning: Cannot modify header information – headers already sent by (output started at /homepages/5/d233564672/htdocs/wp-config.php:1) in /homepages/5/d233564672/htdocs/wp-login.php on line 437

    und beim Anmeldeversuch:
    Warning: Cannot modify header information – headers already sent by (output started at /homepages/5/d233564672/htdocs/wp-config.php:1) in /homepages/5/d233564672/htdocs/wp-includes/pluggable.php on line 918

    Warning: Cannot modify header information – headers already sent by (output started at /homepages/5/d233564672/htdocs/wp-config.php:1) in /homepages/5/d233564672/htdocs/wp-includes/pluggable.php on line 919

    Warning: Cannot modify header information – headers already sent by (output started at /homepages/5/d233564672/htdocs/wp-config.php:1) in /homepages/5/d233564672/htdocs/wp-includes/pluggable.php on line 920

    Hier wurde darauf hingewisen, dass dann was in der config.-Datei nicht stimmt, aber was?

    /** Ersetze database_name_here mit dem Namen der Datenbank, die du verwenden möchtest. */
    define(‚DB_NAME‘, ‚dbXYZ‘);

    /** Ersetze username_here mit deinem MySQL-Datenbank-Benutzernamen */
    define(‚DB_USER‘, ‚dboXYZ‘);

    /** Ersetze password_here mit deinem MySQL-Passwort */
    define(‚DB_PASSWORD‘, ‚MeinPasswort‘);

    /** Ersetze localhost mit der MySQL-Serveradresse */
    define(‚DB_HOST‘, ‚db62.mdh.web.de‘);

    /** Der Datenbankzeichensatz der beim Erstellen der Datenbanktabellen verwendet werden soll */
    define(‚DB_CHARSET‘, ‚utf8‘);

    /** Der collate type sollte nicht geändert werden */
    define(‚DB_COLLATE‘, “);

    DANKE FÜR EURE HILFE!! Bin echt schon verzeifelt…

Ansicht von 12 Antworten - 1 bis 12 (von insgesamt 12)
  • Edi

    (@psychosopher)

    Wurde die Datei wp-config.php bei der Installation angelegt oder manuell?

    Manuell 😉

    Edi

    (@psychosopher)

    Mit einem normalen Texteditor? Es könnte am Format liegen, mit dem Du die Datei gespeichert hast.

    Beginnt die erste Zeile mit „<?php“?

    http://codex.wordpress.org/FAQ_Troubleshooting#How_do_I_solve_the_Headers_already_sent_warning_problem.3F

    Plugins hast Du noch keine hochgeladen?

    Beginnt die erste Zeile mit „<?php“?
    Ja!

    Habe noch keine Plugins hochgeladen!

    Jetzt kommt als Fehlermeldung:

    Warning: Cannot modify header information – headers already sent by (output started at /homepages/5/d233564672/htdocs/wp-config.php:1) in /homepages/5/d233564672/htdocs/wp-admin/install.php on line 57
    WordPress

    Ich stelle mal den kompletten Text der wp-config ein:

    <?php
    /**
    * In dieser Datei werden die Grundeinstellungen für WordPress vorgenommen.
    *
    * Zu diesen Einstellungen gehören: MySQL-Zugangsdaten, Tabellenpräfix,
    * Secret-Keys, Sprache und ABSPATH. Mehr Informationen zur wp-config.php gibt es
    * auf der {@link http://codex.wordpress.org/Editing_wp-config.php wp-config.php editieren}
    * Seite im Codex. Die Informationen für die MySQL-Datenbank bekommst du von deinem Webhoster.
    *
    * Diese Datei wird von der wp-config.php-Erzeugungsroutine verwendet. Sie wird ausgeführt,
    * wenn noch keine wp-config.php (aber eine wp-config-sample.php) vorhanden ist,
    * und die Installationsroutine (/wp-admin/install.php) aufgerufen wird.
    * Man kann aber auch direkt in dieser Datei alle Eingaben vornehmen und sie von
    * wp-config-sample.php in wp-config.php umbenennen und die Installation starten.
    *
    * @package WordPress
    */

    /** MySQL Einstellungen – diese Angaben bekommst du von deinem Webhoster. */
    /** Ersetze database_name_here mit dem Namen der Datenbank, die du verwenden möchtest. */
    define(‚DB_NAME‘, ‚dbXYZ‘);

    /** Ersetze username_here mit deinem MySQL-Datenbank-Benutzernamen */
    define(‚DB_USER‘, ‚dboXYZ‘);

    /** Ersetze password_here mit deinem MySQL-Passwort */
    define(‚DB_PASSWORD‘, ‚MeinPasswort‘);

    /** Ersetze localhost mit der MySQL-Serveradresse */
    define(‚DB_HOST‘, ‚db62.mdh.web.de‘);

    /** Der Datenbankzeichensatz der beim Erstellen der Datenbanktabellen verwendet werden soll */
    define(‚DB_CHARSET‘, ‚utf8‘);

    /** Der collate type sollte nicht geändert werden */
    define(‚DB_COLLATE‘, “);

    /**#@+
    * Sicherheitsschlüssel
    *
    * Ändere jeden KEY in eine beliebige, möglichst einzigartige Phrase.
    * Auf der Seite {@link https://api.wordpress.org/secret-key/1.1/salt/ WordPress.org secret-key service}
    * kannst du dir alle KEYS generieren lassen.
    * Bitte trage für jeden KEY eine eigene Phrase ein. Du kannst die Schlüssel jederzeit wieder ändern,
    * alle angemeldeten Benutzer müssen sich danach erneut anmelden.
    *
    * @seit 2.6.0
    */
    define(‚AUTH_KEY‘, ‚I[V~7yh$3-y- c*:|lDF-@!|)p+fqb@6#z+e onvx6aF[vtcF4GHG[(2,!lcHJdw‘);
    define(‚SECURE_AUTH_KEY‘, ‚(j-Cg[0-1Kv)a/>Xc!C|63iU2kR*1n%}a8wnd-x764>qE`wsM{Xbk]zf+=/gPasl‘);
    define(‚LOGGED_IN_KEY‘, ‚hfS,-OtGZXa?L{q)$T7tuilk>:6/`F>q99cJs<G#fg>F<hs[{5%p]OK?W=~C+T:/‘);
    define(‚NONCE_KEY‘, ‚g{e.{lSBy[x`Z#R#$S28 0R|-Kmn!LjtnYd{=r$N2PG^Mz-RkSLr#A%T+@%@F83c‘);
    define(‚AUTH_SALT‘, ‚&A68&OP*AH^z@3{{,*P$^a7r7r /^C7y@C-,iwjJ-%609Pg[ZCe.GE;;[0Xa/1′);
    define(‚SECURE_AUTH_SALT‘, ‚HI{VY+-05-5x,mZS7kiQN5=:=co7{`%W5rP](V=VF.ad/6ejDsa#SiT?7I*;>Sm!‘);
    define(‚LOGGED_IN_SALT‘, ‚rK7qgug,@&PilBbfWD^1r3|Kl$<bvU#gW]Fx6?*E~ vh^U|q~J[P9n;g,11]J#ui‘);
    define(‚NONCE_SALT‘, ‚*4-|)=WyFP1J$PkS/;#fLZ<J8>hw>M2G-1WQPjFNb0(ECYO!>0;B16=Qo$8FZ:18‘);

    /**#@-*/

    /**
    * WordPress Datenbanktabellen-Präfix
    *
    * Wenn du verschiedene Präfixe benutzt, kannst du innerhalb einer Datenbank
    * verschiedene WordPress-Installationen betreiben. Nur Zahlen, Buchstaben und Unterstriche bitte!
    */
    $table_prefix = ‚wp_‘;

    /**
    * For developers: WordPress debugging mode.
    *
    * Change this to true to enable the display of notices during development.
    * It is strongly recommended that plugin and theme developers use WP_DEBUG
    * in their development environments.
    */
    define(‚WP_DEBUG‘, false);

    /* That’s all, stop editing! Happy blogging. */

    /** Absolute path to the WordPress directory. */
    if ( !defined(‚ABSPATH‘) )
    define(‚ABSPATH‘, dirname(__FILE__) . ‚/‘);

    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . ‚wp-settings.php‘);

    Edi

    (@psychosopher)

    Ich kann den Fehler leider nicht reproduzieren.

    Hast Du noch eine andere Datei manuell bearbeitet?

    Hat WordPress keine Berechtigung, die Datei wp-config.php anzulegen, dass Du sie manuell erstellen musstest?

    Moderator Torsten Landsiedel

    (@zodiac1978)

    Hi Thorsten, erstmal Danke, sorry war paar Tage krank, leider kenn ich mich wohl zu wenig aus, muss glaub nen Fachmann ranlassen, denn ich weiß nicht mal wo genau ich das ?> setzen muss. Ganz am Ende nach

    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . ‚wp-settings.php‘);

    und ohne Lücke oder schon früher?

    Leider kommen dann immer noch folgende Fehlermeldungen:

    Warning: Cannot modify header information – headers already sent by (output started at /homepages/5/d233564672/htdocs/wp-config.php:1) in /homepages/5/d233564672/htdocs/wp-login.php on line 424

    Warning: Cannot modify header information – headers already sent by (output started at /homepages/5/d233564672/htdocs/wp-config.php:1) in /homepages/5/d233564672/htdocs/wp-login.php on line 437

    Warning: Cannot modify header information – headers already sent by (output started at /homepages/5/d233564672/htdocs/wp-config.php:1) in /homepages/5/d233564672/htdocs/wp-includes/pluggable.php on line 918

    Warning: Cannot modify header information – headers already sent by (output started at /homepages/5/d233564672/htdocs/wp-config.php:1) in /homepages/5/d233564672/htdocs/wp-includes/pluggable.php on line 919

    Warning: Cannot modify header information – headers already sent by (output started at /homepages/5/d233564672/htdocs/wp-config.php:1) in /homepages/5/d233564672/htdocs/wp-includes/pluggable.php on line 920

    Moderator Torsten Landsiedel

    (@zodiac1978)

    nd ohne Lücke oder schon früher?

    Ganz am Ende oder weglassen. Wenn danach noch etwas kommt, dann gibt es solche Fehler wie oben …

    Gruß, Torsten

    Die Lösung des Problems ist so simpel, aber es stolze 2 Tage gedauert, bis das Problem gelöst war. Ist in WP 4.4 noch immer präsent!

    Was ist zu tun?
    1. wp-config.php lokal mittels notepad ++ öffnen
    2. Kodierung ==> UTF-8 ohne BOM auswählen (zuerst war bei mir der Punkt drunter ausgewählt, genau hier ist das Problem.)
    3. Datei speichern und per filezilla auf den Server laden.
    4. Endlich kann man durchstarten 🙂

    vgl. Screenshot:
    http://www.svo-borghorst.de/utf-8ob.png

    Beste Grüße aus dem Münsterland
    Jan

    Moderator Bego Mario Garde

    (@pixolin)

    Ist in WP 4.4 noch immer präsent!

    Eigentlich nicht. Die fehlerhafte Kodierung der wp-config-sample.php wurde bereits vor ein paar Tagen behoben. Deinen (völlig korrekten) Vorschlag zur Fehlerbehebung haben wir auch schon in verschiedenen Threads erwähnt. 🙂

Ansicht von 12 Antworten - 1 bis 12 (von insgesamt 12)
  • Das Thema „Fehlermeldung nach Installation“ ist für neue Antworten geschlossen.