Support » Allgemeine Fragen » File(core/post-comments) is not within the allowed path(s):

  • Hallo liebes Support Team,
    ich habe seit einiger Zeit folgende Fehlermeldung / Warnung im Log-File:
    file_exists(): open_basedir restriction in effect. File(core/post-comments) is not within the allowed path(s): (/var/www/clients/client1/web2/web:/var/www/clients/client1/web2/tmp:/var/www/enduro.de/web:/srv/www/enduro.de/web:/usr/share/php5:/tmp:/usr/share/phpmyadmin:/etc/phpmyadmin:/var/lib/phpmyadmin:/usr/share/php)

    Standort: wp-includes/blocks.php:532

    In der blocks.php steht von Zeile von Zeile 513 bis 537 folgendes:

    /**
     * Registers a block type. The recommended way is to register a block type using
     * the metadata stored in the <code>block.json</code> file.
     *
     * @since 5.0.0
     * @since 5.8.0 First parameter now accepts a path to the <code>block.json</code> file.
     *
     * @param string|WP_Block_Type $block_type Block type name including namespace, or alternatively
     *                                         a path to the JSON file with metadata definition for the block,
     *                                         or a path to the folder where the <code>block.json</code> file is located,
     *                                         or a complete WP_Block_Type instance.
     *                                         In case a WP_Block_Type is provided, the $args parameter will be ignored.
     * @param array                $args       Optional. Array of block type arguments. Accepts any public property
     *                                         of <code>WP_Block_Type</code>. See WP_Block_Type::__construct() for information
     *                                         on accepted arguments. Default empty array.
     *
     * @return WP_Block_Type|false The registered block type on success, or false on failure.
     */
    function register_block_type( $block_type, $args = array() ) {
    	if ( is_string( $block_type ) && file_exists( $block_type ) ) {
    		return register_block_type_from_metadata( $block_type, $args );
    	}
    
    	return WP_Block_Type_Registry::get_instance()->register( $block_type, $args );
    }

    Es wäre super, wenn jemand helfen könnte diese Warnung einzustellen. Danke.

    Details zum aktuell installierten WordPress-System:

    
    ### wp-core ###
    
    version: 6.1.1
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Berlin
    permalink: /%postname%-%post_id%/
    https_status: true
    multisite: false
    user_registration: 1
    blog_public: 1
    default_comment_status: closed
    environment_type: production
    user_count: 8
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /var/www/clients/client1/web2/web
    wordpress_size: 5,21 GB (5594357289 bytes)
    uploads_path: /var/www/clients/client1/web2/web/wp-content/uploads
    uploads_size: 15,38 GB (16517091503 bytes)
    themes_path: /var/www/clients/client1/web2/web/wp-content/themes
    themes_size: 23,12 MB (24244102 bytes)
    plugins_path: /var/www/clients/client1/web2/web/wp-content/plugins
    plugins_size: 203,27 MB (213148538 bytes)
    database_size: 362,53 MB (380141283 bytes)
    total_size: 21,17 GB (22728982715 bytes)
    
    ### wp-dropins (2) ###
    
    advanced-cache.php: true
    db.php: true
    
    ### wp-active-theme ###
    
    name: PenNews (pennews)
    version: 6.6.4
    author: PenciDesign
    author_website: http://pencidesign.com
    parent_theme: none
    theme_features: core-block-patterns, widgets-block-editor, post-thumbnails, automatic-feed-links, title-tag, post-formats, editor-style, menus, html5, custom-background, custom-logo, woocommerce, yoast-seo-breadcrumbs, wp-block-styles, align-wide, editor-font-sizes, custom-header, infinite-scroll, jetpack-responsive-videos, wc-product-gallery-lightbox, wc-product-gallery-zoom, widgets
    theme_path: /var/www/clients/client1/web2/web/wp-content/themes/pennews
    auto_update: Deaktiviert
    
    ### wp-themes-inactive (3) ###
    
    PenNews Child: version: 1.0.0, author: PenciDesign, Automatische Aktualisierungen deaktiviert
    Twenty Twenty-Three: version: 1.0, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    Twenty Twenty-Two: version: 1.3, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    
    ### wp-mu-plugins (1) ###
    
    WP Rocket | UnLazyLoad Mobile: author: WP Rocket Support Team, version: (undefined)
    
    ### wp-plugins-active (25) ###
    
    Advanced Ads: version: 1.38.0, author: Thomas Maier, Advanced Ads GmbH, Automatische Aktualisierungen deaktiviert
    Advanced Ads Pro: version: 2.19.2, author: Advanced Ads GmbH, Automatische Aktualisierungen deaktiviert
    Advanced Ads – Google AdSense In-feed Placement: version: 1.1.2, author: Thomas Maier, Automatische Aktualisierungen deaktiviert
    Advanced Ads – Responsive Ads: version: 1.10.5, author: Advanced Ads GmbH, Automatische Aktualisierungen deaktiviert
    Advanced Ads – Tracking: version: 2.4.0, author: Advanced Ads GmbH, Automatische Aktualisierungen deaktiviert
    Akismet Anti-Spam: version: 5.0.1, author: Automattic, Automatische Aktualisierungen deaktiviert
    All In One WP Security: version: 5.1.1, author: All In One WP Security & Firewall Team, Automatische Aktualisierungen deaktiviert
    Complianz Privacy Suite (GDPR/CCPA) premium: version: 6.3.7.2, author: Really Simple Plugins, Automatische Aktualisierungen aktiviert
    Envato Market: version: 2.0.7, author: Envato, Automatische Aktualisierungen deaktiviert
    EventON: version: 4.2.2, author: AshanJay, Automatische Aktualisierungen deaktiviert
    Imagify: version: 2.0, author: WP Rocket, Automatische Aktualisierungen deaktiviert
    Penci Framework: version: 6.6.4, author: PenciDesign, Automatische Aktualisierungen deaktiviert
    Penci PenNews AMP - WordPress Complete AMP: version: 2.8.1, author: PenciDesign, Automatische Aktualisierungen deaktiviert
    Penci PenNews Slider: version: 2.1, author: PenciDesign, Automatische Aktualisierungen deaktiviert
    Print Invoice & Delivery Notes for WooCommerce: version: 4.6.5, author: Tyche Softwares, Automatische Aktualisierungen deaktiviert
    Query Monitor: version: 3.10.1, author: John Blackbourn, Automatische Aktualisierungen deaktiviert
    TablePress: version: 1.14, author: Tobias Bäthge, Automatische Aktualisierungen deaktiviert
    Vafpress Post Formats UI: version: 1.7, author: vafpress, Automatische Aktualisierungen deaktiviert
    WooCommerce: version: 7.1.0, author: Automattic, Automatische Aktualisierungen deaktiviert
    WooCommerce German (de_DE): version: 3.2.0, author: David Decker - DECKERWEB, Automatische Aktualisierungen deaktiviert
    WP-Polls: version: 2.77.0, author: Lester 'GaMerZ' Chan, Automatische Aktualisierungen deaktiviert
    WPBakery Page Builder: version: 6.10.0, author: Michael M - WPBakery.com, Automatische Aktualisierungen deaktiviert
    WP fail2ban: version: 4.4.0.8, author: Charles Lecklider, Automatische Aktualisierungen deaktiviert
    Yoast SEO: version: 19.10, author: Team Yoast, Automatische Aktualisierungen deaktiviert
    Yoast SEO Premium: version: 19.5, author: Team Yoast, Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-inactive (5) ###
    
    Redis Object Cache: version: 2.2.2, author: Till Krüss, Automatische Aktualisierungen deaktiviert
    WP-Optimize - Clean, Compress, Cache: version: 3.2.9, author: David Anderson, Ruhani Rabin, Team Updraft, Automatische Aktualisierungen deaktiviert
    WP Crontrol: version: 1.14.0, author: John Blackbourn & crontributors, Automatische Aktualisierungen deaktiviert
    WP fail2ban (Premium): version: 4.2.7.1, author: Charles Lecklider, Automatische Aktualisierungen deaktiviert
    WP Rocket: version: 3.9.1.1, author: WP Media, Automatische Aktualisierungen deaktiviert
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1690
    imagemagick_version: ImageMagick 6.9.10-23 Q16 x86_64 20190101 https://imagemagick.org
    imagick_version: 3.7.0
    file_uploads: File uploads is turned off
    post_max_size: 50M
    upload_max_filesize: 50M
    max_effective_size: 50 MB
    max_file_uploads: 20
    imagick_limits: 
    	imagick::RESOURCETYPE_AREA: 122 MB
    	imagick::RESOURCETYPE_DISK: 1073741824
    	imagick::RESOURCETYPE_FILE: 768
    	imagick::RESOURCETYPE_MAP: 512 MB
    	imagick::RESOURCETYPE_MEMORY: 256 MB
    	imagick::RESOURCETYPE_THREAD: 1
    imagemagick_file_formats: 3FR, 3G2, 3GP, AAI, AI, ART, ARW, AVI, AVS, BGR, BGRA, BGRO, BIE, BMP, BMP2, BMP3, BRF, CAL, CALS, CANVAS, CAPTION, CIN, CIP, CLIP, CMYK, CMYKA, CR2, CRW, CUR, CUT, DATA, DCM, DCR, DCX, DDS, DFONT, DNG, DPX, DXT1, DXT5, EPDF, EPI, EPS, EPS2, EPS3, EPSF, EPSI, EPT, EPT2, EPT3, ERF, FAX, FILE, FITS, FRACTAL, FTP, FTS, G3, G4, GIF, GIF87, GRADIENT, GRAY, GRAYA, GROUP4, H, HALD, HDR, HISTOGRAM, HRZ, HTM, HTML, HTTP, HTTPS, ICB, ICO, ICON, IIQ, INFO, INLINE, IPL, ISOBRL, ISOBRL6, JBG, JBIG, JNG, JNX, JPE, JPEG, JPG, JPS, JSON, K25, KDC, LABEL, M2V, M4V, MAC, MAGICK, MAP, MASK, MAT, MATTE, MEF, MIFF, MKV, MNG, MONO, MOV, MP4, MPC, MPEG, MPG, MRW, MSL, MTV, MVG, NEF, NRW, NULL, ORF, OTB, OTF, PAL, PALM, PAM, PATTERN, PBM, PCD, PCDS, PCL, PCT, PCX, PDB, PDF, PDFA, PEF, PES, PFA, PFB, PFM, PGM, PGX, PICON, PICT, PIX, PJPEG, PLASMA, PNG, PNG00, PNG24, PNG32, PNG48, PNG64, PNG8, PNM, PPM, PREVIEW, PS, PS2, PS3, PSB, PSD, PTIF, PWP, RADIAL-GRADIENT, RAF, RAS, RAW, RGB, RGBA, RGBO, RGF, RLA, RLE, RMF, RW2, SCR, SCT, SFW, SGI, SHTML, SIX, SIXEL, SPARSE-COLOR, SR2, SRF, STEGANO, SUN, TEXT, TGA, THUMBNAIL, TIFF, TIFF64, TILE, TIM, TTC, TTF, TXT, UBRL, UBRL6, UIL, UYVY, VDA, VICAR, VID, VIFF, VIPS, VST, WBMP, WEBP, WMV, WPG, X, X3F, XBM, XC, XCF, XPM, XPS, XV, XWD, YCbCr, YCbCrA, YUV
    gd_version: 2.3.3
    gd_formats: GIF, JPEG, PNG, WebP, BMP, AVIF, XPM
    ghostscript_version: 9.50
    
    ### wp-server ###
    
    server_architecture: Linux 5.4.0-117-generic x86_64
    httpd_software: nginx/1.18.0
    php_version: 8.1.12 64bit
    php_sapi: fpm-fcgi
    max_input_variables: 5000
    time_limit: 600
    memory_limit: 768M
    max_input_time: 60
    upload_max_filesize: 50M
    php_post_max_size: 50M
    curl_version: 7.68.0 OpenSSL/1.1.1f
    suhosin: false
    imagick_availability: true
    pretty_permalinks: true
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 10.3.34-MariaDB-0ubuntu0.20.04.1
    client_version: mysqlnd 8.1.12
    max_allowed_packet: 16777216
    max_connections: 151
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /var/www/clients/client1/web2/web/wp-content
    WP_PLUGIN_DIR: /var/www/clients/client1/web2/web/wp-content/plugins
    WP_MEMORY_LIMIT: 128M
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_ENVIRONMENT_TYPE: Nicht definiert
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    mu-plugins: writable
    
    • Dieses Thema wurde geändert vor 5 Tage, 12 Stunden von Marko B.
    • Dieses Thema wurde geändert vor 5 Tage, 10 Stunden von Hans-Gerd Gerhards. Grund: Code korrigiert

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 2 Antworten - 1 bis 2 (von insgesamt 2)
  • Hallo,
    wir können dir bei gekauften Themes (hier PenNews) oder Plugins so gut wie gar nicht helfen, weil sie uns nicht zur Verfügung stehen. Wir müssten sonst bei jeder Frage erst einmal das entsprechende Theme oder Plugin kaufen, uns dort einarbeiten und dann kostenlos den Support anbieten, für den du beim Kauf eigentlich bezahlt hast. Du solltest dich in dem Fall an die Entwickler wenden. Lies bitte auch mal in der FAQ II, 1b zu diesem Thema.

    Du kannst ja mal nach einer Sicherung das Plugin Health Check & Troubleshooting installieren. Anschließend kannst du unter Werkzeuge > Website Zustand unter Problembehandlung auf den Button „Problembehandlungsmodus aktivieren“ klicken. Dann werden alle Plugins deaktiviert und als Standardtheme z. B. Twenty Twenty-Two aktiviert. Dann kannst du sehen, ob die beschriebenen Probleme noch weiterhin auftauchen. Aktiviere dann zunächst das Theme von dir und danach Plugin für Plugin im Problembehandlungsmodus und schaue jeweils nach Aktivierung, ob das Problem noch besteht. Auf diese Weise kannst du möglicherweise herausfinden, ob das Problem durch das Theme und/oder ein Plugin verursacht wird. Vorteil dabei ist, dass Besucher deine Website weiter mit allen Infos und Plugins sehen, während nur für dich alle Plugins deaktiviert sind.

    Taucht die Warnung auch auf, wenn du PHP über den Kundenaccount des Hosters wieder auf 7.4 umstellst? – Auch wenn der Support für PHP 7.4 in den nächsten Tagen endet, kann es durchaus sein, dass einige Plugins oder Themes noch nicht entsprechend angepasst sind.

    Akismet entspricht nicht den europäischen Datenschutzvorgaben. Schau dir mal Antispam Bee an. Kostenlos, leistungsfähig und datenschutzkonform.

    Viele Grüße
    Hans-Gerd

    Thread-Starter Marko B

    (@marko-b)

    Hallo Hans-Gerd,

    vielen Dank für die umfangreiche Antwort und danke für den Hinweis mit Akismet. Ich nehme mal direkt Kontakt mit den Theme-Support auf.

    BG Marko

Ansicht von 2 Antworten - 1 bis 2 (von insgesamt 2)