Support » Allgemeine Fragen » Foto wird im Beitrag nicht angezeigt

  • Hallo,
    ich habe auf meiner Webseite, die noch relativ jung ist, einen „About-Beitrag“ hochgeladen, in dem auch ein Foto von mir zu sehen ist, bzw. zu sehen sein sollte. Der Beitrag ist auch im Hauptmenü eingebunden, und wenn man ihn darüber aufruft, funktioniert alles, wie es soll. Wenn man ihn jedoch über die Startseite aufruft, wo alle Beiträge in Kachelform angezeigt werden, wird das Foto im Beitrag nicht angezeigt, sondern nur dieses Icon, das anzeigt, dass die Datei nicht gefunden wurde. Ihr könnt ja auch gerne mal selbst auf jodeges.com vorbei schauen.
    Das Theme, das ich benutze, heißt Hitchcock, und meine aktivierten Plugins sind Aksimet und Lightbox (von Stefan Hüsges).
    Vielen Dank schon mal im Voraus!
    Jonathan

    • Dieses Thema wurde geändert vor 3 Jahre, 5 Monaten von jonideges.
Ansicht von 1 Antwort (von insgesamt 1)
  • Da ist einiges ein wenig verwirrend … 

    So wie es aussieht, gibt es einmal eine statische Seite „About“ und zusätzlich einen Beitrag „About“ vom 17.4.

    Beiträge und Seiten verwenden unterschiedliche Templates. Im Beitrags-Template wird nur eine Bildgröße angezeigt, im Seiten-Template stehen je nach Displaygröße verschiedene Templates zur Verfügung. Das Bild scheint aber in der einen Größe, die im Beitrags-Template verwendet wird, nicht vorhanden zu sein (der Aufruf von https://jodeges.com/wp-content/uploads/2017/04/og_abi_jonathan_deges_mx-Kopie-240×300.jpg gibt eine Fehlermeldung 404 File not found zurück).

    Ich vermute, dass der Arbeitsspeicher zu niedrig ist und die Konvertierung der hochgeladenen Bilder in kleinere Bildgrößen mittendrin abbricht, deshalb die kleine Größe nicht vorhanden ist. Wieviel Arbeitsspeicher (RAM) steht dir zur Verfügung? (Kannst du mit dem Plugin Query Monitor abfragen.) Welche PHP-Version nutzt du? Gibt es im Debug-Modus Fehlermeldungen?

    Kurios ist übrigens auch, dass auf jeder Seite im Slug index.php wiederholt wird. Wie sehen denn da deine Permalink-Einstellungen aus?

    Akismet entspricht übrigens nicht deutschem Datenschutzrecht. Schau dir mal das Plugin Antispam Bee als Alternative an.

Ansicht von 1 Antwort (von insgesamt 1)
  • Das Thema „Foto wird im Beitrag nicht angezeigt“ ist für neue Antworten geschlossen.