Support » Allgemeine Fragen » Fotos hochladen und Anzeige nicht mehr möglich

  • Hallo!
    Habt ihr auch das Problem wenn ihr bei WordPress Fotos bei Medien hochladen wollt dass keine Kleinvorschau wie immer angezeigt wird und wenn man das Foto in die Seite einfügen will es auch nicht funktioniert? Auch das manuelle Hochladen von Fotos über FTP klappt nicht, mir werden diese dann nicht bei den Medien angezeigt.
    Woran liegt das auf einmal? Habe das bei 2 Webseiten nun seit 2 Tagen ca.
    Hoffe ihr könnt mir helfen!!! 🙁

Ansicht von 15 Antworten - 16 bis 30 (von insgesamt 55)
  • Ach ja, noch eine Info, am 17.5. bekam ich eine Mail von DF mit dieser Info: Änderung der IPv6-Adresse
    Hat es vielleicht damit was zu tun?

    Habe das bei 2 Webseiten

    Eventuell nützliche Angaben deinerseits:
    1.
    Welche Themes werden denn auf diesen 2 Websites eingesetzt und in welcher Version?
    2.
    Servereinstellungen überprüfen
    Falls du nicht weiß, wie du das herausfindest:
    Entweder ein Plugin dafür einsetzen, oder mit einem Texteditor wie Notepad++ oder Atom in eine neue, leere Datei

    <? phpinfo();

    eingeben, die Datei als phpinfo.php abspeichern (Kodierung: UTF-8 ohne BOM) und ins Hauptverzeichnis deines Servers hochladen. Danach rufst du die URL deinedomain.de/phpinfo.php auf und bekommst eine Übersicht der wichtigsten Einstellungen deines Servers. Suche auf der Ergebnisseite nach „PHP-Version“ (ganz oben), nach „memory_limit“ und nach „file_uploads“.
    Wie lauten die entsprechenden Einstellungen?

    Nicht vergessen: Hinterher die Datei phpinfo.php wieder löschen.

    Da scheint auch in der wp-config.php etwas nicht zu stimmen. Vielleicht magst du die mal hier teilen? (vorher Zugangsdaten unkenntlich machen) Mit welchem Programm hast du die abgespeichert?

    Ja kommt sofort. Mit Proton und mit filezilla hochgeladen.

    <?php
    /**
     * Grundeinstellungen für WordPress
     *
     * Zu diesen Einstellungen gehören:
     *
     * * MySQL-Zugangsdaten,
     * * Tabellenpräfix,
     * * Sicherheitsschlüssel
     * * und ABSPATH.
     *
     * Mehr Informationen zur wp-config.php gibt es auf der
     * {@link https://codex.wordpress.org/Editing_wp-config.php wp-config.php editieren}
     * Seite im Codex. Die Zugangsdaten für die MySQL-Datenbank
     * bekommst du von deinem Webhoster.
     *
     * Diese Datei wird zur Erstellung der wp-config.php verwendet.
     * Du musst aber dafür nicht das Installationsskript verwenden.
     * Stattdessen kannst du auch diese Datei als wp-config.php mit
     * deinen Zugangsdaten für die Datenbank abspeichern.
     *
     * @package WordPress
     */
    
    // ** MySQL-Einstellungen ** //
    /**   Diese Zugangsdaten bekommst du von deinem Webhoster. **/
    
    /**
     * Ersetze datenbankname_hier_einfuegen mit dem Namen
     * mit dem Namen der Datenbank, die du verwenden möchtest.
     */
    define('DB_NAME', '--');
    
    /**
     * Ersetze benutzername_hier_einfuegen
     * mit deinem MySQL-Datenbank-Benutzernamen.
     */
    define('DB_USER', '--');
    
    /**
     * Ersetze passwort_hier_einfuegen mit deinem MySQL-Passwort.
     */
    define('DB_PASSWORD', '--!');
    
    /**
     * Ersetze localhost mit der MySQL-Serveradresse.
     */
    define('DB_HOST', '--');
    
    /**
     * Der Datenbankzeichensatz, der beim Erstellen der
     * Datenbanktabellen verwendet werden soll
     */
    define('DB_CHARSET', 'utf8');
    
    /**
     * Der Collate-Type sollte nicht geändert werden.
     */
    define('DB_COLLATE', '');
    
    /**#@+
     * Sicherheitsschlüssel
     *
     * Ändere jeden untenstehenden Platzhaltertext in eine beliebige,
     * möglichst einmalig genutzte Zeichenkette.
     * Auf der Seite {@link https://api.wordpress.org/secret-key/1.1/salt/ WordPress.org secret-key service}
     * kannst du dir alle Schlüssel generieren lassen.
     * Du kannst die Schlüssel jederzeit wieder ändern, alle angemeldeten
     * Benutzer müssen sich danach erneut anmelden.
     *
     * @since 2.6.0
     */
    define('AUTH_KEY',         '…');
    define('SECURE_AUTH_KEY',  '…');
    define('LOGGED_IN_KEY',    '…');
    define('NONCE_KEY',        '…');
    define('AUTH_SALT',        '…');
    define('SECURE_AUTH_SALT', '…');
    define('LOGGED_IN_SALT',   '…');
    define('NONCE_SALT',       '…');
    
    /**#@-*/
    
    /**
     * WordPress Datenbanktabellen-Präfix
     *
     * Wenn du verschiedene Präfixe benutzt, kannst du innerhalb einer Datenbank
     * verschiedene WordPress-Installationen betreiben.
     * Bitte verwende nur Zahlen, Buchstaben und Unterstriche!
     */
    $table_prefix  = 'wp_';
    
    /**
     * Für Entwickler: Der WordPress-Debug-Modus.
     *
     * Setze den Wert auf „true“, um bei der Entwicklung Warnungen und Fehler-Meldungen angezeigt zu bekommen.
     * Plugin- und Theme-Entwicklern wird nachdrücklich empfohlen, WP_DEBUG
     * in ihrer Entwicklungsumgebung zu verwenden.
     *
     * Besuche den Codex, um mehr Informationen über andere Konstanten zu finden,
     * die zum Debuggen genutzt werden können.
     *
     * @link https://codex.wordpress.org/Debugging_in_WordPress
     */
    define('WP_DEBUG', true );
    
    /* Das war’s, Schluss mit dem Bearbeiten! Viel Spaß beim Bloggen. */
    /* That's all, stop editing! Happy blogging. */
    
    /** Der absolute Pfad zum WordPress-Verzeichnis. */
    if ( !defined('ABSPATH') )
    	define('ABSPATH', dirname(__FILE__) . '/');
    
    /** Definiert WordPress-Variablen und fügt Dateien ein.  */
    require_once(ABSPATH . 'wp-settings.php');
    ?>

    Lösch mal ganz am Ende das schließende ?> und achte darauf, dass die Kodierung beim Speichern auf „UTF-8“ (ohne BOM) gesetzt ist.

    Die Konstante WP_DEBUG kannst du wieder auf false setzen, wenn du Fehlermeldungen nicht angezeigt haben möchtest:

    define( 'WP_DEBUG', false );

    Das am Ende hatte ich weg und wenn ich es wieder auf false setze verändert sich das Aussehen meiner Webseite… Ich verzweifele echt. Was das mit der Kodierung heisst versteh ich leider nicht.

    Eventuell nützliche Angaben deinerseits:
    1.
    Welche Themes werden denn auf diesen 2 Websites eingesetzt und in welcher Version?

    – Customize und Decode

    2.
    Servereinstellungen:
    Wie lauten die entsprechenden Einstellungen?

    -„PHP-Version“
    PHP Version 5.5.28,
    memory_limit 100M 100M
    file_uploads On On

    Habe diese Fehlermeldungen bei der neuen Seite die ich gestern erstellt habe nicht, da habe ich aber auch kaum Plugins und kaum was bearbeitet bisher.

    Customize und Decode

    Die Frage war zweigeteilt, es fehlt der wichtige 2. Teil:

    Welche Themes werden denn auf diesen 2 Websites eingesetzt und in welcher Version?

    Zum Speicherlimit:

    memory_limit 100M

    Das ist recht wenig.
    Und um das Speicherlimit zu erhöhen, gib mal in der Datei wp-config.php
    oberhalb von

    /* Das war’s, Schluss mit dem Bearbeiten! Viel Spaß beim Bloggen. */
    /* That’s all, stop editing! Happy blogging. */

    folgenden Code ein:

    define( 'WP_MEMORY_LIMIT', '128M' );

    Auch 256M kannst du mal testen.

    Und schau mal, ob du im Kundenmenü deines Hosters die PHP-Version 5.6 einstellen kannst.

    PHP-Version: 5-55STABLE-STANDARD

    Nun kann ich mich nicht mehr in mein Dashboard einloggen??? Was ist das denn nun? ich verzweifel hier noch wirklich! bisher war nie ein problem da.

    Warning: Cannot modify header information – headers already sent by (output started at /…./wordpress/wp-content/plugins/wp-resized-image-quality/wp-resized-image-quality.php:88) in /….wordpress/wp-includes/pluggable.php on line 1171

    FEHLER: Cookies sind wegen einer unerwarteten Ausgabe gesperrt. Hilfe findest du in dieser Dokumentation oder wende dich an das Support-Forum.

    Bei den mehrfachen Änderungen in der wp-config.php hast du vermutlich die Datei nicht mehr im richtigen Format abgespeichert. Verwende einen Editor wie Notepad++ oder Atom, damit du die Kodierung UTF-8 ohne BOM einstellen kannst.
    Vgl. diese Info.

    Ich habe auch in meinem Ordner wordpress wo die ordner wp-admin etc liegen noch viele dateien auf einmal. Meine vorher waren es nicht so viele… soll ich nicht lieber nochmal probieren ein Backup einzuspielen und das jetzige zu löschen alles?

    Ich habe auch in meinem Ordner wordpress wo die ordner wp-admin etc liegen noch viele dateien auf einmal. Meine vorher waren es nicht so viele… soll ich nicht lieber nochmal probieren ein Backup einzuspielen und das jetzige zu löschen alles?

    Kodierung laut Notepad ist richtig.

    Falsche Kodierung ist eine Möglichkeit für diesen Fehler, eine weitere ist folgende:

    Wenn Du diese Fehlermeldung bekommst, dann könnte es daran liegen, dass vor dem öffnenden <?php oder nach dem schließenden ?> noch (Leer-)Zeichen oder Leerzeilen zu finden sind.

    Quelle

    bei wp config leider nein. schon gecheckt….

Ansicht von 15 Antworten - 16 bis 30 (von insgesamt 55)
  • Das Thema „Fotos hochladen und Anzeige nicht mehr möglich“ ist für neue Antworten geschlossen.