Support » Installation » Frisches WordPress, kein GD und ImageKick will auch nicht

  • Gelöst frosch65

    (@frosch65)


    Moin!

    Vorgeschichte: ich möchte endlich mal meine HP aktualisieren (kiel.org, wenns interessiert) und habe mich jetzt für WordPress entschieden. Da hab ich n Kurs gemacht, damit ich nicht ganz dumm dastehe. (tu ich trotzdem, aber egal)

    Ich hab mir auf dem Rechner xampp installiert und da dann auch WP rein. (damit ich erst mal testen und so kann, bevor ich meinen Hoster auf den Keks gehe)

    Die ganz frische Installation zeigt mir schon:
    „Das optionale Modul imagick ist nicht installiert oder wurde deaktiviert.
    Fehler Das erforderliche Modul gd ist nicht installiert oder wurde deaktiviert.“

    Nun hab ich gesucht und gesucht und…
    Das einzige ImagMagick-Plugin, das ich gefunden hab, wurde vor 9 Mon aktualisiert. (Version 1.irgendwas) Aber in anderen aktuellen Hilferufen hab ich Versionen 6.irgendwas gesehen. Also bin ich wohl falsch davor.

    Was mich auch stutzig macht: das GD sollte doch immer dabei sein? Oder nicht? oder wie? (dazu hab ich nu _gar_ nix gefunden)

    Wo mach ich n Denkfehler oder wonach kann ich suchen?
    Im englischen Forum hab ich zwar was gefunden, wurde aber nicht wirklich schlau draus.

    Brauchts noch weitere Info von mir? Die WP und das XAMPP sind beides die aktuältesten Versionen. (ganz frisch runtergeladen)
    BS meiner Kiste ist Win10.
    Und ich hab auch dran gedacht, XAMPP als knecht-root-recht zu starten.

    Danke,
    Bea

    Nachtrag: wenn ich das imagemagick installiere, meckert das Ding über fehlenden imagemagick.php

    • Dieses Thema wurde geändert vor 3 Monaten, 1 Woche von frosch65.
Ansicht von 8 Antworten - 1 bis 8 (von insgesamt 8)
  • XAMPP ist schon ein wenig in die Jahre gekommen. Wenn du das Paket von Bitnami installierst, sollte die Installation etwas leichter von der Hand gehen.

    Wenn du ein umfassenderes Paket zur lokalen Entwicklung möchtest, kann ich auch DevKinsta sehr empfehlen.

    Imagemagick ist eine Grafikbibliothek, die mehr Möglichkeiten beinhaltet und auch etwas bessere Ergebnisse bei der Skalierung von Bildern liefert. Der „Fehlerhinweis“ zu Imagemagick soll dich nur darauf aufmerksam machen, dass „noch mehr geht“. Die GD-Bibliothek sollte allerdings grundsätzlich enthalten sein. Schau mal, ob du in xampp/php/php.ini eine Zeile extension=gd2 findest, die noch auskommentiert ist. Kommentar-Zeichen entfernen, Server neu starten.
    Aber wie gesagt: ich würde lieber Bitnami oder DevKinsta verwenden.

    Du weißt aber schon, dass das hier ein Forum für WordPress-Anwender ist und kein Forum für XAMPP oder sonstige Software?

    ImageMagick ist nicht zwingend erforderlich, aber die GD-Extension sollte eigentlich auch bei XAMPP installiert sein. Kontrolliere mal in der php.ini, ob darin
    extension=gd2
    oder
    ;extension=gd2
    steht. Wenn du ein Semikolon vor dieser Zeile hast, entferne es und starte den Apache neu.

    @pixolin

    XAMPP ist schon ein wenig in die Jahre gekommen.

    Ich selber nutze XAMPP auch nicht mehr, ich habe mir den Apache, MariaDB und PHP einzeln selber installiert, weil ich das ganze Drumherum nicht brauche. Aber in die Jahre gekommen würde ich nicht sagen, die Pakete von XAMPP sind eigentlich immer noch aktuell.

    @bscu Oh, OK. Danke für die Korrektur, ich hatte mich unglücklich ausgedrückt – gemeint war, dass Ergänzungen die Sache erleichtern:

    Bitnami for XAMPP vereinfacht die Entwicklung von PHP-Anwendungen auf ApacheFriends XAMPP erheblich, indem es WordPress, Drupal mit Drush, Joomla! und viele weitere Open-Source-Anwendungen auf XAMPP installiert.

    (Quelle: Bitnami for XAMPP, übersetzt mit Deepl)

    Thread-Ersteller frosch65

    (@frosch65)

    MOin!

    Boah, seid Ihr schnell 🙂
    @pixolin DAnke für die Tipps 🙂 die ersten werde ich mir zu Herzen nehmen, das letztere ausprobieren
    @bscu ja, ich weiß, dass das WP-Forum ist. Aber woher soll ich wissen, dass das an XAMPP liegt? Ich hab _das_ nur dazugeschrieben, damit mein Problem vollständig ist.
    Und: danke für die Hilfe (auch wenns dann ja wohl kein WP-Problem ist)

    Der erste Test war noch nicht erfolgreich 🙁 Aber so schnell geb ich nicht auf 🙂

    Und ich werd wohl xampp dann mal entsorgen 🙂

    Danke und einen schönen Sonntag!

    Bea

    Thread-Ersteller frosch65

    (@frosch65)

    ok, dann werd ich bitnami zufügen. nur hab ichs kapiert (Asche auf mein Haupt)

    Thread-Ersteller frosch65

    (@frosch65)

    Hi!

    Danke. Das wars.

    Viele Grüsse,
    Bea

    Das mit der Asche ist nicht nötig – siehe Hinweis von @bscu.
    Drücken wir es nochmal anders aus: Mit Binami geht’s bequemer und der Fehler sollte auch nicht mehr angezeigt werden.

    Markieren wir den Thread als „gelöst“? Schon erledigt! 😀

    • Diese Antwort wurde geändert vor 3 Monaten, 1 Woche von Bego Mario Garde. Grund: Thread bereits als gelöst markiert
Ansicht von 8 Antworten - 1 bis 8 (von insgesamt 8)