Support » WooCommerce » Funktionsaufruf Thumbnails order-details-item.php

  • Hi zusammen,

    ich hoffe ihr könnt mir helfen. In meinem Theme wird ein Funktionsaufruf für Thumbnails in den Bestelldetails gestartet, allerdings läuft dieser immer in einen Fehler.

    <?php echo apply_filters( 'woocommerce_order_item_thumbnail', $product->get_image(), $item, $order ); ?>

    Das ist der Fehler:

    : Uncaught Error: Call to a member function get_image() on bool in /var/www/vhosts/httpdocs/wp-content/themes/cartzilla/woocommerce/order/order-details-item.php:48

    Meine Frage ist; Wie wird get_image() in Kombination mit dem Funktionsaufruf denn nun verwendet ? Bin leider kein PHP Pro daher hoffe ich auf etwas Hilfe 😛

    Gruß
    John

Ansicht von 2 Antworten - 1 bis 2 (von insgesamt 2)
  • Hallo John,

    probier mal den Teil des Bildes durch

    wp_get_attachment_image_src( get_post_thumbnail_id( $product_id ), 'single-post-thumbnail' )

    zu ersetzen.

    Wo genau im Theme wird das aufgerufen? Hast du dem Support deines Themes bereits geschrieben?

    Viele Grüße
    Jan

    Hallo,
    sorry, wir können dir bei gekauften Themes (hier cartzilla) oder Plugins so gut wie gar nicht helfen, weil sie uns nicht zur Verfügung stehen. Wir müssten sonst bei jeder Frage erst einmal das entsprechende Theme oder Plugin kaufen, uns dort einarbeiten und dann kostenlos den Support anbieten, für den du beim Kauf eigentlich bezahlt hast. Du solltest dich in dem Fall an den Entwickler wenden. Lies bitte auch mal in der FAQ II, 1b zu diesem Thema.
    Viele Grüße
    Hans-Gerd

Ansicht von 2 Antworten - 1 bis 2 (von insgesamt 2)