Support » Plugins » Gallery Bild einfügen bei Erstellung/Bearbeitung Portfolio nicht mehr möglich

  • Gelöst annichje

    (@annichje)


    Liebe Gemeinschaft,

    unsere Website wurde von einem Dritten erstellt der diese nun nicht mehr bearbeiten kann bzw. auch nicht mehr als Hilfe zur Verfügung steht.

    Das Problem: Bei einem bestehenden Portfolio Eintrag oder einem neu erstelltem taucht unterhalb zwar die Funktion „gallery“ auf, wenn ich allerdings auf „Add/Edit“ oder „Delete“ klicke, reagiert wordpress einfach überhaupt nicht.

    Wie gesagt, auch nicht bei bereits bestehenden Seiten. Bei neuen kann eben keine Gallery mehr eingefügt werden.

    Weiß vielleicht jemand was ich tun kann um diese wieder zu aktivieren bzw. ob ich das Plugin (vermute es ist eins) ersetzen kann und soll?

    Sorry für die vielleicht sehr simple Frage, komme aber einfach nicht weiter. Danke für jegliche Hilfe!

Ansicht von 8 Antworten - 1 bis 8 (von insgesamt 8)
  • Ohne eine URL zu deiner Website wird dir da wohl nur eine staatlich geprüfte Hellseherin weiterhelfen können. 😉

    Ein Bericht zu deiner Website wäre ebenfalls hilfreich: Geh bitte auf Werkzeuge > Website-Zustand > Bericht, klick auf den Button und füge den Bericht mit Strg-V unverändert in deine Antwort ein.

    Thread-Ersteller annichje

    (@annichje)

    Danke für die vorausschauende Info, da die Seite hinterlegt ist bin ich davon ausgegangen das sie aufgerufen werden kann. Falsche Annahme.

    Die Website lautet: http://www.ceitec.de

    Hier der Bericht:

    
    ### wp-core ###
    
    version: 5.8
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Berlin
    permalink: /%category%/%post_id%-%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: closed
    environment_type: production
    user_count: 5
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /kunden/265632_32825/wp
    wordpress_size: 2,62 GB (2810890704 bytes)
    uploads_path: /kunden/265632_32825/wp/wp-content/uploads
    uploads_size: 1,23 GB (1318559226 bytes)
    themes_path: /kunden/265632_32825/wp/wp-content/themes
    themes_size: 28,33 MB (29702731 bytes)
    plugins_path: /kunden/265632_32825/wp/wp-content/plugins
    plugins_size: 106,12 MB (111277978 bytes)
    database_size: 17,41 MB (18253175 bytes)
    total_size: 3,99 GB (4288683814 bytes)
    
    ### wp-active-theme ###
    
    name: Sentinel (sentinel)
    version: 4.2
    author: freshface
    author_website: http://themeforest.net/user/freshface/portfolio
    parent_theme: none
    theme_features: core-block-patterns, post-thumbnails, woocommerce, automatic-feed-links, menus, widgets, widgets-block-editor
    theme_path: /kunden/265632_32825/wp/wp-content/themes/sentinel
    auto_update: Deaktiviert
    
    ### wp-themes-inactive (4) ###
    
    Twenty Nineteen: version: 2.1, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    Twenty Seventeen: version: 2.8, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    Twenty Twenty: version: 1.8, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    Twenty Twenty-One: version: 1.4, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-active (15) ###
    
    BackUpWordPress: version: 3.11, author: XIBO Ltd, Automatische Aktualisierungen aktiviert
    Classic Editor: version: 1.6.2, author: WordPress Contributors, Automatische Aktualisierungen deaktiviert
    Contact Form 7: version: 5.4.2, author: Takayuki Miyoshi, Automatische Aktualisierungen aktiviert
    Enable Media Replace: version: 3.5.0, author: ShortPixel, Automatische Aktualisierungen deaktiviert
    freshface WordPress Packery Gallery: version: 1.0.0, author: freshface, Automatische Aktualisierungen deaktiviert
    Limit Login Attempts: version: 1.7.1, author: Johan Eenfeldt, Automatische Aktualisierungen aktiviert
    PHP Compatibility Checker: version: 1.5.0, author: WP Engine, Automatische Aktualisierungen aktiviert
    Portfolio Custom Post Type and Taxonomies: version: 1.0.0, author: freshface, Automatische Aktualisierungen aktiviert
    Rename wp-login.php: version: 2.6.0, author: Ella van Durpe, Automatische Aktualisierungen aktiviert
    Revolution Slider: version: 4.6.5, author: ThemePunch, Automatische Aktualisierungen deaktiviert
    Simple 301 Redirects: version: 2.0.5, author: WPDeveloper, Automatische Aktualisierungen aktiviert
    UpdraftPlus - Backup/Restore: version: 1.16.59, author: UpdraftPlus.Com, DavidAnderson, Automatische Aktualisierungen aktiviert
    User Role Editor: version: 4.60.1, author: Vladimir Garagulya, Automatische Aktualisierungen aktiviert
    WPBakery Page Builder: version: 6.1, author: Michael M - WPBakery.com (latest version: 6.7), Automatische Aktualisierungen deaktiviert
    WP Google Maps: version: 8.1.14, author: WP Google Maps, Automatische Aktualisierungen aktiviert
    
    ### wp-plugins-inactive (2) ###
    
    Login Security Solution: version: 0.56.0, author: Daniel Convissor, Automatische Aktualisierungen aktiviert
    W3 Total Cache: version: 2.1.5, author: BoldGrid, Automatische Aktualisierungen aktiviert
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_GD
    imagick_module_version: Nicht verfügbar
    imagemagick_version: Nicht verfügbar
    imagick_version: Nicht verfügbar
    file_uploads: File uploads is turned off
    post_max_size: 8M
    upload_max_filesize: 8M
    max_effective_size: 8 MB
    max_file_uploads: 20
    gd_version: bundled (2.1.0 compatible)
    gd_formats: GIF, JPEG, PNG
    ghostscript_version: 9.25
    
    ### wp-server ###
    
    server_architecture: Linux 3.18.117-pvops-xen-x64 x86_64
    httpd_software: Apache
    php_version: 7.0.32
    php_sapi: cgi-fcgi
    max_input_variables: 1000
    time_limit: 0
    memory_limit: 256M
    max_input_time: -1
    upload_max_filesize: 8M
    php_post_max_size: 8M
    curl_version: 7.55.1 OpenSSL/1.0.2l
    suhosin: false
    imagick_availability: false
    pretty_permalinks: true
    htaccess_extra_rules: false
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.6.19-67.0-log
    client_version: mysqlnd 5.0.12-dev - 20150407 - $Id: b5c5906d452ec590732a93b051f3827e02749b83 $
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /kunden/265632_32825/wp/wp-content
    WP_PLUGIN_DIR: /kunden/265632_32825/wp/wp-content/plugins
    WP_MEMORY_LIMIT: 40M
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    

    Vielen Dank für die Hilfe!

    Die Website, die du in deinem Profil angibst, muss nicht zwingend die Website sein, bei der ein Problem auftaucht. Wenn du einen neuen Thread startest, gibt es deshalb extra ein Eingabefeld „URL, für die ich Hilfe brauche“.

    Aber nun haben wir ja URL und sogar den Bericht zur Website. Beim Bericht ist mir folgendes aufgefallen (was nicht unbedingt mit deinem Problem zusammenhängen muss):

    wordpress_size: 2,62 GB (2810890704 bytes)

    Das ist recht viel. WordPress selbst macht nur irgendwas um die 80 MB aus, der Rest dürfte von übrig gebliebenen Backups stammen. Da würde ich mal prüfen, ob du dich nicht von dem einen oder anderen Backup trennen kannst. Auch das Cache-Plugin könnte eine Ursache sein. Nur durch Deaktivieren des Plugins wird der erzeugte Zwischenspeicher nicht geleert.

    aktives Theme: Sentinel

    Bei Fragen zu gekauften Themes (hier: Sentinel) können wir dir nicht weiterhelfen, weil sie uns für einen kostenlosen Support nicht kostenlos zur Verfügung stehen.

    Bitte wende dich bei Fragen zu diesem Theme an die Entwickler.

    Plugins:

    BackUpWordPress und UpdraftPlus sind beides Backup-Plugins. Ein Plugin sollte völlig reichen. Hast du mal in einer lokalen Test-Installation ausprobiert, ob du die Backups überhaupt wiederherstellen kannst? (Sonst sind sie wertlos.) Wenn du die Backups von einem Plugin wiederherstellen kannst, kannst du auf das andere Plugin verzichten.

    User Role Editor ist ein Plugin, mit dem Benutzerrechte angepasst oder neu definiert werden können. Das wird gerne benutzt, um Anwender/-innen vor unbedachten Änderungen zu schützen, kann aber auch dazu führen dass Dinge nicht so funktionieren, wie sie sollen. Prüf mal, ob der Fehler weiter besteht, wenn du das Plugin deaktivierst.
    Auch die anderen Plugins können möglicherweise eine Rolle spielen. Um sie alle mal zu deaktivieren und dann einzeln wieder zu aktvieren, kannst du das Plugin Health Check verwenden. Das Plugin wurde vom WordPress-Support-Team zum Testen solcher Fälle erstellt, bietet dir dafür unter Werkzeuge > Website-Zustand einen Problembehandlungsmodus und ändert nichts an deiner Website. Nach Verlassen des Problembehandlungsmodus ist alles wie vorher, nur hast du dann vielleicht den Grund für das Problem herausgefunden. Andere Benutzer oder die Besucher deiner Website bekommen von der Deaktivierung der Plugins nichts mit.

    Server:

    php_version: 7.0.32

    Das ist auf jeden Fall veraltet und wird auch von den PHP-Entwicklern nicht mehr gepflegt. Schau bitte mal, ob du im Kundenmenü deines Webhosters zu einer aktuellen PHP-Version wechseln kannst. Ideal wäre PHP 7.4, 7.3 ist auch noch OK. 8.0 wird noch nicht von allen Themes und Plugins unterstützt.

    Deine Seite gibt einen Fehler wegen gemischter Inhalte aus. Um den Fehler zu beseitigen, kannst du das Plugin Better Search Replace installieren und damit die URL http://wp.ceitec.de/ mit https://ceitec.de/ ersetzen. Achte darauf, alle Tabellen auszuwählen und das Kästchen Testlauf zu deaktivieren. Tippfehler sind mühsam zu korrigieren, vor Ausführen der Ersetzung also bitte nochmal sorgfältig beide URLs prüfen.

    Sonst fällt mir zum Bericht und der Website wenig auf/ein, was helfen könnte. PHP-Version ändern und Plugins vorübergehend zum Testen deaktivieren scheinen mir die wichtigsten Punkte zu sein. Wenn du damit nicht hinkommst, wende dich an den Theme-Entwickler.

    Thread-Ersteller annichje

    (@annichje)

    Vielen herzlichen Dank. Ich habe zunächst die php Version angepasst, habe allerdings dann dass Problem das ich mich in Worpress nicht mehr einloggen kann:

    `Fatal error: Uncaught Error: [] operator not supported for strings in /kunden/265632_32825/wp/wp-content/plugins/revslider/inc_php/framework/base_admin.class.php:72 Stack trace: #0 /kunden/265632_32825/wp/wp-content/plugins/revslider/revslider_admin.php(157): UniteBaseAdminClassRev::addMetaBox(‚Revolution Slid…‘, Object(UniteSettingsAdvancedRev), Array, NULL) #1 /kunden/265632_32825/wp/wp-content/plugins/revslider/revslider_admin.php(68): RevSliderAdmin->addSliderMetaBox() #2 /kunden/265632_32825/wp/wp-content/plugins/revslider/revslider_admin.php(40): RevSliderAdmin->init() #3 /kunden/265632_32825/wp/wp-content/plugins/revslider/revslider.php(146): RevSliderAdmin->__construct(‚/kunden/265632_…‘) #4 /kunden/265632_32825/wp/wp-settings.php(409): include_once(‚/kunden/265632_…‘) #5 /kunden/265632_32825/wp/wp-config.php(84): require_once(‚/kunden/265632_…‘) #6 /kunden/265632_32825/wp/wp-load.php(50): require_once(‚/kunden/265632_…‘) #7 /kunden/265632_32825/wp/wp-admin/admin.php(34): require_once(‚/kunden/265632_… in /kunden/265632_32825/wp/wp-content/plugins/revslider/inc_php/framework/base_admin.class.php on line 72
    Es gab einen kritischen Fehler auf deiner Website. Bitte überprüfe den Posteingang deiner Website-Administrator-E-Mail-Adresse für weitere Anweisungen.

    Erfahre mehr über die Problembehandlung in WordPress.`

    Da die Grundeinstellungen so waren, das die letzten 7 Backups gespeichert werden, habe ich diese Einstellung angepasst und die älteren Backups gelöscht um die Datenmenge zu verringern.

    Kann es am Provider liegen, dass ich mich nun nicht mehr einloggen kann oder ist es von der PHP Version abhängig?

    Kann es am Provider liegen, dass ich mich nun nicht mehr einloggen kann oder ist es von der PHP Version abhängig?

    Das liegt an der PHP-Version, die sich nicht mit dem (wahrscheinlich mit dem Theme mitgelieferten) Plugin Revolution Slider verträgt.

    Sind Theme und Plugin aktuell? Sonst erst ein Update durchführen und dann nochmal die Umstellung auf PHP 7.4 versuchen.

    Weiterhin eine alte, nicht mehr supportete PHP-Version zu nutzen kann aus Sicherheitsgründen keine Lösung sein.

    Thread-Ersteller annichje

    (@annichje)

    Beides ist aktuell, das Theme und auch das Plugin.

    Wenn ich dann auf PHP 7.4 umstelle, verliere ich wieder den Zugriff auf WordPress.

    Die Seite ist weiterhin aufrufbar was ja dann sicherlich für die Sicherheit gut ist, aber ich kann sie eben nicht mehr bearbeiten.

    Ich vermute, auf lange Sicht müssen wir das Theme wechseln. Es ist nur merkwürdig das die Gallery sichtbar ist, auf den bisherigen Seiten auch weiterhin funktioniert, halt nur eben nicht bearbeitet werden kann oder neu eingefügt werden kann.

    Slapping a dead horse here 🙂

    Wie gesagt: zu gekauften Themes können wir dir hier nicht weiterhelfen.

    Vielleicht kommst du aber damit weiter:
    Lösung für: [] operator not supported for strings in wp-content/plugins/revslider/includes/framework/base-admin.class.php:71

    (Vorher ein Backup der Datei machen.)

    Thread-Ersteller annichje

    (@annichje)

    Vielen Dank für die Hilfe. Da der Entwickler nicht zu erreichen ist werde ich das Theme ersetzen.

Ansicht von 8 Antworten - 1 bis 8 (von insgesamt 8)