Support » Allgemeine Fragen » geladene Bilder in die Mediathek nicht sichtbar

  • Gelöst wuestenblumesamy

    (@wuestenblumesamy)


    Hallo Zusammen,

    habe plötzlich ein Problem mit neu geladenen Bildern in die Mediathek. Sie werden nicht angezeigt (keine Vorschau). Lassen sich zwar einfügen in eine Seite, sind aber auch dort nicht sichtbar.
    Die WordPress Version ist auf dem neuesten Stand, Plugins aktualisiert.
    Woran kann das liegen?

    Gruß,
    Samy

Ansicht von 7 Antworten - 1 bis 7 (von insgesamt 7)
  • Hast du eventuell das Plugin „Enhanced Media Library“ installiert? Wenn ja, dann deaktiviere es mal. Ich hatte ähnliche Probleme damit, dieses Plugin ist nicht mit WordPress 5.4.1 kompatibel.

    Nein, das Pugin habe ich nicht.
    Kann es evtl. damit zusammenhängen, dass ein Modul fehlt, wie das empfohlene Modul imagick? Ich habe den Provider gewechselt und meine Website lief zwar tadellos, doch als ich jetzt ein Bild austauschen wollte, ist dieses Problem aufgetaucht.

    Geh mal bitte auf Werkzeuge > Website-Zustand > Bericht, warte einen Moment bis alles geladen ist und kopiere dann per Button den Website-Bericht in deine Zwischenablage. Den kannst du dann bitte hier als neue Antwort unverändert (also mit den Akzentzeichen am Anfang und Ende) einfügen. So erfahren wir ein bisschen mehr über deine Website und können den Fehler besser einschätzen.

    
    ### wp-core ###
    
    version: 5.4.1
    site_language: de_DE
    user_language: de_DE
    permalink: /%postname%/
    https_status: true
    user_registration: 0
    default_comment_status: open
    multisite: false
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /kunden/619056_47058/webseiten/WordPress_02
    wordpress_size: 413,99 MB (434105112 bytes)
    uploads_path: /kunden/619056_47058/webseiten/WordPress_02/wp-content/uploads
    uploads_size: 17,02 MB (17843736 bytes)
    themes_path: /kunden/619056_47058/webseiten/WordPress_02/wp-content/themes
    themes_size: 6,23 MB (6535852 bytes)
    plugins_path: /kunden/619056_47058/webseiten/WordPress_02/wp-content/plugins
    plugins_size: 112,99 MB (118482629 bytes)
    database_size: 55,66 MB (58359808 bytes)
    total_size: 605,90 MB (635327137 bytes)
    
    ### wp-active-theme ###
    
    name: Astra (astra)
    version: 2.4.5
    author: Brainstorm Force
    author_website: https://wpastra.com/about/
    parent_theme: none
    theme_features: astra_hooks, align-wide, automatic-feed-links, title-tag, post-thumbnails, html5, post-formats, custom-logo, customize-selective-refresh-widgets, editor-style, woocommerce, amp, infinite-scroll, widgets, menus
    theme_path: /kunden/619056_47058/webseiten/WordPress_02/wp-content/themes/astra
    
    ### wp-themes-inactive (1) ###
    
    Twenty Twenty: version: 1.3, author: WordPress-Team
    
    ### wp-mu-plugins (2) ###
    
    Elementor Safe Mode: version: 1.0.0, author: Elementor.com
    Health Check Troubleshooting Mode: author: (undefined), version: 1.7.1
    
    ### wp-plugins-active (16) ###
    
    Astra Pro: version: 2.5.1, author: Brainstorm Force
    Astra Widgets: version: 1.2.3, author: Brainstorm Force
    Contact Form 7: version: 5.1.9, author: Takayuki Miyoshi
    Custom Fonts: version: 1.2.1, author: Brainstorm Force
    Disable Emojis (GDPR friendly): version: 1.7.2, author: Ryan Hellyer
    Duplicate Post: version: 3.2.4, author: Enrico Battocchi
    Easy Social Icons: version: 3.0.7, author: cybernetikz
    Elementor: version: 2.9.11, author: Elementor.com
    Elementor Pro: version: 2.9.5, author: Elementor.com
    Health Check & Troubleshooting: version: 1.4.4, author: The WordPress.org community
    Honeypot for Contact Form 7: version: 1.14.1, author: Nocean
    Jetpack by WordPress.com: version: 8.6.1, author: Automattic
    Login Designer: version: 1.2.4, author: Rich Tabor
    Starter Templates: version: 2.2.4, author: Brainstorm Force
    UpdraftPlus - Backup/Restore: version: 1.16.25, author: UpdraftPlus.Com, DavidAnderson
    Yoast SEO Premium: version: 14.2, author: Team Yoast
    
    ### wp-plugins-inactive (4) ###
    
    Google XML Sitemaps: version: 4.1.0, author: Arne Brachhold
    Import / Export Customizer Settings: version: 1.0.2, author: Brainstorm Force (latest version: 1.0.3)
    PayPal PLUS for WooCommerce: version: 2.2.0, author: Inpsyde GmbH (latest version: 2.2.1)
    Yoast SEO: version: 14.0.4, author: Team Yoast (latest version: 14.2)
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_GD
    imagick_module_version: Nicht verfügbar
    imagemagick_version: Nicht verfügbar
    gd_version: bundled (2.1.0 compatible)
    ghostscript_version: 9.25
    
    ### wp-server ###
    
    server_architecture: Linux 3.18.114-pvops-xen-x64 x86_64
    httpd_software: Apache/2.4.41
    php_version: 7.3.10
    php_sapi: cgi-fcgi
    max_input_variables: 1000
    time_limit: 300
    memory_limit: 256M
    max_input_time: -1
    upload_max_size: 8M
    php_post_max_size: 8M
    curl_version: 7.55.1 OpenSSL/1.0.2l
    suhosin: false
    imagick_availability: false
    server-headers: 
    	date: Mon, 08 Jun 2020 16:58:49 GMT
    	server: Apache/2.4.41
    	x-powered-by: PHP/7.3.10
    	expires: Wed, 11 Jan 1984 05:00:00 GMT
    	cache-control: no-cache, must-revalidate, max-age=0
    	link: <https://samy-design.de/wp-json/>; rel="https://api.w.org/", <https://samy-design.de/>; rel=shortlink
    	upgrade: h2
    	content-type: text/html; charset=UTF-8
    htaccess_extra_rules: false
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.6.19-67.0-log
    client_version: mysqlnd 5.0.12-dev - 20150407 - $Id: 7cc7cc96e675f6d72e5cf0f267f48e167c2abb23 $
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /kunden/619056_47058/webseiten/WordPress_02/wp-content
    WP_PLUGIN_DIR: /kunden/619056_47058/webseiten/WordPress_02/wp-content/plugins
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    mu-plugins: writable
    
    ### jetpack ###
    
    site_id: 175020860
    ssl_cert: No
    time_diff: undefined
    version_option: 8.6.1:1591538021
    old_version: 8.5:1588837117
    public: Public
    master_user: #1 samiradia (wuestenblumesamy@web.de)
    current_user: #1 samiradia (wuestenblumesamy@web.de)
    tokens_set: Blog User
    blog_token: o1&EaV1Vh^XZTdTPyfkq!!sIqbO)pCYz
    user_token: R9lwzk$StEnLu23YW$SNgL)$W@x*8Mg^
    version: 8.6.1
    jp_plugin_dir: /kunden/619056_47058/webseiten/WordPress_02/wp-content/plugins/jetpack/
    plan: free
    HTTP_HOST: samy-design.de
    SERVER_PORT: 443
    HTTPS: on
    REMOTE_ADDR: 18.194.81.6
    protect_header: {"trusted_header":"REMOTE_ADDR","segments":1,"reverse":false}
    full_sync: {"started":"Mon, 30 Mar 2020 13:13:11 +0000","finished":"Mon, 30 Mar 2020 13:14:38 +0000","progress":{"options":{"finished":true},"functions":{"finished":true},"constants":{"finished":true},"users":{"total":"1","sent":1,"finished":true,"last_sent":"1"}},"config":{"options":true,"functions":true,"constants":true,"users":[1]}}
    sync_size: undefined
    sync_lag: 0 seconds
    full_sync_size: undefined
    full_sync_lag: 0 seconds
    idc_urls: {"home":"https:\/\/samy-design.de","siteurl":"https:\/\/samy-design.de","WP_HOME":"","WP_SITEURL":""}
    idc_error_option: false
    idc_optin: true
    cxn_tests: All Pass.
    
    

    Da sind eine ganze Reihe ressourcenhungriger Plugins und Theme im Einsatz. Gut möglich, dass der Arbeitsspeicher nicht ausreicht, um die Bilder beim Hochladen zu skalieren.

    Du könntest …

    • im Browser die URL der skalierten Bilder eingeben und schauen, ob sie auf dem Webserver richtig gespeichert wurden.
    • Versuchen, ein kleineres Bild testweise hochzuladen. Dabei geht es weniger um die Dateigröße als die Abmessung der Bilder in Pixel (Auflösung), da die Bilder pixelweise eingelesen werden.
    • das Plugin Health Check installieren und den Upload der Bilder im „Problembehandlungsmodus“ probieren. Dabei werden die Plugins vorübergehend und nur für dich deaktiviert und belegen so nicht den Arbeitsspeicher.

    Falls es am fehlenden Arbeitsspeicher liegen sollte, könnest du entweder überlegen auf das eine oder andere Plugin zu verzichten (Jetpack ist nicht einmal datenschutzkonform) oder beim Webhoster für ein paar Euro extra im Monat mehr Arbeitsspeicher zu buchen.

    – Speicher habe ich genug: 102.400,00 MB
    – ich achte darauf, dass die Bilder eine geringe Auflösung haben, nach Möglichkeit nicht über 100-130 KB
    – nach „Problembehandlungsmodus“ >> Zugriff wird verweigert

    Ich habe auf den Ordner, der auf dem Server neu angelegt wird für die jetzt nachträglichen Bilder, keine Berechtigung/Zugriff.
    Evtl. hängt es doch mit dem empfohlenen PHP Modul zusammen, welches fehlt?

    Wer lange bohrt, stößt auch auf Öl!

    Ich hab´s endlich! Es lag an dem Berechtigungswert des Bilderordners auf dem FTP Server! Er war vorher bei 600, was viel zu wenig ist!

    Lieben Dank für Eure Tipps und die Bemühungen!

    VG,
    Samira

Ansicht von 7 Antworten - 1 bis 7 (von insgesamt 7)