Support » Allgemeine Fragen » Google sagt noindex in HTTP-Header „X-Robots-Tag“ – ist aber nicht

  • Hi alle,

    Bei mir landen viele (ca. 12.000 – nicht alle) Unterseiten nicht mehr im Index. Ich hatte die mal im Dezember 2018 auf Nonindex gesetzt (Meta-Tag) – war ein Fehler. Seitdem kommen viele nicht wieder in den Index.

    Google meldet in der Search Console folgendes:
    – Indexierung zulässig? Nein: „noindex“ wurde im HTTP-Header „X-Robots-Tag“ gefunden

    Wenn ich jetzt aber in Chrome den Header checke, dann zeigt der mir kein x-robots-tag mit Noindex an. Wenn ich in der Search Console die Url manuell auf „Indexierung beantragen“ setze, dann ist die kurze Zeit später im Index.

    Ein ähnliches Problem hatte im Forum auch er hier: https://de.wordpress.org/support/topic/wordpress-sagt-index-google-sagt-noindex/

    Ich habe mit dem Thread-Ersteller telefoniert. Bei ihm lag es an einer Servereinstellung. Es waren bei ihm alle Seiten betroffen. Bei mir nicht alle.

    Das Problem hatte ich im Google-Forum gepostet. Dort schrieb man, dass das Problem bei WordPress liegt. Jetzt seid ihr dran 🙂

    Wäre für jede Hilfe extrem dankbar, weil ich nicht weiter komme.

    • Dieses Thema wurde geändert vor 1 Jahr, 4 Monaten von konstantinm.

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 4 Antworten - 1 bis 4 (von insgesamt 4)
  • Ich hatte mal so etwas in der functions.php:

    <meta name="robots" content="noindex, follow" />

    und dann vergessen rauszunehmen, und mich gewundert, warum die Website nicht gelistet wurde. Vielleicht hast du auch so etwas getan?

    Bei mir ist im Quelltext keine Meta-Robots zu finden. Das ist ja das Problem. Die taucht weder im Quelltext auf, noch wird ein Noindex-HTTP-Header gesendet. Dennoch erkennt Google den seit Monaten

    Schon mal in der .htaccess nachgesehen?

    @bscu Bisher noch nicht. Da steht jede Menge drin.

    – WP Rocket
    – eigene 301-Redirects
    – WordPress-Teil

    Ich habe nichts in Verbindung mit x-robots gefunden.

    Müsste dann ja etwas in der Art mit >>>Header set X-Robots-Tag „noindex, nofollow“<<<< sein oder nicht?

    • Diese Antwort wurde geändert vor 1 Jahr, 4 Monaten von konstantinm.
Ansicht von 4 Antworten - 1 bis 4 (von insgesamt 4)
  • Das Thema „Google sagt noindex in HTTP-Header „X-Robots-Tag“ – ist aber nicht“ ist für neue Antworten geschlossen.