Support » Allgemeine Fragen » Gutenberg: „Aktualisieren gescheitert“ bei Seiten mit URLs

  • Gelöst jakobhd

    (@jakobhd)


    Liebes WordPress-Forum,

    ich bin dabei, meine erste WordPress-Seite einzurichten und eigentlich auch schon recht weit. Wenn ich mit Gutenberg eine Seite mit URLs anlegen möchte, wird mir allerdings ständig angezeigt „Aktualisieren gescheitert“. Anfangs wusste ich nicht, woran es liegt, es sind aber ziemlich sicher externe URLs aller Art, denn ohne diese kann ich die Seite speichern, mit ihnen nicht (auch dann, wenn die Seite nur einen Link enthält). Es kann auch nicht an einer speziellen URL liegen, ich habe verschiedene übliche getestet. Für jeden Hinweis bin ich dankbar.

    Viele Grüße,
    Jakob

Ansicht von 13 Antworten - 1 bis 13 (von insgesamt 13)
  • Kannst du deine Seite mal posten?

    Hast du es denn auch schon mit einem anderen Editor versucht? Es gibt beispielsweise noch Elementor, BeaverBuilder und weitere kostenlose Editoren, mit denen du deine Seite erstellen und gestalten kannst.

    Was heißt denn genau „eine Seite mir URLs“? Du hast also eine Seite erstellt und willst da verschiedene Links/URLs drauf setzen?

    Hallo jackomo89,

    vielen Dank für deine Antwort! Ich habe keine Ahnung woran es liegt, aber heute funktioniert wieder alles. Es war einfach so, dass, wenn ich mit Gutenberg eine neue Seite erstellen wollte, einen beliebigen Titel eingetragen habe und dann in den Text eine beliebige URL als Text eingetragen habe, ich die Seite nicht abspeichern konnte – bei normalem Text ohne URL war alles kein Problem. Jetzt funktioniert es eben wieder und ich kann den Fehler auch nicht mehr reproduzieren.

    Viele Grüße,
    Jakob

    Hallo zusammen,

    ich habe genau das gleiche Problem. Nach Update auf WordPress 5.0 können im Gutenberg Editor kein Posts oder Pages, welche Links im Text enthalten, gepeichert oder veröffentlicht werden. Fehlermedlung „Updating failed“

    Ich habe das Health Check& Troubleshooting Plugin laufen lassen, hier gab es keine Auffälligkeiten und auch mit allen deinstallierten Plugins besteht das Problem fort.

    Ich bin für jeden Hinweis zur Hilfe dankbar.

    Viele Grüße
    Simon

    Hallo Simon,

    das bin ich wohl nicht der Einzige. Leider kann ich mir auch nicht erklären, woran es liegt, dass es bei mir jetzt wieder funktioniert. Gestern ging es nicht und ich habe dann auch frustriert aufgehört. Als ich es heute Vormittag noch einmal probiert habe, ging es plötzlich. Mir ist nicht bewusst, dass ich in der Zwischenzeit irgendeine Einstellung verändert hätte. Ich wäre aber auch daran interessiert, ob jemand eine Idee hat – falls das wieder auftauchen sollte.

    Grüße,
    Jakob

    gleiches Problem hier. Ich dachte es läge erst an der Länge.

    Seite: ramily.de
    ich möchte hier: http://ramily.de/datenschutzerklaerung/
    diesen Text unterbringen: http://ramily.de/blogs/media/DSGVO.html

    weder über Einbetten, noch als HTML, noch als Text in Blöcken möglich abzuspeichern. Weder als Beitrag noch als Seite.

    Ebenfalls WP 5.0

    Hey Leute,

    ich hatte noch ein Problem, dass WP auch admin.php runter laden wollte, sobald ich speichern geklickt habe.

    Beides hing wohl damit zusammen, dass STRATO wo mein WordPress liegt den „ServerSide Security“ Filter aktiviert hatte. Ist so ein Antispam Algorithmus. Dadurch wurden wohl auch die externen Links gespeichert.

    Jetzt geht auch das abspeichern der Datenschutzerklärung 😀

    Interessant, ich bin auch bei Strato. Bei mir war es im übrigen auch der exakt gleiche Datenschutz-Text von https://datenschutz-generator.de/, der das Problem ausgelöst hat (auch wenn in Folge auch keine anderen URLs gespeichert werden konnten). Vielleicht kommen wir dem Problem hier näher.

    Der ServerSide Security Filter scheint mir jedenfalls nur mit eingehenden Nachrichten zu tun zu haben statt mit dem Inhalt von Webseiten. Jedenfalls geht es bei mir wieder, auch ohne dass ich den Filter deaktiviert hätte. Eine Frage an itsrunningback: Hast du in der Zwischenzeit WP 5.0.1 installiert? Wenn es ein bekannter Fehler war, könnte er in der aktuellen Version auch behoben worden sein (obwohl es bei mir auch schon mit 5.0.0 wieder ging).

    Grüße,
    Jakob

    @jakobhd

    Laut Strato lernt der Filter ja dazu. Vielleicht habe ich in zu kurzer Zeit zu viel an der Seite verändert und durch warten wäre dieses Problem ebenfalls irgendwann gelöst worden. Die Speicherung in WordPress scheint wohl Verwand mit dem Eingang zu sein, der durch das SSS gefiltert wird. Ansonsten wäre ja auch mein Abspeichern im Costumizer nicht regelmäßig blockiert worden. Hier gehen wohl zu viele Daten für den Filter hin und her durch Autosave etc.

    Update 5.0.1 ging heute Nacht drauf und auch hier kam der Fehler. Seit das Ding aus ist, habe ich keinerlei Probleme mehr mit WordPress.

    Da wordpress ja eigene Lösungen gegen Spam parat hat, bin ich auf den Filter so oder so nicht angewiesen.

    Grüßle
    David

    Ok, ich lasse den Filter mal an, aber wenn das Problem wiederkommt, weiß ich dann mit welchem Hebel ich es mal probieren kann.

    @sbisch: Hat sich das Problem bei dir geregelt? Wäre interessant zu wissen, ob du auch bei Strato bist.

    Grüße,
    Jakob

    Hallo Jakob, Hallo David,

    ja ich bin auch bei Strato gehostet. Update 5.0.1 ging heute Nacht drauf, danach hat sich erstmal nichts geändert. Nach abschalten des ServerSide Security Filter bei Strato funktioniert alles wieder. Interessanterweise trat das Problem bei mir auch auf als ich den Datenschutzgenerator Text updaten wollte.

    Ich hoffe der Tipp hilft auch noch anderen.

    Danke euch & Grüße
    Simon

    Alles klar, vielen Dank, dann markiere ich das Problem hiermit als gelöst.

    Ich kann auch nichts mehr speichern. (Beiträge oder Seiten) Egal ob mit oder ohne URLs. Code speichern (PHP und CSS in den Theme-Dateien) ist kein Problem.
    Ich hab die Seite mit Gutenberg geschrieben ich mag da jetzt nicht wieder alles rückbauen. Am Vormittag konnte ich problemlos speichern.

    Ich habe Permalinks zurückgesetzt, alle Plugins deaktiviert, Healt-Check ergebnislos durchgeführt, auf 5.0.1 geupdatet. Nichts ändert sich. Das Theme habe ich selbst gecodet, da steht nichts Besonderes drinnen.

    Ich hoste bei Domainfactory. Hat jemand ideen?
    Danke
    Raphael

    • Diese Antwort wurde geändert vor 8 Monate, 1 Woche von  rabox66.
    • Diese Antwort wurde geändert vor 8 Monate, 1 Woche von  rabox66.
    • Diese Antwort wurde geändert vor 8 Monate, 1 Woche von  rabox66.

    Hallo alle bei Strato,

    ja, das ist es. Bisher kannte ich es nur vom Bilderupload: „Upload failed“ ohne weiteren Kommentar. Oder beim Speichern: statt die Seite online zu Speichern versucht das System eine admin.php oder page.php auf die Festplatte zu speichern.

    Jetzt also auch Links, das Problem war mir neu und heute das erstmal aufgetreten. Diesen Eintrag gefunden, SSS bei Strato deaktiviert, Problem gelöst.

    Ich denke mittlerweile, SSS bei Strato deaktivieren sollte zu den Standardeinstellungen für WordPress-Seiten gehören.

    Rabox66: guck oder frage doch mal, ob es bei df etwas ähnliches gibt.

    Danke an alle,
    Daniel

Ansicht von 13 Antworten - 1 bis 13 (von insgesamt 13)
  • Das Thema „Gutenberg: „Aktualisieren gescheitert“ bei Seiten mit URLs“ ist für neue Antworten geschlossen.