Support » Installation » Gutenberg Editor erstellt keine neuen Beiträge hinter einem Reverse Proxy

  • Hallo,

    ich teste gerade mit einem selbstprogrammierten Reverse Proxy und einer aktuellen neue und leeren WordPress-Instanz.

    Das Problem: Neue Beiträge die man mit dem Gutenberg-Editor erstellt hat werden nicht richtig gespeichert.

    Alles Andere funktioniert.
    Ich kann Themes und Plugins installieren, deinstallieren, aktivieren und deaktvieiren, Dateien hochladen. Auch alles mit dem Classic-Editor funktioniert einwandfrei.

    Der Gutenberg-Editor selber scheint auch normal zu funktionieren.
    Aber sobald man etwas veröffentlich oder speichert bekommt man mit dieser URL einen 404. Auch in der Verwaltung der Beiträge tauchen sie nicht auf.

    Allerdings wird die interne URL hochgezählt. Also irgendwas funktioniert schon.

    Die Browserconsole zeigt keine Fehler.

    Hat Jemand einen Tipp für mich?

    Danke

    Stefan

    • Dieses Thema wurde geändert vor 1 Jahr, 2 Monaten von Stefan Kittel.
Ansicht von 10 Antworten - 1 bis 10 (von insgesamt 10)
  • Das scheint eher ein Problem der Serverkonfiguration zu sein.
    Wie sind die Permalinks gesetzt? Funktioniert die Veröffentlichung und Ansicht, wenn du sie auf die Standardeinstellung (/?p=42) setzt?

    Thread-Ersteller Stefan Kittel

    (@stefankittel2)

    Hallo Bego,

    danke für Deine Zeit.

    Permalinkst sind auf Standard.
    Die Ansicht mit /?p=10 funktioniert auch nicht und führt zu einem 404.
    Im Dashboard der Beiträge sind diese auch nicht aufgelistet.

    Wenn ich direkt auf das WordPress zugreife funktioniert es normal.
    Es ist also kein WordPress-Problem.

    Aber ich habe keine Idee wo man anfangen kann zu suchen.

    Stefan

    Wenn ich direkt auf das WordPress zugreife funktioniert es normal.
    Es ist also kein WordPress-Problem.

    Dann kann ich dir leider nicht weiterhelfen.

    … mit einem selbstprogrammierten Reverse Proxy …

    … bietet einfach viel zu viel Fehlermöglichkeiten, um da konkret etwas zu zu sagen.

    Pauschale Aussage (kurz hinter „Have You Tried Turning It Off And On Again?„): Error-Logs anschauen, Netzwerk-Tab und Konsole in den Entwickler-Tools des Browsers prüfen, in WordPress Debugging aktivieren.

    Thread-Ersteller Stefan Kittel

    (@stefankittel2)

    Hallo,

    hast Du eine Idee wie ich mit einem Entwickler des Gutenberg Editors in Verbindung treten kann?

    Ich würde sonst alle Aufrufe und Parameter vergleich was recht aufwendig ist.
    Irgendwo hat der Proxy einen Fehler, aber ich weiß nicht wo und komme dem nicht näher.

    Auf den Gutenberg Editor könnte ich verzichten, aber vermutlich tritt der Fehler auch woanders auf was ich nur noch nicht gesehen habe.

    Stefan

    Du könntest es mal über Slack versuchen: https://de.wordpress.org/slack/

    Hast du denn mal geschaut, ob die REST API funktioniert?
    Einfach an die URL /wp-json anhängen.

    Thread-Ersteller Stefan Kittel

    (@stefankittel2)

    Ich schreibe mal hier weiter.
    Vieleicht hat ja Jemand eine Idee…

    Wenn ich auf „speichern“ Tippe wird folgende URL am Server aufgerufen

    /wp-json/wp/v2/posts/25?_locale=user

    Aber der Aufruf enthält keine POST-Variablen. Es ist schlicht leer.

    _POST=Array
    (
    )

    Also erstellt der Gutenberg Editor eine falsche Anfrage aufgrund von Irgendwas was ihm am Server nicht gefällt…

    So sieht das bei mir in einer Testumgebung aus:

    Screenshot neue Seite veröffentlichen Block-Editor

    Thread-Ersteller Stefan Kittel

    (@stefankittel2)

    So, ich bin 3 Schritte weiter.
    Die Anfrage mit den Post-Inhalten selber kommt dort an.
    Aber sie wird mit einem 401 beantwortet.

    Gibt es ein Log wo Informationen darüber gespeichert werden?

    Error-Log des Webservers?

    Du kannst auch einen Error-Log in WordPress anlegen:

    // Enable WP_DEBUG mode
    define( 'WP_DEBUG', true );
    
    // Enable Debug logging to the /wp-content/debug.log file
    define( 'WP_DEBUG_LOG', true );
    
    // Disable display of errors and warnings
    define( 'WP_DEBUG_DISPLAY', false );
    @ini_set( 'display_errors', 0 );

    (Quelle: Debugging in WordPress)

    „401“ wäre ein Berechtigungsproblem.

    Thread-Ersteller Stefan Kittel

    (@stefankittel2)

    Hallo,

    kein Fehler irgendwo zu sehen.

    Was ich gefunden habe.

    Datei wp-includes/class-wp-user.php

    Die Zeile „$caps = map_meta_cap( $cap, $this->ID, …$args );“ macht aus
    cap=“manage_links“ (Parameter der Funktion) ein
    Array([0] => do_not_allow)
    Damit schägt die Funktion „current_user_can“ fehl und die ganze Funktion damit auch.

    Sehr strange

    Wie gesagt, sonst funktioniert ja alles.
    Ich wüsst also nicht was der Proxy an Parameter verwürfeln könnte das genau dies nicht funktioniert…

    • Diese Antwort wurde geändert vor 1 Jahr, 2 Monaten von Stefan Kittel.
Ansicht von 10 Antworten - 1 bis 10 (von insgesamt 10)
  • Das Thema „Gutenberg Editor erstellt keine neuen Beiträge hinter einem Reverse Proxy“ ist für neue Antworten geschlossen.