Support » Allgemeine Fragen » Gutenberg / FSE: Menü verschwindet auf Beitragsseite

  • Gelöst patbremen

    (@patbremen)


    Hallo alle beisammen!

    Ich nutze das Tove-Theme und habe mir eher versehentlich zwei Menüs erstellt, nennen wir sie Menu A und Menu B. Menu A war zuerst da, gefiel mir aber nicht und so ist Menu B entstanden. Menu A habe ich daraufhin gelöscht.

    Das ist auf allen statischen Seiten auch unproblematisch, überall wird Menu B angezeigt. Wenn ich aber auf die Beitragsseite gehe, erscheint statt des Menüs die Fehlermeldung „Das Template-Teil wurde gelöscht oder ist nicht verfügbar: menu-b“.

    Ich habe bereits alle installierten PlugIns deaktiviert und auch die Beitragsseite gelöscht und unter neuem Namen erneut erstellt. Auch hier das gleiche Problem.

    Ich finde weder in meinem Menü-Template noch auf der Seite, die ich als Beitragsseite nutze, eine Möglichkeit, das Menü individuell nur für diese Seite festzulegen. Ich kann mich auch nicht erinnern, dass ich für die Beitragsseite ein eigenes Menü definiert hätte.

    Nachdem ich nun zwei Abende gegoogelt und beim besten Willen nichts gefunden habe: hat von euch jemand eine Idee, was ich tun kann?

    • Dieses Thema wurde geändert vor 1 Woche, 6 Tage von patbremen.
    • Dieses Thema wurde geändert vor 1 Woche, 6 Tage von Hans-Gerd Gerhards.

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 3 Antworten - 1 bis 3 (von insgesamt 3)
  • Hallo,
    dein thread wurde leider von Akismet – warum auch immer – als Spam erkannt und daher musste ich den thread erst freischalten.

    Ich muss da etwas weiter ausholen und es kann natürlich sein, dass einige Dinge, die ich hier anspreche, für dich klar und möglicherweise überflüssig sind:
    Über Design > Editor (Beta) siehst du die folgenden Menüpunkte, wenn du auf das „W“ oben links klickst:

    • Website
    • Templates
    • Template-Teile

    Wenn du auf „Templates“ klickst, siehst du alle Templates. Das Template „Einzelbeitrag“ ist das Template, das standardmäßig bei einem Beitrag verwendet wird.

    Hier ein kurzes Video dazu (bei Klick auf das Bild, wird das vergrößert dargestellt):
    Screenshot Einstellungen

    Ich finde weder in meinem Menü-Template noch auf der Seite, die ich als Beitragsseite nutze,

    Ich gehe davon aus, dass das Problem mit dem Template „Einzelbeitrag“ zusammenhängt
    Hier solltest du mal schauen, was in der Listenansicht (das sind die drei versetzten Striche oben) gezeigt wird.

    Hier ein Screenshot dazu (bei Klick auf das Bild, wird das Bild vergrößert):
    Screenshot Einstellungen

    Da das „kaputte“ Menü nicht bei allen Seiten gezeigt wird, kann ich mir nicht vorstellen, dass das Problem mit „Header“ unter Template-Teile zusammenhängt. Trotzdem solltest du das auch mal sicherheitshalber prüfen.

    Viele Grüße
    Hans-Gerd

    • Diese Antwort wurde geändert vor 1 Woche, 6 Tage von Hans-Gerd Gerhards. Grund: Ergänzung
    Thread-Ersteller patbremen

    (@patbremen)

    Vielen Dank für deine schnelle Antwort!

    Bitte entschuldige die späte Rückmeldung meinerseits, ich musste gestern Abend und heute den Werder-Aufstieg feiern :D.

    Zunächst: Mein Beitrag wurde als Spam markiert, nachdem ich ihn geschrieben und direkt nach dem Senden noch einmal editiert habe (beim Link zur Webseite hatte ich zunächst nur die Domain angegeben, dann aber um die Unterseite ergänzt, möglicherweise habe ich in zu kurzer Zeit -scheinbar- zu viele Links eingefügt).

    Und dann: DANKE! Dein Hinweis auf die Templates war superhilfreich und hat das Problem gelöst! Offenbar war der gelöschte Header noch auf der Index- und der 404-Seite gespeichert, für alle anderen Seiten passte es.

    Viele Grüße,

    Patrick

    Hallo,
    super – freut mich. Danke für die Rückmeldung.

    Denkst du bitte beim nächsten Mal daran, das Thema dann auch als gelöst zu markieren, wenn das Thema für dich erledigt ist. Danke.
    Gelöst
    Die Option findest du rechts in der Sidebar. Das habe ich jetzt schon gemacht.

    Viele Grüße
    Hans-Gerd

Ansicht von 3 Antworten - 1 bis 3 (von insgesamt 3)