Support » Installation » Habe HP auf MAMP lokal erstellt – sie lässt sich nicht zur Domain „überspielen“

  • Stefan

    (@brbstefan123)


    Hallo zusammen, ich hoffe, ich bin in der „Installation“ mit meiner Frage richtig …
    Ich bin Stefan und schiebe die Umstellung meiner HP wiese-mobil.de (mit Frontpage erstellt) auf WordPress schon lange vor mir her …

    Jetzt habe ich endlich auf einem iMac MAMP installiert und es ist mir gelungen eine ganz nette Form zu finden. Nun habe ich einige Seiten erstellt und lokal gespeichert.

    Mit Hilfe dieser Seite:
    https://www.elmastudio.de/wordpress-vom-lokalen-server-auf-eine-domain-uebertragen/
    habe ich nun diesen Schritt vornehmen wollen.
    Im Grunde hat bis einschl. Punkt 3 alles geklappt.
    Dann die Datenbank-Datei. Hier habe ich mit „Sublime Text“ die nötigen Veränderungen durchgeführt und gespeichert. Ich bekomme beim Importieren dieser Datenbank zu IONOS (1&1) immer diese Fehlermeldung.

    SQL-Befehl:

    FEHLER
    – – – – – – –
    CREATE TABLE wp_commentmeta (
    meta_id bigint(20) UNSIGNED NOT NULL,
    comment_id bigint(20) UNSIGNED NOT NULL DEFAULT ‚0‘,
    meta_key varchar(255) COLLATE utf8mb4_unicode_520_ci DEFAULT NULL,
    meta_value longtext COLLATE utf8mb4_unicode_520_ci
    ) ENGINE=InnoDB DEFAULT CHARSET=utf8mb4 COLLATE=utf8mb4_unicode_520_ci
    MySQL meldet: Dokumentation
    – – – – – – –
    #1046 – Keine Datenbank ausgewählt

    … was habe ich falsch gemacht?

    Ich würde mich so sehr freuen, wenn mir jemand helfen könnte und bedanke mich schon jetzt für euer Verständnis.

    Liebe Grüße,
    Stefan

    – Themes: Twenty Seventeen (extra ganz normal)
    – Plugins auf lokaler Seite (bei MAMP):
    – Duplicator,
    – Easy FancyBox,
    – Elementor und
    – Photonic Gallery & Lightbox for Flickr, SmugMug, Google Photos, Zenfolio and Instagram

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 9 Antworten - 1 bis 9 (von insgesamt 9)
  • Moderator Bego Mario Garde

    (@pixolin)

    … #1046 – Keine Datenbank ausgewählt …

    Hast du beim Import in phpMyAdmin vorher eine neue Datenbank angelegt und diese ausgewählt?

    Hier habe ich mit „Sublime Text“ die nötigen Veränderungen durchgeführt

    Was sind „die nötigen Veränderungen“?
    Hintergrund meiner Frage: WordPress speichert bestimmte Daten serialisiert, d.h. mehrere Informationen landen in einem Datenfeld und werden mit einem Zähler voneinander abgegrenzt. Änderst du den Inhalt, ohne den Zähler anzupassen, kommt die Datenbank durcheinander.
    Ich importiere die Datenbank immer so, wie sie ist und ändere anschließend nur die Felder siteurl und home in der Tabelle wp_options. Dann melde ich mich in der WordPress-Installation an, installiere Better Search Replace und ersetze damit die alte URL durch die neue. Das Plugin berücksichtigt dabei serialisierte Daten und es kommt nicht zum Durcheinander.

    Deine Vorgehensweise ist nicht unbedingt falsch, ich wollte dir nur einen anderen Weg aufzeigen.

    Stefan

    (@brbstefan123)

    Guten Morgen Bego Mario,
    vielen Dank für deine schnelle Reaktion.

    Ja, ich habe eine Kopie der Datenbank angelegt (Datenbank.sql benannt) und diese wie folgt verändert:
    1. den (selbst in MAMP) vergebenen Arbeitsnamen … der stand in Zeile 14 Datenbank: `meinName´in den Datenbanknamen von IONOS (eine Nummer) geändert und
    2. alle „alten“ Links „http://localhost:8888/meinName habe ich in die neue Serveradresse geändert. http://www.wiese-mobil1.de

    Dann hochgeladen und den Fehler bekommen.

    Dein Weg hört sich auch gut an, ich bin nur nicht sicher, ob ich das kann.
    Aber ein Versuch ist es wert und ich teste es.
    … sicher melde ich mich dann wieder ;o)

    Vielen Dank,
    Stefan

    Moderator Bego Mario Garde

    (@pixolin)

    … ich habe eine Kopie der Datenbank angelegt …

    Hm, reden wir gerade ein wenig aneinander vorbei? 😀

    In meinen Kursen vergleiche ich die Datenbank gerne mit der Tabellen-Kalkulation Excel, die TeilnehmerInnen häufig besser bekannt sind:

    • Excel und MySQL sind zwei verschiedene Programme.
    • In Excel kannst du Dateien anlegen, in MySQL sind das Datenbanken.
    • Excel-Dateien und Datenbanken enthalten Tabellen.
    • In den Tabellen gibt es Felder.

    Wenn du eine Datenbank-Auszug exportierst, sind das die Tabellen mit ihren Feldern. Um sie zu importieren, muss eine neue Datenbank angelegt werden. „Sagst“ du phpMyAdmin „So, hier kommt ein Schwung Tabellen mit Feldern.“, möchte phpMyAdmin im Gegenzug wissen, in welcher Datenbank es die Informationen ablegen soll. Deshalb die Meldung „#1046 – Keine Datenbank ausgewählt“.

    (Danke, aber ein Vorname – Bego – reicht.) 🙂

    Stefan

    (@brbstefan123)

    Ok, Bego, danke!

    Wir müssen unbedingt versuchen vom Gleichen zu reden :-),
    deshalb werde es dir so genau wie möglich beschreiben was ich gemacht habe:

    In phpMyAdmin (lokal, MAMP) habe ich auf der linken Seite meine Datenbank angeklickt. Auf der rechten Bildseite habe ich dann die aufgelisteten Tabellen gesehen und habe jetzt oben auf Exportieren geklickt.

    Dann öffnete sich ein Textfeld auf der rechten Bildseite. Diesen Text habe ich komplett markiert (STRG+A) und in „Sublime Text“, einem Editor-Programm, eingefügt und als „Datenbank.sql“ auf dem Desktop/Schreibtisch gespeichert.
    … dann die oben erwähnten Änderungen vorgenommen.

    Diese Datei habe ich von phpMyAdmin (online,IONOS) Importieren lassen.
    Dieser Import wurde von der Fehlermeldung unterbrochen.

    Stefan

    Moderator Bego Mario Garde

    (@pixolin)

    Dann öffnete sich ein Textfeld auf der rechten Bildseite. Diesen Text habe ich komplett markiert (STRG+A) und in „Sublime Text“, einem Editor-Programm, eingefügt und als „Datenbank.sql“ auf dem Desktop/Schreibtisch gespeichert.

    Ohhhh…kay. 😀

    Mach doch mal folgendes:

    1. in phpMyAdmin (MAMP) anmelden
    2. Datenbank der WordPress-Installation in der linken Spalte auswählen
    3. Rechte Spalte auf Tab Export gehen
    4. Option „quick“ wählen und SQL-Datei herunterladen – da brauchst du nichts kopieren, in einen Editor einfügen, usw. Schau dir vielleicht auch mal dieses Video an: https://youtu.be/ffmCGVse8yg
    5. in phpMyAdmin des Zielservers anmelden
    6. prüfen, ob eine Datenbank vorhanden ist (linke Spalte), auswählen. Ist keine Datenbank vorhanden, musst du sie erst anlegen. Eine Anleitung findest du hier. (Nochmal zur Erinnerung: Die Datenbank ist wie eine Datei, in welche die Daten geschrieben werden sollen. Gibt es keine Datenbank, weiß phpMyAdmin nicht, wo es die Daten hinpacken soll.)
    7. Nachdem du die Datenbank ausgewählt hast (!) auf Tab Importieren und die heruntergeladene SQL-Datei hochladen.
    8. Prüfen, ob die WordPress-Tabellen importiert wurden und in Tabelle .._options die Felder siteurl und home korrigieren.
    Stefan

    (@brbstefan123)

    Danke Bego,
    das werde ich versuchen und bin schon gespannt!
    Klappt aber erst heute Abend …

    Ich melde mich auf jeden Fall wieder!
    Vielen Dank,
    Stefan

    Stefan

    (@brbstefan123)

    Guten Morgen Bego, guten Morgen zusammen!

    Ich habe es gestern probiert – leider nur probiert …
    Immerhin weiß ich jetzt, Bego, das ich bei IONOS definitiv eine Datenbank erstellt habe.
    (ich habe jetzt sogar schon 3 ;o)
    Nach Beendigung der von dir beschriebenen Vorgehensweise bekam ich wieder den gleichen Fehler.

    Im Moment bin ich damit einfach überfordert, ich habe noch so viele andere Dinge im Kopf.
    Am WE fahren wir weg, ich würde mich gern am Mittwoch wieder hier melden. Ich würde dir gern mit Bildschirmabgriffen zeigen, wie ich vorgehe.
    Das würde mir helfen … wenn das für dich ok ist?

    Dankeschön und bis dahin,
    Stefan

    Moderator Bego Mario Garde

    (@pixolin)

    Du kannst Screenshots bei einem Bilderdienst wie imgur.com hochladen und dann hier mit einem <img>-Tag einbinden (<img src="https://imgur.com/bildname.png" alt="Um was es geht">).

    bscu

    (@bscu)

    Ich kann für solche Fälle das Plugin „WP Migrate DB“ empfehlen, damit habe ich schon mehrere Umzüge erfolgreich durchgeführt.

Ansicht von 9 Antworten - 1 bis 9 (von insgesamt 9)
  • Das Thema „Habe HP auf MAMP lokal erstellt – sie lässt sich nicht zur Domain „überspielen““ ist für neue Antworten geschlossen.