Support » Allgemeine Fragen » Hack durch Themegrill. Dashboard nicht mehr erreichbar.

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 15)
  • Cache geleert?

    Hilfreich wäre ein Error-Log, den du durch einen Eintrag in der wp-config.php erhältst:

    // Enable WP_DEBUG mode
    define( 'WP_DEBUG', true );
    
    // Enable Debug logging to the /wp-content/debug.log file
    define( 'WP_DEBUG_LOG', true );
    
    // Disable display of errors and warnings
    define( 'WP_DEBUG_DISPLAY', false );
    @ini_set( 'display_errors', 0 );
    
    // Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
    define( 'SCRIPT_DEBUG', true );

    (Quelle: Debugging in WordPress)

    Thread-Ersteller machden

    (@machden)

    Hallo Bego,

    Danke für die schnelle Antwort. Ich bin allerdings ein Laie, was solche Themen angeht. Muss ich den Text aus dem Kasten irgendwo eingeben? Oder muss ich die Datei wp-config.php irgendwie auslesen?
    Normalerweise spiele ich nicht in die einzeln Dateien rum. Ich bin Anwender und benutze das Programm so wie es ist…

    Den Code solltest du in der wp-config.php einfügen:
    Datei per FTP herunterladen, mit einem geeigneten Programmiereditor (z.B. Atom Editor, Visual Studio Code oder Notepad++, alle kostenlos erhältlich) öffnen, Code oberhalb der Zeile /* That's all, stop editing! Happy blogging. */ einfügen, speichern, Datei wieder auf den Webserver übertragen.

    Wenn dir das alles „zu technisch“ ist, solltest du einen Dienstleister beauftragen.

    Thread-Ersteller machden

    (@machden)

    Das habe ich jetzt gemacht wie du beschrieben hast.
    Wenn ich es richtig verstehe, soll eine Datei namens debug.log entstehen, die alle Errors listet.
    Ich habe mich nochmals bei WordPress angemeldet. Die Seite sieht aus wie oben beschrieben, kein Dashboard also.
    Nun logge ich mich wieder aus und suche auf dem FTP-Server nach einer Datei debug.log. Diese gibt es aber nicht.
    Entweder habe ich was falsch gemacht, oder es gab keine Errors??

    Wenn ich mich bei WordPress anmelde stand vorher in der Adressleiste immer http://www.nevlac.org/wp-admin…etc. Jetzt ist nur nevlac.org zu sehen. Gibt es da vielleicht einen Lösungsansatz?

    Hallo,
    die Datei findest du im Verzeichnis wp-content unter dem Namen debug.log.
    Versuche mal die Anmeldung über http://example.com/wp-login.php
    example.com musst du natürlich durch deine Seite ersetzen.
    Viele Grüße
    Hans-Gerd

    Thread-Ersteller machden

    (@machden)

    Hallo Hans-Gerd,

    also, bei mir wird keine Datei debug.log im wp-content Ordner angezeigt.
    Heisst das, dass keine Debugs entstehen? Oder habe ich doch was flasch gemacht?
    Das Ende meiner wp-config Datei sieht so aus:

    /**
     * WordPress Sprachdatei
     *
     * Hier kannst du einstellen, welche Sprachdatei benutzt werden soll. Die entsprechende
     * Sprachdatei muss im Ordner wp-content/languages vorhanden sein, beispielsweise de_DE.mo
     * Wenn du nichts eintr�gst, wird Englisch genommen.
     */
    define('WPLANG', 'de_DE');
    
    /**
     * For developers: WordPress debugging mode.
     *
     * Change this to true to enable the display of notices during development.
     * It is strongly recommended that plugin and theme developers use WP_DEBUG
     * in their development environments.
     */
    
    // Enable Debug logging to the /wp-content/debug.log file
    define( 'WP_DEBUG_LOG', true );
    
    // Disable display of errors and warnings
    define( 'WP_DEBUG_DISPLAY', false );
    @ini_set( 'display_errors', 0 );
    
    // Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
    define( 'SCRIPT_DEBUG', true );
    
    /* That's all, stop editing! Happy blogging. */
    
    /** Absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
      define('ABSPATH', dirname(__FILE__) . '/');
    
    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');

    Gruß,
    Maarten

    Moderatorenhinweis: Bitte Quellcode als ‘Code’ auszeichnen (siehe Icon oben hier im Editor).

    Hallo,

    // Enable WP_DEBUG mode
    define( 'WP_DEBUG', true );

    das fehlt in der wp-config.php, siehe auch den Hinweis von @pixolin
    Viele Grüße
    Hans-Gerd

    Thread-Ersteller machden

    (@machden)

    O ja, danke.
    Hab’s hinzugefügt. Bringt aber nichts. Keine Datei debug.log zu sehen.

    Leg doch mal per FTP im Verzeichnis /wp-content eine leere Datei debug.log an und gib ihr Zugriffsrechte 644 (rw-r–r–). Wenn du dann das Backend aufrufst und wieder eine (fast leere) Seite kommt, sollte eine Fehlermeldung in diese Datei geschrieben werden.

    Nochmal die Frage: Bei Aufruf des Backend hast du mal den Cache deines Browsers geleert?

    Thread-Ersteller machden

    (@machden)

    Ja, cache hatte ich geleert.

    Ich habe mit dem Editor eine leere Datei angelegt. Die versuche ich von meinem Rechner hochzuladen in den Ordner /wp-content. Dabei gibt das das FTP Programm eine Fehlermeldung und sagt: „Es können nur Dateien, keine Verzeichnisse abgelegt werden.“
    Auch das Anlegen einer neuen Datei direkt im FTP Ordner scheint nicht zu funktionieren. Im Menü „Neue Datei erstellen“ geb ich debug.log ein. Es sagt dann: Die Datei wurde erstellt in /www/htdocs/wp-content. Es erschient aber keine debug Datei, auch nicht nach aktualisieren.

    Im Browser erscheint die Datei auch nicht, du solltest sie aber im FTP-programm im Verzeichnis wp-content sehen.

    Wenn das alles nicht klappt, ändere den Eintrag in der wp-config.php auf

    
    …
    define('WPLANG', 'de_DE');
    
    define( 'WP_DEBUG', true );
    define( 'WP_DEBUG_DISPLAY', true );
    
    /* That's all, stop editing! Happy blogging. */
    
    /** Absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
      define('ABSPATH', dirname(__FILE__) . '/');
    
    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');
    

    (Das Auslassungszeichen soll nur andeuten, dass da drüber noch mehr Code steht. Das sollst du natürlich nicht mit einfügen.)

    Thread-Ersteller machden

    (@machden)

    Ich habe jetzt einfach eine readme.txt Datei von einem anderen Ordner in den /wp-content Ordner kopiert und diese komplett geleert und in debug.log umbenannt.
    So weit so gut.
    Nun habe ich mich wieder angemeldet bei WordPress und wieder abgemeldet.
    Die Datei debug.log ist genau so leer wie vorher….

    Thread-Ersteller machden

    (@machden)

    Plugins ausschalten habe ich auch schon versucht. Funktioniert auch nicht.
    Die Webseite läuft mit PHP Version 5.3. Könnte es vielleicht was bringen wenn ich PHP 7.2 aktiviere?

    Die Webseite läuft mit PHP Version 5.3.

    Das ist uralt.

    Könnte es vielleicht was bringen wenn ich PHP 7.2 aktiviere?

    Auf jeden Fall.

    Ok, sieht wirklich gut aus. Ich hatte ein bischen Angst die Datenbank endgültig freizuräumen, danke für den Anreiz. Das Backup hat tatsächlich die Datenbank und die Inhalte wiederhergestellt. Nur die Multisite ist irgendwie noch nicht ganz wieder da. Das schaffe ich aber auch noch.

    Vielen Dank.

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 15)
  • Das Thema „Hack durch Themegrill. Dashboard nicht mehr erreichbar.“ ist für neue Antworten geschlossen.