Support » Allgemeine Fragen » hauptseite lädt gut, weitere Seiten laden nicht oder extrem langsam

  • Gelöst rhythmika

    (@rhythmika)


    Hallo liebes Forum,
    ich suche nun schon einige Zeit Antworten auf meine Fragen, finde diese aber nicht, daher konkret: meine Homepage funktioniert (Theme education basic pro) gut, aber manche Seiten lassen sich plötzlich nicht mehr öffnen oder brauchen ewig.
    Ich bin keine Expertin (learnig by doing) und finde den Fehler nicht.
    Wer kann mir da helfen?
    ZB die Seite https://www.rhythmikstudio.at/kurse/2-bis-6-jahre/
    Auch kann ich im Bearbeitungsmodus die Seite zwar bearbeiten, aber bei „Seite ansehen“ kommt sie schon nicht mehr – auch bei mehrmaligem Aktualisieren.
    Wer kennt das, wer kann mir da bitte helfen?
    DANKE!!

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 10 Antworten - 1 bis 10 (von insgesamt 10)
  • Moderator Bego Mario Garde

    (@pixolin)

    Auf der genannten Seite ist ein recht großes Header-Bild (900 kb), was die Webseite etwas verlangsamt.

    Bei Fragen zu gekauften Themes (hier: Education Base Pro) können wir dir darüber hinaus nicht weiterhelfen, weil sie uns für einen kostenlosen Support nicht kostenlos zur Verfügung stehen.

    Bitte wende dich bei Fragen zu diesem Theme an die Entwickler.

    Thread-Ersteller rhythmika

    (@rhythmika)

    Danke für die rasche Nachricht!
    im Moment schaut es so aus, dass ALLE Seiten auf dem Handy aufgerufen werden können, aber am PC oder Laptop nicht!
    zum Tipp mit dem Support bei den Entwicklern:
    Es ist mir nicht möglich, mich bei ACME für Education basic pro anzumelden, jedesmal werde ich rausgehauen…
    bin schon echt mit den Nerven am ENde!

    Moderator Bego Mario Garde

    (@pixolin)

    m Moment schaut es so aus, dass ALLE Seiten auf dem Handy aufgerufen werden können, aber am PC oder Laptop nicht!

    Das kann ich nicht bestätigen. Mir werden die Seiten nach einer längeren Ladezeit (Seite Galerie nach 12 Sekunden) angezeigt. Das ist zwar für eine funktionierende Webseite zu langsam, aber die Seite läd dann irgendwann doch.

    Hast du mal überlegt ein Cache-Plugin einzusetzen? Gerade bei älteren Multi-Purpose-Themes müssen bei jedem Aufruf einer Webseite diverse Einstellungen erst einmal aus der MySQL-Datenbank abgerufen und aufbereitet werden – das dauert eben. Abhilfe schafft, die Seiten in einem Zwischenspeicher abzulegen und Webseitenbesuchern gleich die fertige Seite aus dem Zwischenspeicher zu liefern – genau das macht ein Cache-Plugin. Probier doch mal Comet Cache aus. Das lässt sich recht einfach einstellen und hat eine gute Performance.

    Das ändert aber alles nichts daran, dass du auf der Seite „Galerie“ satte 47 Megabyte an Daten überträgst. Als Faustformel galt mal, dass Webseiten nicht mehr als 1 MB Datenvolumen haben sollten, aber selbst wenn das heute mit schnelleren Internetzugängen selbst für Mobilfunk nicht mehr so eng gesehen wird, sind die 47MB etwas zuviel des Guten. Ich würde die Bilder entweder mit einem Dienst wie https://tinyjpg.com optimieren oder eines der Optimierungs-Plugins wie EWWW Image Optimizer verwenden.

    Zu deinem Schwierigkeiten, den Support deines Theme-Entwicklers anzusprechen, können wir hier nichts sagen. Eigentlich schließen wir Fragen zu gekauften Themes und Plugins direkt – so steht es auch in den Forenregeln. Ich hab hier eine Ausnahme gemacht, weil ganz allgemein zur Performance etwas gesagt werden kann (siehe oben).

    pezi

    (@pezi)

    Als Faustformel galt mal, dass Webseiten nicht mehr als 1 MB Datenvolumen haben sollten

    Hehe, das waren noch Zeiten, als eine ganze Website auf eine Diskette passte!
    Danke für die Zeitreise zu einer meiner ersten Websites – die eben exakt 1 MB hatte (Diskette kugelt noch herum, nur wo soll ich die hinstecken ;-)).

    Aber: Ich kenne SEO Profis, welche an jedem Bit herummeckern, die Einsparung 0,5 Byte als Religion verkaufen. Aber auf ihren eigenen Startsites plärrt ein 50 MB Video los …

    @rhythmika
    Die einzelnen Galeriebilder selbst sind gar nicht so groß. Evt. würde ein aufteilen der Galerie auf mehrere Seiten, Rubriken die Ladezeit verkürzen.

    Die Site selbst geht bei mir am PC ganz gut.
    Dennoch sind die Tipps zu Cache und Bildoptimierung gute Ratschläge, welche den Ärger mit dem Hersteller evt. obsolet machen. Einfach mal testen, nur keine Nerven wegschmeissen, gell!

    Moderator Bego Mario Garde

    (@pixolin)

    … das waren noch Zeiten, als eine ganze Website auf eine Diskette passte!

    Naja, ich meinte schon einzelne Webseiten. 😀

    Die einzelnen Galeriebilder selbst sind gar nicht so groß.

    Wie meinst du das? 😉

    Screenshot Einstellungen
    (zum Vergrößern anklicken)

    Dazu sind auch noch die Antwortzeiten des Webservers … 🐢 🐢 🐢

    pezi

    (@pezi)

    Dachte ich mir, aber ich meinte echt eine komplette Website.

    Ups.
    Ich hab ein paar nur Stichprobenartig angesehen, waren zw. 100 und 300 kb.
    Das sind entschieden zu gewichtige dabei und die alle in auf einer Seite …

    Ok, 3 Schildis …
    PS: Warum habe ich keine Schildkröten im FF?

    • Diese Antwort wurde geändert vor 1 Monat von pezi.
    Moderator Bego Mario Garde

    (@pixolin)

    Die Schildkröten sind nicht als Auszeichnung gedacht, sondern weisen auf lange Antwortzeiten hin:

    Screenshot Einstellungen
    (zum Vergrößern anklicken)

    pezi

    (@pezi)

    Das ist klar. Nur wo kommen die Viecherl her?

    Thread-Ersteller rhythmika

    (@rhythmika)

    DANKE für Eure Tipps – bin dran, bisher hat sich das Problem noch nicht gelöst.
    Seltsam, dass die Galerie bisher keine Probleme gemacht hat, erst jetzt seit ca 3 Tagen…
    Liebe Grüße aus Wien

    Moderator Bego Mario Garde

    (@pixolin)

    Das Problem wird sich auch nicht von selbst lösen. 🙂

    Ein Multipurpose-Theme mit vielen Einstellungsmöglichkeiten hat den Nachteil, dass alle Einstellungen bei jedem Aufruf einer Webseite aus der Datenbank abgerufen und aufbereitet werden müssen. Deshalb hatte ich ein Cache-Plugin empfohlen. Hast du dich da schon drum gekümmert?

    (Moderne Multipurpose-Themes wie z.B. WP Astra und GeneratePress haben trotzdem eine erstaunlich gute Performance, weil hier viele Optimierungen vorgenommen wurden. Ob bei deinem gekauften Theme „Education Base Pro“ Optimierungen vorgenommen wurden, kann ich nicht beurteilen; das Theme steht mir für kostenlosen Support nicht zur Verfügung.)

    Für deine Webseite kurse/2-bis-6-jahre/ wird bei GTMetrix eine „Time to First Byte“ von 1,1 Sekunden angegeben. Der Wert sieht auch für die Startseite ähnlich aus. Deine Aussage „Hauptseite lädt gut, weitere Seiten laden nicht oder extrem langsam“ kann ich so gesehen nicht bestätigen. Die Startseite bekommt von GTMetrix sogar nur eine „Schulnote: F“ – „Ungenügend“ würden wir hier sagen.

    Time to First Byte (abgekürzt TTFB) ist die Zeit die nach Absenden der Anfrage vergeht, bis mein Browser das erste Byte geliefert bekommt. Der Wert von 1,1 Sekunden ist recht hoch. Mögliche Gründe sind, dass dein Webserver überlastet ist, weil zu viele Anwender oder eine stark frequentierte Website in einem Shared Hosting die Ressource teilen müssen oder dass die Aufbereitung zahlreicher Einstellungen einfach sehr lange dauert. Du kannst das testen, in dem du kurzfristig ein Standard-Theme („Twenty …“) aktivierst und schaust, wie schnell die Website dann läd. Hast du dann immer noch einen TTFB-Wert von über einer Sekunde, solltest du den Webhoster wechseln oder ein anderes, leistungsfähigeres Hosting-Paket buchen.

    Dass die Galerie lange lädt, weil einfach eine Menge Daten mitgeschickt werden, haben wir ausführlich behandelt. Auch die Dateigröße der Bilder ändert sich nicht von selbst.

    Aus meiner Sicht haben wir damit deine Frage ausreichend beantwortet und ich ändere deshalb den Status des Threads auf „gelöst“. Wenn du aber noch Fragen zu diesem Thema hast, kannst du sie gerne hier stellen – der Thread ist ja weiterhin geöffnet. Für neue Fragen zu anderen Themen starte bitte einen neuen Thread.

Ansicht von 10 Antworten - 1 bis 10 (von insgesamt 10)