Support » Allgemeine Fragen » WordPress kaputt konfiguriert?

  • Hallo liebe WordPress-Gemeinde,

    meine Geschichte begann vor einigen Monaten, als ich die Permalink-Struktur auf meinem privaten und selbstgehosteten WordPress-Blog https://www.allesroger.net änderte und dazu auch ein neues SEO-Plugin ausprobierte. Seitdem gehen einige Dinge schief. So spuckte die Google Search Console tausende Fehler aus, crawlte die Seite nicht mehr korrekt und verliert seitdem immer mehr indexierte Seiten, statt die neuen zu finden. Seit einigen Tagen ist meine Seite laut Search Console aus mir unerfindlichen Gründen nicht mal mehr im Google Index.

    Natürlich habe ich eine Menge gelesen und versucht, gegenzusteuern indem ich diverse Optimierungen auf meiner Seite (in den Einstellungen und mit dem SEO Plugin) ausprobiert habe und natürlich auch in der Search Console selbst versucht, die Fehlermeldungen zu verstehen und entsprechende Anpassungen zu machen.

    Gefühlt stimmt derzeit so einiges nicht mehr in meiner WordPress-Installation. Selbst das 2024-Theme funktioniert nicht. Und ich bin langsam rat- bzw. hilflos mit meinem Halbwissen.

    Eine Vermutung, die ich recherchieren konnte, war, dass meine Konfiguration zur WordPress-Adresse und Website-Adresse nicht korrekt sei. Deshalb änderte ich diese unter „Allgemein“ von der Angabe ohne www zu der Angabe mit www . Danach konnte ich mich nicht mehr einloggen. Das ging erst wieder, nachdem ich die Definition in die wp-config.php eingetragen habe. Dort kann ich sie auch nicht mehr entfernen, sonst geht der Login nicht mehr. Die Einstellung im Backend unter „Allgemein“ ist jetzt natürlich ausgegraut. Dafür hat jetzt wohl eine REST-API Probleme.

    Insgesamt sehe ich bei mir völliges Chaos mit http und https sowie www oder kein www, Weiterleitungen, 301 und 404 Fehler usw.

    Ich würde mich sehr freuen, wenn ich hier ein paar wirkliche Tipps bekommen könnte, wie ich wieder Ordnung in meine Installation bekomme. Und gerne auch, was ich tun und lassen sollte. Ich betreibe das Dinge seit 2005 und fühle mich dennoch wieder wie ein Anfänger.

    Anbei der Bericht:

    `
    ### wp-core ###
    
    version: 6.4.1
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Berlin
    permalink: /%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: open
    environment_type: production
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /www/htdocs/w00ac39f
    wordpress_size: loading...
    uploads_path: /www/htdocs/w00ac39f/wp-content/uploads
    uploads_size: loading...
    themes_path: /www/htdocs/w00ac39f/wp-content/themes
    themes_size: loading...
    plugins_path: /www/htdocs/w00ac39f/wp-content/plugins
    plugins_size: loading...
    database_size: loading...
    total_size: loading...
    
    ### wp-dropins (1) ###
    
    advanced-cache.php: true
    
    ### wp-active-theme ###
    
    name: Zuki (zuki)
    version: 1.1.3
    author: Elmastudio
    author_website: http://www.elmastudio.de/
    parent_theme: none
    theme_features: core-block-patterns, wp-block-styles, editor-font-sizes, disable-custom-font-sizes, editor-style, automatic-feed-links, title-tag, menus, custom-background, featured-content, post-thumbnails, infinite-scroll, custom-header, widgets
    theme_path: /www/htdocs/w00ac39f/wp-content/themes/zuki
    auto_update: Deaktiviert
    
    ### wp-themes-inactive (1) ###
    
    Twenty Twenty-Four: version: 1.0, author: Das WordPress-Team, Automatische Aktualisierungen deaktiviert
    
    ### wp-mu-plugins (1) ###
    
    Health Check Troubleshooting Mode: author: (undefined), version: 1.8.1
    
    ### wp-plugins-active (14) ###
    
    Antispam Bee: version: 2.11.5, author: pluginkollektiv, Automatische Aktualisierungen aktiviert
    Autoptimize: version: 3.1.10, author: Frank Goossens (futtta), Automatische Aktualisierungen aktiviert
    Complianz | GDPR/CCPA Cookie Consent: version: 6.5.5, author: Really Simple Plugins, Automatische Aktualisierungen aktiviert
    Contact Form 7: version: 5.8.3, author: Takayuki Miyoshi, Automatische Aktualisierungen aktiviert
    Database Backup for WordPress: version: 2.5.2, author: Delicious Brains, Automatische Aktualisierungen aktiviert
    Gutenberg: version: 17.0.2, author: Gutenberg Team, Automatische Aktualisierungen aktiviert
    Health Check & Troubleshooting: version: 1.7.0, author: The WordPress.org community, Automatische Aktualisierungen aktiviert
    Independent Analytics: version: 2.0.0, author: Independent Analytics, Automatische Aktualisierungen aktiviert
    Simple Yearly Archive: version: 2.2.2, author: Oliver Schlöbe, Automatische Aktualisierungen aktiviert
    Social Icons Widget & Block by WPZOOM: version: 4.2.14, author: WPZOOM, Automatische Aktualisierungen aktiviert
    Super Page Cache for Cloudflare: version: 4.7.5, author: Optimole, Automatische Aktualisierungen deaktiviert
    W3 Total Cache: version: 2.6.0, author: BoldGrid, Automatische Aktualisierungen deaktiviert
    WordPress Popular Posts: version: 6.3.4, author: Hector Cabrera, Automatische Aktualisierungen aktiviert
    Yoast SEO: version: 21.5, author: Team Yoast, Automatische Aktualisierungen aktiviert
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1690
    imagemagick_version: ImageMagick 6.9.10-23 Q16 x86_64 20190101 https://imagemagick.org
    imagick_version: 3.7.0
    file_uploads: 1
    post_max_size: 200M
    upload_max_filesize: 200M
    max_effective_size: 200 MB
    max_file_uploads: 20
    imagick_limits: 
    	imagick::RESOURCETYPE_AREA: 31 GB
    	imagick::RESOURCETYPE_DISK: 1.84467440737E+19
    	imagick::RESOURCETYPE_FILE: 786432
    	imagick::RESOURCETYPE_MAP: 31 GB
    	imagick::RESOURCETYPE_MEMORY: 16 GB
    	imagick::RESOURCETYPE_THREAD: 1
    	imagick::RESOURCETYPE_TIME: 1.84467440737E+19
    imagemagick_file_formats: 3FR, 3G2, 3GP, AAI, AI, ART, ARW, AVI, AVS, BGR, BGRA, BGRO, BIE, BMP, BMP2, BMP3, BRF, CAL, CALS, CANVAS, CAPTION, CIN, CIP, CLIP, CMYK, CMYKA, CR2, CRW, CUR, CUT, DATA, DCM, DCR, DCX, DDS, DFONT, DJVU, DNG, DOT, DPX, DXT1, DXT5, EPDF, EPI, EPS, EPS2, EPS3, EPSF, EPSI, EPT, EPT2, EPT3, ERF, EXR, FAX, FILE, FITS, FRACTAL, FTP, FTS, G3, G4, GIF, GIF87, GRADIENT, GRAY, GRAYA, GROUP4, GV, H, HALD, HDR, HISTOGRAM, HRZ, HTM, HTML, HTTP, HTTPS, ICB, ICO, ICON, IIQ, INFO, INLINE, IPL, ISOBRL, ISOBRL6, JBG, JBIG, JNG, JNX, JPE, JPEG, JPG, JPS, JSON, K25, KDC, LABEL, M2V, M4V, MAC, MAGICK, MAP, MASK, MAT, MATTE, MEF, MIFF, MKV, MNG, MONO, MOV, MP4, MPC, MPEG, MPG, MRW, MSL, MSVG, MTV, MVG, NEF, NRW, NULL, ORF, OTB, OTF, PAL, PALM, PAM, PANGO, PATTERN, PBM, PCD, PCDS, PCL, PCT, PCX, PDB, PDF, PDFA, PEF, PES, PFA, PFB, PFM, PGM, PGX, PICON, PICT, PIX, PJPEG, PLASMA, PNG, PNG00, PNG24, PNG32, PNG48, PNG64, PNG8, PNM, PPM, PREVIEW, PS, PS2, PS3, PSB, PSD, PTIF, PWP, RADIAL-GRADIENT, RAF, RAS, RAW, RGB, RGBA, RGBO, RGF, RLA, RLE, RMF, RW2, SCR, SCT, SFW, SGI, SHTML, SIX, SIXEL, SPARSE-COLOR, SR2, SRF, STEGANO, SUN, SVG, SVGZ, TEXT, TGA, THUMBNAIL, TIFF, TIFF64, TILE, TIM, TTC, TTF, TXT, UBRL, UBRL6, UIL, UYVY, VDA, VICAR, VID, VIFF, VIPS, VST, WBMP, WEBP, WMF, WMV, WMZ, WPG, X, X3F, XBM, XC, XCF, XPM, XPS, XV, XWD, YCbCr, YCbCrA, YUV
    gd_version: 2.2.5
    gd_formats: GIF, JPEG, PNG, WebP, BMP, XPM
    ghostscript_version: 9.50
    
    ### wp-server ###
    
    server_architecture: Linux 5.4.0-166-generic x86_64
    httpd_software: Apache
    php_version: 8.1.22 64bit
    php_sapi: fpm-fcgi
    max_input_variables: 3000
    time_limit: 30
    memory_limit: 128M
    admin_memory_limit: 256M
    max_input_time: 60
    upload_max_filesize: 200M
    php_post_max_size: 200M
    curl_version: 7.68.0 OpenSSL/1.1.1f
    suhosin: false
    imagick_availability: true
    pretty_permalinks: true
    htaccess_extra_rules: true
    current: 2023-11-16T14:29:12+00:00
    utc-time: Thursday, 16-Nov-23 14:29:12 UTC
    server-time: 2023-11-16T15:29:11+01:00
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 10.5.22-MariaDB-1:10.5.22+maria~ubu2004-log
    client_version: mysqlnd 8.1.22
    max_allowed_packet: 67108864
    max_connections: 500
    
    ### wp-constants ###
    
    WP_HOME: https://allesroger.net
    WP_SITEURL: https://allesroger.net
    WP_CONTENT_DIR: /www/htdocs/w00ac39f/wp-content
    WP_PLUGIN_DIR: /www/htdocs/w00ac39f/wp-content/plugins
    WP_MEMORY_LIMIT: 40M
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: true
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_ENVIRONMENT_TYPE: Nicht definiert
    WP_DEVELOPMENT_MODE: undefined
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    mu-plugins: writable
    
    `
    • Dieses Thema wurde geändert vor 7 Monaten, 1 Woche von allesrogernet.
    • Dieses Thema wurde geändert vor 7 Monaten, 1 Woche von allesrogernet.

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 9 Antworten - 1 bis 9 (von insgesamt 9)
  • Hallo,
    schwierig, aber ich versuche es mal:
    Zunächst: Bei Klick auf die Menüpunkte erscheint „Not Found“.
    Vielleicht gibt es ein Problem mit den Permalinks: Das könnte möglicherweise wie folgt gelöst werden: Über Einstellungen > Permalinks im WordPress Dashboard unten auf der Seite auf den Button „Änderungen speichern“ klicken. Hier brauchst du keine Änderungen vornehmen – einfach auf die Schaltfläche klicken.

    Falls das nicht klappt: Einstellung zunächst auf „Standard“ durch Klick auf „Änderungen speichern“ bestätigen und anschließend die Permalinks wieder auf „Beitragsname“ setzen und wiederum bestätigen.

    Falls das nicht klappt, könnte es an der .htaccess liegen:
    Dazu musst du WordPress „zwingen“, eine neue, saubere .htaccess-Datei zu erzeugen:

    • per FTP suchst du die .htaccess-Datei in deinem Stammordner
    • lade eine Kopie der Datei als Sicherung auf deinen Computer
    • lösche danach die .htaccess-Datei von deinem Server
    • gehe zu Einstellungen > Permalinks im WordPress Dashboard
    • unten auf der Seite auf den Button „Änderungen speichern“ klicken (du musst keine Änderungen vornehmen – klicke einfach auf die Schaltfläche)

    Sollte danach das Problem beseitigt sein, lag es an der .htaccess, sonst einfach die gesicherte Datei .htaccess wieder in den Stammordner kopieren.

    Du hast zwei Plugins für Cache installiert, wobei W3 Total Cache recht schwierig einzustellen ist. Ich verwende das Plugin nicht. Es gibt durchaus Cache-Plugins, die man einfacher konfigurieren kann, z. B. Comet Cache. Eine Deinstallation des Plugins W3 Total Cache ist leider nicht ganz einfach, weil sich das Plugin ziemlich tief in den Core eingräbt, siehe hier.

    Zu dem anderen Plugin (Super Page Cache for Cloudflare) kann ich nichts sagen. Grundsätzlich würde ich aber ein Plugin deaktivieren, weil es gerade bei Cache-Plugins Konflikte geben kann, die zu seltsamen Erscheinungen führen können.

    Ich weiß, dass damit nicht alle Probleme angesprochen sind, aber zunächst sollten die genannten Dinge überprüft und ggfs. korrigiert werden, bevor wir dann weitermachen.

    Denke bitte daran, vorher eine Sicherung zu erstellen. Du hast erstaunlicherweise kein Sicherungs-Plugin installiert. Ich verwende dazu in der Regel UpdraftPlus.

    Viele Grüße
    Hans-Gerd

    Thread-Starter allesrogernet

    (@allesrogernet)

    Hallo und vielen Dank für die Tipps.

    Die Permalinks funktionieren wieder und die .htaccess habe ich neu generieren lassen. W3TotalCache ist entfernt, ebenso das Cloudflare Cache Plugin (Ich habe eh keinen Unterschied bemerkt). Comet Cache habe ich nicht installiert, da dies offenbar seit Jahren nicht mehr gewartet wird. Aber ich las einiges gutes über Surge, dass ich nun mal probeweise einsetze, weil sich der Healthcare Check sonst beschwert. Danke auch für den Tipp mit UpdraftPlus.

    Alles tolle Ratschläge, meine Verwirrungen und Sorgen sind allerdings damit noch nicht beseitigt. Noch immer ist das Backend darauf angewiesen, dass in der wp-config.php folgendes eingefügt ist:

    define('WP_HOME','https://allesroger.net');
    define('WP_SITEURL','https://allesroger.net');

    Ohne diese Einträge ist kein Login möglich. Und ich bin auch nicht sicher, was ich denn hier nun korrekterweise schreibe: https oder http? Setze ich ein www vor die URL oder eben nicht? Was ist denn korrekt? Und wie gebe ich das in der Google Search Console an?

    Im Moment steht dort bei der URL Prüfung:

    Sitemaps
    Keine verweisenden Sitemaps gefunden
    Verweisende Seite
    http://allesroger.net/
    http://www.allesroger.net/
    
    Vom Nutzer angegebene kanonische URL
    https://www.allesroger.net/
    Von Google ausgewählte kanonische URL
    https://allesroger.net/

    Also auch Google scheint da alle möglichen Varianten zu nutzen. Ich bin ja nicht mal sicher, ob https bei mir überhaupt korrekt konfiguriert ist. Denn wie gesagt, seit etwa einer Woche behauptet Google, meine URL sei nicht mehr indexiert. Und das kommt mir sehr komisch vor. Mein Blog läuft schon seit vielen Jahren.

    Moderator Michi91

    (@michi91)

    Google probiert alle Varianten aus, die möglicherweise von einem User eingegeben werden könnten. Wichtig ist: DU legst eine Variante fest und solltest diese dann nicht mehr ändern. Sonst zerhaut es die Indexierung und das Ranking…

    https://allesroger.net

    ist doch super und so aktuell auch bis auf für die Startseite im Index…
    https://www.google.com/search?client=firefox-b-d&q=https%3A%2F%2Fallesroger.net#ip=1

    Noch immer ist das Backend darauf angewiesen, dass in der wp-config.php folgendes eingefügt ist:

    Ohne diese Einträge ist kein Login möglich. Und ich bin auch nicht sicher, was ich denn hier nun korrekterweise schreibe: https oder http? Setze ich ein www vor die URL oder eben nicht?

    mit https und ohne www. Genau so wie es jetzt ist. Wenn du lieber mit www. hättest, kannst du es nun aber auch noch einfügen. zerhauen ist dein Ranking ja scheinbar schon 😉
    Auf den wp-config Eintrag kannst du verzichten, wenn in der Datenbank alles korrekt eingestellt ist: https://kinsta.com/de/wissensdatenbank/wordpress-url-andern/#wordpressurl-direkt-in-der-datenbank-ndern

    Grüße 🙂

    • Diese Antwort wurde geändert vor 7 Monaten von Michi91.
    Thread-Starter allesrogernet

    (@allesrogernet)

    Hallo,

    die Änderung in der DB traue ich mir dann doch nicht zu. Nicht, dass ich am Ende noch mehr kaputt mache. Ob ich den Eintrag nun im Backend oder in der wp-config pflege, dürfte keinen Unterschied machen, oder?

    Jedenfalls bin ich schon mal beruhigt, dass soweit alles wieder läuft. Aber eine Sache beunruhigt mich doch, bzw. ich finde keine rechte Antwort da draußen: Auf meiner Seite gibt es noch eine recht hohe Anzahl an 301-Weiterleitungen. Vermutlich hatte ich die durch RankMath erstellen lassen. Die Search Console findet auch weiterhin 404 Errors, die allesamt noch aus der Zeit vor der Permalink Änderung stammen. Ich habe einen Test meiner Seite bei Ahrefs gemacht, dort wurde mir allerdings 100% Health bescheinigt. Die vielen 301 Weiterleitungen scheinen also kein Problem zu sein?

    Und diese Unterscheidung www oder nicht und https oder http macht mich halt auch deshalb weiter nervös, weil die Search Console jede Variante anders zu behandeln scheint. Ich habe jetzt mal alle Varianten dort eingetragen. Ist das korrekt, oder genügt einfach die Domain Property allesroger.net?

    Moderator Michi91

    (@michi91)

    die Änderung in der DB traue ich mir dann doch nicht zu. Nicht, dass ich am Ende noch mehr kaputt mache. Ob ich den Eintrag nun im Backend oder in der wp-config pflege, dürfte keinen Unterschied machen, oder?

    Solange du dir das merkst, dass dort der Wert hinterlegt ist, ist alles okay.

    bezüglich der anderen Fragen kann @wpgerd eventuell helfen? Durch die Erwähnung sollte er nun ne Mail bekommen haben und sich eventuell melden 🙂

    Thread-Starter allesrogernet

    (@allesrogernet)

    Ach, bezüglich der 301 Weiterleitungen fiel mir noch etwas ein. Ich habe die vermutlich in der .htaccess konfiguriert. Weil ich natürlich http Anfragen auf https umbiegen wollte. Vielleicht könnte mir jemand einen Tipp geben, ob das so überhaupt sinnvoll ist, wie ich das hier gemacht habe:

    Header set X-Frame-Options "sameorigin" 
    Header set X-Content-Type-Options nosniff  
    Header set X-XSS-Protection "1; mode=block"
    Header set Referrer-Policy: "no-referrer"
    
    # Die Komprimierung aktivieren
    <FilesMatch "\\.(js|css|html|htm|php|xml|svg)$">
    SetOutputFilter DEFLATE
    </FilesMatch>
    
    # Bot semalt.com blocken
    RewriteEngine on
    RewriteCond %{HTTP_REFERER} ^http://.semalt.com/ [NC]
    RewriteRule ^(.)$ – [F,L]
    
    RewriteEngine On
    RewriteCond %{HTTPS} !=on
    RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
    
    php_value memory_limit 256M
    
    # BEGIN WordPress
    # Die Anweisungen (Zeilen) zwischen „BEGIN WordPress“ und „END WordPress“ sind
    # dynamisch generiert und sollten nur über WordPress-Filter geändert werden.
    # Alle Änderungen an den Anweisungen zwischen diesen Markierungen werden überschrieben.
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    Und vielleicht sollte ich noch dazu erwähnen, dass meine Seite an Cloudflare angebunden ist.

    bezüglich der anderen Fragen kann @wpgerd eventuell helfen? Durch die Erwähnung sollte er nun ne Mail bekommen haben und sich eventuell melden 🙂

    Hallo Roger,
    wenn du deine Seite in der Google Search Console mit der Methode URL-Anzeige verifiziert hast, musst/kannst du für jede Schreibweise eine Property, also alle vier Varianten erstellen. Daten werden aber nur in der Property gesammelt, die mit der auf dem Server eingestellten URL übereinstimmt. Bei dir ist das https://allesroger.net. Wenn es vorher https://www.allesroger.net war, hast du vermutlich dort die alten Daten und bekommst von dort die Meldung, dass die alten URLs nicht mehr gefunden werden.

    Wenn ich mit dem Befehl site:allesroger.net eine Google-Suche mache, sehe ich 765 Seiten, die bei Google indexiert sind. Beim groben durchscrollen hab ich nur zwei Ergebnisse gesehen, die noch unter http://www.allesroger.net indexiert sind. Wenn es Umleitungen gibt, braucht es einfach oft einige Zeit (Wochen), bis der Index aktualisiert ist.

    Du scheinst nicht nur von mit www auf ohne www gewechselt, sondern auch die Struktur der Blogbeiträge (Monats- und Jahresordner) und einiges andere angepasst zu haben. Hab mal den Screaming Frog drüber laufen lassen. Der findet ne ganze Reihe Seiten, die auf Noindex stehen. Wenn das gewollt ist, ist OK, wenn nicht solltest du das überprüfen. Hab dir per Mail nen Link der vollständigen Datei geschickt.

    Gruss aus der Schweiz
    Gerd

    Thread-Starter allesrogernet

    (@allesrogernet)

    Hallo Gerd, und vielen Dank für die Mühe und die ausführliche Antwort. Ich habe mir die von dir bereit gestellte CSV-Datei angesehen und muss gestehen, noch immer nicht ganz schlau draus zu werden, was bei mir eigentlich schief läuft. :-/ Ja, diese ganzen Änderungen in der Permalink-Struktur und die Änderung zur URL ohne www. haben nur Chaos verursacht und meiner Seite langfristig geschadet. Ich habe auch irgendwie das Gefühl, dass diese SEO Plugins wie zuletzt RankMath und jetzt aktuell in Verwendung, YoastSEO, eher Schaden anrichten, als zu helfen. So zumindest erscheint es mir, wenn ich deine Ergebnisse und die Rückmeldung der Search Console anschaue.

    Also ich verstehe richtig, dass die Seiten, die mit einer 301 Weiterleitung markiert und indexierbar sind, kein Problem darstellen, richtig? Warum es allerdings noch immer Seiten mit der richtigen Struktur und einer 301 gibt, die nicht indexierbar sind, erschließt sich mir nicht. Oder sollten die tatsächlich auf no-index stehen, weil sie ja eigentlich falsch sind.

    Dann sind da auch Seiten zu sehen, die ebenfalls die richtige Struktur haben, den Status Code 200 haben und auch auf meinem Blog zu finden sind, die aber dennoch offenbar auf no-index stehen. Das verstehe ich ebenfalls nicht.

    Einige Seiten sind Canonical, viele andere nicht. Ich kann mich nicht erinnern, dass irgendwo bewusst gesteuert zu haben. Sollte ich das und wenn ja, wie? Muss ich dazu jeden einzelnen Beitrag in den Meta Tags als canonical markieren?

    Wie bekomme ich das Chaos nur wieder in den Griff?

    Thread-Starter allesrogernet

    (@allesrogernet)

    Ich habe zusätzlich festgestellt, dass ich die Admin-Oberfläche zwar mit www öffnen kann, bestimmte Aktionen und Plugins aber nicht funktionieren, bzw. nicht speichern und eine Vielzahl interner Medien einen Fehler werfen, weil sie ebenfalls mit dem www Link verknüpft sind. Bevor ich jetzt wieder alles rückgängig mache und auf http://www.allesroger.net ändere, ist das empfehlenswert oder richte ich damit nur noch mehr Schaden an?

    Ich habe mich auch wieder vom Yoast SEO Plugin verabschiedet, weil ich das Gefühl hatte, dadurch nur noch mehr Probleme zu haben. Ich versuche es jetzt jetzt mit dem SEO Framework Plugin, das sehr einfach gestaltet ist.

    • Diese Antwort wurde geändert vor 6 Monaten, 3 Wochen von allesrogernet.
Ansicht von 9 Antworten - 1 bis 9 (von insgesamt 9)
  • Das Thema „WordPress kaputt konfiguriert?“ ist für neue Antworten geschlossen.