Support » Allgemeine Fragen » Hintergrund-Updates funktionieren nicht wie erwartet

  • Gelöst ruedigerboecking

    (@ruedigerboecking)


    Mein Website- Zustand meldet folgenden Sicherheits- Fehler:

    Hintergrund-Updates funktionieren nicht wie erwartet

    Hintergrund-Updates stellen sicher, dass WordPress automatisch aktualisieren kann, wenn ein Sicherheitsupdate für die Version, die zu diesem Zeitpunkt verwendet wird, veröffentlicht wird.

    Abgeschlossen Es wurde kein Versionskontrollsystem gefunden.
    Fehler Deine WordPress-Installation benötigt FTP-Zugangsdaten, um Aktualisierungen durchzuführen. (Deine Website führt aufgrund des Dateibesitzes Aktualisierungen über FTP durch. Kontaktiere hierzu dein Webhosting-Unternehmen.)

    Mein Website- Provider hosteurope.de meint dass sein mein Problem, er könne / wolle da nicht helfen. Wo kannich die FTP Daten eintragen, damit WordPress automatisch aktualisieren kann?

    Wo bekomme ich ein Versionskontrollsystem? Oder ist meine (selbst gemachte) Installation fehlerhaft?

    Grüße aus Bayern an alle Mit- Leser
    Rüdiger

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 11 Antworten - 1 bis 11 (von insgesamt 11)
  • Hallo,

    Wo kannich die FTP Daten eintragen, damit WordPress automatisch aktualisieren kann?

    Wo bekomme ich ein Versionskontrollsystem?

    hmm, keine Ahnung, was du damit meinst. 🤔
    Das solltest du noch mal erläutern.

    Du findest unter Werkzeuge > Websitezustand > Info einen Bericht zur Website. Warte bitte einen Moment bis die Ladeanzeige ganz oben abgeschlossen ist und kopiere dann per Button den Website-Bericht in deine Zwischenablage. Über den Button „Bericht in die Zwischenablage kopieren“ kannst du den Bericht unverändert (bitte mit den Akzentzeichen am Anfang und Ende) einfügen und anschließend hier posten. Evtl. ergeben sich dann weitere Anhaltspunkte, ob und wo das Problem liegt.
    Lies bitte auch noch mal: Bevor du ein neues Thema (Thread) erstellst.

    Viele Grüße
    Hans-Gerd

    Thread-Ersteller ruedigerboecking

    (@ruedigerboecking)

    Hallo Hans-Gerd,

    ich habe alle gelesen. Habe ich einen Fehler gemacht?

    Die Status- Meldung im Website- Zustand sagt:

    1 kritisches Problem

    Hintergrund-Updates funktionieren nicht wie erwartet 
    
    Hintergrund-Updates stellen sicher, dass WordPress automatisch aktualisieren kann, wenn ein Sicherheitsupdate für die Version, die zu diesem Zeitpunkt verwendet wird, veröffentlicht wird.
    
        Abgeschlossen Es wurde kein Versionskontrollsystem gefunden.
        Fehler Deine WordPress-Installation benötigt FTP-Zugangsdaten, um Aktualisierungen durchzuführen. (Deine Website führt aufgrund des Dateibesitzes Aktualisierungen über FTP durch. Kontaktiere hierzu dein Webhosting-Unternehmen.)

    Hier der Bericht über den Website- Zustand:

    
    ### wp-core ###
    
    version: 5.9.3
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Berlin
    permalink: /%year%/%monthnum%/%day%/%postname%/
    https_status: false
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: open
    environment_type: production
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /is/htdocs/wp13819393_QIG920HHD6/www/wp22
    wordpress_size: loading...
    uploads_path: /is/htdocs/wp13819393_QIG920HHD6/www/wp22/wp-content/uploads
    uploads_size: loading...
    themes_path: /is/htdocs/wp13819393_QIG920HHD6/www/wp22/wp-content/themes
    themes_size: loading...
    plugins_path: /is/htdocs/wp13819393_QIG920HHD6/www/wp22/wp-content/plugins
    plugins_size: loading...
    database_size: loading...
    total_size: loading...
    
    ### wp-active-theme ###
    
    name: GeneratePress (generatepress)
    version: 3.1.3
    author: Tom Usborne
    author_website: https://tomusborne.com
    parent_theme: none
    theme_features: core-block-patterns, widgets-block-editor, automatic-feed-links, post-thumbnails, post-formats, woocommerce, title-tag, html5, customize-selective-refresh-widgets, align-wide, responsive-embeds, editor-color-palette, custom-logo, menus, editor-styles, editor-style, widgets
    theme_path: /is/htdocs/wp13819393_QIG920HHD6/www/wp22/wp-content/themes/generatepress
    auto_update: Deaktiviert
    
    ### wp-themes-inactive (1) ###
    
    Twenty Twenty-Two: version: 1.1, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-active (2) ###
    
    Akismet Anti-Spam: version: 4.2.4, author: Automattic, Automatische Aktualisierungen aktiviert
    Shariff Wrapper: version: 4.6.7, author: Jan-Peter Lambeck & 3UU, Automatische Aktualisierungen aktiviert
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_GD
    imagick_module_version: Nicht verfügbar
    imagemagick_version: Nicht verfügbar
    imagick_version: Nicht verfügbar
    file_uploads: File uploads is turned off
    post_max_size: 32M
    upload_max_filesize: 32M
    max_effective_size: 32 MB
    max_file_uploads: 50
    gd_version: bundled (2.1.0 compatible)
    gd_formats: GIF, JPEG, PNG, WebP, BMP, XPM
    ghostscript_version: 9.27
    
    ### wp-server ###
    
    server_architecture: Linux 4.14.132-xenu-he x86_64
    httpd_software: Apache
    php_version: 7.4.28-he.0 64bit
    php_sapi: apache2handler
    max_input_variables: 1000
    time_limit: 30
    memory_limit: 256M
    max_input_time: 60
    upload_max_filesize: 32M
    php_post_max_size: 32M
    curl_version: 7.64.0 OpenSSL/1.1.1n
    suhosin: false
    imagick_availability: false
    pretty_permalinks: true
    htaccess_extra_rules: false
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.7.37-40-log
    client_version: mysqlnd 7.4.28-he.0
    max_allowed_packet: 33554432
    max_connections: 1100
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /is/htdocs/wp13819393_QIG920HHD6/www/wp22/wp-content
    WP_PLUGIN_DIR: /is/htdocs/wp13819393_QIG920HHD6/www/wp22/wp-content/plugins
    WP_MEMORY_LIMIT: 40M
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_ENVIRONMENT_TYPE: Nicht definiert
    DB_CHARSET: utf8mb4
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: not writable
    uploads: not writable
    plugins: not writable
    themes: not writable
    
    

    Liebe Grüße
    Rüdiger

    Hallo,
    schau mal bitte in den Bericht (ganz am Ende):

    wp-content: not writable
    uploads: not writable
    plugins: not writable
    themes: not writable

    Das heißt, du hast gar keine Rechte, z. B. Plugins, Themes upzudaten bzw. zu installieren.
    Bei einer normalen Installation hast du die entsprechenden Rechte.

    Insofern solltest du noch mal mit dem Hoster sprechen und ihn darauf hinweisen. Per FTP kannst du prüfen, ob die Dateirechte richtig gesetzt sind: Dateien sollten auf 644, Verzeichnisse auf 755 gesetzt sein. Die Dateirechte können natürlich auch per FTP entsprechend geändert werden.

    Viele Grüße
    Hans-Gerd

    Thread-Ersteller ruedigerboecking

    (@ruedigerboecking)

    Hallo Hans-Gerd,

    vielen lieben Dank. Das machts etwas klarer. Aber bin ich jetzt schuld (als Selbst- Installateur, weil HostEurope keine vorinstallierten WordPress Pakete mehr anbietet) – oder ist es eine Frage die trotzdem beim Hoster liegt?

    Ich hab deine Antwort mal als Frage an den Support gesendet – ich hoffe die können und wollen mir helfen. Heute morgen wollten sie nicht …..

    Liebe Grüße
    Rüdiger

    Hallo,
    wir freuen uns über eine Rückmeldung.
    Viele Grüße
    Hans-Gerd

    Thread-Ersteller ruedigerboecking

    (@ruedigerboecking)

    Na klar doch – ich melde mich sobald ich Klarheit habe.

    Ich hatte eigentlich genau nach Anleitung WordPress downgeloadet und installiert. Bin mir (noch) keiner Schuld bewußt 😉

    Grüßle
    Rüdiger

    Thread-Ersteller ruedigerboecking

    (@ruedigerboecking)

    Hello again,

    der Support hat geantwortet:

    Wir haben Ihr Anliegen geprüft. Der Hinweis aus dem Forum mit den Rechten hat geholfen und wir haben uns einmal Ihren von Ihnen angelegten FTP Zugnag angeschaut. Sie haben eine normale WordPress Installation, mit allen Rechten. Allerdings haben Sie den FTP Zugang, welchen Sie angelegt haben mit ftp Rechten versehen. Unsere Standart Einstellung sind aber WP Rechte, damit WordPress und dessen Dateien entsprechende Schreibrechte haben. Wir haben dies einmal für Sie korrigiert und dies ebenfalls in der Dateiverwaltung, denn dort waren ebenfalls falsche Rechte vergeben. Testen Sie es bitte in 15 Minuten erneut, dann sollte es funktionieren.

    Ich habe es gerade getestet. Die Fehlermeldung ist tatsächlich weg. Allerdings funktioniert diese Lösung vermutlich nur bei HostEurope Kunden ….

    Danke für die schnelle Hilfe
    Rüdiger

    Die Antwort von hosteurope ist nicht gerade technisch oder detailreich … Aber schön das sie es korrigiert haben 🙂

    Idealweise sind FTP und Webserver User die selben oder zumindest in der gleichen Gruppe. Bei den meisten Hostern ist das inzwischen Standart und von Problemen wie deinem hört man nur noch selten. Früher war das anders. Gut möglich das hosteurope in seinem webinterface da verschiedene Optionen anbietet.

    Thread-Ersteller ruedigerboecking

    (@ruedigerboecking)

    Hallo Michi91,

    ja, sehe ich ähnlich wie Du. Das hat auch erst angefangen zum Problem zu werden seit HostEurope keine vorinstallierten WordPress und MySQL Pakete mehr anbietet.
    Darauf hätte ich bei dem neuen Projekt mehr achten sollen.
    Tut mir leid dass ich so viele „dumme“ Fragen stelle. Aber das kommt dann halt dabei raus 😉
    Liebe Grüße
    Rüdiger

    Hallo,
    super – freut mich, dass es jetzt funktioniert. Danke für die Rückmeldung und “Gelöst”-Markieren. 👍
    Viele Grüße
    Hans-Gerd

    Thread-Ersteller ruedigerboecking

    (@ruedigerboecking)

    danke dir auch

Ansicht von 11 Antworten - 1 bis 11 (von insgesamt 11)