Support » Allgemeine Fragen » Hintergrund-Updates funktionieren nicht wie erwartet

  • Gelöst jessicawb

    (@jessicawb)


    Hallo liebe Community,

    neuerdings habe ich Probleme mit meiner WordPress-Seite, denn Hintergrund-Updates funktionieren nicht und das zieht einen riesigen Rattenschwanz an Problemen mit sich.
    PHP und WordPress sind auf der aktuellsten Version aufgespielt, Plugins auch aktualisiert, soweir vorhanden.

    Nachdem ich nun schon das Forum hier durchsucht und viel ausprobiert habe, möchte ich euch nun um eure Hilfe bitten. Ich hoffe die unterstehenden Informationen, helfen, die Herausforderung zu lösen.

    Vielen Dank,
    Jessica

    Folgende Fehlermeldung erscheint im Status Bericht:
    Fehler Ein Plugin hat Aktualisierungen verhindert, indem es wp_version_check() deaktiviert hat.
    Abgeschlossen Es wurde kein Versionskontrollsystem gefunden.
    Abgeschlossen Deine Installation von WordPress benötigt keine FTP-Zugangsdaten, um Updates durchzuführen.
    Fehler Einige Dateien sind für WordPress nicht beschreibbar:

    
    xmlrpc.php
    wp-blog-header.php
    wp-signup.php
    index.php
    wp-cron.php
    wp-login.php
    wp-settings.php
    wp-mail.php
    wp-links-opml.php
    wp-load.php
    wp-includes/class-wp-user-query.php
    wp-includes/l10n.php
    wp-includes/date.php
    wp-includes/php-compat/readonly.php
    wp-includes/class-wp-oembed.php
    wp-includes/images/w-logo-blue-white-bg.png
    wp-includes/images/blank.gif
    wp-includes/images/down_arrow.gif
    wp-includes/images/spinner.gif
    wp-includes/images/media/interactive.png
    ...

    Der Bericht sieht wie folgt aus.

    
    ### wp-core ###
    
    version: 6.0.1
    site_language: de_DE
    user_language: de_DE
    timezone: +02:00
    permalink: /%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: open
    environment_type: production
    user_count: 3
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /home/wp/disk/wordpress
    wordpress_size: 764,36 MB (801492280 bytes)
    uploads_path: /home/wp/disk/wordpress/wp-content/uploads
    uploads_size: 206,65 MB (216689358 bytes)
    themes_path: /home/wp/disk/wordpress/wp-content/themes
    themes_size: 56,24 MB (58973843 bytes)
    plugins_path: /home/wp/disk/wordpress/wp-content/plugins
    plugins_size: 204,69 MB (214635896 bytes)
    database_size: 17,66 MB (18513920 bytes)
    total_size: 1,22 GB (1310305297 bytes)
    
    ### wp-dropins (1) ###
    
    advanced-cache.php: true
    
    ### wp-active-theme ###
    
    name: Divi Ecommerce (diviecommerce)
    version: 1.2.6
    author: Divi Space
    author_website: https://divi.space
    parent_theme: Divi (Divi)
    theme_features: core-block-patterns, block-templates, widgets-block-editor, post-thumbnails, custom-background, automatic-feed-links, menus, title-tag, post-formats, woocommerce, wc-product-gallery-zoom, wc-product-gallery-lightbox, wc-product-gallery-slider, customize-selective-refresh-widgets, wp-block-styles, editor-style, widgets
    theme_path: /home/wp/disk/wordpress/wp-content/themes/diviecommerce
    auto_update: Aktiviert
    
    ### wp-parent-theme ###
    
    name: Divi (Divi)
    version: 4.17.6
    author: Elegant Themes
    author_website: http://www.elegantthemes.com
    theme_path: /home/wp/disk/wordpress/wp-content/themes/Divi
    auto_update: Aktiviert
    
    ### wp-themes-inactive (1) ###
    
    Twenty Twenty-Two: version: 1.2, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    
    ### wp-mu-plugins (2) ###
    
    InfiniteWP - Client Loader: version: 1.0.1, author: Revmakx
    wp-hide-loader.php: author: (undefined), version: (undefined)
    
    ### wp-plugins-active (26) ###
    
    Borlabs Cookie - Cookie Opt-in: version: 2.2.53, author: Borlabs GmbH, Automatische Aktualisierungen deaktiviert
    Breadcrumb NavXT: version: 7.1.0, author: John Havlik, Automatische Aktualisierungen deaktiviert
    CartFlows: version: 1.10.1, author: CartFlows Inc, Automatische Aktualisierungen deaktiviert
    DHL Shipping Germany for WooCommerce: version: 2.9.2, author: DHL, Automatische Aktualisierungen deaktiviert
    Divi Pixel: version: 2.15.1, author: Octolab OÜ, Automatische Aktualisierungen deaktiviert
    Divi Toolbox: version: 1.6.14, author: Divi Lover, Automatische Aktualisierungen deaktiviert
    Germanized for WooCommerce: version: 3.9.8, author: vendidero, Automatische Aktualisierungen deaktiviert
    Germanized for WooCommerce Pro: version: 3.5.4, author: vendidero, Automatische Aktualisierungen deaktiviert
    InfiniteWP - Client: version: 1.9.8, author: Revmakx, Automatische Aktualisierungen deaktiviert
    Jetpack: version: 11.1.2, author: Automattic, Automatische Aktualisierungen deaktiviert
    Loco Translate: version: 2.6.2, author: Tim Whitlock, Automatische Aktualisierungen deaktiviert
    Newsletter: version: 7.5.0, author: Stefano Lissa & The Newsletter Team, Automatische Aktualisierungen deaktiviert
    Payment Plugins for Stripe WooCommerce: version: 3.3.24, author: Payment Plugins, support@paymentplugins.com, Automatische Aktualisierungen deaktiviert
    Preorders for WooCommerce: version: 1.2.7, author: Bright Plugins, Automatische Aktualisierungen deaktiviert
    Themify - WooCommerce Product Filter: version: 1.3.9, author: Themify, Automatische Aktualisierungen deaktiviert
    TI WooCommerce Wishlist: version: 1.47.0, author: TemplateInvaders, Automatische Aktualisierungen deaktiviert
    Variation Swatches for WooCommerce: version: 2.0.5, author: Emran Ahmed, Automatische Aktualisierungen deaktiviert
    vendidero Helper: version: 2.1.6, author: vendidero, Automatische Aktualisierungen deaktiviert
    WooCommerce: version: 6.7.0, author: Automattic, Automatische Aktualisierungen deaktiviert
    WooCommerce Shipping & Tax: version: 1.26.2, author: WooCommerce, Automatische Aktualisierungen deaktiviert
    WP-PageNavi: version: 2.94.0, author: Lester 'GaMerZ' Chan, Automatische Aktualisierungen deaktiviert
    WPC Fly Cart for WooCommerce: version: 5.0.7, author: WPClever, Automatische Aktualisierungen deaktiviert
    WP Hide & Security Enhancer: version: 1.7.9.2, author: Nsp Code, Automatische Aktualisierungen deaktiviert
    WP Layouts: version: 0.6.17, author: WP Layouts, Automatische Aktualisierungen deaktiviert
    WP Rocket: version: 3.11.4.2, author: WP Media, Automatische Aktualisierungen deaktiviert
    Yoast SEO: version: 19.3, author: Team Yoast, Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-inactive (1) ###
    
    Caldera Forms: version: 1.9.6, author: Caldera Forms, Automatische Aktualisierungen deaktiviert
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1687
    imagemagick_version: ImageMagick 6.9.7-4 Q16 x86_64 20170114 http://www.imagemagick.org
    imagick_version: 3.7.0
    file_uploads: File uploads is turned off
    post_max_size: 2000M
    upload_max_filesize: 2000M
    max_effective_size: 2 GB
    max_file_uploads: 250
    imagick_limits: 
    	imagick::RESOURCETYPE_AREA: 8 GB
    	imagick::RESOURCETYPE_DISK: 1.844674407371E+19
    	imagick::RESOURCETYPE_FILE: 768
    	imagick::RESOURCETYPE_MAP: 8 GB
    	imagick::RESOURCETYPE_MEMORY: 4 GB
    	imagick::RESOURCETYPE_THREAD: 1
    imagemagick_file_formats: 3FR, AAI, AI, ART, ARW, AVI, AVS, BGR, BGRA, BGRO, BIE, BMP, BMP2, BMP3, BRF, CAL, CALS, CANVAS, CAPTION, CIN, CIP, CLIP, CMYK, CMYKA, CR2, CRW, CUR, CUT, DATA, DCM, DCR, DCX, DDS, DFONT, DJVU, DNG, DOT, DPX, DXT1, DXT5, EPDF, EPI, EPS, EPS2, EPS3, EPSF, EPSI, EPT, EPT2, EPT3, ERF, EXR, FAX, FILE, FITS, FRACTAL, FTP, FTS, G3, G4, GIF, GIF87, GRADIENT, GRAY, GROUP4, GV, H, HALD, HDR, HISTOGRAM, HRZ, HTM, HTML, HTTP, HTTPS, ICB, ICO, ICON, IIQ, INFO, INLINE, IPL, ISOBRL, ISOBRL6, JBG, JBIG, JNG, JNX, JPE, JPEG, JPG, JPS, JSON, K25, KDC, LABEL, M2V, M4V, MAC, MAGICK, MAP, MASK, MAT, MATTE, MEF, MIFF, MKV, MNG, MONO, MOV, MP4, MPC, MPEG, MPG, MRW, MSL, MSVG, MTV, MVG, NEF, NRW, NULL, ORF, OTB, OTF, PAL, PALM, PAM, PANGO, PATTERN, PBM, PCD, PCDS, PCL, PCT, PCX, PDB, PDF, PDFA, PEF, PES, PFA, PFB, PFM, PGM, PICON, PICT, PIX, PJPEG, PLASMA, PNG, PNG00, PNG24, PNG32, PNG48, PNG64, PNG8, PNM, PPM, PREVIEW, PS, PS2, PS3, PSB, PSD, PTIF, PWP, RADIAL-GRADIENT, RAF, RAS, RAW, RGB, RGBA, RGBO, RGF, RLA, RLE, RMF, RW2, SCR, SCT, SFW, SGI, SHTML, SIX, SIXEL, SPARSE-COLOR, SR2, SRF, STEGANO, SUN, SVG, SVGZ, TEXT, TGA, THUMBNAIL, TIFF, TIFF64, TILE, TIM, TTC, TTF, TXT, UBRL, UBRL6, UIL, UYVY, VDA, VICAR, VID, VIFF, VIPS, VST, WBMP, WMF, WMV, WMZ, WPG, X, X3F, XBM, XC, XCF, XPM, XPS, XV, XWD, YCbCr, YCbCrA, YUV
    gd_version: 2.3.0
    gd_formats: GIF, JPEG, PNG, WebP, BMP, XPM
    ghostscript_version: unknown
    
    ### wp-server ###
    
    server_architecture: unknown
    httpd_software: nginx/1.17.5
    php_version: 7.4.30 64bit
    php_sapi: fpm-fcgi
    max_input_variables: 10000
    time_limit: 300
    memory_limit: 512M
    max_input_time: 300
    upload_max_filesize: 2000M
    php_post_max_size: 2000M
    curl_version: 7.58.0 OpenSSL/1.1.1
    suhosin: false
    imagick_availability: true
    pretty_permalinks: true
    htaccess_extra_rules: false
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 10.4.25-MariaDB-1:10.4.25+maria~bionic
    client_version: mysqlnd 7.4.30
    max_allowed_packet: 1073741824
    max_connections: 200
    
    ### wp-constants ###
    
    WP_HOME: https://wildblueten.de
    WP_SITEURL: https://wildblueten.de
    WP_CONTENT_DIR: /home/wp/disk/wordpress/wp-content
    WP_PLUGIN_DIR: /home/wp/disk/wordpress/wp-content/plugins
    WP_MEMORY_LIMIT: 512M
    WP_MAX_MEMORY_LIMIT: 512M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: false
    WP_DEBUG_LOG: true
    SCRIPT_DEBUG: false
    WP_CACHE: true
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_ENVIRONMENT_TYPE: Nicht definiert
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    mu-plugins: writable
    
    ### jetpack ###
    
    site_id: 208638438
    ssl_cert: No
    time_diff: undefined
    version_option: 11.1.2:1658333933
    old_version: 11.1:1657139778
    public: Public
    master_user: Kein Masterbenutzer festgelegt.
    current_user: #1 info@wildblueten.de
    tokens_set: None
    blog_token: Not set.
    user_token: Not set.
    version: 11.1.2
    jp_plugin_dir: /home/wp/disk/wordpress/wp-content/plugins/jetpack/
    plan: free
    protect_header: {"trusted_header":"REMOTE_ADDR","segments":1,"reverse":false}
    full_sync: {"started":"Wed, 06 Jul 2022 20:43:57 +0000","finished":"Wed, 06 Jul 2022 20:48:10 +0000","progress":{"comments":{"total":"0","sent":0,"finished":true,"last_sent":"~0"},"constants":{"finished":true},"functions":{"finished":true},"options":{"finished":true},"posts":{"total":"396","sent":396,"finished":true,"last_sent":"3"},"term_relationships":{"total":"181","sent":181,"finished":true,"last_sent":{"object_id":"563","term_taxonomy_id":"16"}},"terms":{"total":"111","sent":111,"finished":true,"last_sent":"1"},"themes":{"finished":true},"updates":{"finished":true},"users":{"total":"2","sent":2,"finished":true,"last_sent":"1"}},"config":{"comments":1,"constants":1,"functions":1,"options":1,"posts":1,"term_relationships":1,"terms":1,"themes":1,"updates":1,"users":1}}
    sync_size: 1
    sync_lag: 4 hours, 22 minutes, 44 seconds
    full_sync_size: undefined
    full_sync_lag: 0 seconds
    idc_urls: {"home":"https:\/\/wildblueten.de","siteurl":"https:\/\/wildblueten.de","WP_HOME":"https:\/\/wildblueten.de","WP_SITEURL":"https:\/\/wildblueten.de"}
    idc_error_option: false
    idc_optin: true
    cxn_tests: {"8":{"name":"test__connection_token_health","label":false,"short_description":"Validierung des Blog-Tokens fehlgeschlagen","long_description":"<p>Eine fehlerfreie Verbindung sorgt daf\u00fcr, dass wichtige Jetpack-Dienste wie Statistiken und Websitesicherheit f\u00fcr deine WordPress-Website zur Verf\u00fcgung gestellt werden.<\/p><p><span class=\"dashicons fail\"><span class=\"screen-reader-text\">Fehler<\/span><\/span> Validierung des Blog-Tokens fehlgeschlagen<\/p><p><strong>Wir empfehlen, Jetpack zu verbinden.<\/strong><\/p>","severity":"critical","action":"https:\/\/wildblueten.de\/wp-admin\/admin.php?page=jetpack#\/reconnect","action_label":"Jetpack jetzt erneut verbinden","show_in_site_health":true,"pass":false,"group":["default"],"type":"direct"}}
    
    

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 9 Antworten - 1 bis 9 (von insgesamt 9)
  • Fangen wir mal mit dem Website-Bericht an:

    • timezone: +02:00 – solltest du auf „Berlin“ umstellen, damit auch die Umstellung auf Winterzeit klappt.
    • wp-active-theme: name: Divi Ecommerce (diviecommerce) – wir bieten hier keinen Support zu gekauften Themes und Plugins an. Wende dich bei Fragen zum Theme an den Entwickler.
    • wp-mu-plugins: InfiniteWP – gut möglich, dass durch die „Fernsteuerung“ die Aktualisierungen beeinträchtigt werden. Ich kann dir zu Bezahldiensten keine Hilfe anbieten. Frag bei InifinitWP nach.
    • Borlabs Cookie, Germanized for WooCommerce Pro, WP Rocket, … – wir bieten hier keinen Support zu gekauften Themes und Plugins an. Wende dich bei Fragen zum Theme an den Entwickler.
    • Jetpack – entspricht nicht den europäischen Datenschutzvorgaben (DSGVO) und sollte deshalb nicht verwendet werden.
    • memory_limit: 512M – könnte mit Blick auf die zahlreichen, ressourcenhungrigen Plugins etwas knapp werden.
    • Die Seite, für die ich Hilfe brauche: http://n.a.%20lokale%20Entwicklung – da wir dir schlecht über die Schulter schauen können, lässt sich das schwer beurteilen.

    Wahrscheinlich hast du bessere Aussichten auf eine Lösung des Problems, wenn du einen Dienstleister hinzuziehst. Da wir hier keinen Support für gekaufte Themes und Plugins anbieten, habe ich außerdem den Status des Thread auf „keine Support-Frage“ geändert.

    Thread-Ersteller jessicawb

    (@jessicawb)

    Hallo Bego Mario Garde,

    lieben Dank für deine Antwort und die Hinweise. Dann werde ich die einzelnen Entwickler direkt kontaktieren.
    Wie kann ich das Memory Limit anpassen/vergrößern?

    Lieben Dank und viele Grüße
    Jessica

    Du hast nicht weiter beschrieben, auf welchem Webserver die Website läuft. Deshalb kann ich nur sehr pauschal antworten, dass das Memory-Limit über die php.ini festgelegt wird. vgl. https://www.php.net/manual/de/ini.core.php#ini.memory-limit

    Thread-Ersteller jessicawb

    (@jessicawb)

    Die Seite läuft über raidboxes. Dort habe ich diese Einstellung nun auch gefunden und auf 1024mb hochgesetzt. Mehr geht nicht.

    Die Seite läuft über raidboxes.

    Soviel zu „Die Seite, für die ich Hilfe brauche: http://n.a./lokale/Entwicklung„. ¯\_(ツ)_/¯

    … und auf 1024mb hochgesetzt

    Das ist doppelt soviel Arbeitsspeicher als vorher.

    Thread-Ersteller jessicawb

    (@jessicawb)

    Ich entnehme deiner Antwort, dass der Arbeitsspeicher mit 1024mb zu viel ist, richtig?

    Was möchtest du mit mir „soviel zu „Die Seite, für dich ich Hilfe brauche:“…sagen?
    Die Seite ist noch nicht öffentlich, da sie noch im Aufbau ist. Daher kann ich auch auf nichts verlinken.

    Ich entnehme deiner Antwort, dass der Arbeitsspeicher mit 1024mb zu viel ist, richtig?

    Nein, wieso? Zuviel Arbeitsspeicher gibt es sowieso nicht (wobei die Performance der Website leiden kann, wenn es zuviele Skripte gibt, die zum Rendern der Webseite ausgeführt werden müssen).

    Mein Hinweis, dass 1024 MB immerhin das doppelte von vorher genutzten 512 MB sind bezog sich auf die Aussage „Mehr geht nicht.“.

    Die Seite ist noch nicht öffentlich, da sie noch im Aufbau ist. Daher kann ich auch auf nichts verlinken.

    Das ist ja auch OK, aber eine Website bei Raidboxes ist nicht das gleiche wie eine „lokale Entwicklung“. Beim einen betreibt der Webhoster den Server, bei einer lokalen Entwicklung hast du eine Serversoftare auf deinem Computer/Mac installiert.

    Es geht einfach darum, dass wir gerne helfen, dabei aber auf die Informationen angewiesen sind, die wir bekommen. Wenn ich dir bei einer „lokalen Entwicklung“ Tipps gebe, in welcher Datei du den Arbeitsspeicher erweitern kannst, du aber tatsächlich WordPress bein einem Webhoster installiert hast, reden wir zwangsläufig aneinander vorbei.

    Hallo @jessicawb,

    denn Hintergrund-Updates funktionieren nicht und das zieht einen riesigen Rattenschwanz an Problemen mit sich.

    Inwiefern? Du kannst alles doch auch manuell aktualisieren …

    … was ich persönlich eh für die bessere Methode halte, da man zuvor ein Backup anlegen und nach den Updates die Website auf – möglicherweise durch Updates verursachte – Fehler prüfen kann. Solche Fehler lassen sich zudem dann besser eingrenzen und es ist eher nachvollziehbar, welche Updates ursäclich in Frage kommen.

    Aber ich vermute, auch manuelle Updates funktionieren nicht?

    Fehler Ein Plugin hat Aktualisierungen verhindert, indem es wp_version_check() deaktiviert hat.
    Abgeschlossen Es wurde kein Versionskontrollsystem gefunden.
    Abgeschlossen Deine Installation von WordPress benötigt keine FTP-Zugangsdaten, um Updates durchzuführen.
    Fehler Einige Dateien sind für WordPress nicht beschreibbar:

    Ich denke, das Plugin „WP Hide & Security Enhancer“ verursacht diese Fehler. Du könntest es testweise deaktivieren UND Caches löschen (Browser und WP Rocket), teste ob die URLs nicht mehr versteckt/umgeschrieben werden und dann schau, ob die Fehler weiterhin auftauchen.

    @pixolin
    als ergändzende Info: Infinite WP hat keinen Einfluss darauf, das kann ich aus eigenen Erfahrungen ausschließen. Infinite WP selbst ist ein kostenloses Plugin, die Addons kosten.

    Die zweite Zeile im mu-plugin ist von WP Hide & Security

    Thread-Ersteller jessicawb

    (@jessicawb)

    Hallo zusammen,

    ein kurzes Update zu meiner Fragestellung. Es konnte alles geklärt und die „Fehler“ behoben werden. Ich habe mich mit Raidboxes direkt in Verbindung gesetzt und folgendes in Erfahrung bringen können:

    Bei raidboxes wird die WordPress-Aktualisierung aus Sicherheitsgründen über das Dashboard ausgespielt. Auch ist der WordPress-Core schreibgeschützt. Das heißt die Fehlermeldung zu den Hintergrundupdates und der WordPress-Versions-Check kann ignoriert werden.

    Die anderen Fehler konnte ich durch kurzfristige Deaktivierung des Passwortschutzes auf der Seite beheben.

    Danke allen, die hier Tipps gegeben haben.
    Viele Grüße
    Jessica

Ansicht von 9 Antworten - 1 bis 9 (von insgesamt 9)