Support » Allgemeine Fragen » Home Seite kommt anstatt angefragte Seite

  • Gelöst riccivform

    (@riccivform)


    Hallo zusammen

    Ich habe seit ich gestern 14 Plugins geupdated habe das Problem, dass bei einer Seite von einem Kunden von mir (alte Website), WordPress ständig nicht richtig weiter leitet.

    Sprich egal ob ich im Dashboard (eingeloggt) oder als Gast auf der Website mich bewege oder sogar eine direkte URL eingebe, ich lande ca. jedes dritte Mal auf der Homeseite statt dort wo ich hin will.

    Geht einfach auf den Link (http://www.maharana.ch/menu-category/menu/) oder klickt auf den

    Ich bin für jede Hilfe dankbar

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 7 Antworten - 1 bis 7 (von insgesamt 7)
  • Hallo,
    wenn du in die developer console von Firefox (Aufruf mit F12) schaust, siehst du, dass im Zusammenhang mit dem verwendeten Theme („Dine & Drink“) ein Fehler erscheint (…/wp-content/themes/dine-and-drink/js/superfish.js?ver=5.7:64.).
    Es könnte also sein, dass das Problem mit dem Theme zusammenhängt. Insofern wäre es sinnvoll, wenn du zunächst ein anderes (evtl. Standard-)Theme aktivierst und da testest, ob das Problem weiterhin besteht.
    Wir können dir bei gekauften Themes (hier „Dine & Drink“) oder Plugins so gut wie gar nicht helfen, weil sie uns nicht zur Verfügung stehen. Wir müssten sonst bei jeder Frage erst einmal das passende Theme oder Plugin kaufen, uns dort einarbeiten und dann kostenlos den Support anbieten, für den du beim Kauf eigentlich bezahlt hast. Du solltest dich in dem Fall an den Entwickler wenden. Lies bitte auch mal in der FAQ (B 5.) zu diesem Thema.
    Viele Grüße
    Hans-Gerd

    Thread-Ersteller riccivform

    (@riccivform)

    Hallo Hans-Gerd

    Vielen Dank für deine Analyse und Antwort!

    Ich habe soeben zuerst das Plugin „Multiple Themes“ deaktiviert und dann ein Standardtheme aktiviert und es hat das Problem leider nicht behoben.

    Falls diese Info hilft:
    Wie gesagt passiert dies ja nicht nur auf der Website sondern im ganzen Backoffice.
    Als Beispiel habe ich vorhin ein Produkt bearbeitet, dann auf „Aktualisieren“ gedrückt und wurde dann auf die Error Seite geleitet. Manchmal kommt diese Error Seite, manchmal eine 404 Seite und manchmal einfach die Homeseite.
    https://prnt.sc/10m5w68

    An der Stelle möchte ich fragen ob es eine Möglichkeit gibt die Seite auf den Stand von vor den Updates (vorgestern) zurückzusetzen? Denn das Problem habe ich erst seit den Updates diverser Plugins und dem WordPress Update.

    Danke schon im Voraus für Antworten

    Hallo,
    Plugins kannst du z. B. mit dem Plugin „WP Rollback“ erreichen – einen entsprechenden Beitrag zu der Anwendung findest du in meinem folgenden Beitrag.
    Allerdings stellt das keine dauerhafte Lösung dar – das sollte dir schon klar sein. Du solltest also mehr Zeit in die Analyse des Problems investieren:
    Es könnte evtl. auch sein, dass das Problem durch einen Konflikt zwischen Plugins verursacht wird.
    Du kannst ja mal nach einer Sicherung das plugin Health Check & Troubleshooting installieren. Wenn du auf den Button „Problembehandlungsmodus aktivieren“ unter Problembehandlung klickst, werden alle plugins deaktiviert und als Standardtheme (wenn vorhanden) twenty twenty oder Twenty Twenty-One aktiviert. Dann kannst du sehen, ob die beschriebenen Probleme noch weiterhin auftauchen. Aktiviere dann Plugin für Plugin im Problembehandlungsmodus und schaue jeweils nach Aktivierung eines Plugins, ob das Problem noch besteht. Auf diese Weise kannst du möglicherweise ein Plugin finden, dass das Problem verursacht. Vorteil dabei ist, dass die Webseite weiter mit allen Infos und plugins für Besucher zu sehen ist, während nur für dich alle plugins deaktiviert sind.
    Lies dir dazu bitte auch mal die Informationen in dem Beitrag zu Health Check durch.
    Außerdem wundere ich mich, dass du kein Backup vor dem Updaten der Webseite von deinem Kunden erstellt hast.
    Viele Grüße
    Hans-Gerd

    Thread-Ersteller riccivform

    (@riccivform)

    Hallo Hans-Gerd

    Vielen Dank für die wertvollen Tipps.

    Ich habe den Health Check installiert und will den durch gehen.
    Doch leider ist es aktuell so schlimm geworden dass die Website praktisch nicht mehr funktioniert (kommt nur noch die Home Seite) und dass ich im Backoffice nur noch die oberen Reiter bedienen kann, alle auf der Seite (inkl. Plugins) führen immer auf die Home Seite, was die ganze Situation um einiges schwieriger macht.
    Irgendwas läuft hier ganz schief und ich habe keine Ahnung was ich tun kann…

    Ja daraus lerne ich definitiv und in Zukunft wird nur noch mit Backup gearbeitet.

    Ich denke ich suche nun einen Profi für solch eine Angelegenheit und schaue ob jemand das Problem lösen kann.

    Lg Riccardo

    Hallo,
    sonst kommt noch die folgende Lösung in Frage:

    1. Lade den Ordner plugins per FTP auf deinen lokalen Rechner.
    2. Benenne auf dem Server per FTP den Ordner plugins um in plugins.old.
    3. Dann legst du einen Ordner plugins wieder neu an.
    4. Jetzt testest du mal, ob du dich wieder anmelden kannst und auf das dashboard zugreifen kannst.
    5. Dann kopierst du aus dem Ordner plugins.old auf dem Server einzeln die jeweiligen Ordner wieder in den Ordner plugins auf dem Server.
    6. Nachdem du jeweils einen Ordner kopierst hast, testest du, ob die Seite funktioniert.
    7. Sollte es funktionieren, kopierst du den nächsten Ordner. Sollte es nicht funktionieren, löschst du den gerade kopierten Ordner wieder. Das ist dann das plugin, das Probleme macht.
    8. Danach setzt du den Vorgang (Schritt 5. – 7.) solange fort, bis du alle Ordner kopiert hast.

    Weitergehende Informationen findest du hier: https://de.wordpress.org/support/topic/wie-deaktiviert-man-alle-plugins-ohne-adminzugang/
    Viele Grüße
    Hans-Gerd

    Thread-Ersteller riccivform

    (@riccivform)

    Hallo Hans-Gerd

    Vielen Dank für deine Hilfe!

    Ich habe nun jemanden engagiert der das Problem erstaunlich schnell lösen konnte.

    Er meinte es war ein Problem in den Permalink Einstellungen.

    Ich wünsche eine gute Woche und setze den Beitrag als gelöst.

    Lg Riccardo

    Hallo,
    freut mich, dass es geklappt hat und danke für die Info 😀
    Viele Grüße
    Hans-Gerd

Ansicht von 7 Antworten - 1 bis 7 (von insgesamt 7)