Support » Installation » Home/Site URL verschieden: Beitrag speichern geht nicht/REST API geht nicht

  • Hallo!
    1) Ich habe einen Webspace wo WP installiert ist und die Verwaltung stattfindet und auch die Seiten laufen und auch MySQL: http://subdomain.domain.at
    2) Dann habe ich eine Domain die dorthin als Frame umgeleitet ist: http://anderedomain.at
    Dort soll der Enduser hin.
    Das funktioniert auch alles.
    Ich habe eine Home-URL und eine Site-URL.

    ABER, wenn die beiden unterschiedlich sind wie beschrieben, kann man keine Beiträge mehr speichern/veröffentlichen und einige Plugins gehen nicht mehr „Problem Connect to WordPress REST API“.
    Wenn ich die beiden URL gleich schalte, also beide auf die WP-Installation, dann geht alles.
    Das will ich aber nicht, denn der Enduser soll ja nur die 2.) URL sehen.
    Was kann ich hier tun?

Ansicht von 4 Antworten - 1 bis 4 (von insgesamt 4)
  • Was meinst du mit „Dann habe ich eine Domain die dorthin als Frame umgeleitet ist“? Ist das eine Multisite mit Domain-Mapping?

    Was meinst du mit „Ich habe eine Home-URL und eine Site-URL.“
    Das sollte jede WordPress-Installation haben (Einstellungen > Allgemein) oder hast du einen Eintrag in der wp-config.php vorgenommen? Welchen? Warum?

    ABER, wenn die beiden unterschiedlich sind wie beschrieben … 

    … wo wird das beschrieben? Die beiden URLs sollten nur dann unterschiedlich sein, wenn du die WordPress-Dateien in einem Unterverzeichnis liegen hast.

    Problem Connect to WordPress REST API

    Das wird ein Ergebnis fehlerhafter URL-Einstellungen sein.

    Wenn ich die beiden URL gleich schalte, also beide auf die WP-Installation, dann geht alles.

    Genau. Die andere Einstellung ist falsch.

    Das will ich aber nicht, denn der Enduser soll ja nur die 2.) URL sehen.

    Beschreib doch nochmal, was du mit „als Frame umgeleitet“ meinst. Ich glaube, hier gibt es einfach ein Missverständnis.

    Hi!
    Danke mal, dass sich jemand dem Problem annimmt 🙂
    Ich versuchs nochmal…
    Also ich habe eine Domain mit Webspace, dort ist alles installiert.
    Zusätzlich habe ich eine „Domain Only“, da gibt es keinen Webspace, die wird nur redirected zur Webspace-Seite.
    Damit der Enduser die umgeleitete nicht sieht, wir das als Frame umgeleitet, d.h. in „enduserdomain.at“ wird eingentlich „wpdomain.at“ angezeigt.
    Nichts ungewöhnliches…
    In „WordPress-Adresse (URL)“ steht die WP-Domain in „Website-Adresse (URL)“ die Enduser-url.
    Das funktioneirt auch wunderbar, alle Seiten, Bilder und Beiträge werden korrekt umgeleitet und vorallem alle permalinks zeigen auf die enduser-domain.

    Aber irgendwie gehen gewisse Dinge nicht mehr in der Verwaltung/Bearbeitung, es scheint es wird dazu nicht die WP-URL verwendet sondern die Site-URL…!?
    Kaum stelle ich temporär die Site-Url gleich, geht alles.
    Womit der Enduser aber falsche/unerwünschte Permnalinks bekommt.

    Ich kann mit der Aussage „als Frame umgeleitet“ nichts anfangen.
    Entweder stellst du eine WordPress-Website in einem iFrame dar, dann müssen aber trotzdem die Einstellungen der URL auf die Installation verweisen. Oder du machst eine Weiterleitung (301-Permanent Redirect), wobei die „enduserdomain“ auf die WordPress-Website weiterleitet – auch hier müssen also die URLs der WordPress-Version „wpdomain.at“ sein (um bei den von dir gewählten Begriffen zu bleiben).

    Was du alternativ machen kannst, ist ein Domain-Mapping einer Website in einer WordPress Multisite-Installation. Eine ausführliche (englische) Beschreibung findest du hier: https://premium.wpmudev.org/blog/domain-mapping-wordpress-multisite/

    Für einfache (Nicht-Multisite) WordPress-Installationen ist ein Domain-Mapping eigentlich nicht vorgesehen. Ggf. lässt sich das mit dem Plugin Multiple Domain Mapping on Single Site einrichten, wobei das Plugin eingentlich dafür gedacht ist, bestimmte Seiten zu mappen.

    Ja, so ist es – es wird eine domain als iframe an ein ziel weitergeleitet, darauf hab ich keinen einfluss, ist ein service des hostproviders.
    somit steht im browser imnmer die richtige adresse, dargestellt wird aber der content von der wp-seite/domain.
    das ist ja eine üblich vorgangsweise und funktioniert auch.
    jetzt gibt es aber die permalinks, die würden ja dann alle auf die wp-domain zeigen und nicht auf die enduser-domain.
    wenn man also die „Website-URL“ auf die enduser-domain stellt, dann funktioniert sogar das, also alle beiträge haben einen link innerhalb der enduser-domain und finden immer zum richtigen ziel.
    und ich hätte gemeint so ist das ja auch gedacht – es gibt eine url für die verwaltung und bei bedarf eine andere wo die site angezeigt wird.
    geht ja auch, nur gehen ganz gewisse dinge nicht mehr.
    ist für mich also nicht logisch, denn wenn es nur verschiedene unterverzeichnisse sein dürfen die sich unterscheiden, warum ist es dann eine voll URL und warum greift die enduser-url auf die verwaltungs-funktionen?

    ich probier mal das plugin…
    danke mal!

Ansicht von 4 Antworten - 1 bis 4 (von insgesamt 4)