Support » Allgemeine Fragen » Homepage lässt sich nicht festlegen

  • Gelöst fbien

    (@fbien)


    Hi zusammen,

    ich habe eine WP-Installation neu aufgesetzt und das Theme „Uncode“ installiert. Nach dem Aufsetzen einiger Inhalte und Designs habe ich nun das Problem, die Homepage nicht über den gewohnten Weg (Einstellungen -> Lesen -> Statische Seite) einrichten zu können. Die Einstellung wird zwar gespeichert, aber wenn ich anschließend die Domain ansurfe, leitet der Browser direkt auf das nicht vorhandene Verzeichnis http://www.meinedomain.de/de/ weiter, was entsprechend zu einer 404-Seite führt.

    Das Problem habe ich erst einmal dem Support des Theme-Anbieters geschildert. Die haben daraufhin im Backend herumgespielt, alle Plugins und letztendlich auch das Theme deaktiviert und festgestellt, dass das Problem weiterhin auftritt. Somit sind sie raus (liegt ja nicht am Theme) und können nicht weiterhelfen. Seitdem hat sich der „Fehler“ allerdings verändert: Jetzt leitet der Browser mich konsequent auf eine der angelegten Seiten (www.meinedomain.de/demo) – egal, welche Seite unter Einstellungen -> Lesen als Homepage festgelegt ist.

    Hat jemand eine Idee, woran das liegen könnte? Der Theme-Support hat geraten WP neu zu installieren… was ich allerdings gern vermeiden würde, wenn irgendwie möglich.

    Vielleicht hat ja jemand eine Idee – würde mich riesig freuen! 🙂

    Danke im Voraus & beste Grüße!

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 10 Antworten - 1 bis 10 (von insgesamt 10)
  • Hallo,
    ich gehe mal davon aus, dass du bereits unter Einstellungen > Allgemein die WordPress-Adresse (URL) und Website-Adresse (URL) geprüft hast und da die entsprechenden Angaben ohne „demo“ stehen.

    Du findest unter Werkzeuge > Websitezustand > Info einen Bericht zur Website. Warte bitte einen Moment bis die Ladeanzeige ganz oben abgeschlossen ist und kopiere dann per Button den Website-Bericht in deine Zwischenablage. Über den Button „Bericht in die Zwischenablage kopieren“ kannst du den Bericht unverändert (bitte mit den Akzentzeichen am Anfang und Ende) einfügen und anschließend hier posten. Evtl. ergeben sich dann weitere Anhaltspunkte, ob und wo das Problem liegt.

    Hier allerdings noch der Hinweis: Wir können dir bei gekauften Themes (hier Uncode) oder Plugins so gut wie gar nicht helfen, weil sie uns nicht zur Verfügung stehen. Wir müssten sonst bei jeder Frage erst einmal das entsprechende Theme oder Plugin kaufen, uns dort einarbeiten und dann kostenlos den Support anbieten, für den du beim Kauf eigentlich bezahlt hast. Lies bitte auch mal in der FAQ II, 1b zu diesem Thema.

    Vielleicht wäre es auch sinnvoll, wenn du selbst mal ein Standardtheme wie z. B. Twenty Twenty aktivierst, um mal zu sehen, ob das Problem tatsächlich dann auch weiterhin auftaucht.

    Viele Grüße
    Hans-Gerd

    Moderator Bego Mario Garde

    (@pixolin)

    Zusätzlich zum Website-Bericht wären auch noch die Inhalte der wp-config.php und .htaccess interessant. (Bitte vor dem Absenden die Zugangsdaten und SALT-Keys aus der Antwort löschen.) Auch ggf. bereits vorgenommene Modifikationen wären wichtig.

    Thread-Ersteller fbien

    (@fbien)

    Hallo zusammen,

    danke für eure Antworten. Den Test mit Twenty Twenty habe ich schon gemacht. Es scheint also tatsächlich nicht am Theme zu liegen.

    Ich kopiere im Folgenden den Zustandsbericht, die htaccess und die wp-config. Zugangsdaten und Keys sind ge-x’t. Mir ist gerade direkt die erste Passage in der htaccess aufgefallen. Darin taucht das besagt /de/-Verzeichnis auf. Kann die verantwortlich sein? Danke für eure Tipps!

    Hier der Zustandsbericht:

    
    ### wp-core ###
    
    version: 5.9.3
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Berlin
    permalink: /%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: open
    environment_type: production
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /var/www/vhosts/dqfcevfr.host263.checkdomain.de/like2like.de
    wordpress_size: 49,85 MB (52274336 bytes)
    uploads_path: /var/www/vhosts/dqfcevfr.host263.checkdomain.de/like2like.de/wp-content/uploads
    uploads_size: 19,23 MB (20161405 bytes)
    themes_path: /var/www/vhosts/dqfcevfr.host263.checkdomain.de/like2like.de/wp-content/themes
    themes_size: 28,37 MB (29747506 bytes)
    plugins_path: /var/www/vhosts/dqfcevfr.host263.checkdomain.de/like2like.de/wp-content/plugins
    plugins_size: 115,06 MB (120651900 bytes)
    database_size: 12,64 MB (13254656 bytes)
    total_size: 225,15 MB (236089803 bytes)
    
    ### wp-active-theme ###
    
    name: Uncode (uncode)
    version: 2.6.0
    author: Undsgn
    author_website: http://www.undsgn.com
    parent_theme: none
    theme_features: core-block-patterns, automatic-feed-links, title-tag, post-thumbnails, custom-logo, custom-header, menus, html5, post-formats, custom-background, infinite-scroll, align-wide, widgets, editor-style
    theme_path: /var/www/vhosts/dqfcevfr.host263.checkdomain.de/like2like.de/wp-content/themes/uncode
    auto_update: Deaktiviert
    
    ### wp-themes-inactive (4) ###
    
    Twenty Twenty: version: 1.9, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    Twenty Twenty-One: version: 1.5, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    Twenty Twenty-Two: version: 1.1, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    Uncode Child: version: 1.0.0, author: Undsgn™, Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-active (6) ###
    
    Duplicate Page: version: 4.4.8, author: mndpsingh287, Automatische Aktualisierungen deaktiviert
    Forminator: version: 1.15.12, author: WPMU DEV, Automatische Aktualisierungen deaktiviert
    Uncode Core: version: 2.6.0, author: Undsgn, Automatische Aktualisierungen deaktiviert
    Uncode Wireframes: version: 1.4.0, author: Uncode, Automatische Aktualisierungen deaktiviert
    Uncode WPBakery Page Builder: version: 6.8.0, author: Michael M - WPBakery.com, Automatische Aktualisierungen deaktiviert
    WPBakery Page Builder Clipboard: version: 5.0.2, author: bitorbit, Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-inactive (9) ###
    
    Akismet Anti-Spam: version: 4.2.2, author: Automattic, Automatische Aktualisierungen deaktiviert
    Dave's WordPress Live Search (4.8.1): version: 1.0.4, author: Dave Ross, Automatische Aktualisierungen deaktiviert
    Hello Dolly: version: 1.7.2, author: Matt Mullenweg, Automatische Aktualisierungen deaktiviert
    LayerSlider: version: 7.0.7, author: Kreatura Media, Automatische Aktualisierungen deaktiviert
    Slider Revolution: version: 6.5.19, author: ThemePunch, Automatische Aktualisierungen deaktiviert
    Uncode Privacy: version: 2.2.1, author: Undsgn, Automatische Aktualisierungen deaktiviert
    Under Construction: version: 3.92, author: WebFactory Ltd (latest version: 3.93), Automatische Aktualisierungen deaktiviert
    Userlike: version: 2.1, author: David Voswinkel <david.voswinkel@userlike.com>, Automatische Aktualisierungen deaktiviert
    VC Particles Background: version: 1.3, author: Boom-Apps, Automatische Aktualisierungen deaktiviert
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1690
    imagemagick_version: ImageMagick 6.9.10-68 Q16 x86_64 2021-02-24 https://imagemagick.org
    imagick_version: 3.7.0
    file_uploads: File uploads is turned off
    post_max_size: 128M
    upload_max_filesize: 128M
    max_effective_size: 128 MB
    max_file_uploads: 20
    imagick_limits: 
    	imagick::RESOURCETYPE_AREA: 80 GB
    	imagick::RESOURCETYPE_DISK: 9.2233720368548E+18
    	imagick::RESOURCETYPE_FILE: 49152
    	imagick::RESOURCETYPE_MAP: 80 GB
    	imagick::RESOURCETYPE_MEMORY: 40 GB
    	imagick::RESOURCETYPE_THREAD: 1
    imagemagick_file_formats: 3FR, 3G2, 3GP, AAI, AI, ART, ARW, AVI, AVS, BGR, BGRA, BGRO, BMP, BMP2, BMP3, BRF, CAL, CALS, CANVAS, CAPTION, CIN, CIP, CLIP, CMYK, CMYKA, CR2, CRW, CUR, CUT, DATA, DCM, DCR, DCX, DDS, DFONT, DNG, DOT, DPX, DXT1, DXT5, EPDF, EPI, EPS, EPS2, EPS3, EPSF, EPSI, EPT, EPT2, EPT3, ERF, EXR, FAX, FILE, FITS, FRACTAL, FTP, FTS, G3, G4, GIF, GIF87, GRADIENT, GRAY, GRAYA, GROUP4, GV, H, HALD, HDR, HISTOGRAM, HRZ, HTM, HTML, HTTP, HTTPS, ICB, ICO, ICON, IIQ, INFO, INLINE, IPL, ISOBRL, ISOBRL6, J2C, J2K, JNG, JNX, JP2, JPC, JPE, JPEG, JPG, JPM, JPS, JPT, JSON, K25, KDC, LABEL, M2V, M4V, MAC, MAGICK, MAP, MASK, MAT, MATTE, MEF, MIFF, MKV, MNG, MONO, MOV, MP4, MPC, MPEG, MPG, MRW, MSL, MSVG, MTV, MVG, NEF, NRW, NULL, ORF, OTB, OTF, PAL, PALM, PAM, PANGO, PATTERN, PBM, PCD, PCDS, PCL, PCT, PCX, PDB, PDF, PDFA, PEF, PES, PFA, PFB, PFM, PGM, PGX, PICON, PICT, PIX, PJPEG, PLASMA, PNG, PNG00, PNG24, PNG32, PNG48, PNG64, PNG8, PNM, PPM, PREVIEW, PS, PS2, PS3, PSB, PSD, PTIF, PWP, RADIAL-GRADIENT, RAF, RAS, RAW, RGB, RGBA, RGBO, RGF, RLA, RLE, RMF, RW2, SCR, SCT, SFW, SGI, SHTML, SIX, SIXEL, SPARSE-COLOR, SR2, SRF, STEGANO, SUN, SVG, SVGZ, TEXT, TGA, THUMBNAIL, TIFF, TIFF64, TILE, TIM, TTC, TTF, TXT, UBRL, UBRL6, UIL, UYVY, VDA, VICAR, VID, VIFF, VIPS, VST, WBMP, WMF, WMV, WMZ, WPG, X, X3F, XBM, XC, XCF, XPM, XPS, XV, XWD, YCbCr, YCbCrA, YUV
    gd_version: bundled (2.1.0 compatible)
    gd_formats: GIF, JPEG, PNG, WebP, BMP, XPM
    ghostscript_version: 9.25
    
    ### wp-server ###
    
    server_architecture: Linux 3.10.0-962.3.2.lve1.5.60.el7.x86_64 x86_64
    httpd_software: Apache
    php_version: 7.4.28 64bit
    php_sapi: fpm-fcgi
    max_input_variables: 8192
    time_limit: 900
    memory_limit: 128M
    admin_memory_limit: 256M
    max_input_time: 900
    upload_max_filesize: 128M
    php_post_max_size: 128M
    curl_version: 7.29.0 NSS/3.53.1
    suhosin: false
    imagick_availability: true
    pretty_permalinks: true
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.7.33
    client_version: mysqlnd 7.4.28
    max_allowed_packet: 33554432
    max_connections: 500
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /var/www/vhosts/dqfcevfr.host263.checkdomain.de/like2like.de/wp-content
    WP_PLUGIN_DIR: /var/www/vhosts/dqfcevfr.host263.checkdomain.de/like2like.de/wp-content/plugins
    WP_MEMORY_LIMIT: 96M
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_ENVIRONMENT_TYPE: Nicht definiert
    DB_CHARSET: utf8mb4
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    

    Hier die .htaccess:

    
    RewriteEngine On
    
    # Deutsch
    RewriteCond %{HTTP:Accept-Language} ^((?!en).)*de.*$ [NC]
    RewriteRule ^$ http://%{HTTP_HOST}/de/ [QSA,L]
    
    # English
    RewriteCond %{HTTP:Accept-Language} ^((?!de).)*en.*$ [NC]
    RewriteRule ^$ http://%{HTTP_HOST}/en/ [QSA,L]
    
    # Default Language (de)
    RewriteCond %{HTTP:Accept-Language} !^.*(de|en).*$ [NC]
    
    # BEGIN WordPress
    # Die Anweisungen (Zeilen) zwischen „BEGIN WordPress“ und „END WordPress“ sind
    # dynamisch generiert und sollten nur über WordPress-Filter geändert werden.
    # Alle Änderungen an den Anweisungen zwischen diesen Markierungen werden überschrieben.
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    <IfModule>
    
    # END WordPress

    Hier die wp-config:

    <?php
    /**
     * Grundeinstellungen für WordPress
     *
     * Diese Datei wird zur Erstellung der wp-config.php verwendet.
     * Du musst aber dafür nicht das Installationsskript verwenden.
     * Stattdessen kannst du auch diese Datei als „wp-config.php“ mit
     * deinen Zugangsdaten für die Datenbank abspeichern.
     *
     * Diese Datei beinhaltet diese Einstellungen:
     *
     * * Datenbank-Zugangsdaten,
     * * Tabellenpräfix,
     * * Sicherheitsschlüssel
     * * und ABSPATH.
     *
     * @link https://wordpress.org/support/article/editing-wp-config-php/
     *
     * @package WordPress
     */
    
    // ** Datenbank-Einstellungen - Diese Zugangsdaten bekommst du von deinem Webhoster. ** //
    /**
     * Ersetze datenbankname_hier_einfuegen
     * mit dem Namen der Datenbank, die du verwenden möchtest.
     */
    define( 'DB_NAME', 'xxx' );
    
    /**
     * Ersetze benutzername_hier_einfuegen
     * mit deinem Datenbank-Benutzernamen.
     */
    define( 'DB_USER', 'xxx' );
    
    /**
     * Ersetze passwort_hier_einfuegen mit deinem Datenbank-Passwort.
     */
    define( 'DB_PASSWORD', 'xxx' );
    
    /**
     * Ersetze localhost mit der Datenbank-Serveradresse.
     */
    define( 'DB_HOST', 'localhost' );
    
    /**
     * Der Datenbankzeichensatz, der beim Erstellen der
     * Datenbanktabellen verwendet werden soll
     */
    define( 'DB_CHARSET', 'xxx' );
    
    /**
     * Der Collate-Type sollte nicht geändert werden.
     */
    define( 'DB_COLLATE', '' );
    
    /**#@+
     * Sicherheitsschlüssel
     *
     * Ändere jeden untenstehenden Platzhaltertext in eine beliebige,
     * möglichst einmalig genutzte Zeichenkette.
     * Auf der Seite {@link https://api.wordpress.org/secret-key/1.1/salt/ WordPress.org secret-key service}
     * kannst du dir alle Schlüssel generieren lassen.
     *
     * Du kannst die Schlüssel jederzeit wieder ändern, alle angemeldeten
     * Benutzer müssen sich danach erneut anmelden.
     *
     * @since 2.6.0
     */
    define( 'AUTH_KEY',         'xxx' );
    define( 'SECURE_AUTH_KEY',  'xxx' );
    define( 'LOGGED_IN_KEY',    'xxx' );
    define( 'NONCE_KEY',        'xxx' );
    define( 'AUTH_SALT',        'xxx' );
    define( 'SECURE_AUTH_SALT', 'xxx' );
    define( 'LOGGED_IN_SALT',   'xxx' );
    define( 'NONCE_SALT',       'xxx' );
    
    /**#@-*/
    
    /**
     * WordPress Datenbanktabellen-Präfix
     *
     * Wenn du verschiedene Präfixe benutzt, kannst du innerhalb einer Datenbank
     * verschiedene WordPress-Installationen betreiben.
     * Bitte verwende nur Zahlen, Buchstaben und Unterstriche!
     */
    $table_prefix = 'wp_';
    
    /**
     * Für Entwickler: Der WordPress-Debug-Modus.
     *
     * Setze den Wert auf „true“, um bei der Entwicklung Warnungen und Fehler-Meldungen angezeigt zu bekommen.
     * Plugin- und Theme-Entwicklern wird nachdrücklich empfohlen, WP_DEBUG
     * in ihrer Entwicklungsumgebung zu verwenden.
     *
     * Besuche den Codex, um mehr Informationen über andere Konstanten zu finden,
     * die zum Debuggen genutzt werden können.
     *
     * @link https://wordpress.org/support/article/debugging-in-wordpress/
     */
    define( 'WP_DEBUG', false );
    define( 'WP_MEMORY_LIMIT', '96M' );
    
    /* Füge individuelle Werte zwischen dieser Zeile und der „Schluss mit dem Bearbeiten“ Zeile ein. */
    
    /* Das war’s, Schluss mit dem Bearbeiten! Viel Spaß. */
    /* That's all, stop editing! Happy publishing. */
    
    /** Der absolute Pfad zum WordPress-Verzeichnis. */
    if ( ! defined( 'ABSPATH' ) ) {
    	define( 'ABSPATH', __DIR__ . '/' );
    }
    
    /** Definiert WordPress-Variablen und fügt Dateien ein.  */
    require_once ABSPATH . 'wp-settings.php';


    Moderationshinweis: Bitte Code nicht in Blockquotes packen – die sind für Zitate gedacht, sorgen bei Code aber dafür, dass dein Beitrag in der Moderations-Warteschlange feststeckt.

    Moderator Bego Mario Garde

    (@pixolin)

    Mir ist gerade direkt die erste Passage in der htaccess aufgefallen. Darin taucht das besagt /de/-Verzeichnis auf. Kann die verantwortlich sein?

    Ja. Hast du vielleicht zwischenzeitlich ein Übersetzungs-Plugin installiert?
    Ich würde die Zeilen auskommentieren/löschen.

    Wieso jetzt auf demo umgeleitet wird, ist mir schleierhaft. Gibt es dazu vielleicht eine Einstellung im Kundenmenü des Webhosters? Wird auch umgeleitet, wenn alle Plugins deaktiviert werden?

    Ggf. wäre noch der Inhalt der functions.php des Themes interessant – gut möglich, dass der Support-Mitarbeiter des Theme-Entwicklers dort etwas zum Testen eingetragen und schlicht vergessen hat.

    Thread-Ersteller fbien

    (@fbien)

    Hast du vielleicht zwischenzeitlich ein Übersetzungs-Plugin installiert?

    Nein, zumindest nicht aktiv. Es wurden einige Plugins zusammen mit dem Theme installiert. Aber wenn es an denen liegen würde, hätte der Support es wissen müssen – zumindest gehe ich davon aus 😉

    Ich würde die Zeilen auskommentieren/löschen.

    Okay, also einfach rauslöschen? Welche Inhalte genau? Die drei Blöcke mit #Deutsch, #Englisch und #Default Language?

    Ich bin gespannt, ob es danach weiterhin auf die Demo-Seite umleitet. Eine entsprechende Einstellung beim Hoster gibt es nicht. Allerdings ist die Demo-Seite ohnehin nur zu Testzwecken angelegt und wird noch gelöscht. Mal sehen, was dann passiert…

    Hier noch die functions.php:

    <?php
    
    /**
     * uncode functions and definitions
     *
     * @package uncode
     */
    
    $ok_php = true;
    if ( function_exists( 'phpversion' ) ) {
    	$php_version = phpversion();
    	if (version_compare($php_version,'5.3.0') < 0) {
    		$ok_php = false;
    	}
    }
    if (!$ok_php && !is_admin()) {
    	$title = esc_html__( 'PHP version obsolete','uncode' );
    	$html = '<h2>' . esc_html__( 'Ooops, obsolete PHP version' ,'uncode' ) . '</h2>';
    	$html .= '<p>' . sprintf( wp_kses( 'We have coded the Uncode theme to run with modern technology and we have decided not to support the PHP version 5.2.x just because we want to challenge our customer to adopt what\'s best for their interests.%sBy running obsolete version of PHP like 5.2 your server will be vulnerable to attacks since it\'s not longer supported and the last update was done the 06 January 2011.%sSo please ask your host to update to a newer PHP version for FREE.%sYou can also check for reference this post of WordPress.org <a href="https://wordpress.org/about/requirements/">https://wordpress.org/about/requirements/</a>' ,'uncode', array('a' => 'href') ), '</p><p>', '</p><p>', '</p><p>') . '</p>';
    
    	wp_die( $html, $title, array('response' => 403) );
    }
    
    /**
     * Setup post data.
     */
    require_once get_template_directory() . '/core/inc/class-uncode-setup-data.php';
    
    /**
     * Load core utilities functions.
     */
    require_once get_template_directory() . '/core/inc/core-utilities.php';
    
    /**
     * Install functions.
     */
    require_once get_template_directory() . '/core/inc/install.php';
    
    /**
     * Load the main functions.
     */
    require_once get_template_directory() . '/core/inc/main.php';
    
    /**
     * Load widget functions.
     */
    require_once get_template_directory() . '/core/inc/widget-functions.php';
    
    /**
     * Load privacy functions
     */
    require_once get_template_directory() . '/core/inc/privacy.php';
    
    /**
     * Load API functions.
     */
    require_once get_template_directory() . '/core/inc/api/loader.php';
    
    /**
     * Load the admin functions.
     */
    require_once get_template_directory() . '/core/inc/admin.php';
    
    /**
     * Load the uncode export file.
     */
    require_once get_template_directory() . '/core/inc/export/uncode_export.php';
    
    /**
     * Load the color system.
     */
    require_once get_template_directory() . '/core/inc/colors.php';
    
    /**
     * Load TGM plugins activation.
     */
    require_once get_template_directory() . '/core/plugins_activation/init.php';
    
    /**
     * Load the media enhanced function.
     */
    global $wp_version;
    if ( version_compare( $wp_version, '5.3-RC', '>=' ) ) {
    	require_once( ABSPATH . WPINC . '/class-wp-oembed.php' );
    } else {
    	require_once( ABSPATH . WPINC . '/class-oembed.php' );
    }
    require_once get_template_directory() . '/core/inc/media-enhanced.php';
    
    /**
     * Load the bootstrap navwalker.
     */
    require_once get_template_directory() . '/core/inc/wp-bootstrap-navwalker.php';
    
    /**
     * Load the bootstrap navwalker.
     */
    require_once get_template_directory() . '/core/inc/uncode-comment-walker.php';
    
    /**
     * Load menu builder.
     */
    if ($ok_php) {
    	require_once get_template_directory() . '/partials/menus.php';
    }
    
    /**
     * Load header builder.
     */
    if ($ok_php) {
    	require_once get_template_directory() . '/partials/headers.php';
    }
    
    /**
     * Load elements partial.
     */
    if ($ok_php) {
    	require_once get_template_directory() . '/partials/elements.php';
    }
    
    /**
     * Custom template tags for this theme.
     */
    require_once get_template_directory() . '/core/inc/template-tags.php';
    
    /**
     * Helpers functions.
     */
    require_once get_template_directory() . '/core/inc/helpers.php';
    require_once get_template_directory() . '/core/inc/helpers/init.php';
    require_once get_template_directory() . '/core/inc/adaptive-images.php';
    
    /**
     * Customizer additions.
     */
    require_once get_template_directory() . '/core/inc/customizer.php';
    
    /**
     * Load Jetpack compatibility file.
     */
    require_once get_template_directory() . '/core/inc/jetpack.php';
    
    /**
     * Load third-party compatibility file.
     */
    require_once get_template_directory() . '/core/inc/compatibility/compatibility.php';
    
    /**
     * Deprecated functions.
     */
    require_once get_template_directory() . '/core/inc/deprecated-functions.php';
    Thread-Ersteller fbien

    (@fbien)

    Update: Wenn ich den besagten Abschnitt auskommentiere, führt das zu einem „Internal Server Error 500″… 🙁

    Moderator Bego Mario Garde

    (@pixolin)

    Es sieht nicht so aus, wie wenn in der functions.php eine Umleitungsregel angehängt wurde.

    Du kannst die .htaccess auch in .htaccess.old umbenennen und dann unter Einstellungen > Permalinks die gewünschte Struktur erneut speichern. Dabei sollte eine neue .htaccess erstellt werden.

    Thread-Ersteller fbien

    (@fbien)

    Du kannst die .htaccess auch in .htaccess.old umbenennen und dann unter Einstellungen > Permalinks die gewünschte Struktur erneut speichern. Dabei sollte eine neue .htaccess erstellt werden.

    Das habe ich soeben getan. Die neue .htaccess enthält wieder den besagten Abschnitt. ABER: Jetzt funktioniert’s! 🙂

    Wie kann das denn sein, wo die Inhalte doch gleich geblieben sind? Natürlich freue ich mich aber in erster Linie, dass das Problem behoben ist.

    Vielen Dank euch für die schnelle und gute Hilfe!

    Moderator Bego Mario Garde

    (@pixolin)

    WordPress bietet Entwicklern die Möglichkeit, eigene Inhaltstypen (Custom Post Types) zu erstellen – sowas wie „Portfolio“ oder „Products“. Damit auch für dieses Inhaltstypen die Weiterleitung funktioniert müssten aber die Permalink-Einstellungen neu eingelesen werden, was sehr häufig vergessen wird.

    In dem Moment, wo du das Menü Einstellungen > Permalinks aufrufst, werden (selbst wenn du hier gar nichts machst) ebenfalls die Permalinks neu eingelesen. Das reicht unter Umständen schon, um eine „verbogene“ Weiterleitung zurechtzubiegen.

    Freut mich, wenn’s jetzt wieder läuft.

    Thread-Ersteller fbien

    (@fbien)

    WordPress bietet Entwicklern die Möglichkeit, eigene Inhaltstypen (Custom Post Types) zu erstellen – sowas wie „Portfolio“ oder „Products“.

    Ah stimmt, das ist im Theme tatsächlich der Fall. Wieder ein Stück schlauer 🙂

    Danke vielmals!

Ansicht von 10 Antworten - 1 bis 10 (von insgesamt 10)