Ansicht von 4 Antworten – 1 bis 4 (von insgesamt 4)
  • Moderator Bego Mario Garde

    (@pixolin)

    .htaccess komplett löschen, Backend aufrufen (nicht über den Link http://deinedomain.de/wp-admin sondern über http://deinedomain.de/wp-login.php), Menü Einstellungen > Permalinks > gewünschte Einstellung (z.B: „Beitragsname“) auswählen und speichern. Dabei bitte sorgfältig prüfen ob ein Hinweis kommt, dass keine .htaccess erstellt werden konnte. In dem Fall musst Du die Datei selbst erstellen – ansonsten alles OK. Jetzt solltest Du wieder auf alle Seiten zugreifen können.

    Zum Schutz Deines Anmeldeformulars würde ich bevorzugt eine Zwei-Faktor-Autorisierung (z.B. https://wordpress.org/plugins/two-factor-auth/) oder zumindest eine Sperre bei zu häufiger Fehleingabe (z.B. https://wordpress.org/plugins/login-lockdown/) installieren.

    Thread-Starter dischue

    (@dischue)

    Das ging aber schnell! Vielen Dank, das scheint die lösung gewesen zu sein! Also im Pinzip habe ich nur die vorhandenen Einstellungen bestätigt (zunächst anderen Punkt für Permalinks markiert, dann wieder den ursprünglichen und dann auf „Anderungen speichern“) – nun scheint es zu funktionieren.
    Aber warum ist das so? Die htaccess dürfte doch an den Permalinks nichts ändern…?
    Aber Danke schon mal!!

    Moderator Bego Mario Garde

    (@pixolin)

    Permalinks funktionieren auf Apache Webservern nur mit dem Modul mod_rewrite und entsprechenden Umleitungsregeln in der .htaccess. Ohne ist nur die Startseite, nicht aber Folgeseiten erreichbar.

    Wird WordPress installiert, sind erstmal nur normale Links nach dem Muster http://domain.de/?p=123 voreingestellt, damit WordPress auch auf Servern ohne das Modul mod_rewrite funktioniert. Wechselt man nun per Einstellung zu Pretty Permalinks, trägt WordPress die notwendigen Umleitungsregeln in eine .htaccess-Datei ein. Ist keine vorhanden, versucht WordPress, diese Datei anzulegen. Je nach Serverkonfiguration/Benutzerrechten funktioniert das manchmal nicht. In diesen Fällen muss man dann selber eingreifen und die von WordPress vorgeschlagenen Umleitungsregeln in die .htaccess eintragen.

    Thread-Starter dischue

    (@dischue)

    Danke für die Erläuterung – auch wenn ich kaum etwas davon verstand…. 😉
    Da nach „ändern“ meiner Permalinks keine htaccess angelegt wurde, funktioniert das bei mir nicht? – Kann aber auch nicht sein, da die Beiträge genau in dem eingestellten Schema (http://meinblog.de/2015/07/Beispielbeitrag/) verlinkt werden.
    Wie auch immer, das ursächliche Problem scheint erstmal behoben… 😉

Ansicht von 4 Antworten – 1 bis 4 (von insgesamt 4)
  • Das Thema „htaccess entfernen bringt Fehler 404“ ist für neue Antworten geschlossen.