Support » Allgemeine Fragen » HTML 500, Menü weg nur noch Hauptseite erreichbar

  • Gelöst steved84

    (@steved84)


    Hallo,

    auf meiner Website ist nur noch die Hauptseite erreichbar.
    Das Menü ist komplett weg und alle Unterseiten lassen sich nicht mehr aufrufen.
    Mögliche fehlerhafte Plugins habe ich bereits deaktiviert.
    Alle Unterseiten verweisen per Canonical Link oder per Redirect auf die Startseite.

    Hat jemand einen Tip?

    Danke

    Steve

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 14 Antworten - 1 bis 14 (von insgesamt 14)
  • Mit dem eingeschalteten Maintenance-Mode können wir uns bei der Website nichts anschauen. Kommst du noch ins Backend? Dann wäre ein Bericht zur Website hilfreich: Geh bitte auf Werkzeuge > Website-Zustand > Bericht, klick auf den Button und füge den Bericht mit Strg-V unverändert in deine Antwort ein.

    Thread-Starter steved84

    (@steved84)

    Ja hab noch Zugriff aufs Backend.
    Wartungsseite ist deaktiviert.
    Hier der Bericht….

    
    ### wp-core ###
    
    version: 5.7.1
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Berlin
    permalink: /%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: undefined
    environment_type: production
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /home/www/public_html/wordpress
    wordpress_size: loading...
    uploads_path: /home/www/public_html/wordpress/wp-content/uploads
    uploads_size: loading...
    themes_path: /home/www/public_html/wordpress/wp-content/themes
    themes_size: loading...
    plugins_path: /home/www/public_html/wordpress/wp-content/plugins
    plugins_size: loading...
    database_size: loading...
    total_size: loading...
    
    ### wp-active-theme ###
    
    name: OceanWP (oceanwp)
    version: 2.0.8
    author: Nick
    author_website: https://oceanwp.org/about-me/
    parent_theme: none
    theme_features: core-block-patterns, align-wide, wp-block-styles, responsive-embeds, editor-styles, editor-style, menus, post-formats, title-tag, automatic-feed-links, post-thumbnails, custom-header, custom-logo, html5, woocommerce, wc-product-gallery-zoom, wc-product-gallery-lightbox, wc-product-gallery-slider, customize-selective-refresh-widgets, widgets
    theme_path: /home/www/public_html/wordpress/wp-content/themes/oceanwp
    auto_update: Deaktiviert
    
    ### wp-themes-inactive (1) ###
    
    Twenty Twenty-One: version: 1.3, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-active (8) ###
    
    Antispam Bee: version: 2.9.4, author: pluginkollektiv, Automatische Aktualisierungen deaktiviert
    Contact Form 7: version: 5.4.1, author: Takayuki Miyoshi, Automatische Aktualisierungen deaktiviert
    Disable Gutenberg: version: 2.4, author: Jeff Starr, Automatische Aktualisierungen deaktiviert
    GDPR Cookie Consent: version: 2.0.1, author: WebToffee, Automatische Aktualisierungen deaktiviert
    Google Analytics for WordPress by MonsterInsights: version: 7.17.0, author: MonsterInsights, Automatische Aktualisierungen aktiviert
    Under Construction: version: 3.88, author: WebFactory Ltd, Automatische Aktualisierungen deaktiviert
    Yoast SEO: version: 16.2, author: Team Yoast, Automatische Aktualisierungen deaktiviert
    Yoast SEO Premium: version: 16.2, author: Team Yoast, Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-inactive (3) ###
    
    Internal Link Juicer: version: 1.2.14, author: Internal Link Juicer, Automatische Aktualisierungen deaktiviert
    WP-Optimize - Clean, Compress, Cache: version: 3.1.9, author: David Anderson, Ruhani Rabin, Team Updraft, Automatische Aktualisierungen deaktiviert
    WP24 Domain Check: version: 1.8.2, author: WP24, Automatische Aktualisierungen deaktiviert
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1690
    imagemagick_version: ImageMagick 6.9.10-23 Q16 x86_64 20190101 https://imagemagick.org
    file_uploads: File uploads is turned off
    post_max_size: 1024M
    upload_max_filesize: 16M
    max_effective_size: 16 MB
    max_file_uploads: 20
    imagick_limits: 
    	imagick::RESOURCETYPE_AREA: 122 MB
    	imagick::RESOURCETYPE_DISK: 1073741824
    	imagick::RESOURCETYPE_FILE: 192
    	imagick::RESOURCETYPE_MAP: 512 MB
    	imagick::RESOURCETYPE_MEMORY: 256 MB
    	imagick::RESOURCETYPE_THREAD: 1
    gd_version: 2.2.5
    ghostscript_version: 9.27
    
    ### wp-server ###
    
    server_architecture: Linux 5.11.16-cmag1-hp+ x86_64
    httpd_software: Apache
    php_version: 8.0.3 64bit
    php_sapi: cgi-fcgi
    max_input_variables: 1000
    time_limit: 30
    memory_limit: 256M
    max_input_time: 60
    upload_max_filesize: 16M
    php_post_max_size: 1024M
    curl_version: 7.64.0 OpenSSL/1.1.1d
    suhosin: false
    imagick_availability: true
    pretty_permalinks: true
    htaccess_extra_rules: false
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 10.3.12-MariaDB-1:10.3.12+maria~stretch-log
    client_version: mysqlnd 8.0.3
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /home/www/public_html/wordpress/wp-content
    WP_PLUGIN_DIR: /home/www/public_html/wordpress/wp-content/plugins
    WP_MEMORY_LIMIT: 256M
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    

    Du verwendest PHP 8.0. Da noch nicht alle Themes und Plugins auf die neueste WordPress-Version aktualisiert wurden, kann das zu Problemen führen. Du solltest im Kundenmenü des Webhosters die PHP-Version auswählen können (häufig unter „Experten-Einstellungen“). Wähl doch bitte mal PHP 7.4 (PHP 7.3 wäre auch noch OK) und schau, ob dadurch die Fehler verschwinden.

    Thread-Starter steved84

    (@steved84)

    Habs auf 7.4 umgestellt, geht aber auch nicht

    Bei beiden Websites nicht?

    Mit dem Plugin Health Check kannst du testen, wie sich die Website mit deaktivierten Plugins und einem Standard-Theme verhalten würde. Ist sie dann immer noch defekt, stimmt etwas an der Serverkonfiguration nicht.

    Thread-Starter steved84

    (@steved84)

    Was meinst Du mit beide Websites nicht?

    Healthcheck hab ich installiert, hat aber nix zusätzliches ergeben.
    Außer das alle Plugins nur mit PHP 7.3 laufen, das hab ich jetzt nochmal geändert.
    Geht aber trotzdem nicht.

    Ryte zeigt aber ein Fehler an

    Ryte bietet eine kostenlose Indexierungs-Prüfung für Benutzer von Yoast SEO. Die Anfrage an Ryte, um zu prüfen, ob deine Website von Suchmaschinen gefunden werden kann, ist aufgrund eines Fehlers gescheitert.

    Details zum Fehler: cURL error 28: Operation timed out after 5095 milliseconds with 0 bytes received (http_request_failed)
    Hab mich dort registriert um die Seite zu analysieren, hängt sich aber immer auf.

    Was meinst Du mit beide Websites nicht?

    Sorry, das war eine Verwechslung.
    Ich hab heute schon zu viele Fragen beantwortet. 🙂

    Healthcheck hab ich installiert, hat aber nix zusätzliches ergeben.

    Vielleicht ein Missverständnis? Das Plugin hat einen Problembehandlungsmodus, mit dem du simulieren kannst, wie sich deine Website verhält, wenn alle Plugins deaktiviert sind. Der muss aber aktiviert werden, anschließend sollst du die Plugins einzeln wieder aktivieren und jeweils testen, wie sich die Website verhält. Ziel ist, herauszufinden, ob ein Plugin den Fehler verursacht. (Steht auch so alles in unserer FAQ.)

    Mögliche fehlerhafte Plugins habe ich bereits deaktiviert.

    Laut Bericht sind im Moment 8 Plugins aktiviert.

    Thread-Starter steved84

    (@steved84)

    Hab den Problembehandlungsmodus aktiviert und zuerst die Themes getestet.
    Ich verwende normal das Ocean WP, das habe ich deaktiviert und das Twenty Twenty installiert und aktiviert. Dann ist das Menü wieder da. Habe das Ocean dann deinstalliert und neu installiert und aktiviert….
    Das Menü ist dann aber wieder weg!?

    Hallo,
    dann teste doch mal, ob es hilft, wenn Du nach einer Sicherung OceanWP von hier runterlädst, lokal entpackst und dann die Dateien per FTP wieder in den entsprechenden Ordner hochlädst. Es könnte ja vielleicht sein, dass die eine oder andere Datei defekt ist.
    Viele Grüße
    Hans-Gerd

    … oder im Customizer die falschen Einstellungen gemacht wurden.

    Thread-Starter steved84

    (@steved84)

    Habe das Theme manuell runtergeladen und per FTP hochgeladen, kein Erfolg.
    Den Costumizer hab ich mehrmals durchgeschaut, da finde ich keinen Fehler.
    Das Menü ist auf Leiste ganz oben gestellt, so hat es auch immer funktioniert.

    An was kann es noch liegen?

    Die Seite mit dem Impressum wird zumindest mit einem Navigationsmenü ausgegeben (und erzeugt keine Fehlermeldung „500 – Internal Server Error“).

    Für die Startseite hast du nicht das Standard-Template sondern ein Template „Landing Page“ verwendet, das maßgeblich die Gestaltung der Seite ändert. Probier doch mal was passiert, wenn du hier auch das Standard-Template auswählst.

    Thread-Starter steved84

    (@steved84)

    Bingo, das wars! Geht wieder

    Vielen Dank!

    Prima. 🙂 Danke für die Rückmeldung.

Ansicht von 14 Antworten - 1 bis 14 (von insgesamt 14)
  • Das Thema „HTML 500, Menü weg nur noch Hauptseite erreichbar“ ist für neue Antworten geschlossen.