Support » Allgemeine Fragen » HTML erlauben

  • Nikelaos

    (@nikelaos)


    WP 5.8.1, Classic-Editor, Text-Ansicht
    ======================================

    Hallo!

    Folgendes Problem ist aufgetaucht:
    Ich verfasse einen Post und möchte dort einen HTML-Kommentar
    <!-- ... -->
    eingeben.

    Bin ich nicht als Admin eingeloggt, wird mir beim Speichern/Veröffentlichen obiges zu
    <ampersand>lt;!-- ... --<ampersand>gt;
    gewandelt.

    Speichere ich den gleichen Post als (Super-)Admin, wird der ohne Umwandlung gespeichert.

    Dies scheint ein Verhalten zu sein, dass neu ist. Ich beobachte das zu ersten Mal.

    Welche Möglichkeiten gibt es, nicht-Admins die Verwendung von HTML zu erlauben?

    Danke im voraus!

    • Dieses Thema wurde geändert vor 1 Monat von Nikelaos.
    • Dieses Thema wurde geändert vor 1 Monat von Nikelaos.
    • Dieses Thema wurde geändert vor 1 Monat von Nikelaos.
    • Dieses Thema wurde geändert vor 1 Monat von Nikelaos.
Ansicht von 6 Antworten - 16 bis 21 (von insgesamt 21)
  • Thread-Ersteller Nikelaos

    (@nikelaos)

    Danke, @la-geek , für diesen Tipp.

    Nur: Der Problembehandlungsmodus kann, soweit mein Test in meinem „Sandkasten“ zeigt, nur mit Adminitstratorenrechten aktiviert werden. Das Problem tritt jedoch nur dann auf, wenn ich nicht als Administrator angemeldet bin. Und wenn ich mich als Admin anmelde, den Problembehandlungsmodus aktiviere und mich abmelde und wieder anmelde, wird der Modus mit der Abmeldung offenbar beendet.

    Ein explizites Recht zur Aktivierung des Problembehandlungsmodus habe ich nicht gefunden.

    Ich werde also dieses Standardverfahren nicht anwenden können.

    Mir bleibt wohl nichts anderes als der mühevolle Weg des Als Admin anmelden – Plugin deaktivieren – als Redakteur anmelden und schauen, ob es geht. Doch ich denke nicht, dass das diese Mühe wert ist. So häufig komme ich wohl nicht in diese Situation und wenn, habe ich immer noch die Möglichkeit über die Admin-Anmeldung das Verhalten zu umgehen.

    Vielleicht stoße ich ja irgendwann einmal durch Zufall auf die Ursache.

    Moderator Angelika Reisiger

    (@la-geek)

    Mir bleibt wohl nichts anderes als der mühevolle Weg des Als Admin anmelden – Plugin deaktivieren – als Redakteur anmelden und schauen, ob es geht.

    2 unterschiedliche Browser nehmen 🙂

    Moderator Bego Mario Garde

    (@pixolin)

    Oder ein „Neues privates Browser-Fenster“. 🙂

    Thread-Ersteller Nikelaos

    (@nikelaos)

    Ahhh, zwei Browser. Geschickt! 😉 Ich hab’s mit einem privaten Firefox probiert, doch es funktioniert nicht, die Plugins sind dann als Redakteur weiterhin aktiviert. 🙁

    Ich habe mir nun eine Übersicht über die verwendeten Plugins erstellt. Zwei habe ich gefunden, die in der nicht funktionierenden, neuen Installation aktiviert sind, in der funktionierenden, alten, jedoch nicht. Alle anderen Plugins sind identisch, können also wohl nicht die Ursache sein.

    Doch die Deaktivierung dieser zwei Kandidaten bringt keine Änderung.

    Auch die Einstellung der neuen Inst auf PHP 7.4., unter dem die alte, funktionierende, Installation läuft, bringt nichts. Genauso wie auch die Umstellung der alten auf 8.0 nichts bringt: Das Verhalten ist dort nicht reproduzierbar.

    Die Änderung in der alten Inst auf utf8mb4 in der wp-config wie in der neuen bringt auch nichts: es funktioniert dann auch noch.

    Sonst habe ich mit dem Plugin „System-Info“ keine Unterschiede feststellen können. Damit bin ich mit meinem Latein am Ende.

    Bug-Meldung? Wenn ja: Wo?

    Moderator Bego Mario Garde

    (@pixolin)

    Der Problembehandlungsmodus des Plugins Health Check bezieht sich immer nur auf den gerade angemeldeten Benutzer. Wenn du damit temporär Plugins deaktivierst, bekommen andere Benutzer (bzw. du selbst mit einer Anmeldung unter einem anderen Account in einem privaten Fenster) davon nichts mit. Du kannst aber ganz normal Plugins vorübergehend deaktivieren und gleich im anderen Browser-Tab die Auswirkung testen. Das hatte Angelika wohl gemeint.

    Thread-Ersteller Nikelaos

    (@nikelaos)

    Danke, @pixolin , so verstanden ist das freilich hilfreich…

Ansicht von 6 Antworten - 16 bis 21 (von insgesamt 21)