Support » Allgemeine Fragen » HTTP Error nur bei bestimmten Bildern – Upload

  • Hallo zusammen,

    ich habe ein seltsames Problem. Bestimmte Bilder kann ich nicht hochladen, da ich sofort einen HTTP Error bekomme.

    Das hochzuladende Bild ist dann zwar in der Galerie vorhanden, allerdings nur als „graues sheet“. Ich kann das Bild auch extern aufrufen, allerdings nicht verwenden. Ich nutze bspw das Plugin Slider Revolution. Wenn ich das Bild hier verwende entsteht ein AJAX Fehler.

    Was ich bereits versucht habe:

    – Den Standardbildeditor von WP geändert
    – Alle Plugins deaktiviert
    – Ein neues Theme ausprobiert
    – Beim Hoster um Support gebeten, die den Fehler zwar reproduzieren können, aber nicht wissen woran es liegt und mich selbst darum gebeten haben, mich an die Community zu wenden.

    Interessant ist, dass dieser Fehler bei einem anderen Hoster nicht entsteht.

    Hätte hier noch jemand eine Idee?

    Viele Grüße

Ansicht von 5 Antworten - 1 bis 5 (von insgesamt 5)
  • Hallo,
    schau mal Dir mal bitte den folgenden Link an, in dem das Thema u. a. besprochen wurde.
    Es gibt mehrere Dinge, die Du – abgesehen von dem genannten Lösungsansatz – versuchen kannst, um das Problem zu lösen (manche davon hast Du ja bereits getestet):

    • überprüfe sicherheitshalber, ob sich die Dateien im Ordner uploads befinden
    • überprüfe die Fehlerprotokolle auf dem Server.
    • nenne die .htaccess um und prüfe dann, ob das Problem behoben ist (die Datei bitte vorher sichern) – siehe auch hier.
    • prüfe ob das Problem auch besteht, wenn Du die Plugins deaktiviert UND ein Standard-Theme wie twentyseventeen aktiviert hast. Du kannst dazu auch das plugin Health Check & Troubleshooting installieren. Wenn Du unter „Werkzeuge“->“Website-Zustand“ gehst, kannst Du den Problembehandlungsmodus aktivieren. Danach würde ich jeweils Plugin für Plugin aktivieren und dann danach direkt testen, ob der Upload funktioniert.
      Wenn Du dann irgendwann nach Aktivierung von plugin xyz bemerkst, dass das Problem wieder besteht, hast Du den Übeltäter.
      Außerdem wäre es hilfreich, wenn Du den Bericht zur Webseite kopierst und hier postest. Den findest Du unter „Website-Zustand“ -> Bericht.

    Das Problem ist hier schon häufiger diskutiert worden. Hier zunächst mal ein Link auf einen älteren Beitrag, in dem das Problem auch diskutiert wurde. Ansonsten kannst Du oben in der Suche auch mal upload eingeben und Du erhältst dann viele Treffer dazu.
    Viele Grüße
    Hans-Gerd

    Hier der Bericht:

    ### wp-core ###

    version: 5.2.2
    site_language: de_DE
    user_language: de_DE
    permalink: /%postname%/
    https_status: false
    user_registration: 0
    default_comment_status: closed
    multisite: false
    user_count: 5
    dotorg_communication: true

    ### wp-paths-sizes ###

    wordpress_path: /kunden/319049_59755/landingpage_logisticgate
    wordpress_size: 172,42 MB (180792021 bytes)
    uploads_path: /kunden/319049_59755/landingpage_logisticgate/wp-content/uploads
    uploads_size: 111,16 MB (116561372 bytes)
    themes_path: /kunden/319049_59755/landingpage_logisticgate/wp-content/themes
    themes_size: 7,13 MB (7472325 bytes)
    plugins_path: /kunden/319049_59755/landingpage_logisticgate/wp-content/plugins
    plugins_size: 65,21 MB (68381311 bytes)
    database_size: 3,34 MB (3500634 bytes)
    total_size: 359,26 MB (376707663 bytes)

    ### wp-active-theme ###

    name: Twenty Seventeen (twentyseventeen)
    version: 2.2
    author: dem WordPress-Team
    author_website: https://de.wordpress.org/
    parent_theme: none
    theme_features: automatic-feed-links, title-tag, post-thumbnails, menus, html5, post-formats, custom-logo, customize-selective-refresh-widgets, editor-style, editor-styles, wp-block-styles, responsive-embeds, starter-content, custom-header, widgets
    theme_path: /kunden/319049_59755/landingpage_logisticgate/wp-content/themes/twentyseventeen

    ### wp-themes-inactive (3) ###

    Astra: version: 2.0.0, author: Brainstorm Force (latest version: 2.0.1)
    Twenty Nineteen: version: 1.4, author: Das WordPress-Team
    Twenty Sixteen: version: 2.0, author: dem WordPress-Team

    ### wp-mu-plugins (1) ###

    Health Check Troubleshooting Mode: author: (undefined), version: 1.7.0

    ### wp-plugins-active (8) ###

    CMP – Coming Soon & Maintenance Plugin: version: 3.5.9, author: NiteoThemes
    Duplicate Post: version: 3.2.3, author: Enrico Battocchi
    Duplicator: version: 1.3.18, author: Snap Creek
    Elementor: version: 2.6.8, author: Elementor.com
    Elementor Pro: version: 2.6.3, author: Elementor.com (latest version: 2.6.4)
    Health Check & Troubleshooting: version: 1.4.0, author: The WordPress.org community
    Slider Revolution: version: 6.0.9, author: ThemePunch (latest version: 6.1.0)
    WP Floating Menu Pro: version: 2.0.6, author: AccessPress Themes

    ### wp-plugins-inactive (6) ###

    Akismet Anti-Spam: version: 4.1.2, author: Automattic
    Algori PDF Viewer Lite: version: 1.0.3, author: Kevin Bazira
    Classic Editor: version: 1.5, author: WordPress Contributors
    Header and Footer Scripts: version: 2.1.1, author: Digital Liberation
    Options for Twenty Nineteen: version: 1.2.2, author: webd.uk
    PDF Poster Free: version: 1.3, author: Abu Hayat Polash

    ### wp-media ###

    image_editor: WP_Image_Editor_GD
    imagick_module_version: Nicht verfügbar
    imagemagick_version: Nicht verfügbar
    gd_version: bundled (2.1.0 compatible)
    ghostscript_version: 9.25

    ### wp-server ###

    server_architecture: Linux 3.18.114-pvops-xen-x64 x86_64
    httpd_software: Apache/2.4.39
    php_version: 7.2.11
    php_sapi: cgi-fcgi
    max_input_variables: 1000
    time_limit: 180
    memory_limit: 256M
    max_input_time: -1
    upload_max_size: 32M
    php_post_max_size: 32M
    curl_version: 7.55.1 OpenSSL/1.0.2l
    suhosin: false
    imagick_availability: false
    server-headers:
    date: Thu, 22 Aug 2019 08:27:02 GMT
    server: Apache/2.4.39
    x-powered-by: PHP/7.2.11
    expires: Thu, 19 Nov 1981 08:52:00 GMT
    cache-control: no-store, no-cache, must-revalidate
    pragma: no-cache
    retry-after: 86400
    set-cookie: PHPSESSID=8e7dd3d6a9df80e7353bc25f9ae202e7; path=/
    upgrade: h2c
    content-type: text/html; charset=UTF-8
    htaccess_extra_rules: true

    ### wp-database ###

    extension: mysqli
    server_version: 5.6.19
    client_version: mysqlnd 5.0.12-dev – 20150407 – $Id: 38fea24f2847fa7519001be390c98ae0acafe387 $

    ### wp-constants ###

    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /kunden/319049_59755/landingpage_logisticgate/wp-content
    WP_PLUGIN_DIR: /kunden/319049_59755/landingpage_logisticgate/wp-content/plugins
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined

    ### wp-filesystem ###

    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    mu-plugins: writable

    – Die Dateiberechtigungen sind richtig gesetzt. Ich kenne das Problem hinsichtlich Domainfactory. Das habe ich gleich zu Anfang überprüft

    – Alle Plugins wurden deaktiiviert (Ich nutze sowieso ein Standard Theme) und das Problem besteht weiterhin

    – Was mich gerade etwas wundert ist, dass die Seite problemlos funktioniert wenn ich die .htacsses vom Server lösche – der Bilderupload natürlich nicht

    – Die Fehlerprotokolle auf dem Server zeigen, dass der Upload im Skript unterbrochen wird

    – Wie gesagt, das SELTSAME daran ist, dass ich manche Bilder hochladen kann, andere wiederum nicht.

    Ich bin hier mit meinem Latein echt am Ende.

    Probier doch mal, ein Bild mit kleinen Abmessungen hochzuladen, z.B.

    WordPress-Logo

    – klappt es dann?

    Wenn die Vorschaubilder nur ein graues Kästchen sind, reicht häufig der Arbeitsspeicher nicht aus, um das Bild zu skalieren.

    Du könntest deshalb

    • versuchen, die Bildgröße (hier geht es um die Anzahl der Pixel, nicht die Dateigröße) zu verringern,
    • dich (vorübergehend?) ein paar Plugins zu deativieren oder
    • beim Webhoster mehr Arbeitsspeicher (memory_limit) zu beauftragen.

    versuchen, die Bildgröße (hier geht es um die Anzahl der Pixel, nicht die Dateigröße) zu verringern,

    VIELEN LIEBEN DANK für diese wichtige Lektion! Das hat das Problem behoben, nur kann ich da ja in 300 Jahren nicht drauf kommen, wenn der Support des Hosters das Problem nachstellt aber keine Ahnung hat woran es liegen könnte, eine Performancebeteiligung der Server aber kategorisch ausschließt.

    Die Performance des Servers war ja vermutlich auch nicht die Ursache.

    Webhoster sind ein wenig wie Wohnungs-Vermieter: Du kannst anrufen, wenn es kein warmes Wasser gibt oder der Strom im ganzen Haus ausgefallen ist, aber für deine Einrichtung fühlen sie sich nicht zuständig.

Ansicht von 5 Antworten - 1 bis 5 (von insgesamt 5)