Support » Allgemeine Fragen » http-fehler

  • Hallo,

    Problematik: wenn ich jpeg- Dateien hochladen möchte erscheint die Fehlermeldung „http-fehler“.
    lade ich die jpegs auf einer Seite z.b. in der mediengallerie hoch, dann erscheinen sie zwar trotz Fehlermeldung im Bereich, werden aber auf der Website nicht angezeigt.

    ich bin im forum schon auf einigen Threads bzgl. der Fehlermeldung gewesen und habe die Lösungsvorschläge ausprobiert:
    -jpegs datei minimiert
    -theme deaktiviert, ein anderes aktiviert
    -php umgestellt
    -plugin deaktiviert, neu gestartet
    – disable jpeg compression plugin installiert
    – .htaccess erweitert auf:
    AddHandler php56-cgi .php
    php_value memory_limit 256M
    php_value max_input_vars 10000

    leider hat keiner der Lösungswege funktioniert. Hat jemand noch einen Tipp?

    Vielen vielen Dank,
    Desi

Ansicht von 6 Antworten - 1 bis 6 (von insgesamt 6)
  • Probier doch mal folgendes: Plugin Code Snippets installieren, neues Snippet anlegen mit folgenden Inhalt:

    add_filter( ‘wp_image_editors’, ‘change_graphic_lib’ );
    
    function change_graphic_lib($array) {
    return array( ‘WP_Image_Editor_GD’, ‘WP_Image_Editor_Imagick’ );
    }

    Snippet aktivieren und Hochladen testen. Klappt es damit?

    Gute Morgen @pixolin,
    vielen Dank für die Rückmeldung. Leider hat der Tipp auch nicht funktioniert. Habe aber nun durch Fiddler eine genauere Fehlermeldung herausbekommen. und zwar Fehler 500 und /wp-admin/async-upload.php HTTP/1.1 .. im webspace konnte ich die Datei nicht auffinden. Ich bin leider erst ganz am Anfang von wordpress&programmieren. Ist das ein interner Fehler der bei meinem Anbieter liegt oder kann ich selbst den Fehler beheben?

    Es gibt leider bei dieser Fehlermeldung (und auch bei der Meldung 500-Internal Server Error) keine eindeutige Lösung. Deshalb müssen wir verschiedene Dinge ausprobieren. Wenn die oben beschriebene Lösung nicht funktioniert, probier doch bitte mal, folgenden Code in die .htaccess einzufügen:

    <IfModule mod_security.c>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </IfModule>

    Kannst du dieses Bild hochladen?
    WordPress-Logo

    Falls das auch nicht geht, lad doch mal dieses Skript herunter, entpacke es und lade die Datei memory-test.php in dein Web-Stammverzeichnis hoch. Dann rufst du http://deinedomain.de/memory-test.php im Browser auf und schaust, welche Fehlermeldung ausgegeben wird (das Skript belegt schrittweise so viel Hauptspeicher wie möglich und meldet dann einen Fehler, wenn der Hauptspeicher erschöpft ist).

    So, als ich den Code in die .htaccess eingefügt habe, blieb die Fehlermeldung nach wie vor bestehen.

    Das Bild kann ich problemlos herunterladen-generell sind .png Dateien kein Problem. Die Fehlermeldung tritt immer bei .jpg auf.

    Bei dem zweiten Lösungsweg bin ich mir nicht sicher, ob ich ihn richtig umsetzen konnte. Ich habe die memory-test.php Datei heruntergeladen und mit Hilfe von FileZilla auf den Server in den Ordner hinterlegt, in dem sich auch die Ordner wp-admin, wp-content, wp-includes befinden. War das Richtig?
    Wenn ich auf die http://deinedomain.de/memory-test.php werde ich auf hosting-agency.de geleitet & dass die Seite existiert nicht.

    Hast du WordPress in einem Unterverzeichnis installiert? Dann müsstest du das in der URL mit angeben, z.B. http://deinedomain.de/wordpress/memory-test-php

    Da der Eintrag in der .htaccess keine Änderung bewirkt hat, kannst du ihn wieder entfernen.

    Du schreibst „plugin deaktiviert, neu gestartet“ – hast du mal alle Plugins deaktiviert und ein Standard-Theme (Twenty …) aktiviert, um Fehlerquellen auszuschließen?

    Ich hatte ganz am Anfang alle Plugins deaktiviert gehabt& das Theme geändert- ohne Erfolg. Jetzt habe ich einfach noch einmal alle Plugins deaktiviert und es hat tatsächlich direkt bei meinem Theme geklappt.
    Habe nur zwei Plugins vom Theme wieder aktiviert und seitdem kann ich die Bilder hochladen. Möchte trotzdem im Laufe der Woche noch einmal alle Plugins durchgehen und schauen welcher den Fehler ausgelöst hatte.
    Vielen vielen Dank für die Geduld und die Hilfestellungen!!
    Schönen Abend Dir noch.

Ansicht von 6 Antworten - 1 bis 6 (von insgesamt 6)
  • Das Thema „http-fehler“ ist für neue Antworten geschlossen.