Support » Allgemeine Fragen » HTTP Fehler bei Bilder Upload

  • Guten Abend,

    ich bin seit heute User von WP und habe mir direkt ein schönes Theme zugelegt. Leider klappt noch nicht alles so wie ich das will, liegt evtl. auch daran, dass ich Anfänger bin.

    Ein Problem ist, dass ich keine Bilddateien hochladen kann bzw. nur bis zu einer Größe von ca. 500 kb (.jpg und .png hat bisher geklappt).
    Ich nutze als Host celeros mit dem Paket „webhosting start“, da habe eigentlich genug Space zur Verfügung.

    Ich habe aber auch schon ein Bild (1,7 mb) über den FTP Client hochgeladen, das wird mir auch im Browser angezeigt.
    Nur eben nicht über die Uploadfunktion von WP. Da erscheint nach dem Upload (immer bis 100%) jedes mal HTTP Fehler.

    Ich konnte jetzt nichts finden, was speziell auf diese Sache abzielt und würde es aber gerne doch beheben bzw. eben Bilder hochladen.

    Kann mir da jemand weiterhelfen?

    Beste Grüße,
    J

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 19)
  • Moderator espiat

    (@espiat)

    Hallo,

    hast du den DEBUG Modus angeschaltet und gibt es Fehler?

    Hat du es schon damit probiert? Upload Size erhöhen.
    Beschrieben wird dies z.B. hier: http://www.wpbeginner.com/wp-tutorials/how-to-increase-the-maximum-file-upload-size-in-wordpress/

    Sorry der doofen Nachfrage, ich kenn mich wie gesagt noch nicht so gut aus:) Wo schalte ich den DEBUG Modus denn an oder aus? 🙂

    Mit deinem zweiten Vorschlag habe ich es noch nicht probiert.
    Punkt 1 sagt ja die functions Datei soll abgeändert werden bzw

    1 @ini_set( ‚upload_max_size‘ , ’64M‘ );
    2 @ini_set( ‚post_max_size‘, ’64M‘);
    3 @ini_set( ‚max_execution_time‘, ‚300‘ );

    hinzugefügt. Soll ich das einfach mal Einfügen und die Datei dann hochladen. Wenn ja, ist es egal an welcher Stelle?

    Vielen Dank schonmal für deine Antwort!

    Moderator espiat

    (@espiat)

    Debug-Modus: Google hilft dir an der Stelle bestimmt auch weiter. 😉

    Du kannst auch deine maximale Uploadgrö?e sehen unter:
    Medien -> Datei hinzufügen

    Dort steht dann „Maximale Dateigrö?e für Upload: xx MB.“

    Was steht da bei dir?

    Was die php.ini angeht- kommt drauf an, was du genau für Rechte hast auf deinem Hoster. Solltest du eine php.ini einfügen können bzw. diese sogar ändern können, dann musst du Sie in das Root-Verzecihnis einfügen, wie in dem Link beschrieben ist:

    If you do not see one, then create a file called php.ini and upload it in the root folder.

    Bei manchen Hostern kannst du auch die Werte der php.ini im Loginbereich bearbeiten.

    Das ändern der functions.php würde ich dir erstmal als Anfänger nicht empfehlen. Beim Themeupdate können die Werte dann überschrieben werden. Hierzu solltest du vielleicht ein „Child-Theme“ erstellen.
    Solltest du es dort einfügen wollen dann beachte immer die 1. Regel:

    „Backup machen, Backup machen, Backup machen- falls etwas schief geht.“

    Also als maximale Uploadgröße steht da 8mb, deshalb wundert es mich ja. Es lädt immer komplett hoch bis 100% und dann kommt direkt die Anzeige mit http Fehler.

    Ok zu DEBUG:
    Das steht in der conifg.php

    * Change this to true to enable the display of notices during development.
    * It is strongly recommended that plugin and theme developers use WP_DEBUG
    * in their development environments.
    */
    define(‚WP_DEBUG‘, false);

    Moderator espiat

    (@espiat)

    machste

    define('WP_DEBUG', true);

    draus und ergänzt (falls es dort nicht steht)

    // Enable Debug logging to the /wp-content/debug.log file
    define('WP_DEBUG_LOG', true);
    
    // Disable display of errors and warnings
    define('WP_DEBUG_DISPLAY', false);
    @ini_set('display_errors',0);

    Speicherort wird hier beschrieben:
    http://codex.wordpress.org/Debugging_in_WordPress#WP_DEBUG_LOG

    PS: Kannst du deine Servereinstellung (upload_max_size) deines Hosters sehen?

    Weisst du wie du per „phpinfo()“ diese Info abrufen kannst?

    Welchen Hoster hast du?

    Hast du schon mal das probiert? ->

    Du benutzt den Mehrdateienuploader. Treten Probleme auf? Benutze dann stattdessen den Browser Uploader.

    Einfach nach „…true);“ dann „//Enable Debug…“ einfügen, speichern und hochladen?

    Sehen kann man die Bestimmt, ich weiß nur nicht wo hehe 🙂
    Also ich weiß nicht wie ich diese Info abrufen kann.

    Bin bei Celeros mit dem Webhosting Start Paket.

    Edit:
    Ja, hab beide Uploader probiert. Gleiches Problem:)

    Moderator espiat

    (@espiat)

    Hallo,

    ich habe dir nun den Hinweis gegeben, dass mit der phpinfo abzurufen.
    In den FAQ deines Hosters steht folgendes:

    Welche PHP-Versionen stehen bei Celeros Online zur Verfügung?
    Installiert sind derzeit die Versionen PHP 4.X.X und PHP 5.X.X. Die entsprechend aktuellen Versionen können Sie mittels einer phpinfo direkt aus Ihrem Confixx-Bereich aufrufen oder durch Verwendung unserer globalen PHP-Info. Die URL setzt sich hierbei aus dem Servernamen/info.php zusammen. (Beispiel: https://anna.servertools24.de/info.php)

    Ein bisschen mehr Eigen-Initiative deinerseits wäre wünschenswert- findest du nicht?

    Hey,

    ich weiß garnicht wo ich da Eigeninitiative ergreifen soll, ohne etwas aus Unwissen zu vernichten oder kaputt zu machen. Faul bin ich ganz sicher nicht 🙂 Eher leicht überfordert, weil das alles neu für mich ist und ich versuche zu verstehen.

    In der Info steht „upload_max_filesize 8M 8M“.
    Das Memory limit ist „memory_limit 64M 64M“.
    Müsste ja jeweils langen.

    Also meinst du ich soll das mit Enable Debug in die config.php einfügen? Wenn ja, direkt nach „define(‚WP_DEBUG‘, true);“ ?

    Danke 😉

    PS:
    Über den Browserupload kommt folgendes (auch bei einer Datei von 200 kb)

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, hostmaster@configcenter.info and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Moderator espiat

    (@espiat)

    Sind in der .htaccess (Rootordner) einige Angaben zum max upload?

    sollte normal so aussehen (Mit Permalinks):

    # BEGIN WordPress
    
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    
    # END WordPress

    2. Wenn der debug befehl schon eingefügt ist, dann ändere:
    define('WP_DEBUG', false);
    in
    define('WP_DEBUG', true);

    Ok also ich habe DEBUG in true abgeändert und hochgeladen. Das hat jetzt aber erstmal nichts geändert.

    Ich kann keine htaccess finden, kann das sein? Auch über Suchfunktion finde ich nichts mit diesem Namen. In rewrite.php habe ich etwas gefunden, das dem von dir geposteten ähnelt:

    $rules .= „RewriteCond %{REQUEST_FILENAME} -f [OR]\n“ .
    „RewriteCond %{REQUEST_FILENAME} -d\n“ .
    „RewriteRule ^.*$ – [S=$num_rules]\n“;

    Ich habe gerade in swfupload.js folgendes gefunden:

    SWFUpload.UPLOAD_ERROR = {
    HTTP_ERROR : -200,

    Hat das etwas zu sagen, dass da ein Minus steht?

    Ich danke dir echt für deine Mühe 😉

    Moderator espiat

    (@espiat)

    die .htaccess sollte im rootverzeichniss sein.

    hast du in deinem ftp prog auch „versteckte Dateien anzeigen“ angestellt.

    Benutzt du Permalinks?

    Wir haben jetzt 3 Möglichkeiten, wo diese Einstellung festgesetzt werden könnte(n):
    1. .htaccess
    2. php.ini
    3. in der functions.php des themes

    Diese 3 Orte musst du absuchen. Werden vielleicht auch Plugins benutzt, die diese Einstellung haben könnten?

    Dein WordPress, Theme, PHP und mysql Version sind aktuell?

    Moderator espiat

    (@espiat)

    Wichtig: Kannst du Dateien mit 100kb hochladen?

    1. Ich nutze ClassicFTP und habe zumindest nichts ausgeschaltet. In den Einstellungen gibt es auch keinen Punkt versteckte Dateien anzeigen, da sind lediglich 3 Punkte zum ausäwhlen.

    2. Was heißt nutzen… Ich denke schon, aber wahrscheinlich nicht bewusst.
    Ich zeig dir einfach mal meine Seite, um die es geht 😉
    http://www.lifeofjulian.de

    3. Also die functions.php des Themes habe ich schonmal gefunden! Da konnte ich jetzt zwei Einträge zum Size Media Upload finden. Aber jeweils nur für „Thumbnail“.

    4. Ich habe kein Plugin installiert.

    5. Die Versionen sind alle die aktuellsten.

    6. Also eine Datei mit 119kb konnte ich hochladen.

    Moderator espiat

    (@espiat)

    Ah interessant. Ich vermute – es liegt wohl an deiner Servereinstellung dem FastCGI. Bitte deinen Hoster sich einmal den Wert „FcgidMaxRequestLen“ anzusehen.

    Dieser ist wahrscheinlich zu klein eingestellt.

    Ok ich hab denen heute mal geschrieben, kam jetzt noch keine Antwort aber ich hoffe dass es damit behoben werden kann. Ich melde mich, sobald eine Rückmeldung kommt.

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 19)
  • Das Thema „HTTP Fehler bei Bilder Upload“ ist für neue Antworten geschlossen.