Support » Allgemeine Fragen » „https:“ bei externen URLs weg

  • Hallo,

    ich habe einen Blogartikel geschrieben und dort auf https://de.statista.com/ verlinkt. Im Editor und in der Datenbank sieht der Link so aus
    <a href="https://de.statista.com/" >statista.com</a>

    Wenn ich jedoch die Seite aufrufe und mir den Html-Code ansehe ist dort kein „https:“ mehr vorhanden. Es schaut dann so aus:
    <a href="//de.statista.com/" >statista.com</a>

    Wieso ist das so?
    Wie kann ich das abstellen?
    Wird das als Fehler im Browser interpretiert?

    Wenn ich in dem Artikel auf eine unverschlüsselte Seite verlinke tritt das Problem nicht auf. Dann bleibt das „http:“ auch im Html-Code bestehen.

    Ich hätte gerne, dass der Link zur verschlüßelten Seite im Html-Code richtig dargestellt wird <a href="https://de.statista.com/">statista.com</a>.

    Vielen Dank und Grüße,
    Ferit

    • Dieses Thema wurde geändert vor 4 Jahre, 5 Monaten von freeko.
Ansicht von 3 Antworten - 1 bis 3 (von insgesamt 3)
  • Hallo @freeko und willkommen im Forum,

    die Angabe einer Hyperreferenz ohne Angabe des Schemas (http oder https) ist korrekt und sorgt dafür, dass der Link mit https aufgerufen wird, wenn die verlinkende Seite https verwendet. Damit soll die Anzeige einer Fehlermeldung wegen gemischtem Inhalt verhindert werden. Paul Irish nennt das in seinem Blog eine protokoll-relative URL: https://www.paulirish.com/2010/the-protocol-relative-url/

    Ich kenne eigentlich die Verwendung von protokoll-relativen URLs nur aus einigen Themes oder der Verwendung des Plugin Really Simple SSL, das eine Umstellung auf https erleichtern soll (und dann genau solche Fragen wie hier aufwirft). Ich stelle eine Website lieber ohne Plugin auf https um.

    Thread-Starter freeko

    (@freeko)

    Hallo @pixolin,

    danke für die schnelle Antwort.

    Also das Plugin Really Simple SSL habe ich eigentlich nicht genutzt bei der Umstellung auf https.

    Gibt es denn eine Möglichkeit trotzdem den Link mit https auszuspielen?
    Also so das der Code im HTML genau so ausschaut?
    <a href="https://de.statista.com/">statista.com</a>

    Vielen Dank und Grüße,
    Ferit

    Also das Plugin Really Simple SSL habe ich eigentlich nicht genutzt bei der Umstellung auf https.

    Wäre möglich gewesen … Ohne Link zur Website können wir hier sowieso nur raten.

    Gibt es denn eine Möglichkeit trotzdem den Link mit https auszuspielen?

    Wo, an welcher Stelle und warum? 🙂

    Ich weiß nicht, welche Plugins und welches Theme du verwendest und bin im Raten nicht so gut, wie du schon gemerkt hast. ¯\_(ツ)_/¯

Ansicht von 3 Antworten - 1 bis 3 (von insgesamt 3)
  • Das Thema „„https:“ bei externen URLs weg“ ist für neue Antworten geschlossen.