Support » Allgemeine Fragen » https und doch nicht sicher?

  • Guten Tag, ich habe meine Seite auf https umgestellt, aber in den Browsern wird der Hinweis „nicht sicher“ eingeblendet….!?

    MacOS BigSur

    Vielen Dank!

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 2 Antworten - 1 bis 2 (von insgesamt 2)
  • Hallo,
    kann ich im Inkognito-Modus von Chrome an sich nicht nachvollziehen.
    Allerdings scheinen in der .htaccess Einträge zu fehlen:
    Gehe mal bitte auf die folgende Seite, führe den Test durch und schaue dann auf „Force HTTPS“. Da findest du einen Link mit den Einträgen für die .htaccess. Nutze dafür aber bitte einen geeigneten Editor wie Notepad++.
    Viele Grüße
    Hans-Gerd

    Die Webseiten lassen sich im Moment auch mit http://… aufrufen und da dabei die Übertragung nicht verschlüsselt wird, wäre z.B. der Aufruf des Anmeldeformulars tatsächlich unsicher, weil die Anmeldedaten dann von jedem im Netzwerk mitgelesen werden können. Es wäre sinnvoll, hier eine Weiterleitung aller Seitenaufrufe mit http://… einzurichten, die automatisch die verschlüsselten Seiten aufrufen. Viele Webhoster haben dazu im Kundenmenü eine eigene Option (ggf. beim Support nachfragen). Alternativ kann auch eine Regeln in der Konfigurationsdatei .htaccess oberhalb des von WordPress erstellten Code-Blocks eingefügt werden:

    RewriteEngine On 
    RewriteCond %{HTTPS} off 
    RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI}

    Damit das Backend besser geschützt ist, wäre es sinnvoll, die WordPress-Konfigurationsdatei wp-config.php mit folgender Zeile zu ergänzen:

    define( 'FORCE_SSL_ADMIN', true );

    Die Zeile muss mit einem geeigneten Code-Editor (z.B. VS Code, kostenlos für alle Betriebssysteme erhältlich) oberhalb von oberhalb von /* That's all, stop editing! Happy blogging. */ eingefügt werden.

    Nachtrag: Mir ist gerade aufgefallen, dass bei der Umstellung auf HTTPS ein Fehler gemacht wurde. Bitte geh (vor allen anderen oben angesprochenen Änderungen) im WordPress-Backend auf Einstellungen > Allgemein und prüfe, dass beide URLs mit https:// beginnen. Sind die Felder ausgegraut und lassen sich nicht bearbeiten, wurde die URL in der wp-config.php überschrieben. Dann wären die Einträge zu löschen und anschließend kannst du die (dann änderbaren) Felder im WordPress-Backend korrigieren.

    • Diese Antwort wurde geändert vor 1 Monat, 1 Woche von Bego Mario Garde. Grund: Nachtrag
Ansicht von 2 Antworten - 1 bis 2 (von insgesamt 2)